Ubuntu

Change log for “gedit” package in Ubuntu

175 of 186 results
Published in utopic-release 1 hour ago
Published in trusty-release on 2014-03-27
Deleted in trusty-proposed (Reason: moved to release)
gedit (3.10.4-0ubuntu4) trusty; urgency=medium

  * Add 00git_state_property_type.patch: Fix type of GeditWindow state
    property, to avoid crashes with autopilot when introspecting it.
    (LP: #1283966)
 -- Martin Pitt <email address hidden>   Wed, 26 Mar 2014 15:34:58 +0100

Available diffs

Superseded in trusty-release on 2014-03-27
Deleted in trusty-proposed on 2014-03-29 (Reason: moved to release)
gedit (3.10.4-0ubuntu3) trusty; urgency=medium

  * Fix snippets plugin with Python 3.4 (LP: #1282607)
 -- Marc Deslauriers <email address hidden>   Thu, 20 Feb 2014 09:56:39 -0500

Available diffs

Superseded in trusty-release on 2014-02-20
Deleted in trusty-proposed on 2014-02-22 (Reason: moved to release)
gedit (3.10.4-0ubuntu2) trusty; urgency=medium

  * debian/patches/git_store_dialog.patch: tweaks to the save files dialog,
    give enough space to list several documents (lp: #988946)
  * debian/patches/git_save_run_tool_order.patch:
    - save the *modified* documents before running a tool (lp: #1244338)
 -- Sebastien Bacher <email address hidden>   Mon, 10 Feb 2014 16:49:22 +0100
Superseded in trusty-release on 2014-02-10
Deleted in trusty-proposed on 2014-02-11 (Reason: moved to release)
gedit (3.10.4-0ubuntu1) trusty; urgency=medium

  * New upstream release
 -- Robert Ancell <email address hidden>   Tue, 04 Feb 2014 10:25:10 +0000
Superseded in trusty-release on 2014-02-05
Deleted in trusty-proposed on 2014-02-06 (Reason: moved to release)
gedit (3.10.3-0ubuntu3) trusty; urgency=medium

  * debian/patches/fix_snippet_warning.patch: fix deprecation warning in
    the snippet plugin. (LP: #1270458)
 -- Marc Deslauriers <email address hidden>   Sat, 18 Jan 2014 12:27:20 -0500

Available diffs

Superseded in trusty-release on 2014-01-18
Deleted in trusty-proposed on 2014-01-20 (Reason: moved to release)
gedit (3.10.3-0ubuntu2) trusty; urgency=medium

  * debian/patches/git_filebrowser_toolbar.patch:
    - use correct toolbar styling, thanks Lars Uebernickel (lp: #1260761)
 -- Sebastien Bacher <email address hidden>   Fri, 10 Jan 2014 15:57:37 +0100
Superseded in trusty-release on 2014-01-10
Deleted in trusty-proposed on 2014-01-11 (Reason: moved to release)
gedit (3.10.3-0ubuntu1) trusty; urgency=medium

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Tue, 07 Jan 2014 11:39:52 +0100

Available diffs

Superseded in trusty-release on 2014-01-07
Deleted in trusty-proposed on 2014-01-08 (Reason: moved to release)
gedit (3.10.2-0ubuntu1) trusty; urgency=medium

  * New upstream release
 -- Robert Ancell <email address hidden>   Tue, 17 Dec 2013 12:47:09 +1300

Available diffs

Superseded in trusty-release on 2013-12-17
Deleted in trusty-proposed on 2013-12-18 (Reason: moved to release)
gedit (3.10.1-0ubuntu1) trusty; urgency=low

  * New upstream version, 3.10 has mostly bug fixes and small improvements
  * debian/control.in:
    - recommends gir1.2-gtksource-3.0, since some ofthe plugins import it
      (lp: #1239130)
    - updated depends on glib, gtk and gtksourceview
  * debian/gedit-common.install: install the new appdata directory
 -- Sebastien Bacher <email address hidden>   Thu, 12 Dec 2013 15:47:50 +0100
Superseded in trusty-release on 2013-12-12
Published in saucy-release on 2013-07-14
Deleted in saucy-proposed (Reason: moved to release)
gedit (3.8.3-0ubuntu3) saucy; urgency=low

  * Mark gedit-dev Architecture: any
 -- Jeremy Bicha <email address hidden>   Sun, 14 Jul 2013 00:00:36 -0400

Available diffs

Superseded in saucy-release on 2013-07-14
Deleted in saucy-proposed on 2013-07-15 (Reason: moved to release)
gedit (3.8.3-0ubuntu2) saucy; urgency=low

  * Bump dh compat to 9 and update install directories
  * debian/patches/08_multiarch_fallback.patch:
    - Load plugins from the non-multiarch directory too for
      compatibility with existing packages
 -- Jeremy Bicha <email address hidden>   Sat, 13 Jul 2013 22:07:36 -0400

Available diffs

Superseded in saucy-release on 2013-07-14
Deleted in saucy-proposed on 2013-07-15 (Reason: moved to release)
gedit (3.8.3-0ubuntu1) saucy; urgency=low

  * New upstream release
  * debian/control.in:
    - Build-depend on libzeitgeist-2.0-dev instead of libzeitgeist-dev
  * debian/patches/07_use_del_instead_ctrl_del.patch:
    - Use Delete, not Ctrl+Delete, to delete files in file browser
      side panel to match our Nautilus behavior (LP: #1163287)
  * debian/patches/10_add_zeitgeist_to_active_plugins.patch:
    - Dropped, replaced by override in ubuntu-settings &
      ubuntu-gnome-default-settings
  * debian/patches/revert_new_libzg_depends.patch:
    - Dropped, no longer needed
 -- Jeremy Bicha <email address hidden>   Wed, 26 Jun 2013 17:13:08 -0400

Available diffs

Superseded in saucy-release on 2013-06-27
Deleted in saucy-proposed on 2013-06-29 (Reason: moved to release)
gedit (3.8.2-0ubuntu1) saucy; urgency=low

  * New upstream version
  * debian/patches/revert_new_libzg_depends.patch:
    - revert the port to the new libzg until we get that one

  [ Jeremy Bicha ]
  * debian/control.in:
    - Depend on python3-gi instead of python-gi
    - Drop libsm and libice from build-depends, they are no longer needed.

  [ Rico Tzschichholz ]
  * debian/control.in:
    - Bump build-depends on libgtk-3-dev (>= 3.7.10),
      libgtksourceview-3.0-dev (>= 3.2.0)

  [ Robert Ancell ]
  * debian/control.in:
    - Use standards version 3.9.4
    - Bump build-depends on libglib2.0-dev and libpeas-dev
    - Bump python depends
  * debian/rules:
    - Use Python 3
 -- Sebastien Bacher <email address hidden>   Fri, 24 May 2013 18:58:18 +0200

Available diffs

Superseded in saucy-release on 2013-05-25
Published in raring-release on 2012-11-13
Deleted in raring-proposed (Reason: moved to release)
gedit (3.6.2-0ubuntu1) raring; urgency=low

  * New upstream release
  * debian/patches/git_new_win_no_tab.patch:
    - Applied upstream
 -- Robert Ancell <email address hidden>   Tue, 13 Nov 2012 12:57:29 +1300

Available diffs

Superseded in raring-release on 2012-11-13
Deleted in raring-proposed on 2012-11-14 (Reason: moved to release)
gedit (3.6.1-0ubuntu3) raring; urgency=low

  * debian/patches/git_new_win_no_tab.patch:
    - don't create new instances with several tabs (lp: #965510)
 -- Sebastien Bacher <email address hidden>   Mon, 12 Nov 2012 11:17:49 +0100

Available diffs

Superseded in raring-release on 2012-11-12
Deleted in raring-proposed on 2012-11-20 (Reason: moved to release)
gedit (3.6.1-0ubuntu2) raring; urgency=low

  * Upload to raring
 -- Sebastien Bacher <email address hidden>   Mon, 05 Nov 2012 18:07:17 +0100

Available diffs

Published in quantal-updates on 2012-11-14
Deleted in quantal-proposed (Reason: moved to -updates)
gedit (3.6.1-0ubuntu1) quantal-proposed; urgency=low

  * New upstream bug fix version (lp: #1070771)
    - File Browser side panel improvements
    - Fix print preview in landscape mode
    - Misc bugfixes
 -- Sebastien Bacher <email address hidden>   Wed, 24 Oct 2012 12:50:11 +0200

Available diffs

Superseded in raring-release on 2012-11-05
Published in quantal-release on 2012-09-27
gedit (3.6.0-0ubuntu1) quantal; urgency=low

  * New upstream stable release
 -- Robert Ancell <email address hidden>   Tue, 25 Sep 2012 10:01:38 +1200

Available diffs

Superseded in quantal-release on 2012-09-27
gedit (3.5.3-0ubuntu1) quantal; urgency=low

  * New upstream bugfix release
  * debian/patches/quicklist-new-document:
    - Applied upstream
 -- Robert Ancell <email address hidden>   Thu, 20 Sep 2012 10:42:31 +1200

Available diffs

Superseded in quantal-release on 2012-09-19
gedit (3.5.2-0ubuntu1) quantal; urgency=low

  * New upstream release
  * debian/rules:
    - Run additional steps required for autoreconf
  * debian/patches/03_no_gnu_gettext.patch:
    - Can't use both IT_PROG_INTLTOOL and AM_GNU_GETTEXT
 -- Robert Ancell <email address hidden>   Fri, 31 Aug 2012 17:19:38 +1200

Available diffs

Superseded in quantal-release on 2012-09-06
gedit (3.5.1-0ubuntu2) quantal; urgency=low

  * Pass --new-document instead of --new-window in the "Open a New Document"
    action. (LP: #1027584)
 -- Iain Lane <email address hidden>   Mon, 23 Jul 2012 11:09:02 +0100

Available diffs

Superseded in quantal-release on 2012-07-23
gedit (3.5.1-0ubuntu1) quantal; urgency=low

  * New upstream release
 -- Robert Ancell <email address hidden>   Mon, 23 Jul 2012 09:45:16 +1200

Available diffs

Superseded in quantal-release on 2012-07-22
gedit (3.4.2-1ubuntu1) quantal; urgency=low

  * Rebase on Debian unstable, remaining Ubuntu changes:
  * debian/control:
    - Add build-depends on libzeitgeist-dev
  * debian/rules:
    - Build without --Bsymbolic-functions to fix issues
  * debian/watch:
    - Watch for unstable versions
  * debian/patches/02_add_keywords.patch:
    - Add new keywords for unity and gnome-shell
  * debian/patches/05_menu_label.patch:
    - Don't display in menu as "gedit Text Editor"
  * debian/patches/06_lp_401692.patch:
    - Default name of a new document is now 'Untitled Document'.
  * debian/patches/10_add_zeitgeist_to_active_plugins.patch:
    - Enable the zeitgeist plugin by default
 -- Robert Ancell <email address hidden>   Mon, 28 May 2012 16:41:45 +1200

Available diffs

Superseded in quantal-release on 2012-05-28
gedit (3.4.1-0ubuntu2) quantal; urgency=low

  * debian/control:
    - Use standards version 3.9.3
    - Drop dependency on liblaunchpad-integration-3.0-dev
  * debian/patches/01_lpi.patch:
    - Dropped, we no longer do Launchpad integration
 -- Robert Ancell <email address hidden>   Mon, 14 May 2012 15:53:15 +1200

Available diffs

Superseded in quantal-release on 2012-05-14
Published in precise-release on 2012-04-16
Deleted in precise-proposed (Reason: moved to release)
gedit (3.4.1-0ubuntu1) precise-proposed; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Mon, 16 Apr 2012 21:13:04 +0200

Available diffs

Superseded in precise-release on 2012-04-16
Deleted in precise-proposed on 2012-04-18 (Reason: moved to release)
gedit (3.4.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - Translation updates
 -- Robert Ancell <email address hidden>   Tue, 27 Mar 2012 11:16:47 +1100

Available diffs

Superseded in precise-release on 2012-03-29
gedit (3.3.8-0ubuntu1) precise; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Tue, 20 Mar 2012 20:05:57 +0100

Available diffs

Superseded in precise-release on 2012-03-20
gedit (3.3.7-0ubuntu2) precise; urgency=low

  * Really dropped the action group patch which is in the new version
  * debian/control.in, debian/gedit.install, debian/gedit-dev.install:
    - install the gi override in the main binary, needed at runtime
      (lp: #953957)
  * debian/patches/05_menu_label.patch:
    - updated to list the action group at the end and solve parsing issues
 -- Sebastien Bacher <email address hidden>   Tue, 13 Mar 2012 15:35:19 +0100

Available diffs

Superseded in precise-release on 2012-03-13
gedit (3.3.7-0ubuntu1) precise; urgency=low

  * New upstream version
  * debian/patches/03_add_unity_quicklist.patch:
    - drop, the patch is included in the new version
  * debian/rules: build without --Bsymbolic-functions to fix issues

  [ Jeremy Bicha ]
  * New upstream release
 -- Sebastien Bacher <email address hidden>   Tue, 06 Mar 2012 21:19:05 +0100

Available diffs

Superseded in precise-release on 2012-03-06
gedit (3.3.5-0ubuntu2) precise; urgency=low

  * Break below in 2 patches
  * Fix incorrect quicklist placement

  [ Nekhelesh Ramananthan ]
  * debian/patches/02_add_keywords.patch:
    - add new keywords for unity and gnome-shell
  * debian/patches/03_add_unity_quicklist.patch:
    - add static quicklist for unity
 -- Didier Roche <email address hidden>   Mon, 05 Mar 2012 16:50:52 +0100

Available diffs

Superseded in precise-release on 2012-03-05
gedit (3.3.5-0ubuntu1) precise; urgency=low

  * New upstream release.
  * debian/control.in: Bump minimum GTK to 3.3.15
    for switch to GResource
  * debian/gedit-common.install: Drop ui install
 -- Jeremy Bicha <email address hidden>   Fri, 02 Mar 2012 18:28:56 -0500

Available diffs

Superseded in precise-release on 2012-03-03
gedit (3.3.4-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Improved help
    - Fixed bugs (including several memory leaks)
  * debian/control.in:
    - Build-depends on yelp-tools instead of gnome-doc-utils & scrollkeeper
  * debian/gedit-common.install:
    - Updated for new help install location
 -- Jeremy Bicha <email address hidden>   Wed, 22 Feb 2012 21:54:14 -0500

Available diffs

Superseded in precise-release on 2012-02-23
gedit (3.3.3-0ubuntu1) precise; urgency=low

  * New upstream version:
    - correctly re-use running instance (lp: #777292)
    - use correct menuitem separator (lp: #902814)
  * debian/gedit-dev.install:
    - updated to include the pygobject override
  * debian/patches/11_correct_gettext_domain.patch:
    - dropped, the fix is in the new version
  * debian/patches/git_invalid_unrefing.patch:
    - dropped, the fix is in the new version
 -- Sebastien Bacher <email address hidden>   Mon, 06 Feb 2012 22:57:01 +0100

Available diffs

Superseded in precise-release on 2012-02-06
gedit (3.3.2-0ubuntu3) precise; urgency=low

  * debian/patches/git_invalid_unrefing.patch:
    - don't call unref on tab close, that leads to segfaults (lp: #903975)
 -- Sebastien Bacher <email address hidden>   Wed, 01 Feb 2012 16:04:02 +0100

Available diffs

Superseded in precise-release on 2012-02-01
gedit (3.3.2-0ubuntu2) precise; urgency=low

  * debian/patches/11_correct_gettext_domain.patch:
    - correctly define the gettext domain
 -- Sebastien Bacher <email address hidden>   Thu, 26 Jan 2012 21:46:30 +0100

Available diffs

Superseded in precise-release on 2012-01-26
gedit (3.3.2-0ubuntu1) precise; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Mon, 09 Jan 2012 15:12:28 +0100

Available diffs

Superseded in precise-release on 2012-01-09
gedit (3.2.6-0ubuntu1) precise; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Wed, 04 Jan 2012 11:23:35 +0100

Available diffs

Superseded in precise-release on 2012-01-04
gedit (3.2.5-0ubuntu1) precise; urgency=low

  * Rebase on Debian 3.2.3-1, remaining changes:
    - Port to dh_python2
    - debian/patches/01_lpi.patch: Add Launchpad integration
    - debian/patches/05_menu_label.patch: Drop 'gedit' from menu name
    - debian/patches/06_lp_401692.patch: Use 'Untitled Document'
    - debian/patches/10_add_zeitgeist_to_active_plugins.patch: Use zeitgeist
    - debian/watch: Watch unstable releases too
  * New upstream release.

Available diffs

Published in oneiric-updates on 2011-12-13
Deleted in oneiric-proposed (Reason: moved to -updates)
gedit (3.2.3-0ubuntu0.1) oneiric-proposed; urgency=low

  * New upstream release
    - Fixes crash when dragging text into gedit (LP: #863773)
    - Fixes "Edit->Insert Date" menu item (LP: #840765)
  * debian/patches/07_pyconsole_crash.patch:
    - Dropped, applied upstream
 -- Michael Terry <email address hidden>   Fri, 02 Dec 2011 12:16:58 -0500

Available diffs

Superseded in precise-release on 2011-12-09
gedit (3.2.3-0ubuntu1) precise; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Mon, 21 Nov 2011 11:32:25 +0100

Available diffs

Superseded in precise-release on 2011-11-21
gedit (3.2.2-0ubuntu1) precise; urgency=low

  [ Manish Sinha ]
  * Append libzeitgeist-dev as build-depends and libzeitgeist-1.0-1 as
    gedit dependency to enable zeitgeist-dataprovider plugin

  [ Didier Roche ]
  * New upstream version:
    - More help awesome (Jim Campbell)
    - Misc bugfixes
    - New and updated translations
  * debian/control.in:
    - remove the hard dep on libzeitgeist-1.0-1, let dh_shlibdeps do the
      work
  * debian/patches/10_add_zeitgeist_to_active_plugins.patch:
    - enable the zeitgeist plugin by default
 -- Didier Roche <email address hidden>   Sat, 12 Nov 2011 17:12:45 +0100

Available diffs

Superseded in oneiric-updates on 2011-12-13
Superseded in precise-release on 2011-11-15
Deleted in oneiric-proposed on 2011-12-14 (Reason: moved to -updates)
gedit (3.2.1-0ubuntu2) oneiric-proposed; urgency=low

  * debian/patches/07_pyconsole_crash.patch:
    - Don't crash when opening the pythonconsole plugin's preferences
      (LP: #849225)
 -- Michael Terry <email address hidden>   Thu, 20 Oct 2011 15:00:35 -0400

Available diffs

Superseded in oneiric-updates on 2011-11-03
Superseded in precise-release on 2011-11-01
Deleted in oneiric-proposed on 2011-11-04 (Reason: moved to -updates)
gedit (3.2.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream version (LP: #876592)
   - More help awesome (Jim Campbell)
   - Use GtkGrid in the replace dialog. (Paolo Borelli)
   - Misc bugfixes
   - New and updated translations
  * debian/control.in:
    - require latest python-gobject-dev
 -- Didier Roche <email address hidden>   Mon, 17 Oct 2011 16:41:39 +0200

Available diffs

Superseded in precise-release on 2011-10-20
Published in oneiric-release on 2011-09-26
gedit (3.2.0-0ubuntu1) oneiric; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Mon, 26 Sep 2011 22:28:41 +0200

Available diffs

Superseded in oneiric-release on 2011-09-26
gedit (3.1.6-0ubuntu1) oneiric; urgency=low

  * New upstream version
  * debian/gedit.install: updated for the new version
 -- Sebastien Bacher <email address hidden>   Mon, 19 Sep 2011 21:38:57 +0200

Available diffs

Superseded in oneiric-release on 2011-09-19
gedit (3.1.5-0ubuntu1) oneiric; urgency=low

  * New upstream release.
  * Drop 07_revert_pygobject_bump.patch, we now do want to build against
    pygobject 3. Bump build dependency in debian/control.in accordingly.
 -- Martin Pitt <email address hidden>   Tue, 06 Sep 2011 16:20:26 +0200

Available diffs

Superseded in oneiric-release on 2011-09-06
gedit (3.1.4-0ubuntu1) oneiric; urgency=low

  * New upstream version
  * Refresh debian/patches/01_gedit-bugreport-location.patch
  * Revert upstream commit to bump the minimum pygobject version. It doesn't
    look like anything actually requires it, so we don't need to block
    on the new version
    - add debian/patches/07_revert_pygobject_bump.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden>   Mon, 22 Aug 2011 13:09:05 +0100

Available diffs

Superseded in oneiric-release on 2011-08-22
gedit (3.1.3-0ubuntu1) oneiric; urgency=low

  * New upstream version, clean patches which are in the new version
 -- Sebastien Bacher <email address hidden>   Thu, 04 Aug 2011 11:48:53 +0200

Available diffs

Superseded in oneiric-release on 2011-08-09
gedit (3.1.2-0ubuntu1) oneiric; urgency=low

  * New upstream release.
  * debian/control.in:
    - Bump libpeas requirement to 1.1.0
  * debian/patches/07_unity_quicklist.patch:
    - Refreshed and stopped from patching a generated version of the
      desktop file
 -- Michael Terry <email address hidden>   Tue, 12 Jul 2011 15:21:03 -0400

Available diffs

Superseded in oneiric-release on 2011-07-12
gedit (3.1.1-0ubuntu4) oneiric; urgency=low

  * debian/rules
    - Call dh_python2 twice to build for both public and private
      modules.
 -- Barry Warsaw <email address hidden>   Tue, 28 Jun 2011 04:36:52 +0100

Available diffs

Superseded in oneiric-release on 2011-06-28
gedit (3.1.1-0ubuntu3) oneiric; urgency=low

  * debian/control.in, debian/rules
    - Convert to dh_python2.  (LP: #788514)
 -- Barry Warsaw <email address hidden>   Mon, 27 Jun 2011 16:30:43 +0100

Available diffs

Superseded in oneiric-release on 2011-06-27
gedit (3.1.1-0ubuntu2) oneiric; urgency=low

  * debian/patches/07_unity_quicklist.patch: Add Unity static quicklist
    items for Create a New Document and Open a New Window.
 -- Bilal Akhtar <email address hidden>   Tue, 07 Jun 2011 17:54:14 +0530

Available diffs

Superseded in oneiric-release on 2011-06-27
gedit (3.1.1-0ubuntu1) oneiric; urgency=low

  * New upstream release.
  * debian/control.in:
    - Require GTK+ 3.1.6
  * debian/watch:
    - Look at unstable releases too
 -- Michael Terry <email address hidden>   Mon, 27 Jun 2011 05:29:37 -0400

Available diffs

Superseded in oneiric-release on 2011-06-27
gedit (3.0.5-0ubuntu1) oneiric; urgency=low

  * New upstream version
 -- Rodrigo Moya <email address hidden>   Fri, 17 Jun 2011 10:16:57 +0200

Available diffs

Superseded in oneiric-release on 2011-06-17
gedit (3.0.4-0ubuntu2) oneiric; urgency=low

  * control.in: recommends gir1.2-gtksource-3.0 (lp: #791760)
 -- Sebastien Bacher <email address hidden>   Fri, 03 Jun 2011 12:41:04 +0200

Available diffs

Superseded in oneiric-release on 2011-06-03
gedit (3.0.4-0ubuntu1) oneiric; urgency=low

  * New upstream version
  * debian/patches/07_intltool.patch:
    - Remove upstreamed patch
 -- Rodrigo Moya <email address hidden>   Wed, 01 Jun 2011 10:14:40 +0200

Available diffs

Superseded in oneiric-release on 2011-06-01
gedit (3.0.3-0ubuntu1) oneiric; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Wed, 25 May 2011 13:44:08 +0200

Available diffs

Superseded in oneiric-release on 2011-05-25
gedit (3.0.2-0ubuntu1) oneiric; urgency=low

  * New upstream version

Superseded in oneiric-release on 2011-05-04
Obsolete in natty-release on 2013-06-04
gedit (2.30.4-2ubuntu1) natty; urgency=low

  * Merge from debian unstable.  Remaining changes: (LP: #708401)
    - debian/control.in:
      + Bump gedit-dev depends on libgtksourceview2.0-dev (>= 2.8.0)
      + Build-Depends on dh-autoreconf, gnome-common.
      + Build-Depends on liblaunchpad-integration-dev.
      + Don't recommends python-gnome2 it's not used nowadays.
    - debian/rules:
      + Run autoreconf on build.
    - debian/patches/01_lpi.patch:
      + Launchpad integration.
    - debian/patches/02_gconf_import.patch:
      + Correct gconf import.
    - debian/patches/05_menu_label.patch:
      + Don't display in menu as "gedit Text Editor".
    - debian/patches/06_lp_401692.patch:
      + Default name of a new document is now 'Untitled Document'.
    - debian/patches/07_intltool.patch:
      + Don't use both Intltool and GNU gettext build system.
    - debian/patches/90_autoreconf.patch:
      + Dropped, autoreconf now runs on build.
    - debian/watch:
      + Watch unstable series.

Superseded in natty-release on 2011-02-04
gedit (2.30.4-1ubuntu3) natty; urgency=low

  * No-change rebuild for new python default
 -- Didier Roche <email address hidden>   Fri, 10 Dec 2010 12:58:38 +0100

Available diffs

Superseded in natty-release on 2010-12-10
gedit (2.30.4-1ubuntu2) natty; urgency=low

  * debian/patches/02_gconf_import.patch:
    - correct gconf import, thanks Jason Conti and LaserJock (lp: #654867)
 -- Sebastien Bacher <email address hidden>   Fri, 05 Nov 2010 19:10:00 +0100

Available diffs

Superseded in natty-release on 2010-11-05
gedit (2.30.4-1ubuntu1) natty; urgency=low

  * Resynchronise on Debian
  * debian/control.in: don't recommends python-gnome2 it's not used nowadays

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
gedit (2.30.3-1ubuntu1) maverick; urgency=low

  * Merge with Debian unstable, remaining Ubuntu changes:
  * debian/control.in:
    - Bump gedit-dev depends on libgtksourceview2.0-dev
    - Build-depend on dh-autoreconf, gnome-common
    - Build-depend on liblaunchpad-integration-dev
    - Add Vcs-BZR link
  * debian/rules:
    - Use autoreconf.mk
  * debian/patches/01_lpi.patch:
    - Launchpad integration
  * debian/patches/05_menu_label.patch:
    - Don't display in menu as "gedit Text Editor"
  * debian/patches/06_lp_401692.patch:
    - Default name of a new document is now 'Untitled Document'.
  * debian/patches/07_intltool.patch:
    - Don't use both Intltool and GNU gettext build system
  * debian/patches/90_autoreconf.patch:
    - Obsolete as run from debian/rules
  * debian/watch:
    - Watch unstable versions
 -- Robert Ancell <email address hidden>   Fri, 13 Aug 2010 14:59:13 +1000
Superseded in maverick-release on 2010-08-24
gedit (2.30.3-0ubuntu3) maverick; urgency=low

  * debian/patches/11_lp_401692.patch:
    - Default name of a new document is now 'Untitled Document'. (LP: #401692)
 -- Bilal Akhtar <email address hidden>   Mon, 26 Jul 2010 08:50:38 +0530
Superseded in maverick-release on 2010-07-26
gedit (2.30.3-0ubuntu2) maverick; urgency=low

  * debian/patches/04_menu_label.patch:
    - Don't display in menu as "gedit Text Editor"
 -- Robert Ancell <email address hidden>   Thu, 24 Jun 2010 14:40:09 +1000
Superseded in maverick-release on 2010-06-24
gedit (2.30.3-0ubuntu1) maverick; urgency=low

  * New upstream version
    - Misc bugfixes
    - Handle empty input gracefully (lp: #586848)
    - Translations update
 -- Sebastien Bacher <email address hidden>   Mon, 21 Jun 2010 15:14:19 +0200

Available diffs

Published in lucid-updates on 2010-06-30
Deleted in lucid-proposed (Reason: moved to -updates)
gedit (2.30.3-0ubuntu0.1) lucid-proposed; urgency=low

  * New upstream version
    - Misc bugfixes
    - Handle empty input gracefully (lp: #586848)
 -- Sebastien Bacher <email address hidden>   Mon, 21 Jun 2010 15:00:17 +0200
Superseded in maverick-release on 2010-06-21
gedit (2.30.2-1ubuntu1) maverick; urgency=low

  * Resync on Debian, Ubuntu changes:
  * debian/control.in:
    - Bump gedit-dev depends on libgtksourceview2.0-dev
    - Build-depend on liblaunchpad-integration-dev
    - Add Vcs-BZR link
  * debian/rules:
    - Run autoconf on build
  * debian/patches/01_lpi.patch:
    - Launchpad integration
  * debian/patches/90_autoreconf.patch:
    - Obsolete as run from debian/rules
  * debian/watch:
    - Watch unstable versions
 -- Robert Ancell <email address hidden>   Thu, 27 May 2010 14:55:48 +1000
Superseded in lucid-updates on 2010-06-30
Superseded in maverick-release on 2010-05-27
Deleted in lucid-proposed on 2010-07-01 (Reason: moved to -updates)
gedit (2.30.2-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release:
    - Fix cut and paste typo that broke syntax detection

Superseded in maverick-release on 2010-05-03
Published in lucid-release on 2010-04-14
gedit (2.30.0git20100413-0ubuntu1) lucid; urgency=low

  * Updating to git snaptshot since 2.30.1 will be after lucid
  * debian/patches/90_autoconf.patch:
    - new version update
 -- Sebastien Bacher <email address hidden>   Wed, 14 Apr 2010 16:41:13 +0200
Superseded in lucid-release on 2010-04-14
gedit (2.30.0-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - Fix a crash in the new file saving code (lp: #542846)
    - Misc bugfixes
 -- Sebastien Bacher <email address hidden>   Mon, 29 Mar 2010 23:18:50 +0200

Available diffs

Superseded in lucid-release on 2010-03-29
gedit (2.29.9-0ubuntu2) lucid; urgency=low

  * No-change rebuild against a reverted CDBS.
 -- Steve Kowalik <email address hidden>   Sat, 20 Mar 2010 18:27:55 +1100

Available diffs

Superseded in lucid-release on 2010-03-20
gedit (2.29.9-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - Fix a file corruption bug in the new file saving code
    - Misc bugfixes
  * debian/patches/80_not_using_localmodlibs.patch:
    - dropped, the change is in the new version
 -- Sebastien Bacher <email address hidden>   Thu, 18 Mar 2010 00:37:05 +0100

Available diffs

Superseded in lucid-release on 2010-03-19
gedit (2.29.8-0ubuntu1) lucid; urgency=low

  * New upstream version
    - Rework encoding validation
    - Misc bugfixes
  * Refreshed patches:
    - 01_gedit-bugreport-location.patch
    - 01_lpi.patch
    - 03_python_path.patch
    - 80_not_using_localmodlibs.patch
    - 90_autoconf.patch
    - 99_ltmain_as-needed.patch
 -- Chris Coulson <email address hidden>   Wed, 03 Mar 2010 22:44:53 +0000

Available diffs

Superseded in lucid-release on 2010-03-04
gedit (2.29.7-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - Many string fixes
    - Misc bugfixes
  * debian/control.in:
    - updated gtksourceview and pygtksourceview requirements
    - Misc bugfixes
  * debian/patches/90_autoconf.patch:
    - new version update
 -- Sebastien Bacher <email address hidden>   Mon, 22 Feb 2010 23:48:52 +0100

Available diffs

175 of 186 results