update patch to support different releases

Bug #37917 reported by Gustavo Franco
14
Affects Status Importance Assigned to Milestone
germinate (Ubuntu)
Wishlist
Colin Watson

Bug Description

As i told Colin, i've worked on 'update' code into ubuntu-meta to give it the possibility to update both ubuntu-* metapackages dependencies based on his seeds and utnubu-*, based on my slightly different seeds.

I'll fork ubuntu-meta in Debian using utnubu-meta name (as defined with Colin), but we can share the same 'update' script if you want. I wrote a patch that uses ConfigParser to do necessary configuration changes.

ConfigParser patch:
http://people.debian.org/~stratus/ubuntu-meta/update-utnubu.patch

The configuration i'm using (it contains dapper bits too):
http://people.debian.org/~stratus/ubuntu-meta/update-config

You can notice in the patch that if you run 'update' it will have the same behaviour as before, but if you use 'update sid' it
will do what i need for utnubu-meta. :-)

Gustavo Franco (stratus)
Changed in ubuntu-meta:
assignee: nobody → kamion
Colin Watson (cjwatson)
Changed in ubuntu-meta:
status: Unconfirmed → Confirmed
Revision history for this message
Colin Watson (cjwatson) wrote :

Thanks! I've uploaded a variant of this change in germinate 0.15 as germinate-update-metapackage; we'll be syncing that into Edgy soon, at which point I'll also update the ubuntu-meta package with an example update.cfg. The main changes I made from your patch were to put dist in the configuration file (in a [DEFAULT] section) and to move the archive_base stuff into the configuration file. A working configuration file for ubuntu-meta/dapper now looks like this:

[DEFAULT]
dist: dapper

[dapper]
seeds: minimal standard desktop live
architectures: i386 amd64 powerpc ia64 sparc hppa
seed_base: http://people.ubuntu.com/~cjwatson/seeds/
archive_base/default: http://archive.ubuntu.com/ubuntu/
archive_base/ports: http://ports.ubuntu.com/ubuntu-ports/
archive_base/hppa: %(archive_base/ports)s
archive_base/ia64: %(archive_base/ports)s
archive_base/sparc: %(archive_base/ports)s
components: main restricted

Changed in germinate:
status: Confirmed → Fix Committed
Revision history for this message
Colin Watson (cjwatson) wrote :

germinate 0.16 synced to Edgy.

Changed in germinate:
status: Fix Committed → Fix Released
Revision history for this message
Colin Watson (cjwatson) wrote :

germinate (0.16) unstable; urgency=low

  * Add --bzr option to automatically check out seeds from bzr.
  * Switch from urllib to urllib2.
  * Refactor duplicated seed-fetching code into new Germinate.seeds module.
  * Add optional seed_dist setting in update.cfg files, to allow setting a
    default seed distribution.
  * Add --bzr option to update-metapackage as well (mostly implementing
    https://launchpad.net/distros/ubuntu/+spec/ubuntu-meta-from-bzr).

 -- Colin Watson <email address hidden> Fri, 9 Jun 2006 12:15:01 +0100

germinate (0.15) unstable; urgency=low

  * Source moved to bzr; update copyright file.
  * Add germinate-update-metapackage script to help manage updating
    ubuntu-meta et al (thanks, Gustavo Franco; closes:
    https://launchpad.net/bugs/37917).
  * Improve man page documentation of --seed-packages slightly (see
    #363536).

 -- Colin Watson <email address hidden> Fri, 9 Jun 2006 01:04:21 +0100

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers