ghostscript 8.71.dfsg.1-0ubuntu5.7 source package in Ubuntu

Changelog

ghostscript (8.71.dfsg.1-0ubuntu5.7) lucid-security; urgency=medium

  * SECURITY UPDATE: denial of service via crafted ICC color profile
    - debian/patches/CVE-2014-8137.dpatch: prevent double-free in
      jasper/src/libjasper/base/jas_icc.c, remove assert in
      jasper/src/libjasper/jp2/jp2_dec.c.
    - CVE-2014-8137
  * SECURITY UPDATE: denial of service or code execution via invalid
    channel number
    - debian/patches/CVE-2014-8138.dpatch: validate channel number in
      jasper/src/libjasper/jp2/jp2_dec.c.
    - CVE-2014-8138
  * SECURITY UPDATE: denial of service or code execution via off-by-one
    - debian/patches/CVE-2014-8157.dpatch: fix off-by-one in
      jasper/src/libjasper/jpc/jpc_dec.c.
    - CVE-2014-8157
  * SECURITY UPDATE: denial of service or code execution via memory
    corruption
    - debian/patches/CVE-2014-8158.dpatch: remove HAVE_VLA to use more
      sensible buffer sizes in jasper/src/libjasper/jpc/jpc_qmfb.c.
    - CVE-2014-8158
 -- Marc Deslauriers <email address hidden>   Thu, 22 Jan 2015 13:09:28 -0500

Upload details

Uploaded by:
Marc Deslauriers on 2015-01-22
Uploaded to:
Lucid
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
text
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
ghostscript_8.71.dfsg.1.orig.tar.gz 20.2 MiB bea84ec26a63faf2f7a2208416c9baf7bb6dfb4a3d4a02abc0ed1988775f3e9b
ghostscript_8.71.dfsg.1-0ubuntu5.7.diff.gz 73.6 KiB d9c578358063272e6a8ea01c969d076b217a0fecfb628445d1b7df76d01e5592
ghostscript_8.71.dfsg.1-0ubuntu5.7.dsc 2.4 KiB ebf251ebd74be9c32df7cb5a15ee515a91614600f13a929c7f719004def0cbd5

View changes file

Binary packages built by this source

ghostscript: No summary available for ghostscript in ubuntu lucid.

No description available for ghostscript in ubuntu lucid.

ghostscript-cups: No summary available for ghostscript-cups in ubuntu lucid.

No description available for ghostscript-cups in ubuntu lucid.

ghostscript-doc: No summary available for ghostscript-doc in ubuntu lucid.

No description available for ghostscript-doc in ubuntu lucid.

ghostscript-x: No summary available for ghostscript-x in ubuntu lucid.

No description available for ghostscript-x in ubuntu lucid.

gs: No summary available for gs in ubuntu lucid.

No description available for gs in ubuntu lucid.

gs-aladdin: No summary available for gs-aladdin in ubuntu lucid.

No description available for gs-aladdin in ubuntu lucid.

gs-common: No summary available for gs-common in ubuntu lucid.

No description available for gs-common in ubuntu lucid.

gs-esp: No summary available for gs-esp in ubuntu lucid.

No description available for gs-esp in ubuntu lucid.

gs-esp-x: No summary available for gs-esp-x in ubuntu lucid.

No description available for gs-esp-x in ubuntu lucid.

gs-gpl: No summary available for gs-gpl in ubuntu lucid.

No description available for gs-gpl in ubuntu lucid.

libgs-dev: No summary available for libgs-dev in ubuntu lucid.

No description available for libgs-dev in ubuntu lucid.

libgs-esp-dev: No summary available for libgs-esp-dev in ubuntu lucid.

No description available for libgs-esp-dev in ubuntu lucid.

libgs8: No summary available for libgs8 in ubuntu lucid.

No description available for libgs8 in ubuntu lucid.