glib2.0 2.16.6-0ubuntu1.1 source package in Ubuntu

Changelog

glib2.0 (2.16.6-0ubuntu1.1) hardy-security; urgency=low

  * SECURITY UPDATE: possible arbitrary code execution when processing large
    Base64 strings
    - debian/patches/91_CVE-2008-4316.patch: update glib/gbase64.c to properly
      verify the string length and set the length of the output buffer.
    - CVE-2008-4316

 -- Jamie Strandboge <email address hidden>   Thu, 12 Mar 2009 16:46:11 -0500

Upload details

Uploaded by:
Jamie Strandboge on 2009-03-12
Uploaded to:
Hardy
Original maintainer:
Ubuntu Development Team
Architectures:
any
Section:
libs
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
glib2.0_2.16.6.orig.tar.gz 6.2 MiB 977d5720f7f43a76261804e79cade381fa874385a45bf52a9cc4440106256f88
glib2.0_2.16.6-0ubuntu1.1.diff.gz 33.1 KiB a32c09ef177c7476b6873dde50189f9c8bfcb724ab0e1e78e527b9a210850d0a
glib2.0_2.16.6-0ubuntu1.1.dsc 1.1 KiB cea50869ff55f174b7f5f134434741ba88722900b60e294d47878400c55615e1

View changes file

Binary packages built by this source

libgio-fam: No summary available for libgio-fam in ubuntu hardy.

No description available for libgio-fam in ubuntu hardy.

libglib2.0-0: No summary available for libglib2.0-0 in ubuntu hardy.

No description available for libglib2.0-0 in ubuntu hardy.

libglib2.0-0-dbg: No summary available for libglib2.0-0-dbg in ubuntu hardy.

No description available for libglib2.0-0-dbg in ubuntu hardy.

libglib2.0-data: No summary available for libglib2.0-data in ubuntu hardy.

No description available for libglib2.0-data in ubuntu hardy.

libglib2.0-dev: No summary available for libglib2.0-dev in ubuntu hardy.

No description available for libglib2.0-dev in ubuntu hardy.

libglib2.0-doc: No summary available for libglib2.0-doc in ubuntu hardy.

No description available for libglib2.0-doc in ubuntu hardy.

libglib2.0-udeb: No summary available for libglib2.0-udeb in ubuntu hardy.

No description available for libglib2.0-udeb in ubuntu hardy.