glib2.0 2.18.2-0ubuntu2.1 source package in Ubuntu

Changelog

glib2.0 (2.18.2-0ubuntu2.1) intrepid-security; urgency=low

  * SECURITY UPDATE: possible arbitrary code execution when processing large
    Base64 strings
    - debian/patches/61_CVE-2008-4316.patch: update glib/gbase64.c to properly
      verify the string length and set the length of the output buffer.
    - CVE-2008-4316

 -- Jamie Strandboge <email address hidden>   Thu, 12 Mar 2009 16:37:14 -0500

Upload details

Uploaded by:
Jamie Strandboge on 2009-03-12
Uploaded to:
Intrepid
Original maintainer:
Ubuntu Desktop
Architectures:
any
Section:
libs
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
glib2.0_2.18.2.orig.tar.gz 6.5 MiB 5e46adaaa229036690dc35b6d2071ef9da03601a97ca3cfe0a978bed6337730c
glib2.0_2.18.2-0ubuntu2.1.diff.gz 32.2 KiB ce5f529e658d0bb41c7cb54c65df3a80241a0c0cad61e0de85c90a339c181905
glib2.0_2.18.2-0ubuntu2.1.dsc 1.5 KiB 720a78f5bd3cfd32692a2485b053eb85e3aa49b24886a4506ecee5b4805f8c0a

View changes file

Binary packages built by this source

libgio-fam: No summary available for libgio-fam in ubuntu intrepid.

No description available for libgio-fam in ubuntu intrepid.

libglib2.0-0: No summary available for libglib2.0-0 in ubuntu intrepid.

No description available for libglib2.0-0 in ubuntu intrepid.

libglib2.0-0-dbg: No summary available for libglib2.0-0-dbg in ubuntu intrepid.

No description available for libglib2.0-0-dbg in ubuntu intrepid.

libglib2.0-data: No summary available for libglib2.0-data in ubuntu intrepid.

No description available for libglib2.0-data in ubuntu intrepid.

libglib2.0-dev: No summary available for libglib2.0-dev in ubuntu intrepid.

No description available for libglib2.0-dev in ubuntu intrepid.

libglib2.0-doc: No summary available for libglib2.0-doc in ubuntu intrepid.

No description available for libglib2.0-doc in ubuntu intrepid.

libglib2.0-udeb: No summary available for libglib2.0-udeb in ubuntu intrepid.

No description available for libglib2.0-udeb in ubuntu intrepid.