Change log for glm package in Ubuntu

135 of 35 results
Published in groovy-release on 2020-05-03
Deleted in groovy-proposed (Reason: moved to Release)
glm (0.9.9.8+ds-1) unstable; urgency=medium

  * Team Upload
  * [7dd6485] New upstream version 0.9.9.8+ds
  * [4271349] Dropping the patch queue
    Upstream has merged the patch we've cherry-picked from the GitHub issue
    tracker previously to provide CMake package configs for glm.
    Due this we can drop again our patch queue.
  * [ec891c1] d/libglm-dev.install: Adjust install CMake package config
    The installation of the *.cmake files within libglm-dev needs some small
    adaptation due changed structure of the source.

 -- Carsten Schoenert <email address hidden>  Sat, 02 May 2020 20:41:19 +0200

Available diffs

Superseded in groovy-release on 2020-05-03
Published in focal-release on 2020-01-10
Deleted in focal-proposed (Reason: moved to Release)
glm (0.9.9.7+ds-1) unstable; urgency=medium

  * Team Upload
  * [c7ff2bd] gbp: add config section for import-orig
  * [8b335ae] New upstream version 0.9.9.7+ds
  * [52bb1a4] d/watch: adding some version mangling

 -- Carsten Schoenert <email address hidden>  Thu, 09 Jan 2020 19:43:54 +0100

Available diffs

Superseded in focal-release on 2020-01-10
Deleted in focal-proposed on 2020-01-11 (Reason: moved to Release)
glm (0.9.9.6-2) unstable; urgency=medium

  * Team Upload
  * [2778f0f] Adding a patch queue
    added patches:
     Add-a-CMake-Package-config.patch
    This patch adds back the CMake package config that were already installed
    in previous versions of glm. The non existence of these config files
    were detected correctly by the autopkgtest.
    (Closes: #940906)
  * [f188581] d/libglm-dev.install: install CMake package config (again)
  * [e78de54] d/control: increase Standards-Version to 4.4.1
    No further changes needed.

 -- Carsten Schoenert <email address hidden>  Tue, 10 Dec 2019 18:51:22 +0100
Superseded in focal-proposed on 2019-12-10
glm (0.9.9.6-1) unstable; urgency=medium

  * New upstream version 0.9.9.6
  * Remove all quilt patches, they are obsolete now.
  * Deal with upstream no longer providing an install option.
  * Bump Standards-Version.

 -- Guus Sliepen <email address hidden>  Sun, 15 Sep 2019 15:39:43 +0200
Superseded in focal-release on 2019-12-11
Published in eoan-release on 2019-04-18
Obsolete in disco-release on 2020-07-14
Deleted in disco-proposed (Reason: moved to release)
glm (0.9.9.3-2) unstable; urgency=medium

  * Unconditionally disable GLM_HAS_CONSTEXPR. (Closes: #920791)

 -- Guus Sliepen <email address hidden>  Thu, 31 Jan 2019 23:03:04 +0100

Available diffs

Superseded in disco-release on 2019-02-01
Deleted in disco-proposed on 2019-02-02 (Reason: moved to release)
glm (0.9.9.3-1) unstable; urgency=medium

  * Updated debian/watch file.
  * New upstream version 0.9.9.3
  * Bump Standards-Version.
  * Build-Depend on debhelper-compat instead of using debian/compat.
  * Remove fix for GLM_FORCE_CTOR_INIT, it has been applied upstream.
  * Refresh patches.

 -- Guus Sliepen <email address hidden>  Mon, 28 Jan 2019 13:09:45 +0100

Available diffs

Superseded in disco-release on 2019-01-28
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2018-03-29
Deleted in bionic-proposed (Reason: moved to release)
glm (0.9.9~a2-2) unstable; urgency=medium

  [ Andrew Caudwell ]
  * Backport upstream commit adding GLM_FORCE_CTOR_INIT. (Closes: #892861)

  [ Guus Sliepen ]
  * Remove unnecessary --parallel from debian/rules.
  * Update Vcs-* and Homepage links in debian/control.
  * Move glm.pc to /usr/share/pkgconfig/.

 -- Guus Sliepen <email address hidden>  Thu, 29 Mar 2018 15:08:45 +0200

Available diffs

Superseded in bionic-release on 2018-03-29
Deleted in bionic-proposed on 2018-03-31 (Reason: moved to release)
glm (0.9.9~a2-1) unstable; urgency=medium

  * New upstream release.
    - Fixes FTBTS with GCC 7.3. Closes: #888550, #888661
  * Remove the fix-infiloop patch.
  * Rebuild the reference manual using Doxygen. Closes: #879517
  * Bump Standards-Version.
  * Add Rules-Requires-Root: no.

 -- Guus Sliepen <email address hidden>  Sun, 28 Jan 2018 18:37:59 +0100
Superseded in bionic-release on 2018-03-02
Deleted in bionic-proposed on 2018-03-03 (Reason: moved to release)
glm (0.9.8.4-1.1ubuntu1) bionic; urgency=medium

  * debian/patches/fix-gcc-7-3-build.patch: added (LP: #1745685)

 -- Olivier Tilloy <email address hidden>  Sat, 27 Jan 2018 00:00:00 +0100
Superseded in bionic-release on 2018-01-29
Deleted in bionic-proposed on 2018-01-31 (Reason: moved to release)
glm (0.9.8.4-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Cherrypick patch from upstream for FTBFS for GCC-7 (Closes: #870217)
  * Replace priority extra with optional. Fixes linitian:
    priority-extra-is-replaced-by-priority-optional
  * Remove Testsuite: autopkgtest from d/control as it is no longer
    needed. Fixes lintian unnecessary-testsuite-autopkgtest-header

 -- Tobias Frost <email address hidden>  Sun, 22 Oct 2017 15:21:32 +0200

Available diffs

Superseded in bionic-release on 2017-11-04
Obsolete in artful-release on 2020-07-10
Deleted in artful-proposed on 2020-07-10 (Reason: moved to release)
glm (0.9.8.4-1) unstable; urgency=medium

  * New upstream release.
  * Make libglm-doc Multi-Arch: foreign.
  * Drop patches/fix-packing-test, a proper fix has been applied upstream.
  * Bump Standards-Version.

 -- Guus Sliepen <email address hidden>  Sat, 24 Jun 2017 17:27:12 +0200

Available diffs

Superseded in artful-release on 2017-06-25
Deleted in artful-proposed on 2017-06-27 (Reason: moved to release)
glm (0.9.8.3-3) unstable; urgency=medium

  * Fix FTBFS on i386. Closes: 860701

 -- Guus Sliepen <email address hidden>  Wed, 19 Apr 2017 16:39:23 +0200

Available diffs

Superseded in artful-release on 2017-04-30
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
glm (0.9.8.3-2) unstable; urgency=medium

  * Team upload

  [ Ghislain Antony Vaillant ]
  * Clear old patch queue, no longer needed
  * Fix CMake detection on all architectures
    - New patch Fix-CMake-package-version-file.patch (Closes: #850277, #850243)

 -- Ghislain Antony Vaillant <email address hidden>  Wed, 11 Jan 2017 23:58:59 +0000
Superseded in zesty-proposed on 2017-01-12
glm (0.9.8.3-1) unstable; urgency=medium

  * New upstream version 0.9.8.3
  * Bump debian/compat.

 -- Guus Sliepen <email address hidden>  Wed, 07 Dec 2016 16:27:40 +0100

Available diffs

Superseded in zesty-release on 2017-01-12
Deleted in zesty-proposed on 2017-01-14 (Reason: moved to release)
glm (0.9.8.1-1) unstable; urgency=medium

  * New upstream version 0.9.8.1

 -- Guus Sliepen <email address hidden>  Thu, 06 Oct 2016 15:19:26 +0200

Available diffs

Superseded in zesty-release on 2016-11-03
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
glm (0.9.7.5-1) unstable; urgency=medium

  * New upstream release.
  * Add a glm.pc file. Closes: #737088
  * Bump Standards-Version.

 -- Guus Sliepen <email address hidden>  Mon, 30 May 2016 12:43:03 +0200

Available diffs

Superseded in yakkety-release on 2016-05-31
Deleted in yakkety-proposed on 2016-06-01 (Reason: moved to release)
glm (0.9.7.4-1) unstable; urgency=medium

  * New upstream release.
  * Install .cmake files in /usr/lib/cmake/glm. Closes: #812855

 -- Guus Sliepen <email address hidden>  Wed, 06 Apr 2016 15:58:47 +0200

Available diffs

Superseded in yakkety-release on 2016-04-27
Published in xenial-release on 2016-01-25
Deleted in xenial-proposed (Reason: moved to release)
glm (0.9.7.2-1) unstable; urgency=medium

  * New upstream release.

 -- Guus Sliepen <email address hidden>  Sun, 24 Jan 2016 22:49:41 +0100

Available diffs

Superseded in xenial-release on 2016-01-25
Deleted in xenial-proposed on 2016-01-26 (Reason: moved to release)
glm (0.9.7.1-1) unstable; urgency=medium

  * New upstream release.

 -- Guus Sliepen <email address hidden>  Sun, 20 Sep 2015 14:38:03 +0200

Available diffs

Superseded in xenial-release on 2015-10-26
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
glm (0.9.6.3-1) unstable; urgency=medium


  * New upstream release. Closes: #766154

 -- Guus Sliepen <email address hidden>  Mon, 20 Apr 2015 13:19:12 +0200

Available diffs

Superseded in wily-release on 2015-05-06
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
glm (0.9.5.4-1) unstable; urgency=medium


  * New upstream release.
  * Bump Standards-Version.

 -- Guus Sliepen <email address hidden>  Mon, 06 Oct 2014 14:30:41 +0200

Available diffs

Superseded in vivid-release on 2014-10-24
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
glm (0.9.5.3-1) unstable; urgency=medium


  * New upstream release.

 -- Guus Sliepen <email address hidden>  Fri, 16 May 2014 12:21:49 +0200

Available diffs

Superseded in utopic-release on 2014-05-16
Deleted in utopic-proposed on 2014-05-17 (Reason: moved to release)
glm (0.9.5.2-1) unstable; urgency=medium


  * New upstream release.

 -- Guus Sliepen <email address hidden>  Tue, 04 Mar 2014 14:01:01 +0100

Available diffs

Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2014-02-27
Deleted in trusty-proposed (Reason: moved to release)
glm (0.9.5.1-1) unstable; urgency=medium


  * New upstream release.
    - Fixes attempt to access private class members. Closes: #736264
  * Apply commit d7862e4 from upstream to prevent the tests from trying to use
    SSE2 instructions on platforms that don't support them. Closes: #735270

 -- Guus Sliepen <email address hidden>  Wed, 05 Feb 2014 16:47:42 +0100
Superseded in trusty-proposed on 2014-02-05
glm (0.9.5.0-1) unstable; urgency=medium


  * New upstream release.
  * Bump Standards-Version.

 -- Guus Sliepen <email address hidden>  Tue, 07 Jan 2014 14:49:22 +0100

Available diffs

Superseded in trusty-release on 2014-02-27
Deleted in trusty-proposed on 2014-02-28 (Reason: moved to release)
glm (0.9.4.6-2) unstable; urgency=low


  [ Steve Langasek ]
  * Add Multi-Arch: foreign header to facilitate cross-compilation.

 -- Guus Sliepen <email address hidden>  Wed, 09 Oct 2013 23:07:07 +0200
Superseded in trusty-release on 2013-10-22
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
glm (0.9.4.4-1ubuntu1) saucy; urgency=low

  * Mark libglm-dev Multi-Arch: foreign, to satisfy the deps of foreign-arch
    reverse-dependencies (e.g., libmirserver-dev).
 -- Steve Langasek <email address hidden>   Wed, 09 Oct 2013 13:25:58 -0700
Superseded in saucy-release on 2013-10-09
Superseded in saucy-release on 2013-08-05
Deleted in saucy-proposed on 2013-10-11 (Reason: moved to release)
glm (0.9.4.4-1) unstable; urgency=low


  * New upstream release.
  * Run build-time tests. Closes: #707536

 -- Guus Sliepen <email address hidden>  Thu, 18 Jul 2013 12:46:46 +0200

Available diffs

Superseded in saucy-release on 2013-07-18
Deleted in saucy-proposed on 2013-07-20 (Reason: moved to release)
glm (0.9.4.3-1) unstable; urgency=low


  * New upstream release.

 -- Guus Sliepen <email address hidden>  Sun, 05 May 2013 10:45:59 +0200

Available diffs

Superseded in saucy-release on 2013-05-05
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
glm (0.9.3.3+dfsg-0.1) unstable; urgency=low


  * Non-maintainer upload.
  * Repack without non DFSG-free material. Closes: #685232

 -- David Prévot <email address hidden>  Thu, 30 Aug 2012 23:34:20 -0400

Available diffs

Superseded in quantal-release on 2012-09-30
glm (0.9.3.3-1) unstable; urgency=low


  * New upstream release.

 -- Guus Sliepen <email address hidden>  Mon, 25 Jun 2012 22:55:53 +0200

Available diffs

Superseded in quantal-release on 2012-06-29
glm (0.9.3.2-1) unstable; urgency=low


  * New upstream release.

 -- Guus Sliepen <email address hidden>  Wed, 21 Mar 2012 00:14:12 +0100
Superseded in quantal-release on 2012-04-30
Published in precise-release on 2011-11-25
glm (0.9.2.7-1) unstable; urgency=low

  * New upstream release.
  * Don't install jquery.js, it is not used anyway.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  25 Nov 2011 10:06:40 +0000

Available diffs

Superseded in precise-release on 2011-11-25
glm (0.9.2.6-1) unstable; urgency=low

  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 Oct 2011 10:55:04 +0000

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
glm (0.9.2.0-2) unstable; urgency=low

  * Fix grammar in the package description.
  * Set section of libglm-doc to doc.

135 of 35 results