GmailFS won't mount

Bug #62349 reported by Alec Wright on 2006-09-25
30
Affects Status Importance Assigned to Milestone
gmailfs (Ubuntu)
Undecided
Daniel Hahler

Bug Description

Binary package hint: gmailfs

GMailFS won't mount. Whenever i try to mount a GMailFS drive, it says that the filesystem gmailfs doesn't exist.

Changed in gmailfs:
status: Unconfirmed → Confirmed
status: Confirmed → Unconfirmed
Michael R. Head (burner) wrote :

How are you using gmailfs? What's the commandline?

Here's what I use (note that it doesn't work yet due to bug 62767), but I don't get the "gmailfs filesystem doesn't exist" problem
mount.gmailfs none tmp -e -p -o username=suppressingfire,fsname=zOlRRa

Alec Wright (alecjw) wrote :

sudo mount -t gmailfs /usr/local/bin/gmailfs.py /path/of/mount/point -o username=alecjw,password=not_telling_you,fsname=not_telling_you_this_either.
Is the command I use.

Lord_Alba (lupo-alberto75) wrote :

you have to copy:

/usr/share/gmailfs/gmailfs.py in /usr/local/bin
and
/usr/bin/mount.gmailfs in /sbin

but now there is another problem:
when i give the mount command (with all the option, cause it doesn't care about gmail.conf) i obtain these messages:

Traceback (most recent call last):
  File "/sbin/mount.gmailfs", line 162, in ?
    main(mountpoint, odata, useEncfs)
  File "/sbin/mount.gmailfs", line 88, in main
    gmailfs.main(mountpoint, odata)
  File "/usr/local/bin/gmailfs.py", line 1133, in main
    server = Gmailfs(mountpoint, odata)
  File "/usr/local/bin/gmailfs.py", line 603, in __init__
    self.ga.login()
  File "/usr/lib/site-python/libgmail/__init__.py", line 318, in login
    pageData = self._retrievePage(redirectURL)
  File "/usr/lib/site-python/libgmail/__init__.py", line 331, in _retrievePage
    resp = urllib2.urlopen(req)
  File "/usr/lib/python2.4/urllib2.py", line 130, in urlopen
    return _opener.open(url, data)
  File "/usr/lib/python2.4/urllib2.py", line 356, in open
    req = meth(req)
  File "/usr/lib/python2.4/urllib2.py", line 943, in do_request_
    raise URLError('no host given')
urllib2.URLError: <urlopen error no host given>

Lord_Alba

N7DR (doc-evans) wrote :

I have spoken with the author of gmailfs.

It seems that the packager never actually tested this package. There are at least two fatal packaging bugs. (There may be more, but we know about these two).

1. mount.gmailsfs needs to be in /sbin. (This is discussed earlier in this thread.)

2. The error described by Lord Alba is due to libgmail not properly parsing the response from gmail. In order to get rid of this bug, the gmailfs author believes that at least version 0.1.5 of libgmail is needed, whereas the package dependency listing requires only 0.0.8 or later (and in fact the current kubuntu version is 0.1.4-2build1, which does not meet the requirement of being >= 0.1.5).

So it seems that two things need to happen to fix this bug (which currently renders the entire gmailfs package simply a waste of time and space at the moment):

1. libgmail needs to be updated
2. the packaging for gmailfs needs to be fixed as described above

We don't know whether this will be sufficient to allow the (revised) gmailfs package to be used, but it is certainly necessary.

Alec Wright (alecjw) wrote :

Ok. I've just tried it out in Feisty and IT WORKS! Because Feisty has version 0.1.5 of python-libgmail. I expect it's in edgy backports.

N7DR (doc-evans) wrote :

Incidentally, I am using dapper. (My attempt to upgrade to edgy was a disaster :-) ) So if this is fixed, I request that it be backported to dapper.

Alec Wright (alecjw) wrote :

I've just realised that its available in edgy too... and dapper backports. :D

N7DR (doc-evans) wrote :

Which dapper backports?

In my sources.list I have:

deb http://us.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse

but synaptic says that 0.1.4-2build1 is the latest available.

N7DR (doc-evans) wrote :

BTW, I running amd64. Maybe it's not been backported to that architecture? (There does seem a tendency in Kubuntu to forget about building 64-bit packages :-( )

Matti Lindell (mlind) wrote :

This has been fixed since Edgy.

Changed in gmailfs:
status: Unconfirmed → Fix Released
Alec Wright (alecjw) wrote :

N7DR, it's python, so it will work on all architectures, and kubuntu uses the same repos as ubuntu.

Also, to the devs, can I request that gmailfs is removed from dapper, breezy and hoary? They're totally useless anyway, and just misleading.

Alec Wright (alecjw) wrote :

It has been fixed, but as mlind rightly said, only since edgy. Gmailfs should be removed form dapper and earlier.

Changed in gmailfs:
status: Fix Released → Confirmed

fixed in edgy, feisty, gutsy.

There's no way to remove packages from current releases.

Changed in gmailfs:
status: Confirmed → Fix Released
Massimiliano Arione (garakkio) wrote :

Currently in Gutsy gmailfs is NOT working. It throws a "HTTP Error 400: Bad Request" error. I tried also to set level = DEBUG:

11/16/07 12:42:56 ERROR OpenSSLProxy is missing. Can't use HTTPS proxy!
11/16/07 12:42:56 INFO Starting gmailfs in child process (PID 7829)
11/16/07 12:42:56 INFO Mountpoint: /media/gmailfs
11/16/07 12:42:56 INFO Named mount options: {'password': '********'}
11/16/07 12:42:56 WARNING mount: warning, should mount with username=gmailuser option, using default
11/16/07 12:42:56 WARNING mount: warning, should mount with password=gmailpass option, using default
11/16/07 12:42:56 WARNING mount: warning, should mount with fsname=name option, using default
11/16/07 12:42:56 INFO waiting for /media/gmailfs to become a mountpoint
11/16/07 12:42:57 INFO Connected to gmail
11/16/07 12:42:58 DEBUG get stat:/
11/16/07 12:42:58 DEBUG check getnodemsg:/
11/16/07 12:42:58 DEBUG ind:0
11/16/07 12:42:58 DEBUG dirpath:/ name:
11/16/07 12:42:59 DEBUG ind:0
11/16/07 12:42:59 DEBUG dirpath:/ name:
11/16/07 12:42:59 INFO Sent message failed
11/16/07 12:42:59 INFO Sent message failed
11/16/07 12:43:00 INFO Sent message failed
11/16/07 12:43:00 ERROR Send failed too many times
11/16/07 12:43:00 ERROR gmailfs child died, exiting...

Massimiliano Arione (garakkio) wrote :

not working in gutsy

Changed in gmailfs:
status: Fix Released → Confirmed
Sam Peterson (peabodyenator) wrote :

I also confirm that this doesn't work in gutsy. HTTP 400 error.

according to forum
http://ubuntuforums.org/showthread.php?t=596352
solution is to upgrade to latest version of libgmail.

Daniel Hahler (blueyed) wrote :

We have version 0.1.8-1 of python-libgmail in Hardy, so it should be fixed there.
Can you confirm, that it is fixed for Hardy?

You can probably fix it for other Ubuntu releases by installing the most recent python-libgmail from https://launchpad.net/ubuntu/hardy/i386/python-libgmail/0.1.8-1

Changed in gmailfs:
assignee: nobody → blueyed
status: Confirmed → Incomplete

I can confirm that this is fixed in Hardy.

Thanks.

Changed in gmailfs:
status: Incomplete → Fix Released
David K. (dcrabs) wrote :

Hi,
On Hardy I get alwas this when I try to mount it:
07/28/08 14:27:47 ERROR OpenSSLProxy is missing. Can't use HTTPS proxy!
07/28/08 14:27:53 ERROR OpenSSLProxy is missing. Can't use HTTPS proxy!
07/28/08 14:27:53 INFO Starting gmailfs in child process (PID 17061)
07/28/08 14:27:53 INFO Mountpoint: /home/david/gmail
07/28/08 14:27:53 INFO Named mount options: {'username': 'xxxxxxx', 'password': '********', 'fsname': 'xxxxxxx'}
07/28/08 14:27:53 INFO waiting for /home/david/gmail to become a mountpoint
07/28/08 14:27:54 INFO Connected to gmail
07/28/08 14:27:57 ERROR gmailfs child died, exiting...
I tried upgrading libgmailfs but there was no change.

What's the command line ?

David K. (dcrabs) wrote :

mount.gmailfs /usr/lib/python2.5/site-packages/gmailfs.py /home/david/gmail -o username=myusername, password=mypassword, fsname=somerandomstuff

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers