gmerlin 1.0.0~dfsg-2 source package in Ubuntu

Changelog

gmerlin (1.0.0~dfsg-2) experimental; urgency=low

  * Add patch to prevent FTBFS with newest toolchain;
    this builds fine on Ubuntu Natty, too.

gmerlin (1.0.0~dfsg-1) experimental; urgency=low

  [ IOhannes m zmölnig ]
  * New upstream release:
    - The origin tarball was repacked to remove the include/gmerlin/bg_sem.h
      file, which was covered by BSD-4-clause license terms.
  * adjusted remove_desktop_encoding_key.patch to new upstream
  * fix_577328.patch is no longer needed (fixed in upstream)
  * Switch to 3.0 (quilt) source format.
  * let CDBS handle get-orig-source
  * exclude CVS directories when repackaging source
  * provide a debian policy compliant bg_sem.h
  * Add git-buildpackage configfile, enabling pristine-tar and signed
    tags.
  * added missing parameter types
  * remove (accidental) double call to (deprecated) png_set_gray...()
  * fix various typos reported by lintian
  * fixed typo in manpage
  * link against libxml/libm when needed
  * more consistent .desktop files (remove .png suffix)
  * link app-icons to default place
  * move images from libgmerlin-doc to gmerlin-doc
  * adding manpages
  * put internal binaries into /usr/lib/gmerlin
  * debian/rules: added copyright notice
  * include cdbs/utils.mk for copyright checks
  * re-created debian/copyright (with the help of licensecheck)
  * ignore binaries from licensecheck
  * generate debian/copyright_hints
  * remove generated manpages on "clean"
  * fix path when generating manpages
  * patch to prevent segfault when there is no plugin
  * store/restore autogenerated files
  * clean up clean target
  * moved gmerlin_visualizer_slave to libgmerlin
  * gmerlin.info is generated (no need for patching)
  * regenerated debian/copyright_newhints
  * Suggest: gmerlin-encoders
  * added plugin.sym to libgmerlin0
  * removed trailing whitespaces

  [ Alessio Treglia ]
  * Drop quilt support, package format is 3.0 (quilt) and it's enough.
  * Add .gitignore file to skip quilt patches.
  * debian/control{,.in}:
    - Apply one-dep-per-line style to improve readibility.
    - Add myself to the Uploaders field.
    - Build against the version of gavl available in experimental.
    - Re-enable libasound2-dev on kfreebsd-*, hurd-i386 architectures
      since it is provided by 'liboss-salsa-dev'.
    - Set priority to optional, no reason to keep it as 'extra'.
    - Set -DBG package's priority to 'extra'.
    - Bump Standards.
    - Update Maintainer field, add Vcs-* tags.
    - Fix duplicate-short-description lintian warning.
    - Clean-up, remove trailing whitespaces.
  * Disable building of static libraries.
  * Don't install static libraries, they are no longer built.
  * Add DEP-3 headers to patches.
  * Fix debian-watch-file-should-mangle-version lintian warning.
  * debian/copyright:
    - Update to DEP-5 candidate rev.157,
    - A bit of clean-up, re-formatting of license texts.
  * Update libgmerlin0.symbols file
  * Add --as-needed to linking flags.
 -- Alessio Treglia <email address hidden>   Mon, 17 Jan 2011 15:39:32 +0100

Upload details

Uploaded by:
Alessio Treglia on 2011-01-17
Uploaded to:
Natty
Original maintainer:
Debian Multimedia Team
Architectures:
any
Section:
sound
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
gmerlin_1.0.0~dfsg.orig.tar.gz 2.3 MiB feb0c4bb6ba7c4e991f5b1836ff96ebc44cf89058ca1f3f49e7d1bba0494e1e0
gmerlin_1.0.0~dfsg-2.debian.tar.gz 30.3 KiB 635eb547d77457451e9d68f83cc90136572fc986a69efdb271806df206d24a57
gmerlin_1.0.0~dfsg-2.dsc 1.8 KiB d7dfbe08bbd08bd82392312a03ddc78d77b309333cff9757be8e170f0f3d3a43

Available diffs

View changes file

Binary packages built by this source

gmerlin: No summary available for gmerlin in ubuntu oneiric.

No description available for gmerlin in ubuntu oneiric.

gmerlin-data: No summary available for gmerlin-data in ubuntu natty.

No description available for gmerlin-data in ubuntu natty.

gmerlin-dbg: No summary available for gmerlin-dbg in ubuntu oneiric.

No description available for gmerlin-dbg in ubuntu oneiric.

gmerlin-doc: No summary available for gmerlin-doc in ubuntu oneiric.

No description available for gmerlin-doc in ubuntu oneiric.

libgmerlin-dev: No summary available for libgmerlin-dev in ubuntu natty.

No description available for libgmerlin-dev in ubuntu natty.

libgmerlin-doc: No summary available for libgmerlin-doc in ubuntu oneiric.

No description available for libgmerlin-doc in ubuntu oneiric.

libgmerlin0: No summary available for libgmerlin0 in ubuntu oneiric.

No description available for libgmerlin0 in ubuntu oneiric.