gnome-obex-send cannot find devices

Bug #70718 reported by Fırat Küçük on 2006-11-07
42
Affects Status Importance Assigned to Milestone
gnome-bluetooth (Baltix)
Undecided
Unassigned
gnome-bluetooth (Ubuntu)
Undecided
Bluetooth

Bug Description

Binary package hint: gnome-bluetooth

gnome-obex-send cannot find devices but "hcitool scan" command can find.

Same here. When I run

#n0ha@one:~$ hcitool scan
Scanning ...
        00:16:B8:E7:D9:F4 W300i
#n0ha@one:~$ sudo hcitool cc 00:16:B8:E7:D9:F4

my phone and PC get successfully paired together. Nevertheless, when running gnome-obex-send and pressing 'Refresh' button, no devices are found. The Refresh button stays disabled.

Arkturus (akliuha) wrote :

Excactly the same in here.

akliuha@Helium:~$ hcitool scan
Scanning ...
        00:13:70:AC:19:D4 Nokia

Also I am able to sync my calendar with evolution through opensync/gnokii-plugin(over bluetooth) and xgnokii works fine through bluetooth.

Only gnome send/receive files over bluetooh does not work.

lilleswing (lilleswing) wrote :

Exactly the same

karl@BITE:~$ hcitool scan
Scanning ...
        00:19:2C:03:8D:FC Motorola Phone
        00:16:CF:FD:69:1B DELLBYTE

I'm able to recieve files on my computer just fine, but when I run gnome-obex-send it just searches forever.

loko (arph) wrote :

For me it is the same.

So i tried to install the bluetooth-thing from source.

i installed libbtctl 0.8.2 and also gnome-bluetooth 0.8

but this didn't help. if i run gnome-obex-send, the gui pop up, but no device is found.

Sometimes it is finding the bluetooth-mouse, but not the telephone, and sometimes it doesn't find anything.

Example, on the first run i get this:

user@user-laptop:~$ sudo gnome-obex-send
** Message: inquiry complete
conn_request: bdaddr 00:07:61:xx:xx:xx
conn_complete: status 0x00
** Message: device 00:07:61:xx:xx:xx Bluetooth Travel Mouse found
** Message: device 00:07:61:xx:xx:xx Bluetooth Travel Mouse found
conn_request: bdaddr 00:07:61:xx:xx:xx
conn_complete: status 0x00

but on the second run i get only this:

user@user-laptop:~$ sudo gnome-obex-send
** Message: inquiry complete

and thats all

TodTop (topalov1678) wrote :

Same Problem with gnome-bluetooth.

Bevor I use it with Dapper and register Bluetooth-Devices with gnome-bluetooth-manager, then send files with gnome-obex-send.

In Edgy is the gnome-bluetooth-manager no more Part of the Application.

When I try to refresh Devices in gnome-obex-send it just searches forever.

Otherwise is simply to send files with my Handy to Computer.

Onkar Shinde (onkarshinde) wrote :

to all those who are having problem,

There are two ways gnome-obex-send can be used. It can also be used from right click menu of a file.

Can someone of you try the 5th test at https://wiki.ubuntu.com/Bluetooth/TestPlan and see if GUI method passes?

Please read all the requisites before trying.

Arkturus (akliuha) wrote :

Thank you for showing the way to the test plan. I went through all the steps. The trick to get gnome-obex-send to work was to add "-d <btaddrs>" so for example "gnome-obex-send -d 00:16:70:C4:19:F5 test.jpg" works just fine. It used to work without the address.

The GUI method did not work. It has now bee searching for my phone for 5 minutes and still going (As in the animation is running. My bluetooth device stobbed blinking a while ago).

Arkturus (akliuha) wrote :

Now I got the GUI to work. When I use the send to-command and choose obex, it starts to search for devices. It won't find any devices until i try to connect to the computer from my phone. The connection attempt fails, but the send to prompt finds my phone. After that the file sending goes smoothly.

I can confirm this behaviour. Command line discovery and send works, but GUI is busted. It seems that bug #62944 (marked fix released) fixed it for somebody but ot for all of us.

Marcel Holtmann (holtmann) wrote :

This is a bug in the gnome-bluetooth code. You can issue "hciconfig hci0 inqmode" as root to set your device back into the inquiry results mode for Bluetooth 1.1 devices. Then it should find remote devices again.

To be 100% clear, this is a gnome-bluetooth bug and not an issue of the functionality of hcid.

I agree 100% with Marcel: this is (IMHO) a gnome-bluetooth bug, the underlying layer works pretty well. In effect, this bug is specify to "affect" gome-bluetooth, no?
Nevertheless, the same thing happens with kdebluetooth for example. So I do not know what to point exactly. Is there a mid layer between hci and GUI? Maybe dbus?

Moreover, it's a regression from Dapper, so I think it shld be marked at least of medium importance.

Marcel Holtmann (holtmann) wrote :

Starting with bluez-utils-3.x we set the adapter into Inquiry with RSSI if it supports it and most Bluetooth 1.2 or later ones do. So in this mode you will see HCI_Inquiry_Result_With_RSSI and no longer HCI_Inquiry_Result events. Since the gnome-bluetooth and kdebluetooth only listen to later one, they won't find any devices in range. The Linux kernel and the tools from bluez-utils are capable of handling this. In fact they already handle the HCI_Extended_Inquiry_Response that will be introduced with Bluetooth 2.1.

The regression is that bluez-utils-2.x kept the Bluetooth 1.1 inquiry mode, while bluez-utils-3.x will use the best possible mode.

NLoscalzo (nwloscalzo) wrote :

Same deal on my computer-

* Kensington USB Bluetooth Adapter
* Can see my Orange SPVC550 smartphone using HCITool scan
* Can pair (apparently) when initiated from the phone side. Notification area icon appears and asks for corresponding PIN
* Can send file to laptop when initiated on phone side
* Can't see anything in chooser dialog from gnome-phone-manager nor obex send utility (as per bug)

Running edgy on a Dell e1505 laptop.

Thanks !

Onkar Shinde (onkarshinde) wrote :

Marking it as confirmed since so many users have reported it.

Changed in gnome-bluetooth:
status: Unconfirmed → Confirmed
Onkar Shinde (onkarshinde) wrote :

@Marcel,

Since you are upstream author, do you have time to fix this?

Marcel Holtmann (holtmann) wrote :

I am not the upstream author of gnome-bluetooth. Otherwise, I would have already fixed this. The proper interface to use is the new D-Bus based API. It will take care of all this stuff.

Marcel: "hciconfig hci0 inqmode" -- does not issue gnome-obex-send dialog to find my phone, while I'm able to see it using "hcitool scan"

I can confirm that here on my Dell D600 Laptop using Edgy and trying to send some files to my Nokia N80 too. In order to send files, I need first to know the BT address of my mobile, using "hcitool scan" and then use that address on gnome-obex-send, eg: "gnome-obex-send -d <bt_address> file".

Changed in gnome-bluetooth:
assignee: nobody → bluetooth
François Montel (zerohalo) wrote :

I confirm this bug, running a clean install of edgy. gnome-obex-send only works from command line with -d <bt address> parameter. gnome-obex-send gui (or "sent to" from nautilus) will not discover the bt device (mine is a palm PDA).

I ran "sudo hciconfig hci0 inqmode" but that didn't fix the problem.

Since this is something that worked in Dapper and is broken in Edgy, I'd recommend setting this bug to a higher priority. Thank you!

Marcel Holtmann (holtmann) wrote :

You have to switch to the old inquiry mode with "sudo hciconfig hci0 inqmode 0". Starting with bluez-utils-3.x the best available inquiry mode will be selected by default and this is not gonna change. You have to fix gnome-bluetooth.

Christian Wolf (christianwolf) wrote :

In order to work around this problem, you therefore can add the hciconfig command that Marcel mentioned to /etc/rc.local, between the comments and the exit command.

See the atached example.

Martey Dodoo (martey) wrote :

I created <a href="http://bugzilla.gnome.org/show_bug.cgi?id=396194">upstream bug #396194</a> in hopes of helping to resolve this issue.

Loe Spee (lgespee) wrote :

I can also confirm this behavior.

* Scanning on the console with hcitool:
     $ hcitool scan
     Scanning ...
             00:17:4B:1D:0B:E9 Arthur Dent

  PASS

* Sending a file on the console with gnome-obex-send:
     $ gnome-obex-send --dest=00:17:4B:1D:0B:E9 filename.ext
     Browsing 00:17:4B:1D:0B:E9 ...
     Service Name: OBEX Object Push
     Service RecHandle: 0x10003
     Protocol Descriptor List:
       "L2CAP" (0x0100)
       "RFCOMM" (0x0003)
         Channel: 9
       "OBEX" (0x0008)
     Service Class ID List:
       "OBEX Object Push" (0x1105)
     ** Message: device 00:17:4B:1D:0B:E9 (OBEX Object Push) port 9

  PASS

* Scanning with the GUI:
     1) $ gnome-obex-send
     2) Press the "Refresh" button

  FAIL

No devices are found, however the led on the bluetooth dongle changes from blinking to constant lighting when the "Refresh" button is pressed. It changes back to blinking however after a few minutes and no devices are found.

ThomasDahlmann (tdd-lnxgeek) wrote :

Running the command:
hciconfig hci0 inqmode 0

fixes the issue for me. I can now see and select devices in sight and send files.

Loe Spee (lgespee) wrote :

Thanks Thomas Dahlmann,

That did also fix the issue for me, except for the fact that scanning using hcitool is still a lot faster. But at least I can send files now from Nautilus :).

ThomasDahlmann (tdd-lnxgeek) wrote :

Any time ;ø)

Still my Ubuntu desktop is way faster than my Windows.

It's a pain every time you have to do the "cli solution" to get something at the desktop working. I like the idea of having a cli backup but the GUI should also work, it is a desktop non the less.

Alessio Caiazza (nolith) wrote :

Same problem on my ibook g4 with feisty.
From CLI works correcly, from GUI not.
The rc.local hacks fixed the problem.

Littleiffel (thierry-nicola) wrote :

I had the same problem using a Thinkpad x60. Running the command
hciconfig hci0 inqmode 0
solved the problem.

The "rc.local hack" makes the job after every restart...

Markus Golser (golserma) wrote :

Same Problem here the rc.local workaround works for me!

Jason (jasonxh) wrote :

Exactly the same here. Why is nobody fixing it for over 4 months?

Ciddan (ciddan) wrote :

I ran into this bug yesterday - I can absolutley confirm the bug. The inqmode 0 didn't seem to do anything for me - I'll test the rc.local hack later today and see if it does the trick. It's kinda wierd that this hasn't been fixed yet. Really old bug plus it seems to be an easy fix, at least from what Marcel Holtmann has said about it.

Stephan Elsner (elsni) wrote :

I have the same problem. But sudo hciconfig hci0 inqmode 0 does not work for me, it says:
Can't set inquiry mode on hci0: Input/output error (5)

I have a tecom usb bluetooth stick with broadcom chip

Mario Limonciello (superm1) wrote :

Hi guys, gnome-obex-send is no longer available as of Hardy (functionality is in bluez now), so i'm going to close this bug. If issues persist with bluez, please file a bug against that project.

Changed in gnome-bluetooth:
status: Confirmed → Won't Fix
Przemek K. (azrael) on 2009-12-17
Changed in gnome-bluetooth (Baltix):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers