Hearts crashes on startup

Bug #65274 reported by Theo van Klaveren
16
Affects Status Importance Assigned to Milestone
gnome-hearts (Ubuntu)
Fix Released
High
Nafallo Bjälevik

Bug Description

Binary package hint: gnome-hearts

GNOME Hearts crashes on startup in edgy. Backtrace:

#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb744e34b in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb7f2a1b6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3 <signal handler called>
#4 0x0804e068 in cards_image_set_size ()
#5 0x0804ec67 in on_configure_event ()
#6 0xb7a4cb00 in _gtk_marshal_BOOLEAN__BOXED ()
   from /usr/lib/libgtk-x11-2.0.so.0
#7 0xb751c79b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#8 0xb752cb93 in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
#9 0xb752de7f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#10 0xb752e279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#11 0xb7b605f8 in gtk_widget_get_default_style ()
   from /usr/lib/libgtk-x11-2.0.so.0
#12 0xb79ca240 in gtk_drawing_area_new () from /usr/lib/libgtk-x11-2.0.so.0
#13 0xb7529199 in g_cclosure_marshal_VOID__BOXED ()
   from /usr/lib/libgobject-2.0.so.0
#14 0xb751afb9 in g_value_set_boxed () from /usr/lib/libgobject-2.0.so.0
#15 0xb751c87d in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#16 0xb752d02a in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
#17 0xb752e0b7 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#18 0xb752e279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#19 0xb7b657ea in gtk_widget_size_allocate ()
   from /usr/lib/libgtk-x11-2.0.so.0
#20 0xb7b5c1b2 in gtk_vbox_new () from /usr/lib/libgtk-x11-2.0.so.0
#21 0xb7529199 in g_cclosure_marshal_VOID__BOXED ()
   from /usr/lib/libgobject-2.0.so.0
#22 0xb751afb9 in g_value_set_boxed () from /usr/lib/libgobject-2.0.so.0
#23 0xb751c87d in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#24 0xb752d02a in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
#25 0xb752e0b7 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#26 0xb752e279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#27 0xb7b657ea in gtk_widget_size_allocate ()
   from /usr/lib/libgtk-x11-2.0.so.0
#28 0xb7b75b91 in gtk_window_new () from /usr/lib/libgtk-x11-2.0.so.0
#29 0xb7529199 in g_cclosure_marshal_VOID__BOXED ()
   from /usr/lib/libgobject-2.0.so.0
#30 0xb751afb9 in g_value_set_boxed () from /usr/lib/libgobject-2.0.so.0
#31 0xb751c79b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#32 0xb752d02a in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
#33 0xb752e0b7 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#34 0xb752e279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#35 0xb7b657ea in gtk_widget_size_allocate ()
   from /usr/lib/libgtk-x11-2.0.so.0
#36 0xb79b774c in gtk_container_resize_children ()
   from /usr/lib/libgtk-x11-2.0.so.0
#37 0xb7b75df4 in gtk_window_new () from /usr/lib/libgtk-x11-2.0.so.0
#38 0xb7529b29 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#39 0xb751afb9 in g_value_set_boxed () from /usr/lib/libgobject-2.0.so.0
#40 0xb751c79b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#41 0xb752d1e3 in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
#42 0xb752e0b7 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#43 0xb752e279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#44 0xb79b77e3 in gtk_container_check_resize ()
   from /usr/lib/libgtk-x11-2.0.so.0
#45 0xb79b7863 in gtk_container_check_resize ()
   from /usr/lib/libgtk-x11-2.0.so.0
#46 0xb74a2aa1 in g_source_is_destroyed () from /usr/lib/libglib-2.0.so.0
#47 0xb74a4802 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#48 0xb74a77df in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#49 0xb74a7b89 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#50 0xb7a47574 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#51 0x08051f42 in main ()

Thread 1 (Thread -1225300304 (LWP 12933)):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb744e34b in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#2 0xb7f2a1b6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3 <signal handler called>
No symbol table info available.
#4 0x0804e068 in cards_image_set_size ()
No symbol table info available.
#5 0x0804ec67 in on_configure_event ()
No symbol table info available.
#6 0xb7a4cb00 in _gtk_marshal_BOOLEAN__BOXED ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#7 0xb751c79b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#8 0xb752cb93 in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#9 0xb752de7f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#10 0xb752e279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#11 0xb7b605f8 in gtk_widget_get_default_style ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#12 0xb79ca240 in gtk_drawing_area_new () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#13 0xb7529199 in g_cclosure_marshal_VOID__BOXED ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#14 0xb751afb9 in g_value_set_boxed () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#15 0xb751c87d in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#16 0xb752d02a in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#17 0xb752e0b7 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#18 0xb752e279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#19 0xb7b657ea in gtk_widget_size_allocate ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#20 0xb7b5c1b2 in gtk_vbox_new () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#21 0xb7529199 in g_cclosure_marshal_VOID__BOXED ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#22 0xb751afb9 in g_value_set_boxed () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#23 0xb751c87d in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#24 0xb752d02a in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#25 0xb752e0b7 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#26 0xb752e279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#27 0xb7b657ea in gtk_widget_size_allocate ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#28 0xb7b75b91 in gtk_window_new () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#29 0xb7529199 in g_cclosure_marshal_VOID__BOXED ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#30 0xb751afb9 in g_value_set_boxed () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#31 0xb751c79b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#32 0xb752d02a in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#33 0xb752e0b7 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#34 0xb752e279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#35 0xb7b657ea in gtk_widget_size_allocate ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#36 0xb79b774c in gtk_container_resize_children ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#37 0xb7b75df4 in gtk_window_new () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#38 0xb7529b29 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#39 0xb751afb9 in g_value_set_boxed () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#40 0xb751c79b in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#41 0xb752d1e3 in g_signal_chain_from_overridden ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#42 0xb752e0b7 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#43 0xb752e279 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#44 0xb79b77e3 in gtk_container_check_resize ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#45 0xb79b7863 in gtk_container_check_resize ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#46 0xb74a2aa1 in g_source_is_destroyed () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#47 0xb74a4802 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#48 0xb74a77df in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#49 0xb74a7b89 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#50 0xb7a47574 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#51 0x08051f42 in main ()
No symbol table info available.
#0 0xffffe410 in __kernel_vsyscall ()

Revision history for this message
Vassilis Pandis (pandisv) wrote :

I can reproduce this with 0.1.2-1ubuntu1 too (x86).

Changed in gnome-hearts:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Revision history for this message
Vassilis Pandis (pandisv) wrote :
Changed in gnome-hearts:
assignee: nobody → motu
importance: Medium → High
Revision history for this message
Sander Marechal (s-marechal) wrote :

Hello.

Hearts crashes due to a change in the gnome-games card styles. bonded.png was replaced by bonded.svg and hearts uses bonded.png as the default cardset. When it can't find it, the game crashes.

I'm attaching a quick patch written by Andreas Henriksson on Debian BTS. I'm working on gnome-hearts-0.1.3 which should remove the crashing behaviour alltogether.

Or, simply sync to get gnome-hearts-0.1.2-2 from Debian.

Revision history for this message
Nafallo Bjälevik (nafallo) wrote :

I simply added the patch pointed to by Sander. Okey to upload to edgy-updates?

Changed in gnome-hearts:
assignee: motu → nafallo
status: Confirmed → Fix Committed
Revision history for this message
Nafallo Bjälevik (nafallo) wrote :

I've put source and packages for amd64 and i386 on my personal repo:
deb http://repo.nafallo.info/foo ./

Revision history for this message
Daniel Holbach (dholbach) wrote :

The policy at http://wiki.ubuntu.com/MOTU/SRU will be ready by the weekend.

Revision history for this message
StefanPotyra (sistpoty) wrote :

^^ please file an SRU-Request ;)

Cheers,
    Stefan.

Revision history for this message
Sander Marechal (s-marechal) wrote :

gnome-hearts-0.1.3 was just uploaded to Debian unstable. This fixes the bug in a proper manner. The patch I pointed to earlier makes gnome-hearts load slowly because two card styles will be loaded at startup: the one from the conf file and a backup style. With some svg's taking 10 seconds to load on my amd64 this isn't very friendly to the end-user. 0.1.3 only loads a backup style when the configured one cannot be loaded. It also adds the same behaviour to background images.

Just sync gnome-hearts-0.1.3 from debian, apply the ubuntu patch (replaces the gnome-cards-data dependency with gnome-games-data) and all should be well.

Revision history for this message
Michael Bienia (geser) wrote :

gnome-hearts 0.1.3-1ubuntu1 got uploaded to feisty.

Revision history for this message
Sander Marechal (s-marechal) wrote :

Great. Will it be put in Edgy too? Because the patch I pointed to in the 3rd comment is a quick dirty patch that needs a proper fix.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Hi,

as mentioned earlier, it would be good to have the infos from the sru-request (as in debdiff, how has the bug been adressed). Christian, are you working on this?

Cheers,
     Stefan.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Hi,

I'm unsubscribing motu-sru now. Please resubscribe us, once you've got a debdiff at hand.

Thanks,
    Stefan.

Revision history for this message
Justin Chudgar (justinzane) wrote :

Still happening with 0.1.3-1 in Fiesty. Info attached and below.

root@justin01:/home/justin# dpkg -l | grep hearts
ii gnome-hearts 0.1.3-1ubuntu1 The classic hearts card game for the GNOME d

root@justin01:/home/justin# uname -a
Linux justin01 2.6.19-7-generic #2 SMP Wed Nov 29 04:57:58 UTC 2006 i686 GNU/Linux

Revision history for this message
Sander Marechal (s-marechal) wrote :

It doesn't look like the same bug to me. This bug is about a crash because the card style or background image specified in ~/.gnome-hearts.cnf doesn't exist. Your crash seems to happen when it tries to add a style to the hashmap. Please check if the two files mentioned in your ~/.gnome-hearts.cnf exist on your system. If they do, this is a new bug. Please refile.

If you want a fresh .cnf, just delete the one in your home directory and rerun hearts. It will create a fresh .cnf for you.

Revision history for this message
Sander Marechal (s-marechal) wrote :

The bug is caused by the 01_gnome_cards_data.patch in debian/patches -- a patch that Ubuntu shouldn't be using anyway since it doesn't have gnome-cards-data to start with.

See: http://bugzilla.jejik.com/show_bug.cgi?id=13

I'll build gnome-hearts-0.1.3-2 for Debian tonight. Ubuntu can either sync from that or drop the gnome-cards-data patch alltogether.

Revision history for this message
Sander Marechal (s-marechal) wrote :

Ubuntu could sync from the Dapper packages I made that don't carry the gnome-cards-data patch and rely on gnome-games-data instead. You can find them at http://packages.jejik.com/ubuntu

PS: Who is the gnome-hearts package maintainer for Ubuntu?

Revision history for this message
Sander Marechal (s-marechal) wrote :

gnome-hearts_0.1.3-2 is available in Debian/unstable.

Revision history for this message
ville palo (vi64pa) wrote :

Packages in ubuntu universe are maintained by MOTU-team https://wiki.ubuntu.com/MOTU/.

gnome-hearts_0.1.3-2 should be merged from debian to feisty.

Revision history for this message
Michael Bienia (geser) wrote :

Sync requested for gnome hearts 0.1.3-2 from Debian (bug #76991).

Revision history for this message
Conrad Knauer (atheoi) wrote :

I just upgraded to Feisty's 0.1.3-2 and it works great, thanks!

Revision history for this message
ville palo (vi64pa) wrote :

SRU Request: Bug #79059

Revision history for this message
ville palo (vi64pa) wrote :

gnome-hearts 0.1.2-1ubuntu1.1~proposed1 in now in edgy proposed repos, please test it and if it works add a comment "Works for me" to SRU Request: Bug #79059

Revision history for this message
Barry deFreese (bddebian) wrote :

A fix has been released so I am closing this bug. If you have an issue with the updated package, please respond to this bug: https://bugs.launchpad.net/bugs/79059

Thank you.

Changed in gnome-hearts:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers