gnome-menus doesn't send notification for new .desktop files

Bug #64264 reported by Chris Lord on 2006-10-05
40
Affects Status Importance Assigned to Milestone
gnome-menus
Unknown
Medium
gnome-menus (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: alacarte

If you add/edit menus in Edgy, the menu shown in alacarte isn't updated until you reload alacarte and the actual gnome menu isn't updated until either a package upgrade updates it or you kill gnome-panel.

Related branches

Travis Watkins (amaranth) wrote :

Alacarte and the menu both get their updates from gnome-menus.

Pete Ryland (pdr) wrote :

Ok, I've been looking at this and I think I've worked out what is going wrong. It is indeed in gnome-menus, and it's not passing on the notifications from gnome-vfs that the .desktop files have been created/changed/etc. I'll post a patch shortly. This will also close five or six other duplicate bugs.

Changed in gnome-menus:
assignee: nobody → pdr
status: Unconfirmed → Confirmed
Pete Ryland (pdr) wrote :

Ok, here is the patch. This seems to make everything work as it should.

Pete Ryland (pdr) wrote :

And here is another patch, which fixes the handling of .desktop files with a space in their name (amongst other uri-encodable characters). The problem was that gnomvfs converts spaces to %20 encoding. I've fixed this by using gnomevfs's helper functions to do the encoding and decoding.

Sebastien Bacher (seb128) wrote :

Pete, thanks for your work on that. What was that gnome-menus upload you did for edgy (which is frozen)?

Wouter Bolsterlee (uws) wrote :

Could you please use unified diff (diff -u) when sending diffs? (also to gnome mailing lists)

Pete Ryland (pdr) wrote :

Seb, no problems. The upload I tried to make was just for the above two patches. I put the first one into the debian/patches directory as 11_desktop_notifications.patch and the second one was simply applied (to the gnomevfs patch). I should have known it wasn't going to work. :-/ I can send you a debdiff or something if you like.

Sebastien Bacher (seb128) wrote :

attaching a "diff -u" version of the patches to the bug would be nice

Changed in gnome-menus:
status: Unknown → Unconfirmed
Sebastien Bacher (seb128) wrote :

Comment from upstream:

"Doesn't look right to me.

Take the simple case of a .desktop file being deleted. We only want to invoke
the monitors if something has actually changed in our view of the world, so we
only want to invoke monitors if cached_dir_remove_entry() returns TRUE

Also marking this bug as NEEDINFO, as there isn't enough info for me to figure
out the bug myself - e.g. what exactly is alacarte doing when you copy an item,
what does the gnome-menus verbose log show etc. ?"

Changed in gnome-menus:
status: Unconfirmed → Needs Info
Philip Paquette (pcpaquette) wrote :

Subscribing Travis Watkins to this bug, since upstream developers have marked this bug as "Needs Info" in February and Travis is probably the person who can answer best the question: "what exactly is alacarte doing when you copy an item, what does the gnome-menus verbose log show etc. ?""

Changed in gnome-menus:
importance: Undecided → Low
Changed in gnome-menus:
status: Needs Info → Rejected
Changed in gnome-menus:
importance: Low → Medium
Changed in gnome-menus:
assignee: pdr → desktop-bugs
Sebastien Bacher (seb128) wrote :

gnome-menus (2.19.90-0ubuntu2) gutsy; urgency=low

  * debian/patches/07_gnomevfs.patch:
    - patch change by Pete Ryland, fix notification for path with spaces
      and special chars (LP: #64264)

 -- Sebastien Bacher <email address hidden> Fri, 24 Aug 2007 15:48:17 +0200

Changed in gnome-menus:
status: Confirmed → Fix Released
Changed in gnome-menus:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.