Change log for gnome-online-accounts package in Ubuntu

175 of 89 results
Published in focal-release on 2019-11-15
Deleted in focal-proposed (Reason: moved to Release)
gnome-online-accounts (3.34.1-1ubuntu1) focal; urgency=medium

  * Merge with debian, remaining changes:
    + debian/rules:
      - Make sure that gnome-online-accounts.pot is refreshed so the
        strings from 0001-ubuntu-sso-provider.patch are included (LP: #1759251).
      - Build with --enable-ubuntu-sso
    + debian/control.*:
      - Add b-d on libsnapd-glib-dev
      - depends on python3 and python3-macaroonbakery for the ubuntu sso
        provider.
    + debian/gnome-online-accounts.install:
      install usr/share/goa-1.0/scripts/lpa_helper.py
    + debian/libgoa-backend-1.0-1.symbols:
      Add goa_ubuntu_sso_provider_get_type
    + Ubuntu-specific patches:
      - debian/patches/0001-ubuntu-sso-provider.patch
      - debian/patches/0002-livepatch-auth.patch

 -- Sebastien Bacher <email address hidden>  Tue, 05 Nov 2019 16:23:32 +0100

Available diffs

Superseded in focal-release on 2019-11-15
Published in eoan-release on 2019-09-15
Deleted in eoan-proposed (Reason: moved to release)
gnome-online-accounts (3.34.0-1ubuntu1) eoan; urgency=medium

  * Merge with debian, remaining changes:
    + debian/rules:
      - Make sure that gnome-online-accounts.pot is refreshed so the
        strings from 0001-ubuntu-sso-provider.patch are included (LP: #1759251).
      - Build with --enable-ubuntu-sso
    + debian/control.*:
      - Add b-d on libsnapd-glib-dev
      - depends on python3 and python3-macaroonbakery for the ubuntu sso
        provider.
    + debian/gnome-online-accounts.install:
      install usr/share/goa-1.0/scripts/lpa_helper.py
    + debian/libgoa-backend-1.0-1.symbols:
      Add goa_ubuntu_sso_provider_get_type
    + Ubuntu-specific patches:
      - debian/patches/0001-ubuntu-sso-provider.patch
      - debian/patches/0002-livepatch-auth.patch

 -- Sebastien Bacher <email address hidden>  Fri, 13 Sep 2019 16:23:06 +0200

Available diffs

Superseded in eoan-release on 2019-09-15
Deleted in eoan-proposed on 2019-09-17 (Reason: moved to release)
gnome-online-accounts (3.33.91-1ubuntu1) eoan; urgency=medium

  * Merge with debian, remaining changes:
    + debian/rules:
      - Make sure that gnome-online-accounts.pot is refreshed so the
        strings from 0001-ubuntu-sso-provider.patch are included (LP: #1759251).
      - Build with --enable-ubuntu-sso
    + debian/control.*:
      - Add b-d on libsnapd-glib-dev
      - depends on python3 and python3-macaroonbakery for the ubuntu sso
        provider.
    + debian/gnome-online-accounts.install:
      install usr/share/goa-1.0/scripts/lpa_helper.py
    + debian/libgoa-backend-1.0-1.symbols:
      Add goa_ubuntu_sso_provider_get_type
    + Ubuntu-specific patches:
      - debian/patches/0001-ubuntu-sso-provider.patch
      - debian/patches/0002-livepatch-auth.patch
  * Refresh patches

Superseded in eoan-release on 2019-08-25
Published in disco-release on 2019-04-03
Deleted in disco-proposed (Reason: moved to release)
gnome-online-accounts (3.32.0-1ubuntu1) disco; urgency=medium

  * Update to the stable version, based on the Debian update

Available diffs

Superseded in disco-release on 2019-04-03
Deleted in disco-proposed on 2019-04-05 (Reason: moved to release)
gnome-online-accounts (3.31.90-1ubuntu1) disco; urgency=medium

  * Resynchronize on Debian (LP: #1815317), remaining changes:
    + debian/rules:
      - Make sure that gnome-online-accounts.pot is refreshed so the
        strings from 0001-ubuntu-sso-provider.patch are included (LP: #1759251).
      - Build with --enable-ubuntu-sso
    + debian/control.*:
      - Add b-d on libsnapd-glib-dev
      - depends on python3 and python3-macaroonbakery for the ubuntu sso
        provider.
    + debian/gnome-online-accounts.install:
      install usr/share/goa-1.0/scripts/lpa_helper.py
    + debian/libgoa-backend-1.0-1.symbols:
      Add goa_ubuntu_sso_provider_get_type
    + Ubuntu-specific patches:
      - debian/patches/0001-ubuntu-sso-provider.patch
      - debian/patches/0002-livepatch-auth.patch
  * debian/patches/0001-ubuntu-sso-provider.patch:
    - Move from binary icons to svg ones.
  * debian/patches/0001-Add-Ubuntu-Single-Sign-on-icons.patch:
    - Drop the patch because no longer required. The icons are now included in
      the above d/p/0001-ubuntu-sso-provider.patch as svg (non binary) images.
  * debian/patches/0002-livepatch-auth.patch:
    - Refreshed using gbp pq rebase.
  * debian/source/include-binaries:
    - Drop as no longer required. Binary images have been removed from distro
      patches.

Available diffs

Superseded in disco-release on 2019-02-15
Deleted in disco-proposed on 2019-02-16 (Reason: moved to release)
gnome-online-accounts (3.30.1-1ubuntu1) disco; urgency=medium

  * Resynchronize on Debian, remaining changes:
    + debian/rules:
      - Make sure that gnome-online-accounts.pot is refreshed so the
        strings from 0001-ubuntu-sso-provider.patch are included (LP: #1759251).
      - Build with --enable-ubuntu-sso
    + debian/control.*:
      - Add b-d on libsnapd-glib-dev
      - depends on python3 and python3-macaroonbakery for the ubuntu sso
        provider.
    + debian/gbp.conf:
      - Set the upstream branch to upstream/latest.
    + debian/gnome-online-accounts.install:
      install usr/share/goa-1.0/scripts/lpa_helper.py
    + debian/libgoa-backend-1.0-1.symbols:
      Add goa_ubuntu_sso_provider_get_type
    + debian/source/include-binaries:
      Add debian/patches/0001-Add-Ubuntu-Single-Sign-on-icons.patch to properly
      deal with new binary images.
    + Ubuntu-specific patches:
      - debian/patches/0001-Add-Ubuntu-Single-Sign-on-icons.patch
      - debian/patches/0001-ubuntu-sso-provider.patch
      - debian/patches/0002-livepatch-auth.patch
  * debian/patches/0001-ubuntu-sso-provider.patch:
  * debian/patches/0001-Add-Ubuntu-Single-Sign-on-icons.patch:
    - Split the patch in order to separate the binary files from the non-binary
      ones.

Available diffs

Superseded in disco-release on 2019-01-24
Published in cosmic-release on 2018-09-03
Deleted in cosmic-proposed (Reason: moved to release)
gnome-online-accounts (3.30.0-1ubuntu1) cosmic; urgency=medium

  * Merge from Debian unstable (LP: #1790458). Remaining changes:
    + debian/rules:
      - Make sure that gnome-online-accounts.pot is refreshed so the
        strings from 0001-ubuntu-sso-provider.patch are included (LP: #1759251).
      - Build with --enable-ubuntu-sso
    + debian/control.*:
      - Add b-d on libsnapd-glib-dev
      - depends on python3 and python3-macaroonbakery for the ubuntu sso
        provider.
    + debian/gbp.conf:
      - Set the upstream branch to upstream/latest.
    + debian/gnome-online-accounts.install:
      install usr/share/goa-1.0/scripts/lpa_helper.py
    + debian/libgoa-backend-1.0-1.symbols:
      Add goa_ubuntu_sso_provider_get_type
    + debian/source/include-binaries:
      Add debian/patches/0001-Add-Ubuntu-Single-Sign-on-icons.patch to properly
      deal with new binary images.
    + Ubuntu-specific patches:
      - debian/patches/0001-Add-Ubuntu-Single-Sign-on-icons.patch
      - debian/patches/0001-ubuntu-sso-provider.patch
      - debian/patches/0002-livepatch-auth.patch
  * debian/patches/0001-ubuntu-sso-provider.patch:
  * debian/patches/0001-Add-Ubuntu-Single-Sign-on-icons.patch:
    - Split the patch in order to separate the binary files from the non-binary
      ones.

Superseded in cosmic-release on 2018-09-03
Deleted in cosmic-proposed on 2018-09-04 (Reason: moved to release)
gnome-online-accounts (3.29.91-1ubuntu2) cosmic; urgency=medium

  * debian/control*:
    - Bump libsnapd-glib-dev to (>= 1.43).
  * debian/patches/0001-ubuntu-sso-provider.patch:
    - Use SNAPD_ERROR_AUTH_CANCELLED instead of SNAPD_ERROR_PERMISSION_DENIED
      to understand if Polkit dialog was dimissed by the user.

 -- Andrea Azzarone <email address hidden>  Fri, 24 Aug 2018 11:49:17 +0200
Superseded in cosmic-proposed on 2018-08-24
gnome-online-accounts (3.29.91-1ubuntu1) cosmic; urgency=medium

  * Merge from Debian experimental (LP: #1788130). Remaining changes:
    + debian/rules:
      - Make sure that gnome-online-accounts.pot is refreshed so the
        strings from 0001-ubuntu-sso-provider.patch are included (LP: #1759251).
      - Build with --enable-ubuntu-sso
    + debian/control.*:
      - Add b-d on libsnapd-glib-dev
      - depends on python3 and python3-macaroonbakery for the ubuntu sso
        provider.
    + debian/gbp.conf:
      - Set the upstream branch to upstream/latest.
    + debian/gnome-online-accounts.install:
      install usr/share/goa-1.0/scripts/lpa_helper.py
    + debian/libgoa-backend-1.0-1.symbols:
      Add goa_ubuntu_sso_provider_get_type
    + debian/source/include-binaries:
      Add debian/patches/0001-ubuntu-sso-provider.patch to properly deal with
      new binary images.
    + Ubuntu-specific patches:
      - debian/patches/0001-ubuntu-sso-provider.patch
      - debian/patches/0002-livepatch-auth

Published in bionic-updates on 2018-06-21
Deleted in bionic-proposed (Reason: moved to -updates)
gnome-online-accounts (3.28.0-0ubuntu2.1) bionic-proposed; urgency=medium

  * debian/patches/0001-ubuntu-sso-provider.patch: Add a link to the
    link to the privacy policy in U1 login dialog (LP: #1773213).
  * debian/patches/0002-livepatch-auth: Refresh patch.

 -- Andrea Azzarone <email address hidden>  Fri, 25 May 2018 09:04:11 -0500
Superseded in cosmic-release on 2018-08-25
Deleted in cosmic-proposed on 2018-08-26 (Reason: moved to release)
gnome-online-accounts (3.28.0-0ubuntu3) cosmic; urgency=medium

  * debian/patches/0001-ubuntu-sso-provider.patch: Add a link to the
    link to the privacy policy in U1 login dialog (LP: #1773213).
  * debian/patches/0002-livepatch-auth: Refresh patch.

 -- Andrea Azzarone <email address hidden>  Fri, 25 May 2018 09:04:11 -0500
Superseded in cosmic-release on 2018-06-08
Published in bionic-release on 2018-04-18
Deleted in bionic-proposed (Reason: moved to release)
gnome-online-accounts (3.28.0-0ubuntu2) bionic; urgency=medium

  * debian/patches/0002-livepatch-auth: Don't show an error message if the
    polkit authentication dialog is dimissed by the user (LP: #1764989).

 -- Andrea Azzarone <email address hidden>  Wed, 18 Apr 2018 16:52:39 +0200
Superseded in bionic-release on 2018-04-18
Deleted in bionic-proposed on 2018-04-20 (Reason: moved to release)
gnome-online-accounts (3.28.0-0ubuntu1) bionic; urgency=medium

  * New upstream release

 -- Jeremy Bicha <email address hidden>  Fri, 13 Apr 2018 14:33:07 -0400
Superseded in bionic-release on 2018-04-14
Deleted in bionic-proposed on 2018-04-15 (Reason: moved to release)
gnome-online-accounts (3.27.92-1ubuntu3) bionic; urgency=medium

  * debian/rules:
    Make sure that gnome-online-accounts.pot is refreshed so the
    strings from 0001-ubuntu-sso-provider.patch are included
    (LP: #1759251).

 -- Gunnar Hjalmarsson <email address hidden>  Tue, 27 Mar 2018 23:17:00 +0200
Superseded in bionic-release on 2018-03-29
Deleted in bionic-proposed on 2018-03-30 (Reason: moved to release)
gnome-online-accounts (3.27.92-1ubuntu2) bionic; urgency=medium

  * debian/patches/0002-livepatch-auth:
    clear the otp text entry when a second otp is required (LP: #1757444)

 -- Andrea Azzarone <email address hidden>  Wed, 21 Mar 2018 15:19:11 +0100
Superseded in bionic-proposed on 2018-03-22
gnome-online-accounts (3.27.92-1ubuntu1) bionic; urgency=medium

  * debian/control.in:
    - Add b-d on libsnapd-glib-dev
    - depends on python3-macaroonbakery for the ubuntu sso provide
  * debian/gnome-online-accounts.install:
    install usr/share/goa-1.0/scripts/lpa_helper.py
  * debian/libgoa-backend-1.0-1.symbols:
    Add goa_ubuntu_sso_provider_get_type
  * debian/patches/0001-ubuntu-sso-provider.patch:
    Add an Ubuntu Single Sing-On provider (lp: #1752472)
  * debian/patches/0002-livepatch-auth:
    Get the Canonical Livepatch authentication token.
  * debian/rules:
    Build with --enable-ubuntu-sso
  * debian/source/include-binaries:
    Add debian/patches/0001-ubuntu-sso-provider.patch to properly deal with
    new binary images.

 -- Andrea Azzarone <email address hidden>  Tue, 06 Mar 2018 08:46:07 +0100
Superseded in bionic-release on 2018-03-26
Deleted in bionic-proposed on 2018-03-27 (Reason: moved to release)
gnome-online-accounts (3.27.92-1) unstable; urgency=medium

  * New upstream release candidate
  * Release to unstable

 -- Jeremy Bicha <email address hidden>  Mon, 05 Mar 2018 14:24:07 -0500

Available diffs

Superseded in bionic-release on 2018-03-06
Deleted in bionic-proposed on 2018-03-07 (Reason: moved to release)
gnome-online-accounts (3.27.3-1) experimental; urgency=medium

  * New upstream development release
  * Drop obsolete Build-Depends on gnome-common & intltool (Closes: #829843)
  * Bump minimum libwebkit2gtk4.0-dev to 2.12.0
  * Build-Depend on autoconf-archive
  * Drop telepathy support. It will be completely removed in 3.29 anyway.
  * Update symbols for removed "private" backend symbols

 -- Jeremy Bicha <email address hidden>  Tue, 20 Feb 2018 19:52:24 -0500

Available diffs

Superseded in bionic-release on 2018-02-21
Deleted in bionic-proposed on 2018-02-22 (Reason: moved to release)
gnome-online-accounts (3.26.2-2) unstable; urgency=medium

  * Update Vcs fields for migration to https://salsa.debian.org/
  * Use dh_missing --fail-missing
  * Don't enable Media Server option and drop dleyna-server recommends.
    It is an experimental untested feature that was only used in GNOME
    Photos and the GNOME Photos maintainer recommended we disable it.
    (LP: #1738448)

 -- Jeremy Bicha <email address hidden>  Thu, 01 Feb 2018 20:29:48 -0500

Available diffs

Superseded in bionic-release on 2018-02-02
Deleted in bionic-proposed on 2018-02-03 (Reason: moved to release)
gnome-online-accounts (3.26.2-1) unstable; urgency=medium

  * New upstream release
  * Update Vcs fields for conversion to git
  * Add debian/gbp.conf
  * Bump Standards-Version to 4.1.2
  * Mark libgoa-1.0-doc as Multi-Arch: foreign
  * Add all of m4/ (except ax_config_dir.m4) to Files-Excluded so that
    we use the system versions instead
  * debian/libgoa-backend-1.0-1.symbols:
    Drop realmd symbols. The backend library is a "private" API
  * Don't recommend realmd: libkrb is used directly instead now.
  * Don't recommend dleyna-server on Ubuntu since it's in universe.

 -- Jeremy Bicha <email address hidden>  Fri, 15 Dec 2017 11:54:46 -0500
Superseded in bionic-release on 2017-12-16
Published in artful-release on 2017-10-04
Deleted in artful-proposed (Reason: moved to release)
gnome-online-accounts (3.26.1-1ubuntu1) artful; urgency=medium

  * Sync with Debian. Remaining changes:
    - Suggest instead of recommend dleyna-server and realmd

Superseded in artful-release on 2017-10-04
Deleted in artful-proposed on 2017-10-05 (Reason: moved to release)
gnome-online-accounts (3.26.0-1ubuntu1) artful; urgency=medium

  * Sync with Debian. Remaining changes:
    - Suggest instead of recommend dleyna-server and realmd

Superseded in artful-release on 2017-09-18
Deleted in artful-proposed on 2017-09-19 (Reason: moved to release)
gnome-online-accounts (3.25.92-1ubuntu1) artful; urgency=medium

  * Sync with Debian. Remaining changes:
    - Suggest instead of recommend dleyna-server and realmd

Superseded in artful-release on 2017-09-06
Deleted in artful-proposed on 2017-09-08 (Reason: moved to release)
gnome-online-accounts (3.25.90-0ubuntu1) artful; urgency=medium

  * New upstream release
    - Fix Facebook login (LP: #1709621)
  * debian/control.in:
    - Bump minimum libglib2.0-dev to 2.52
  * debian/rules: Explicitly enable Todoist and Telepathy
  * Add new symbols and drop 2 apparently unused symbols
    that are part of the "private" API
    - goa_oauth2_provider_get_authentication_cookie
    - goa_oauth_provider_get_authentication_cookie

 -- Jeremy Bicha <email address hidden>  Wed, 09 Aug 2017 10:02:07 -0400

Available diffs

Superseded in artful-release on 2017-08-09
Deleted in artful-proposed on 2017-08-11 (Reason: moved to release)
gnome-online-accounts (3.24.1-0ubuntu1) artful; urgency=medium

  * New upstream translations release

 -- Jeremy Bicha <email address hidden>  Sun, 23 Jul 2017 18:27:20 -0400
Superseded in artful-release on 2017-07-24
Deleted in artful-proposed on 2017-07-26 (Reason: moved to release)
gnome-online-accounts (3.24.0-0ubuntu2) artful; urgency=medium

  [ Ken VanDine ]
  * debian/control.in:
    - Drop dleyna-server from a recommends to a suggests

  [ Jeremy Bicha ]
  * debian/control.in:
    - Drop realmd from a recommends to a suggests

 -- Jeremy Bicha <email address hidden>  Tue, 25 Apr 2017 22:25:19 -0400

Available diffs

Superseded in artful-release on 2017-04-26
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
gnome-online-accounts (3.24.0-0ubuntu1) zesty; urgency=medium

  * New upstream translations release

 -- Jeremy Bicha <email address hidden>  Tue, 21 Mar 2017 14:46:24 -0400
Superseded in zesty-release on 2017-03-23
Deleted in zesty-proposed on 2017-04-07 (Reason: moved to release)
gnome-online-accounts (3.23.92-0ubuntu1) zesty; urgency=medium

  * New upstream release

 -- Jeremy Bicha <email address hidden>  Thu, 16 Mar 2017 20:36:05 -0400
Superseded in zesty-release on 2017-03-17
Deleted in zesty-proposed on 2017-03-18 (Reason: moved to release)
gnome-online-accounts (3.23.91-0ubuntu1) zesty; urgency=medium

  * New upstream release

 -- Jeremy Bicha <email address hidden>  Wed, 01 Mar 2017 14:30:09 -0500

Available diffs

Superseded in zesty-release on 2017-03-01
Deleted in zesty-proposed on 2017-03-03 (Reason: moved to release)
gnome-online-accounts (3.23.4-0ubuntu1) zesty; urgency=medium

  * New upstream release
    - This renames the ownCloud provider to Nextcloud

 -- Jeremy Bicha <email address hidden>  Wed, 15 Feb 2017 11:35:45 -0500
Superseded in zesty-release on 2017-02-16
Deleted in zesty-proposed on 2017-02-17 (Reason: moved to release)
gnome-online-accounts (3.22.4-1) unstable; urgency=medium

  * New upstream release.

 -- Michael Biebl <email address hidden>  Fri, 13 Jan 2017 23:24:29 +0100

Available diffs

Superseded in zesty-release on 2017-01-14
Deleted in zesty-proposed on 2017-01-15 (Reason: moved to release)
gnome-online-accounts (3.22.3-2) unstable; urgency=medium

  * Add Breaks: evolution-data-server (<< 3.22.3). This ensures we don't taint
    the new Google API key. Older versions of evolution-data-server were
    polling the Google servers very aggressively, hitting the daily limit for
    the CalDAV and Tasks APIs.
  * Tighten dependency between gnome-online-accounts and libgoa-backend-1.0-1.

 -- Michael Biebl <email address hidden>  Fri, 16 Dec 2016 18:35:06 +0100

Available diffs

Obsolete in yakkety-updates on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to -updates)
gnome-online-accounts (3.20.5-0ubuntu0.1) yakkety; urgency=medium

  * New upstream bugfix release (LP: #1649995)
    - Use a new Google API key because there are authentication errors
      for anyone using the same key as old, buggy versions of
      evolution-data-server

 -- Jeremy Bicha <email address hidden>  Fri, 16 Dec 2016 06:38:44 -0500
Superseded in zesty-release on 2016-12-17
Deleted in zesty-proposed on 2016-12-18 (Reason: moved to release)
gnome-online-accounts (3.22.3-1) unstable; urgency=medium

  * New upstream release.

 -- Michael Biebl <email address hidden>  Wed, 14 Dec 2016 17:05:53 +0100

Available diffs

Superseded in zesty-release on 2016-12-15
Deleted in zesty-proposed on 2016-12-16 (Reason: moved to release)
gnome-online-accounts (3.22.2-1) unstable; urgency=medium

  * New upstream release.
  * Enable all hardening build flags.

 -- Michael Biebl <email address hidden>  Tue, 08 Nov 2016 15:25:00 +0100

Available diffs

Superseded in zesty-release on 2016-11-09
Deleted in zesty-proposed on 2016-11-10 (Reason: moved to release)
gnome-online-accounts (3.22.1-1) unstable; urgency=medium

  * New upstream release.

 -- Michael Biebl <email address hidden>  Tue, 11 Oct 2016 13:32:11 +0200
Superseded in zesty-release on 2016-10-26
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
gnome-online-accounts (3.20.4-0ubuntu1) yakkety; urgency=medium

  * New upstream bugfix release

 -- Jeremy Bicha <email address hidden>  Tue, 27 Sep 2016 01:22:08 -0400
Superseded in yakkety-release on 2016-09-28
Deleted in yakkety-proposed on 2016-09-29 (Reason: moved to release)
gnome-online-accounts (3.20.3-1) unstable; urgency=medium

  * New upstream release.
  * Update symbols file for libgoa-backend-1.0-1.

 -- Michael Biebl <email address hidden>  Sun, 07 Aug 2016 18:37:33 +0200
Superseded in yakkety-proposed on 2016-08-08
gnome-online-accounts (3.20.2-1) unstable; urgency=medium

  * New upstream release.
  * Convert from cdbs to dh.
  * Pass --as-needed to dh_autoreconf to reduce runtime dependencies.

 -- Michael Biebl <email address hidden>  Fri, 08 Jul 2016 14:15:38 +0200
Superseded in yakkety-release on 2016-08-08
Published in xenial-release on 2016-02-17
Deleted in xenial-proposed (Reason: moved to release)
gnome-online-accounts (3.18.3-1ubuntu2) xenial; urgency=medium

  * Undo the change. We're in sync now.

 -- Iain Lane <email address hidden>  Mon, 08 Feb 2016 14:57:59 +0000
Superseded in xenial-release on 2016-02-17
Deleted in xenial-proposed on 2016-02-18 (Reason: moved to release)
gnome-online-accounts (3.18.3-1ubuntu1) xenial; urgency=medium

  * Merge with Debian, Remaining change:
    - debian/patches/0001-Revert-back-to-webkit1.patch: Revert back to webkit1;
      we don't have a sufficient version of webkit2 in main.

 -- Tim Lunn <email address hidden>  Wed, 13 Jan 2016 10:35:08 +1100
Superseded in xenial-release on 2016-01-13
Deleted in xenial-proposed on 2016-01-14 (Reason: moved to release)
gnome-online-accounts (3.18.2.1-1ubuntu1) xenial; urgency=medium

  * debian/patches/0001-Revert-back-to-webkit1.patch: Revert back to webkit1;
    we don't have a sufficient version of webkit2 in main. :(
  * 3.18 update (LP: #1466290)

Deleted in wily-proposed on 2015-08-14 (Reason: Doesn't build, removing per request of darkxst)
gnome-online-accounts (3.16.3-1) unstable; urgency=medium

  * New upstream release.
  * Add Upstream-Name and Upstream-Contact to debian/copyright.

 -- Michael Biebl <email address hidden>  Mon, 15 Jun 2015 20:31:35 +0200
Superseded in xenial-release on 2015-11-24
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-22 (Reason: moved to release)
gnome-online-accounts (3.14.2-1ubuntu1) vivid; urgency=medium

  * debian/patches/git_facebook_remove_chat.patch: Facebook have dropped
    support for XMPP (LP: #1432859)
  * debian/patches/git_facebook_remove_read_mailbox.patch: removed unused
    permission that is restricted usage.
 -- Tim Lunn <email address hidden>   Tue, 17 Mar 2015 10:29:03 +0000
Superseded in vivid-release on 2015-03-17
Deleted in vivid-proposed on 2015-03-18 (Reason: moved to release)
gnome-online-accounts (3.14.2-1) unstable; urgency=medium


  * New upstream bugfix release
  * debian/rules: Disable yahoo provider, it is experimental, broken and
    nothing is using it anyway (Closes: #764816)
  * debian/control.in: Use the canonical URL for the Vcs-Svn field

 -- Laurent Bigonville <email address hidden>  Thu, 04 Dec 2014 22:51:04 +0100

Available diffs

Superseded in vivid-release on 2014-12-05
Deleted in vivid-proposed on 2014-12-06 (Reason: moved to release)
gnome-online-accounts (3.14.1-1) unstable; urgency=medium


  * New upstream release.
  * debian/control.in:
    - Bump Standards-Version to 3.9.6 (no further changes)
    - Fix the short description to please lintian
    - Update Homepage URL
    - Recommends dleyna-server on linux architectures, it can be used to add
      Media servers and mine their content

 -- Laurent Bigonville <email address hidden>  Mon, 20 Oct 2014 00:29:37 +0200

Available diffs

Superseded in vivid-release on 2014-10-24
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
gnome-online-accounts (3.12.4-1) unstable; urgency=medium


  * Team upload.

  [ Jackson Doak ]
  * New upstream release

 -- Andreas Henriksson <email address hidden>  Thu, 31 Jul 2014 20:54:38 +0200

Available diffs

Superseded in utopic-release on 2014-08-01
Deleted in utopic-proposed on 2014-08-02 (Reason: moved to release)
gnome-online-accounts (3.12.2-1) unstable; urgency=medium


  [ Laurent Bigonville ]
  * debian/control.in: Recommends realmd package (Closes: #725965)

  [ Andreas Henriksson ]
  * New upstream release.
    - Removes chat support from Windows Live provider (XMPP gateway gone).
  * Bump Standards-Version to 3.9.5

 -- Andreas Henriksson <email address hidden>  Fri, 16 May 2014 11:42:52 +0200
Superseded in utopic-release on 2014-06-13
Published in trusty-release on 2014-04-01
Deleted in trusty-proposed (Reason: moved to release)
gnome-online-accounts (3.10.3-0ubuntu1) trusty; urgency=medium

  * New upstream release.
    - kerberos: Leaking credentials, cursors, principals and GDateTime
 -- Jackson Doak <email address hidden>   Thu, 27 Mar 2014 07:05:13 +1100
Superseded in trusty-release on 2014-04-01
Deleted in trusty-proposed on 2014-04-02 (Reason: moved to release)
gnome-online-accounts (3.10.2-1) experimental; urgency=medium


  * Sync from Ubuntu: Use Conflicts/Replaces for libgoa-1.0-0; we want to make
    sure this package is really gone.
  * New upstream bugfix release:
    - telepathy: Choose better icons
    - Adapt to changes in the redirect URI used by Facebook
    - live: Does not update MailEnabled
    - kerberos: don't crash if keyring credentials disappear
    - kerberos: Leaking timerfds when we fall back to polling the ccache
    - Support kernel keyring based Kerberos accounts
    - Support Windows Live mail
    - Adding Google or Facebook accounts adds a second Jabber account
    - oauth2: Propagate the error if the dialog is dismissed during refresh
    - kerberos: still consuming 100% CPU
    - identity: don't queue two temporary accounts for one identity
    - oauth2: Don't parse the DOM to detect access_denied
    - goaalarm: add locks when setting up timers
    - kerberos: correctly show sign in errors when mistyping password
  * debian/libgoa-backend-1.0-1.symbols:
    - Updated

 -- Iain Lane <email address hidden>  Mon, 06 Jan 2014 11:39:44 +0000
Superseded in trusty-release on 2014-01-08
Deleted in trusty-proposed on 2014-01-09 (Reason: moved to release)
gnome-online-accounts (3.10.2-0ubuntu1) trusty; urgency=medium

  * New upstream release:
    - telepathy: Choose better icons
    - Adapt to changes in the redirect URI used by Facebook
    - live: Does not update MailEnabled
    - kerberos: don't crash if keyring credentials disappear
    - kerberos: Leaking timerfds when we fall back to polling the ccache
    - Support kernel keyring based Kerberos accounts
    - Support Windows Live mail
    - Adding Google or Facebook accounts adds a second Jabber account
    - oauth2: Propagate the error if the dialog is dismissed during refresh
    - kerberos: still consuming 100% CPU
    - identity: don't queue two temporary accounts for one identity
    - oauth2: Don't parse the DOM to detect access_denied
    - goaalarm: add locks when setting up timers
    - kerberos: correctly show sign in errors when mistyping password
  * debian/libgoa-backend-1.0-1.symbols:
    - Updated
 -- Robert Ancell <email address hidden>   Tue, 17 Dec 2013 13:06:46 +1300
Superseded in trusty-release on 2013-12-17
Deleted in trusty-proposed on 2013-12-18 (Reason: moved to release)
gnome-online-accounts (3.10.0-2ubuntu1) trusty; urgency=low

  * Use proper Conflicts/Replaces on libgoa-1.0-0 instead of a versioned
    Breaks/Replaces that fails to upgrade under update-manager.
 -- Steve Langasek <email address hidden>   Mon, 09 Dec 2013 09:18:39 -0800
Superseded in trusty-release on 2013-12-10
Deleted in trusty-proposed on 2013-12-11 (Reason: moved to release)
gnome-online-accounts (3.10.0-2) experimental; urgency=low


  * Drop debian version from breaks

 -- Sjoerd Simons <email address hidden>  Sat, 02 Nov 2013 22:07:53 +0100

Available diffs

Superseded in trusty-release on 2013-12-07
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
gnome-online-accounts (3.8.3-2) unstable; urgency=low


  [ Jeremy Bicha ]
  * debian/patches/drop-google-password-interface*.patch:
    - Now that Google CalDav supports OAuth v2 for CalDav and
      evolution-data-server has been updated for it, drop the
      password-based UI that didn't work with Google Two-Factor
      Authentication anyway (patches backported from git)
  * debian/patches/revert-deadlock-fix.patch:
    - Backport revert of 3.8.3 commit that could cause 100% cpu use

 -- Michael Biebl <email address hidden>  Thu, 19 Sep 2013 18:58:06 +0200
Superseded in saucy-release on 2013-09-19
Deleted in saucy-proposed on 2013-09-21 (Reason: moved to release)
gnome-online-accounts (3.8.3-1ubuntu1) saucy; urgency=low

  * Sync with Debian. Remaining changes:
    - debian/patches/drop-google-password-interface*.patch:
      + Now that Google CalDav supports OAuth v2 for CalDav and
        evolution-data-server has been updated for it, drop the
        password-based UI that didn't work with Google Two-Factor
        Authentication anyway (patches backported from git)
    - debian/patches/drop-google-password-interface-4.patch:
      + Backport another commit to fix Google CardDAV support
    - debian/patches/revert-deadlock-fix.patch:
      + Backport revert of 3.8.3 commit that could cause 100% cpu use

Available diffs

Superseded in saucy-release on 2013-09-19
Deleted in saucy-proposed on 2013-09-20 (Reason: moved to release)
gnome-online-accounts (3.8.2-1ubuntu1) saucy; urgency=low

  * debian/patches/drop-google-password-interface*.patch:
    - Now that Google CalDav supports OAuth v2 for CalDav and
      evolution-data-server has been updated for it, drop the
      password-based UI that didn't work with Google Two-Factor
      Authentication anyway (patches backported from git) (LP: #1175122)
 -- Jeremy Bicha <email address hidden>   Wed, 10 Jul 2013 14:24:42 -0400
Superseded in saucy-release on 2013-07-10
Deleted in saucy-proposed on 2013-07-12 (Reason: moved to release)
gnome-online-accounts (3.8.2-1) unstable; urgency=low


  [ Thomas Bechtold ]
  * New upstream release.

  [ Tim Lunn ]
  * debian/rules:
    - Explicitly enable owncloud
    - Don't try to enable Twitter or Yahoo support as they are not currently
      included
  * debian/libgoa-1.0-common: install arch-independent css file here rather
    than in libgoa-1.0-0

  [ Jeremy Bicha ]
  * debian/control.in: Add Breaks/Replaces for above change. This is only
    needed for users of experimental though.

  [ Michael Biebl ]
  * Upload to unstable.

 -- Michael Biebl <email address hidden>  Fri, 24 May 2013 17:59:18 +0200
Obsolete in quantal-updates on 2015-04-24
Obsolete in quantal-security on 2015-04-24
gnome-online-accounts (3.6.0-0ubuntu1.1) quantal-security; urgency=low

  * SECURITY UPDATE: incorrect ssl cert validation (LP: #1117411)
    - debian/patches/CVE-2013-0240.patch: properly validate ssl certs and
      fix cancellation in src/goa/goaenums.h, src/goa/goaerror.c,
      src/goabackend/goaewsclient.c, src/goabackend/goaewsclient.h,
      src/goabackend/goaexchangeprovider.c,
      src/goabackend/goagoogleprovider.c, src/goabackend/goautils.*,
      src/goabackend/goawebview.c.
    - debian/libgoa-1.0-0.symbols: updated with new symbol.
    - CVE-2013-0240
    - CVE-2013-1799
 -- Marc Deslauriers <email address hidden>   Thu, 21 Mar 2013 13:37:59 -0400
Published in precise-updates on 2013-03-25
Published in precise-security on 2013-03-25
gnome-online-accounts (3.4.0-0ubuntu1.1) precise-security; urgency=low

  * SECURITY UPDATE: incorrect ssl cert validation (LP: #1117411)
    - debian/patches/CVE-2013-0240.patch: properly validate ssl certs in
      src/goabackend/{goaoauthprovider,goaoauth2provider}.c.
    - CVE-2013-0240
 -- Marc Deslauriers <email address hidden>   Thu, 21 Mar 2013 14:33:43 -0400
Obsolete in oneiric-updates on 2015-04-24
Obsolete in oneiric-security on 2015-04-24
gnome-online-accounts (3.2.1-0ubuntu1.1) oneiric-security; urgency=low

  * SECURITY UPDATE: incorrect ssl cert validation (LP: #1117411)
    - debian/patches/CVE-2013-0240.patch: properly validate ssl certs in
      src/goabackend/{goaoauthprovider,goaoauth2provider}.c.
    - CVE-2013-0240
 -- Marc Deslauriers <email address hidden>   Thu, 21 Mar 2013 14:37:12 -0400
Superseded in saucy-release on 2013-06-04
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
gnome-online-accounts (3.6.2-1ubuntu1) raring; urgency=low

  * SECURITY UPDATE: incorrect ssl cert validation (LP: #1117411)
    - debian/patches/CVE-2013-0240.patch: properly validate ssl certs and
      fix cancellation in src/goa/goaenums.h, src/goa/goaerror.c,
      src/goabackend/goaewsclient.c, src/goabackend/goaewsclient.h,
      src/goabackend/goaexchangeprovider.c,
      src/goabackend/goagoogleprovider.c,
      src/goabackend/goahttpclient.*, src/goabackend/goautils.*,
      src/goabackend/goawebview.c.
    - debian/libgoa-1.0-0.symbols: updated with new symbol.
    - CVE-2013-0240
    - CVE-2013-1799
 -- Marc Deslauriers <email address hidden>   Thu, 21 Mar 2013 13:22:10 -0400
Superseded in raring-release on 2013-03-22
Deleted in raring-proposed on 2013-03-23 (Reason: moved to release)
gnome-online-accounts (3.6.2-1) experimental; urgency=low


  * New upstream release
    - Adjust .symbols file: some symbols have been dropped, but were not part
      of the public API 

 -- Laurent Bigonville <email address hidden>  Sat, 09 Feb 2013 23:23:42 +0100
Superseded in raring-release on 2013-02-11
Deleted in raring-proposed on 2013-02-12 (Reason: moved to release)
gnome-online-accounts (3.6.2-0ubuntu1) raring; urgency=low

  * New upstream release
  * debian/libgoa-1.0-0.symbols:
    - Updated
 -- Robert Ancell <email address hidden>   Wed, 14 Nov 2012 11:54:09 +1300
Superseded in raring-release on 2012-11-14
Deleted in raring-proposed on 2012-11-20 (Reason: moved to release)
gnome-online-accounts (3.6.1-1) experimental; urgency=low


  * Team upload
  * New upstream release
    - update symbols file
    - recommend the experimental gnome-control-center: the GOA panel doesn't
      seem to work correctly any more with the one from 3.4

 -- Simon McVittie <email address hidden>  Mon, 22 Oct 2012 21:56:13 +0100
Superseded in raring-release on 2012-10-29
Obsolete in quantal-release on 2015-04-24
gnome-online-accounts (3.6.0-0ubuntu1) quantal; urgency=low

  * New upstream stable release
 -- Robert Ancell <email address hidden>   Tue, 25 Sep 2012 09:54:47 +1200

Available diffs

Superseded in quantal-release on 2012-09-27
gnome-online-accounts (3.5.92-0ubuntu1) quantal; urgency=low

  * New upstream bugfix release
  * debian/libgoa-1.0-0.symbols:
    - Updated
 -- Robert Ancell <email address hidden>   Tue, 18 Sep 2012 09:31:56 +1200
Superseded in quantal-release on 2012-09-17
gnome-online-accounts (3.5.91-0ubuntu1) quantal; urgency=low

  * New upstream bugfix release
  * debian/libgoa-1.0-0.symbols:
    - Twitter and Yahoo symbols removed
 -- Robert Ancell <email address hidden>   Wed, 05 Sep 2012 15:14:30 +1200
Superseded in quantal-release on 2012-09-06
gnome-online-accounts (3.5.90-0ubuntu1) quantal; urgency=low

  * New upstream release.
  * debian/control.in:
    - Build-depend on krb5-config, libgcr-3-dev, and libkrb5-dev
  * debian/rules:
    - Enable Kerberos provider
  * debian/libgoa-1.0-0.symbols: Added new symbols
 -- Jeremy Bicha <email address hidden>   Mon, 20 Aug 2012 22:37:44 -0400

Available diffs

Superseded in quantal-release on 2012-08-21
gnome-online-accounts (3.5.5-0ubuntu1) quantal; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Tue, 07 Aug 2012 19:11:50 +0200

Available diffs

Superseded in quantal-release on 2012-08-07
gnome-online-accounts (3.5.4-0ubuntu1) quantal; urgency=low

  * New upstream release (LP: #1025533)
  * debian/control:
    - Add build-depends on libsecret-1-dev
    - Drop build-depends on libgnome-keyring-dev
  * debian/libgoa-1.0-0.symbols:
    - Updated
 -- Robert Ancell <email address hidden>   Mon, 30 Jul 2012 14:49:17 +0200

Available diffs

Superseded in quantal-release on 2012-07-30
gnome-online-accounts (3.5.3-0ubuntu1) quantal; urgency=low

  * New upstream release
  * debian/rules:
    - Facebook is enabled by default
  * debian/libgoa-1.0-0.symbols:
    - Updated
 -- Robert Ancell <email address hidden>   Tue, 26 Jun 2012 10:52:30 +1200

Available diffs

Superseded in quantal-release on 2012-06-25
gnome-online-accounts (3.5.2-0ubuntu1) quantal; urgency=low

  * New upstream release (LP: #1009293)
  * debian/control:
    - Bump build-depends on libgtk-3-dev
  * debian/libgoa-1.0-0.symbols:
    - Updated
 -- Robert Ancell <email address hidden>   Fri, 15 Jun 2012 12:34:34 +1200

Available diffs

Superseded in quantal-release on 2012-06-15
gnome-online-accounts (3.5.1-0ubuntu2) quantal; urgency=low

  * debian/control:
    - libgoa-1.0-dev depends on libgtk-3-dev and librest-dev
 -- Robert Ancell <email address hidden>   Fri, 18 May 2012 15:22:07 +1200

Available diffs

Superseded in quantal-release on 2012-05-18
gnome-online-accounts (3.5.1-0ubuntu1) quantal; urgency=low

  * New upstream release
  * debian/libgoa-1.0-0.symbols:
    - Updated
  * debian/watch:
    - Watch for unstable versions
  * debian/patches/01_git_fix_build.patch:
    - Applied upstream
 -- Robert Ancell <email address hidden>   Thu, 17 May 2012 12:15:47 +1200
Superseded in quantal-release on 2012-05-17
gnome-online-accounts (3.4.2-1) unstable; urgency=low


  * New upstream release.

 -- Michael Biebl <email address hidden>  Tue, 15 May 2012 16:27:22 +0200

Available diffs

175 of 89 results