Ubuntu

Change log for “gnome-panel” package in Ubuntu

175 of 271 results
Published in trusty-release on 2014-04-13
Deleted in trusty-proposed (Reason: moved to release)
gnome-panel (1:3.8.0-1ubuntu11) trusty; urgency=medium

  * Set XDG_MENU_PREFIX to "gnome-flashback-" in the desktop file
    (lp: #1305348, #1304645).
 -- Alberts Muktupavels <email address hidden>   Sun, 13 Apr 2014 12:27:07 +0300
Superseded in trusty-release on 2014-04-13
Deleted in trusty-proposed on 2014-04-15 (Reason: moved to release)
gnome-panel (1:3.8.0-1ubuntu10) trusty; urgency=medium

  * Update 01_menus_rename.patch to use separate menus file for
    gnome-flashback session (lp: #1267787).
 -- Alberts Muktupavels <email address hidden>   Mon, 17 Mar 2014 09:00:22 +0200
Superseded in trusty-release on 2014-03-17
Deleted in trusty-proposed on 2014-03-18 (Reason: moved to release)
gnome-panel (1:3.8.0-1ubuntu9) trusty; urgency=low

  * Revert changes to 41_classic_layout.patch introduced in -1ubuntu4,
    this causes two keyboard indicators to be visible.
  * Identify as Unity, again (LP: #1224217).
  * Use unity-settings-daemon instead of gnome-settings-daemon.
  * Add gnome-flashback-services.desktop to autostart indicators.
  * Bump Standards-Version to 3.9.5, no changes needed.
 -- Dmitry Shachnev <email address hidden>   Sat, 01 Mar 2014 14:39:38 +0400
Superseded in trusty-release on 2014-03-11
Deleted in trusty-proposed on 2014-03-12 (Reason: moved to release)
gnome-panel (1:3.8.0-1ubuntu8) trusty; urgency=low

  * Backport upstream commit to fix moving applets in panel.
 -- Dmitry Shachnev <email address hidden>   Mon, 24 Feb 2014 09:50:50 +0400
Superseded in trusty-release on 2014-02-24
Deleted in trusty-proposed on 2014-02-25 (Reason: moved to release)
gnome-panel (1:3.8.0-1ubuntu7) trusty; urgency=medium

  * Update 51_show_in_unity.patch to also remove StartupNotify header
    to work around LP: #1256961. Thanks (again) Alberts Muktupāvels.
 -- Dmitry Shachnev <email address hidden>   Sat, 22 Feb 2014 11:33:07 +0400
Superseded in trusty-release on 2014-02-22
Deleted in trusty-proposed on 2014-02-23 (Reason: moved to release)
gnome-panel (1:3.8.0-1ubuntu6) trusty; urgency=medium

  * Set UBUNTU_MENUPROXY to 0 instead of unsetting it.
    Thanks Alberts Muktupāvels.
 -- Dmitry Shachnev <email address hidden>   Wed, 19 Feb 2014 17:16:13 +0400
Superseded in trusty-release on 2014-02-20
Deleted in trusty-proposed on 2014-02-21 (Reason: moved to release)
gnome-panel (1:3.8.0-1ubuntu5) trusty; urgency=low

  * Remove the two symbols. This is indeed an API/ABI break, but none
    of Debian/Ubuntu packages use those symbols, and new applets fix
    some bugs and crashes. I will discuss with upstream the possibility
    to avoid such breaks in the future.
 -- Dmitry Shachnev <email address hidden>   Sun, 16 Feb 2014 15:20:41 +0400
Superseded in trusty-proposed on 2014-02-16
gnome-panel (1:3.8.0-1ubuntu4) trusty; urgency=low

  * Restore notification area (LP: #1263591).
  * Remove 85_disable_shutdown_on_ltsp.patch, it was not accepted
    upstream.
  * Backport upstream patch to drop gconf usage in bindings.
  * Show in Unity, a new work-around for LP: #1224217.
 -- Dmitry Shachnev <email address hidden>   Sun, 16 Feb 2014 13:23:00 +0400
Superseded in trusty-release on 2014-02-17
Deleted in trusty-proposed on 2014-02-18 (Reason: moved to release)
gnome-panel (1:3.8.0-1ubuntu3) trusty; urgency=low

  * Rebuild for libgweather transition.
  * Remove gnome-screensaver from required components (LP: #1199074).
 -- Dmitry Shachnev <email address hidden>   Thu, 16 Jan 2014 12:46:14 +0400
Superseded in trusty-release on 2014-01-20
Deleted in trusty-proposed on 2014-01-21 (Reason: moved to release)
gnome-panel (1:3.8.0-1ubuntu2) trusty; urgency=low

  [ Dmitry Shachnev ]
  * Backport upstream patches to:
    - fix building with gweather 3.9.2 and newer versions.
    - fix problem when panel size was not updated.
  * Drop obsolete breaks on historic versions of gnome-session and
    gnome-power-manager.
  * Drop ‘with’ word from sessions names to make them shorter.

  [ Alberts Muktupāvels ]
  * Move gnome-screensaver from Depends to Recommends.
 -- Dmitry Shachnev <email address hidden>   Sat, 11 Jan 2014 14:56:20 +0400
Superseded in trusty-release on 2014-01-11
Deleted in trusty-proposed on 2014-01-12 (Reason: moved to release)
gnome-panel (1:3.8.0-1ubuntu1) trusty; urgency=low

  * Merge with Debian unstable, remaining changes:
    - Use an epoch in version number.
    - Recommend indicator-applet-complete.
    - Adjust Breaks/Replaces for Ubuntu versioning.
    - Drop 14_revert_timedate_change.patch, we are using timedated.
    - Add patches:
      + 40_unset_menuproxy.patch
      + 41_classic_layout.patch
      + 50_ubuntu_sessions.patch
      + 85_disable_shutdown_on_ltsp.patch
    - Add apport hook.
  * Use new display names for sessions: "GNOME Flashback (with Compiz)"
    and "GNOME Flashback (with Metacity)".
  * Tweak the session files to always start nautilus-classic.
 -- Dmitry Shachnev <email address hidden>   Fri, 22 Nov 2013 10:20:12 +0400
Superseded in trusty-proposed on 2013-11-22
gnome-panel (1:3.6.2-0ubuntu16) trusty; urgency=low

  * No-change rebuild for new e-d-s
 -- Iain Lane <email address hidden>   Wed, 13 Nov 2013 13:13:25 +0000
Superseded in trusty-release on 2013-11-27
Published in saucy-release on 2013-09-13
Deleted in saucy-proposed (Reason: moved to release)
gnome-panel (1:3.6.2-0ubuntu15) saucy; urgency=low

  * Identify as GNOME; identifying as Unity is buggy (LP: #1224217)
 -- Jeremy Bicha <email address hidden>   Thu, 12 Sep 2013 22:29:02 -0400
Superseded in saucy-release on 2013-09-13
Deleted in saucy-proposed on 2013-09-14 (Reason: moved to release)
gnome-panel (1:3.6.2-0ubuntu14) saucy; urgency=low

  * debian/patches/50_ubuntu_sessions.patch:
    - Set DesktopName and X-LightDM-DesktopName to Unity instead of GNOME
      since Flashback uses indicators and the same "fallback" components
      Unity does. This will also allow for a more consistent experience
      for Edubuntu which offers both Unity and Flashback.
 -- Jeremy Bicha <email address hidden>   Tue, 10 Sep 2013 10:50:55 -0400
Superseded in saucy-release on 2013-09-10
Deleted in saucy-proposed on 2013-09-11 (Reason: moved to release)
gnome-panel (1:3.6.2-0ubuntu13) saucy; urgency=low

  * Drop bin/gnome-session-flashback as it wasn't consistently used and
    caused problems with upstart user sessions. (LP: #1217991)
  * Add aliases for gnome-fallback to gnome-flashback and
    gnome-fallback-compiz to gnome-flashback-compiz.
 -- Stephane Graber <email address hidden>   Thu, 29 Aug 2013 12:31:32 -0400
Published in precise-updates on 2013-08-29
Deleted in precise-proposed (Reason: moved to -updates)
gnome-panel (1:3.4.1-0ubuntu1.2) precise-proposed; urgency=low

  * Fix gnome-panel creation when using separate x screens. (LP: #1083811)
    - Backport 91-fix_panels_in_separate_screens.patch and
      93_use_correct_screen.patch from Saucy.
 -- Alberts Muktupavels <email address hidden>   Tue, 30 Jul 2013 00:40:19 +0300
Superseded in saucy-release on 2013-08-29
Deleted in saucy-proposed on 2013-08-30 (Reason: moved to release)
gnome-panel (1:3.6.2-0ubuntu12) saucy; urgency=low

  * debian/patches/93_use_correct_screen.patch:
    - Fix gnome-panel creation under two or more separate x screens
  * debian/patches/94_fix_background.patch
    - Fix gnome-panel background (LP: #1196177)
 -- Alberts Muktupavels <email address hidden>   Thu, 18 Jul 2013 19:28:02 +0300
Superseded in saucy-release on 2013-08-12
Deleted in saucy-proposed on 2013-08-13 (Reason: moved to release)
gnome-panel (1:3.6.2-0ubuntu11) saucy; urgency=low

  * gnome-session-flashback.postrm, .prerm:
    - Fix one more location that needed renaming
 -- Jeremy Bicha <email address hidden>   Thu, 20 Jun 2013 23:01:15 -0400
Superseded in saucy-proposed on 2013-06-21
gnome-panel (1:3.6.2-0ubuntu10) saucy; urgency=low

  * Use a proper transitional package instead of Provides
 -- Jeremy Bicha <email address hidden>   Thu, 20 Jun 2013 22:55:06 -0400
Superseded in saucy-release on 2013-06-21
Deleted in saucy-proposed on 2013-06-22 (Reason: moved to release)
gnome-panel (1:3.6.2-0ubuntu9) saucy; urgency=low

  * Have gnome-session-flashback provide gnome-session-fallback
    to ensure complete upgrades
 -- Jeremy Bicha <email address hidden>   Thu, 20 Jun 2013 13:58:19 -0400
Superseded in saucy-proposed on 2013-06-20
gnome-panel (1:3.6.2-0ubuntu8) saucy; urgency=low

  * 00-Fix-the-GNOME-Flashback-session-name.patch,
    02_flashback_desktop.patch,
    50_ubuntu_sessions.patch:
    - Rename gnome-flashback.desktop to gnome-fallback.desktop
      so that users of GNOME Fallback will get GNOME Flashback
      automatically regardless of system default session
 -- Jeremy Bicha <email address hidden>   Thu, 20 Jun 2013 13:22:44 -0400
Superseded in saucy-release on 2013-06-21
Deleted in saucy-proposed on 2013-06-22 (Reason: moved to release)
gnome-panel (1:3.6.2-0ubuntu7) saucy; urgency=low

  * Sync with Debian svn (LP: #1185873). Remaining changes:
    - Use epoch
    - Add apport hook
    - debian/control:
      + Recommend indicator-complete
      + Don't depend on nautilus 3.8 yet
    - debian/patches/14_revert_timedate_change.patch:
      + Dropped, we're using timedated
    - debian/patches/40_unset_menuproxy.patch:
      + Make sure gnome-panel and the applets don't pick up menu proxies.
    - debian/patches/41_classic_layout.patch:
      + Change the defaults to be more "classic Ubuntu": Show indicators
        & show desktop, drop GNOME clock & notification area
    - debian/patches/85_disable_shutdown_on_ltsp.patch:
      + Suppress the shutdown option in the panel if LTSP_CLIENT is set.
  * debian/patches/50_ubuntu_sessions.patch:
    - Merge patch from gnome-session to split sessions into GNOME Flashback
      (No effects) using Metacity and GNOME Flashback using Compiz
  * debian/patches/51_dont_require_nautilus38.patch:
    - Run Flashback without Nautilus 3.8 since it's not in Saucy yet

Superseded in saucy-release on 2013-06-20
Deleted in saucy-proposed on 2013-06-21 (Reason: moved to release)
gnome-panel (1:3.6.2-0ubuntu6) saucy; urgency=low

  * No-change rebuild against latest libical
 -- Jeremy Bicha <email address hidden>   Sun, 16 Jun 2013 22:03:21 -0400
Superseded in saucy-proposed on 2013-06-17
gnome-panel (1:3.6.2-0ubuntu5) saucy; urgency=low

  * debian/patches/40_unset_menuproxy.patch: include stdlib.h, needed
    for unsetenv (fixes build failure).
 -- Dmitry Shachnev <email address hidden>   Thu, 13 Jun 2013 16:44:28 +0400
Superseded in saucy-release on 2013-06-19
Deleted in saucy-proposed on 2013-06-20 (Reason: moved to release)
gnome-panel (1:3.6.2-0ubuntu4) saucy; urgency=low

  [ Tim Lunn ]
  * Rebuild for gnome-desktop 3.8 transition (LP: #1184812)
    - debian/patches/git_panel_run_dialog_resurrect_terminal.patch
      clock_applet_needs_terminal.patch

  [ Jeremy Bicha ]
  * git-build-with-gweather38.patch:
    - Backport patch to build with gweather 3.8 (LP: #1184168)
 -- Tim Lunn <email address hidden>   Tue, 28 May 2013 11:55:23 +1000
Superseded in saucy-release on 2013-05-28
Published in raring-release on 2012-12-18
Deleted in raring-proposed (Reason: moved to release)
gnome-panel (1:3.6.2-0ubuntu3) raring; urgency=low

  [ Alberts Muktupāvels ]
  * debian/patches/fix-for-1083811.patch:
    + Don't set screen to default screen when it exist. (LP: #1083811)
    + Set screen for menu, otherwise menu always appears on first screen.
 -- Iain Lane <email address hidden>   Tue, 18 Dec 2012 13:22:53 +0000

Available diffs

Superseded in raring-release on 2012-12-18
Deleted in raring-proposed on 2012-12-19 (Reason: moved to release)
gnome-panel (1:3.6.2-0ubuntu2) raring; urgency=low

  * debian/patches/90-remove_artifact_on_icon_animation.patch:
    + Remove black frame artifact on launcher icon zoom animation.
 -- <email address hidden> (Y.Gicquel)   Sun, 18 Nov 2012 16:42:53 +0100
Superseded in raring-release on 2012-11-19
Deleted in raring-proposed on 2012-11-20 (Reason: moved to release)
gnome-panel (1:3.6.2-0ubuntu1) raring; urgency=low

  * New upstream release
 -- Robert Ancell <email address hidden>   Thu, 15 Nov 2012 16:48:52 +1300
Superseded in raring-release on 2012-11-15
Published in quantal-release on 2012-10-11
Deleted in quantal-proposed (Reason: moved to release)
gnome-panel (1:3.6.0-0ubuntu2) quantal-proposed; urgency=low

  * debian/control.in: Drop X-Ubuntu-Use-Langpack:. This does not currently
    work due to LP #1048556, so let's include the upstream translations into
    the packages again.
 -- Martin Pitt <email address hidden>   Thu, 11 Oct 2012 08:05:48 +0200
Superseded in quantal-release on 2012-10-11
gnome-panel (1:3.6.0-0ubuntu1) quantal; urgency=low

  * New upstream stable release
 -- Robert Ancell <email address hidden>   Wed, 26 Sep 2012 10:43:23 +1200
Superseded in quantal-release on 2012-09-27
gnome-panel (1:3.5.92-0ubuntu1) quantal; urgency=low

  * New upstream release
    + Rework user menu in order to match GNOME Shell 3.6
  * Update watch file to also match unstable releases
  * debian/patches/16_remove_online_accounts_from_user_menu.patch: Remove,
    applied upstream.
 -- Iain Lane <email address hidden>   Mon, 17 Sep 2012 12:32:57 +0100
Superseded in quantal-release on 2012-09-17
gnome-panel (1:3.5.91-0ubuntu1) quantal; urgency=low

  * New upstream bugfix release.
  * debian/control.in:
    - Build-depend on yelp-tools instead of gnome-doc-utils
  * debian/gnome-panel-data.install:
    - Update for new help install location
  * debian/gnome-panel-data.install debian/source_gnome-panel.py:
    - Port apport hook to gsettings and re-enable
  * debian/rules:
    - Drop obsolete --disable-scrollkeeper
  * debian/patches/14_revert_timedate_change.patch: Refreshed
 -- Jeremy Bicha <email address hidden>   Sat, 08 Sep 2012 22:00:03 -0400
Superseded in quantal-release on 2012-09-09
gnome-panel (1:3.5.4-0ubuntu2) quantal; urgency=low

  * Support launchpad translation
 -- Sebastien Bacher <email address hidden>   Wed, 25 Jul 2012 18:53:17 +0200
Superseded in quantal-release on 2012-07-26
gnome-panel (1:3.5.4-0ubuntu1) quantal; urgency=low

  * New upstream release
  * debian/control:
    - Bump build-depends on libdconf-dev
 -- Robert Ancell <email address hidden>   Thu, 19 Jul 2012 10:25:08 +1200
Superseded in quantal-release on 2012-07-18
Deleted in quantal-proposed on 2012-07-20 (Reason: moved to release)
gnome-panel (1:3.5.3-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release
  * debian/control:
    - Bump build-depends on libecal1.2-dev, libedataserver1.2-dev,
      libgweather-3-dev
    - Drop build-depends on libedataserverui-3.0-dev
  * debian/gnome-panel-data.install:
    - No longer has gconf schema
  * debian/patches/15_avoid_applet_loading_failures.patch:
    - Applied upstream
 -- Robert Ancell <email address hidden>   Thu, 05 Jul 2012 14:27:47 +1200
Superseded in precise-updates on 2013-08-29
Deleted in precise-proposed on 2013-08-30 (Reason: moved to -updates)
gnome-panel (1:3.4.1-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/15_avoid_applet_loading_failures.patch:
    - Use on_bus_acquired instead of on_name_acquired.
      This helps prevent race conditions at session starts which can lead
      to panel applets failing to load. (lp: #727660)
 -- Sebastien Bacher <email address hidden>   Tue, 26 Jun 2012 12:05:46 +0200
Superseded in quantal-release on 2012-07-06
gnome-panel (1:3.4.2.1-2ubuntu2) quantal; urgency=low

  * Rebuild for the libgnome-desktop SOVER bump.
 -- Adam Conrad <email address hidden>   Thu, 07 Jun 2012 15:58:38 -0600
Superseded in quantal-release on 2012-06-07
gnome-panel (1:3.4.2.1-2ubuntu1) quantal; urgency=low

  * Resynchronize with Debian. Remaining changes:
    - debian/control:
      + Recommend indicator-complete
      + Use epoch in breaks/replaces version
    - debian/patches/01_menus_rename.patch: Dropped, Debian-specific
    - debian/patches/40_unset_menuproxy.patch:
      + Make sure gnome-panel and the applets don't pick up menu proxies.
    - debian/patches/41_classic_layout.patch:
      + Change the defaults to be more "classic Ubuntu": Show indicators
        & show desktop, drop GNOME clock & notification area
    - debian/patches/85_disable_shutdown_on_ltsp.patch:
      + Suppress the shutdown option in the panel if LTSP_CLIENT is set.
  * Dropped extra intltool-update run from debian/rules; I don't think
    this is needed anymore

Superseded in quantal-release on 2012-05-25
Published in precise-release on 2012-04-16
Deleted in precise-proposed (Reason: moved to release)
gnome-panel (1:3.4.1-0ubuntu1) precise-proposed; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Mon, 16 Apr 2012 15:10:41 +0200
Superseded in precise-release on 2012-04-16
Deleted in precise-proposed on 2012-04-18 (Reason: moved to release)
gnome-panel (1:3.4.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Mon, 26 Mar 2012 12:41:05 +0200
Superseded in precise-release on 2012-03-29
gnome-panel (1:3.3.92-0ubuntu1) precise; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Tue, 20 Mar 2012 13:20:49 +0100
Superseded in precise-release on 2012-03-20
gnome-panel (1:3.3.91-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Several theme fixes, thanks Peter Hurley!  (LP: #828392)
 -- Jeremy Bicha <email address hidden>   Mon, 05 Mar 2012 20:34:01 -0500
Superseded in precise-release on 2012-03-06
gnome-panel (1:3.3.90-0ubuntu1) precise; urgency=low

  * New upstream release.
  * debian/control.in:
    - Bump minimum GTK to 3.3.8 & gdk-pixbuf to 2.25.2
  * debian/patches/13_disable_missing_help.patch: Dropped, upstream.
 -- Jeremy Bicha <email address hidden>   Tue, 21 Feb 2012 08:10:48 -0500
Superseded in precise-release on 2012-02-21
gnome-panel (1:3.3.5-0ubuntu2) precise; urgency=low

  * debian/patches/41_classic_layout.patch:
    - Change the defaults to be more "classic Ubuntu": Show indicators
      & show desktop, drop GNOME clock & notification area (LP: #846378)
 -- Jeremy Bicha <email address hidden>   Fri, 10 Feb 2012 14:48:34 -0500
Superseded in precise-release on 2012-02-10
gnome-panel (1:3.3.5-0ubuntu1) precise; urgency=low

  * New upstream release.
  * debian/control.in:
    - Bump minimum glib to 2.31.14
  * debian/patches/13_disable_missing_help.patch:
    Updated patch from bugzilla
  * debian/patches/14_revert-timedate-change.patch:
    - Revert switch to systemd timedate protocol until ubuntu-system-
      services supports it
 -- Jeremy Bicha <email address hidden>   Wed, 08 Feb 2012 00:17:11 -0500
Superseded in precise-release on 2012-02-08
gnome-panel (1:3.3.3-0ubuntu2) precise; urgency=low

  * Rebuild for latest evolution-data-server
 -- Jeremy Bicha <email address hidden>   Thu, 12 Jan 2012 09:52:55 -0500
Superseded in precise-release on 2012-01-12
gnome-panel (1:3.3.3-0ubuntu1) precise; urgency=low

  * Merge with Debian. Remaining changes:
  * New upstream release
  * debian/control:
    - Recommend gnome-settings-daemon which has the timezone polkit service
    - Recommend gnome-session-fallback
    - Break libpanel-applet2-0, libpanel-applet-3-0, and python-gnomeapplet
    - Drop python and python-gconf recommends
    - Use epoch in breaks/replaces version
  * debian/rules:
    - Update translations template.
  * debian/patches/01_panel_submenus.patch: Dropped, Debian-specific
  * debian/patches/12_panel_icon_size_fixes.patch: Dropped, upstream
  * debian/patches/13_disable_missing_help.patch:
    - Disable help buttons since the user guide no longer includes that
      content (LP: #846470, #885959)
  * debian/patches/40_unset_menuproxy.patch:
    - Make sure gnome-panel and the applets don't pick up menu proxies.
  * debian/patches/85_disable_shutdown_on_ltsp.patch:
    - Suppress the shutdown option in the panel if LTSP_CLIENT is set.
  * debian/watch: Watch for unstable releases

Superseded in precise-release on 2011-12-21
Published in oneiric-release on 2011-09-26
gnome-panel (1:3.2.0-0ubuntu1) oneiric; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden>   Mon, 26 Sep 2011 11:24:36 +0200
Superseded in oneiric-release on 2011-09-26
gnome-panel (1:3.1.91-0ubuntu1) oneiric; urgency=low

  * New upstream release.
  * Drop ubuntu-about.desktop: We don't ship ghelp:about-ubuntu any more
  * debian/watch: Watch for .bz2
 -- Jeremy Bicha <email address hidden>   Mon, 05 Sep 2011 06:48:56 -0400
Superseded in oneiric-release on 2011-09-06
Superseded in oneiric-release on 2011-08-19
gnome-panel (1:3.1.5-0ubuntu1) oneiric; urgency=low

  * New upstream release.
  * debian/control: Bump gnome-menus dependencies
  * debian/libpanel-applet-4-dev.install: No longer any *.a files to install
  * debian/patches/09_default_icons.patch: Disabled until it can be ported
  * debian/patches/90_build_fixes.patch: Dropped, applied upstream
 -- Jeremy Bicha <email address hidden>   Wed, 17 Aug 2011 21:57:14 -0400
Superseded in oneiric-release on 2011-08-18
gnome-panel (1:3.0.2-0ubuntu6) oneiric; urgency=low

  * No-change rebuild against libedataserverui-3.0-1.
 -- Loic Minier <email address hidden>   Wed, 13 Jul 2011 13:32:55 +0200
Superseded in oneiric-release on 2011-07-13
gnome-panel (1:3.0.2-0ubuntu5) oneiric; urgency=low

  * No-change rebuild against libgnome-desktop-3-2.
 -- Steve Langasek <email address hidden>   Fri, 24 Jun 2011 22:04:47 -0700
Superseded in oneiric-release on 2011-06-25
gnome-panel (1:3.0.2-0ubuntu4) oneiric; urgency=low

  * debian/control.in: since the new version works only with gtk3 breaks on
    old libpanel-applet versions python-gnomeapplet
 -- Sebastien Bacher <email address hidden>   Wed, 15 Jun 2011 21:06:09 +0200
Superseded in oneiric-release on 2011-06-15
gnome-panel (1:3.0.2-0ubuntu3) oneiric; urgency=low

  * debian/control.in: use epoch in breaks and replaces version
 -- Sebastien Bacher <email address hidden>   Mon, 30 May 2011 18:05:53 +0200
Superseded in oneiric-release on 2011-05-30
gnome-panel (1:3.0.2-0ubuntu2) oneiric; urgency=low

  * debian/control.in:
    - Recommends gnome-session-fallback to get the corresponding session,
      for people directly installing gnome-panel and for update handling.
 -- Didier Roche <email address hidden>   Mon, 30 May 2011 12:59:41 +0200
Superseded in oneiric-release on 2011-05-30
gnome-panel (1:3.0.2-0ubuntu1) oneiric; urgency=low

  [ Sebastien Bacher ]
  * New upstream version
  * debian/control.in:
    - the new libgweather version is in oneiric, use it
    - drop the python and python-gconf depends,
      they were added for gnome-panel-add which is still using gconf and buggy
  * debian/gnome-panel-data.install:
    - don't install the apport hook, it's only getting gconf datas which
      doesn't work since gnome-panel uses gsettings
  * debian/patches/90_build_fixes.patch:
    - restore build fix from git not applied in the new serie
  * debian/patches/01_panel_submenus.patch:
    - don't take that Debian diff, the .menus use the upstream naming in Ubuntu
  * debian/patches/06_no_resize_grip.patch:
    - dropped, the issue is fixed in the new version
  * debian/patches/50_fix-potfiles.patch:
    - dropped, the issue is fixed in the new version
  * debian/watch:
    - track unstable series as well

  Drop those delta, since gnome-panel is not the default Ubuntu session now we
  can go back to an experience closer to the upstream one:
  * debian/control.in:
    - drop the indicators recommends, unity-2d is the ubuntu fallback session
      so we can get back to use an upstream config for gnome-panel and reduce
      the delta we carry
  * debian/patches/04_default_panel_config.patch:
    - don't modify the upstream layout
  * debian/patches/05_no_session_delay.patch:
    - no need to tweak the upstream session to optimize it
  * debian/patches/16_compiz_workspace_switcher.patch:
    - go back to the upstream switcher behaviour
  * debian/patches/25_dynamic_fusa_detection.patch:
    - not needed since we use the upstream layout, could be ported if someone
      is wanting to do the work though
  * debian/patches/30_disable-initial-animation.patch, debian/rules:
    - drop the --disable-initial-animation, that was some login optimization
      but since it's not the default desktop you should go back to the
      upstream behaviour

  [ Jeremy Bicha ]
  * New upstream version
  * Merge from Debian experimental, remaining Ubuntu changes:
  * debian/control:
    - Recommends gnome-settings-daemon which has the timezone polkit service
  * debian/rules:
    - Update translations template.
  * debian/gnome-panel-data.install:
    - Install apport hook
    - Install the "About Ubuntu" menu item.
  * debian/patches/01_layout.patch:
    - Disabled, Help & About Ubuntu don't fit as well in Gnome Panel 3
  * debian/patches/01_panel_submenus.patch.
    - Dropped
  * debian/patches/03_dnd_places_link.patch:
    - Disabled, when using Drag'n'Drop from Places menu, install a link launcher
      (.desktop file) instead of copying the entire directory.
  * debian/patches/17_about-ubuntu-translation.patch:
    - List ubuntu-about.desktop for translation.
  * debian/patches/40_unset_menuproxy.patch:
    - Make sure gnome-panel and the applets don't pick up menu proxies.
  * debian/patches/50_fix-potfiles.patch
    - Fix i18n
  * debian/patches/85_disable_shutdown_on_ltsp.patch:
    - Suppress the shutdown option in the panel if LTSP_CLIENT is set.
  * debian/patches/71_change_bookmark_submenu_limit_value.patch
    - Dropped, picked up by Debian
  * debian/patches/18_lockdown_lock_editor.patch:
  * debian/patches/90_git_wnck_show_realize.patch:
  * debian/patches/90_fix_linking_DSO_link.patch:
  * debian/patches/91_gir_annotations.patch
  * debian/patches/92_git_calendar_day.patch
  * debian/patches/92_git_fix_applets_in_multiscreen.patch:
    - Dropped, applied upstream
  * debian/watch:
    - watch unstable versions

Superseded in oneiric-release on 2011-05-30
gnome-panel (1:2.32.1-0ubuntu7) oneiric; urgency=low

  * debian/control.in:
    - gnome-panel recommends gnome-session-fallback to install the classic
      sessions on upgrade
 -- Didier Roche <email address hidden>   Tue, 24 May 2011 12:18:34 +0200
Obsolete in natty-updates on 2013-06-04
Superseded in oneiric-release on 2011-05-24
Deleted in natty-proposed on 2013-06-04 (Reason: moved to -updates)
gnome-panel (1:2.32.1-0ubuntu6.5) natty-proposed; urgency=low

  * debian/patches/92_git_calendar_day.patch:
    - gtk_calendar_get_date returns the month between 0 and 11, so add +1
      to the month being passed to Evolution (LP: #760523)
  * debian/patches/92_git_fix_applets_in_multiscreen.patch:
    - Add upstream patch to fix addition of applets in multiscreen (LP: #774427)
 -- Rodrigo Moya <email address hidden>   Mon, 02 May 2011 12:59:50 +0200
Superseded in natty-updates on 2011-05-10
Superseded in oneiric-release on 2011-05-10
Deleted in natty-proposed on 2011-05-11 (Reason: moved to -updates)
gnome-panel (1:2.32.1-0ubuntu6.4) natty-proposed; urgency=low

  * debian/patches/50_fix-potfiles.patch:
    - add patch from gabor (LP: #760707) to fix i18n
 -- Michael Vogt <email address hidden>   Thu, 21 Apr 2011 13:33:41 +0200
Superseded in oneiric-release on 2011-05-02
Obsolete in natty-release on 2013-06-04
gnome-panel (1:2.32.1-0ubuntu6.3) natty; urgency=low

  * debian/patches/25_dynamic_fusa_detection.patch: Check for indicator
    applet complete as well as fusa.  (LP: #506404)
 -- Ted Gould <email address hidden>   Tue, 19 Apr 2011 08:48:23 -0500
Superseded in natty-release on 2011-04-19
gnome-panel (1:2.32.1-0ubuntu6.2) natty; urgency=low

  * Update the layout to be closer from the previous cycle oben changing back
    the logo menu for the 3 menus, dropping the indicator-appmenu from the
    default layout and adding back the firefox launcher since it seems that's
    what most users are waiting from the classic session.
 -- Sebastien Bacher <email address hidden>   Thu, 07 Apr 2011 17:15:32 +0200
Superseded in natty-release on 2011-04-07
gnome-panel (1:2.32.1-0ubuntu6.1) natty; urgency=low

  * debian/patches/92_git_calendar_day.patch:
    - git commit, open the right day when clicking in the calendar (lp: #139627)
 -- Sebastien Bacher <email address hidden>   Thu, 31 Mar 2011 16:03:16 +0200
Superseded in natty-release on 2011-03-31
gnome-panel (1:2.32.1-0ubuntu6) natty; urgency=low

  * Update the default layout to be closer from the unity one
  * debian/control.in: updated the recommends to match those
 -- Sebastien Bacher <email address hidden>   Tue, 25 Jan 2011 15:46:30 +0100
Superseded in natty-release on 2011-01-25
gnome-panel (1:2.32.1-0ubuntu5) natty; urgency=low

  * debian/control.in:
    - updated the gtk requirement to the version having the new api required

  [ Cody Russell ]
  * debian/patches/06_no_resize_grip.patch:
    - Disable resize grips on GtkWindow (lp: #702879)
 -- Sebastien Bacher <email address hidden>   Wed, 19 Jan 2011 11:30:44 +0100
Superseded in natty-release on 2011-01-19
gnome-panel (1:2.32.1-0ubuntu4) natty; urgency=low

  * Updated for gir abi transition.
 -- Sebastien Bacher <email address hidden>   Thu, 16 Dec 2010 18:57:57 +0100
Superseded in natty-release on 2010-12-16
gnome-panel (1:2.32.1-0ubuntu3) natty; urgency=low

  * debian/patches/16_compiz_workspace_switcher.patch:
    - change the gconf path according to new upstream location
 -- Didier Roche <email address hidden>   Fri, 10 Dec 2010 14:48:56 +0100
Superseded in natty-release on 2010-12-10
gnome-panel (1:2.32.1-0ubuntu2) natty; urgency=low

  * README.Debian:
    - clean outdated README
  * debian/patches/91_gir_annotations.patch:
    - git commit to fix the gir by adding annotations where it's required,
      thanks Rodrigo Moya
 -- Sebastien Bacher <email address hidden>   Tue, 30 Nov 2010 18:10:24 +0100
Superseded in natty-release on 2010-11-30
gnome-panel (1:2.32.1-0ubuntu1) natty; urgency=low

  * New upstream version:
    Panel
    - Support relocating the .gnome2 directory with an environment
    variable, like libgnome does
    libpanel-applet
    - Fix build breakage caused by wrong include
    Misc
    - Link gnome-desktop-item-edit against X libs too
  * debian/patches/90_fix_linking_DSO_link.patch:
    - updated for the new version
 -- Sebastien Bacher <email address hidden>   Wed, 17 Nov 2010 15:20:32 +0100
Superseded in natty-release on 2010-11-17
gnome-panel (1:2.32.0.2-0ubuntu2) natty; urgency=low

  * debian/patches/16_compiz_workspace_switcher.patch:
    - update for seeing the pager capplet with new compiz (it will need to
      export the layout to the root window then to see the effective number of
      viewport/worskpace to be taken into account)
  * debian/patches/90_fix_linking_DSO_link.patch:
    - fix FTBFS due to missing DSO linking
 -- Didier Roche <email address hidden>   Tue, 09 Nov 2010 19:05:02 +0100
Superseded in natty-release on 2010-11-09
gnome-panel (1:2.32.0.2-0ubuntu1) natty; urgency=low

  * New upstream version
  * debian/control.in:
    - recommends python-gconf and python rather than depends on it,
      gnome-panel-add is the only code to use those
    - clean the python-gnome2 depends
    - list the new binaries for libpanel-applet3 and gir
    - set a new gnome-panel-bonobo binary with the bonobo loader
    - recommends gnome-settings-daemon which has the timezone polkit service
    - updated glib requirement and the build depends for the gir build
    - use dh-autoreconf
  * Updated the .install files for the new version
  * debian/patches/01_layout.patch:
    - new version update
  * debian/patches/04_default_panel_config.patch:
    - updated the layout
  * debian/patches/90_git_wnck_show_realize.patch,
    debian/patches/91_git_wnck_pager_update.patch:
   - the fixes are in the next version
  * debian/patches/99_ltmain_as-needed.patch:
    - dropped, it's not required with --as-needed by default in natty
  * debian/rules:
    - call dh_girepository
    - comment the ldflag options to workaround build issues
    - updated shlibs version
    - use dh-autoreconf rather than the cdbs way
 -- Sebastien Bacher <email address hidden>   Tue, 09 Nov 2010 15:06:29 +0100
Superseded in natty-release on 2010-11-09
Obsolete in maverick-release on 2013-03-05
gnome-panel (1:2.30.2-1ubuntu3) maverick; urgency=low

  * Don't set a documentation browser launcher on the default configuration
 -- Sebastien Bacher <email address hidden>   Fri, 27 Aug 2010 10:42:14 +0200
Superseded in maverick-release on 2010-08-27
gnome-panel (1:2.30.2-1ubuntu2) maverick; urgency=low

  * debian/control.in:
    - Remove "linux-any" for now since soyuz doesn't handle it
 -- Robert Ancell <email address hidden>   Wed, 14 Jul 2010 10:34:47 +1000
Superseded in maverick-release on 2010-07-14
gnome-panel (1:2.30.2-1ubuntu1) maverick; urgency=low

  * Merge with Debian unstable, remaining Ubuntu changes:
  * debian/control:
    - Add Vcs-Bzr info.
    - gnome-panel suggests menu-xdg rather than depends on it.
    - gnome-panel recommends indicator-applet.
  * debian/rules:
    - Run autotools on build
    - Compile with --disable-initial-animation
    - don't build in process applets during the unstable cycle so crash issues
      should be easier to debug and reported on the corresponding binary
    - Update translations template.
  * debian/application-default-icon.png:
    - Default icon for the menu entries.
  * debian/gnome-panel-data.install:
    - Install apport hook
    - Install the "About Ubuntu" menu item.
    - Install the default menu icon.
  * debian/gnome-panel-data.preinst:
    - Clean conffiles which are not in the new version on upgrade.
  * debian/gnome-panel.install:
    - Install the files necessary to migrate existing panel configs
      on upgrade, to add the FUSA and indicator applet.
    - No /usr/lib/gnome-panel/*.so due to not building in process applets
  * debian/gnome-panel.postrm:
    - Remove GConf defaults on uninstall.
  * debian/gnome-panel.preinst:
    - Clean up indicator-applet.desktop and
      /usr/share/gconf/defaults/25_gnome_panel_indicator_applet on upgrade.
  * debian/source_gnome-panel.py:
    - Apport hook
  * debian/ubuntu-about.desktop.in:
    - "About Ubuntu" menu item.
  * debian/patches/01_layout.patch:
    - Changes to the panel layout.
  * debian/patches/01_panel_submenus.patch.
    - Dropped
  * debian/patches/02_mixel_applet.patch.
    - Dropped
  * debian/patches/03_dnd_places_link.patch:
    - When using Drag'n'Drop from Places menu, install a link launcher
      (.desktop file) instead of copying the entir directory.
  * debian/patches/04_default_panel_config.patch:
    - Change to the default configuration.
  * debian/patches/05_no_session_delay.patch:
    - Don't set X-GNOME-Autostart-Phase=Panel to avoid delaying other softwares
      start on login
  * debian/patches/06_clock_permissions.patch.
    - Dropped
  * debian/patches/16_compiz_workspace_switcher.patch:
    - Allow the workspace switcher to change the desktop layout
      when using compiz.
  * debian/patches/17_about-ubuntu-translation.patch:
    - List ubuntu-about.desktop for translation.
  * debian/patches/18_lockdown_lock_editor.patch:
    - Change to have lockdown locking the menu editor
  * debian/patches/25_dynamic_fusa_detection.patch:
    - Removes the shutdown, logout and lock screen items when the
      FUSA applet is on the panel
  * debian/patches/30_disable-initial-animation.patch:
    - Patch to add build-time flag to disable the initial slide-in animation.
  * debian/patches/40_unset_menuproxy.patch:
    - Make sure gnome-panel and the applets don't pick up menu proxies.
  * debian/pacthes/70_relibtoolize.patch:
    - Not required, autotools run on build
  * debian/patches/71_change_bookmark_submenu_limit_value.patch:
    - Set the bookmarks number before submenu to 8 which should let users
      configure some before hitting the limit
  * debian/patches/85_disable_shutdown_on_ltsp.patch:
    - Suppress the shutdown option in the panel if LTSP_CLIENT is set.
  * debian/patches/90_git_wnck_show_realize.patch:
  * debian/patches/91_git_wnck_pager_update.patch:
    - git changes to fix races in the wnck-applet code leading to crashes
      (lp: #508452)
  * debian/watch:
    - watch unstable versions
 -- Robert Ancell <email address hidden>   Tue, 13 Jul 2010 17:33:58 +1000
Superseded in maverick-release on 2010-07-13
gnome-panel (1:2.30.2-0ubuntu2) maverick; urgency=low

  * debian/patches/90_git_wnck_show_realize.patch,
    debian/patches/91_git_wnck_pager_update.patch:
    - git changes to fix races in the wnck-applet code leading to crashes
      (lp: #508452)
 -- Sebastien Bacher <email address hidden>   Tue, 06 Jul 2010 12:13:01 +0200
Published in lucid-updates on 2010-07-14
Deleted in lucid-proposed (Reason: moved to -updates)
gnome-panel (1:2.30.2-0ubuntu0.2) lucid-proposed; urgency=low

  * debian/patches/90_git_wnck_show_realize.patch,
    debian/patches/91_git_wnck_pager_update.patch:
    - git changes to fix races in the wnck-applet code leading to crashes
      (lp: #508452)
 -- Sebastien Bacher <email address hidden>   Tue, 06 Jul 2010 12:13:01 +0200
175 of 271 results