screensaver starts when movie plays

Bug #59688 reported by David Prieto
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
gnome-screensaver (Ubuntu)
Undecided
Unassigned
totem (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-screensaver

Hi, I thought that playing a movie in Totem was supposed to keep gnome-screensaver from start.... however I just watched a movie and had to move the mouse once and again because the screensaver kept going off. Is this supposed to work like this?

Thanks.

By the way, I'm on Edgy. Could that be related?

Revision history for this message
Matti Lindell (mlind) wrote :

Can you reproduce this when totem is running on fullscreen mode? When windowed, totem doesn't keep gnome-screensaver from kicking in, but seems to work when on fullscreen.

I cannot reproduce this on current up-to-date Edgy.

Revision history for this message
David Prieto (frandavid100-gmail) wrote :

Yeah it happens even if the movie is on FS.

I watched another movie yesterday tho, and the screensaver did not appear. I'll play the one that I was watching while the problem happened today, to see if it happens again.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for your bug. Do you use totem-gstreamer or totem-xine? Do you have a xinerama setup or a standard one screen setup?

Changed in totem:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Revision history for this message
David Prieto (frandavid100-gmail) wrote :

I'm on gstreamer and standard setup.

I'm thinking that I had CTRL+ALT+BACKed before watching the movie, got some error messages when logging back in, and the interface was all weird, like GTK1. So maybe something was just not working right.

I'll play the same movie today, and if I can't reproduce it I guess you can disregard this bug.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Your previous description looks like gnome-settings-daemon was not running, maybe the dbus session bus was not correctly configured too. Let we know if you can get the issue on a normally working desktop

Revision history for this message
Matti Lindell (mlind) wrote :

David, can you reproduce this anymore?

Revision history for this message
David Prieto (frandavid100-gmail) wrote :

Sorry, I had totally forgotten about this!

I didn't get the error again, please close the bug.

And thanks a lot :)

Revision history for this message
Sebastien Bacher (seb128) wrote :

closing since it works now, feel free to reopen if you get the issue again

Changed in totem:
status: Needs Info → Rejected
Changed in gnome-screensaver:
status: Unconfirmed → Rejected
Revision history for this message
David Prieto (frandavid100-gmail) wrote :

Curiously, it's happening again and now gnome-settings-daemon IS running. Watching movies in fullscreen mode just doesn't keep gnome-screensaver from starting anymore in Feisty.

Revision history for this message
Sebastien Bacher (seb128) wrote :

the feisty bug is known and fixed upstream

Revision history for this message
Sitsofe Wheeler (sitsofe) wrote :

(This is mentioned upstream in http://bugzilla.gnome.org/show_bug.cgi?id=344577 )

Revision history for this message
Matthew McGowan (mmcg069) wrote :

Hi,

This bug is appearing in Ibex for me. Whilst watching movies the screensaver will come on.

matthew@matthew-desktop:~$ apt-cache policy totem
totem:
  Installed: 2.24.2-0ubuntu2
  Candidate: 2.24.2-0ubuntu2
  Version table:
 *** 2.24.2-0ubuntu2 0
        500 http://nz.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

matthew@matthew-desktop:~$ lsb_release -rd
Description: Ubuntu intrepid (development branch)
Release: 8.10

Revision history for this message
goto (gotolaunchpad) wrote :

mmnz: Yes, here in Intrepid too. It gets on my nerves. Just wanted to report this bug. Am I allowed to set it to "confirmed" or "new"? "Invalid" is wrong in my opinion.
Thanks.

Revision history for this message
goto (gotolaunchpad) wrote :

Set to confirmed.

Changed in totem:
status: Invalid → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

could somebody having the issue send the bug to bugzilla.gnome.org?

Changed in totem:
importance: Undecided → Low
status: Confirmed → Incomplete
Revision history for this message
goto (gotolaunchpad) wrote :

done.
Is there a way to help?

Changed in totem:
status: Incomplete → Triaged
Changed in totem:
status: Unknown → Incomplete
Changed in totem:
status: Incomplete → New
Changed in totem:
status: New → Incomplete
Changed in totem:
status: Incomplete → Fix Released
Revision history for this message
Pedro Villavicencio (pedro) wrote :

this is fixed on jaunty.

Changed in totem:
status: Triaged → Fix Released
Revision history for this message
Yuriy Voziy (yuretsz) wrote :

I've updated ubuntu form interpid to jaunty and the bug is still here.

Changed in totem (Ubuntu):
status: Fix Released → New
Revision history for this message
Sebastien Bacher (seb128) wrote :

don't reopen a closed bug but rather open a new one

Changed in totem (Ubuntu):
status: New → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

don't reopen a closed bug but rather open a new one if you have a similar issue

Changed in totem:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.