gnome-shell 3.0.1-1 source package in Ubuntu

Changelog

gnome-shell (3.0.1-1) experimental; urgency=low

  [ Laurent Bigonville ]
  * debian/control.in:
    - Bump priority to optional

  [ Sjoerd Simons ]
  * New upstream release

gnome-shell (3.0.0.2-1) experimental; urgency=low

  * Team upload.

  [ Frederic Peters ]
  * New upstream release (2.91.93).
  * debian/control.in:
    + added dependency on gnome-icon-theme-symbolic.
    + bumped gnome-shell dependency.
    + bumped gir1.2-freedesktop build-dep to 0.10.6, for a fix to
      cairo-1.0.typelib

  [ Raphaël Hertzog ]
  * New upstream release (3.0.0.2).
  * New patch 02_rpath-bluetooth-applet.patch by Rico Tzschichholz to
    add an RPATH so that the compilation doesn't fail when g-ir-scanner
    tries to analyze libgnome-shell.so linked against
    libgnome-bluetooth-applet.so.0 which is in a private directory.
  * Add a lintian override for the RPATH that we can't avoid.
  * Teach dpkg-shlibdeps how to find that private lib and add the
    corresponding dependency in debian/slibs.local.
  * Update and add a bunch of build-depends to match the latest configure
    requirements.
  * Add gir1.2-gnomebluetooth-1.0 and gir1.2-networkmanager-1.0 to Depends
    because they are needed to benefit from the improved UI associated to the
    respective status bar applet.

  [ Laurent Bigonville ]
  * debian/control.in: {Build-}Depends against gir1.2-mutter-3.0 instead of
    gir1.2-mutter-2.91

gnome-shell (2.91.92-1) experimental; urgency=low

  * New upstream release.
  * debian/patches/, remove patches from upstream git:
    + 0001-altTab-fix-incorrect-positioning-with-multiple-monit.patch
    + 05_use_dbus_for_shutdown_and_logout.patch
  * debian/control.in:
    + add build-dep on libtelepathy-logger-dev and gir1.2-telepathylogger-0.2.
    + bump build-dep on libxfixes-dev, it needs the one from experimental, for
      pointer barriers.

gnome-shell (2.91.91-2) experimental; urgency=low

  * debian/patches/04_gnome_session_quit.patch: remove, replaced by:
  * debian/patches/05_use_dbus_for_shutdown_and_logout.patch: use Session
    D-Bus interface for shutdown and logout. (from git) (closes: #618870)

gnome-shell (2.91.91-1) experimental; urgency=low

  * New upstream release.

  [ Emilio Pozuelo Monfort ]
  * debian/control.in:
    + Depend on gsettings-desktop-schemas. Closes: #614945.
    + Depend on gir1.2-mutter-2.91. Closes: #615588.

  [ Frederic Peters ]
  * debian/control.in:
    + Don't depend on mutter, it now links against libmutter-wm0.
  * debian/patches/03_fix_dconf_service_location.patch: remove, no longer
    necessary now that gnome-shell is a real binary and doesn't try to arrange
    its own environment.
  * debian/patches/04_gnome_session_quit.patch: use gnome-session-save in
    fallback if gnome-session-quit doesn't work, so gnome-shell keeps working
    with older gnome-session versions.

  [ Emilio Pozuelo Monfort ]
  * d/p/0001-altTab-fix-incorrect-positioning-with-multiple-monit.patch:
    + Patch from upstream git, fix Alt+Tab with multiple monitors.

gnome-shell (2.91.90-1) experimental; urgency=low

  * New upstream release.
    + Build depend on libtelepathy-glib-dev for the updated Telepathy
      integration.
    + Build depend on libpolkit-agent-1-dev for the new authorization dialogs.
    + Build depend, and depend, on appropriate gir packages (polkit,
      telepathy, and upower).
    + Update build dep on libmutter-dev.
    + Update depends for new libgnomekbd gir package name.
    + Remove Recommends on xserver-xephyr.

gnome-shell (2.91.6-1) experimental; urgency=low

  [ Emilio Pozuelo Monfort ]
  * debian/control.in:
    + Depend on gnome-control-center for My Account / System settings.

  [ Laurent Bigonville ]
  * New upstream release.
  * debian/control.in:
    - Bump build-dependencies
    - Add libecal1.2-dev, libedataserver1.2-dev and libedataserverui1.2-dev
      build-dependencies
    - Make mutter depends on libdconf0 | gsettings-backend instead of
      libdconf0 only

  [ Emilio Pozuelo Monfort ]
  * debian/control.in:
    + Update for the new gtk+ 3 package names.
    + Add missing dependency on gir1.2-gnomekbd-3.0.

gnome-shell (2.91.5-1) experimental; urgency=low

  * New upstream release.
    + debian/patches/02_fix_build_with_latest_gtk.patch:
      - Removed, fixed upstream.
    + debian/patches/01_favorite_apps.patch:
      - Refreshed.
    + debian/control.in:
      - Updated build dependencies.

gnome-shell (2.91.3-2) experimental; urgency=low

  * debian/control.in:
    - Build depend on libdconf0 for dconf-service. Closes: #595598.

gnome-shell (2.91.3-1) experimental; urgency=low

  [ Emilio Pozuelo Monfort ]
  * New upstream release (Closes: #605098, CVE-2010-4000).
    - debian/control.in:
      + Updated dependencies and build dependencies.
    - debian/patches/02_undo_gtk3_transition.diff:
      + Removed, let's use GTK+3 from now on.
    - debian/patches/03_fix_dconf_service_location.diff:
      + Updated.
  * debian/control.in,
    debian/rules:
    - Remove hack to get the typelibs scanned. Pass the private
      directory to dh_girepository instead. Update the minimum
      build dependency on gobject-introspection accordingly.
  * debian/control.in:
    - Build depend on gir1.2 packages.
    - Remove gir dependencies, they are autogenerated.

  [ Laurent Bigonville ]
  * debian/control.in: Add Vcs-* fields
  * debian/watch: Add watch file

  [ Emilio Pozuelo Monfort ]
  * debian/patches/02_fix_build_with_latest_gtk.patch:
    - Patch from upstream git, fix build with GTK+ 2.91.6.
  * debian/control.in:
    - Bump the libgtk3.0-dev accordingly.
  * debian/patches/*.diff:
    - Renamed to debian/patches/*.patch.

gnome-shell (2.31.5-2) experimental; urgency=low

  * debian/control:
  - depend and build-depend on gir1.0-glib-2.0 (>= 0.6.15~git20100713)
  - also depend on gjs, because the clock preferences uses gjs-console for
    some reason

gnome-shell (2.31.5-1) experimental; urgency=low

  * New development release.
  - depend on mutter 2.31.5
  - refresh patches
  - fixes requirements on mutter (Closes: #586124)
  * debian/control.in:
  - Build-depend on glib >= 2.25.11-1 because we use glib-compile-schemas
  - Build-depend on gtk+ >= 2.21.1
  - Build-depend on gobject-introspection >= 0.6.15~git20100713-1 because
    we need newer glib bindings
  - Build-depend on gir1.0-json-glib-1.0 (Closes: #584660), thanks to
    Raphael Hertzog for pointing out the fix
  - gnome-shell depends on gir1.0-gconf-2.0 >= 2.31.5 to run
  * debian/patches/02_undo_gtk3_transition.diff:
  - undo gtk2->gtk3 migration since we do not yet have gtk+ 3 on Debian
  * debian/patches/03_fix_dconf_service_location.diff:
  - fix the path used to start dconf-service

gnome-shell (2.31.2-1) experimental; urgency=low

  * New upstream release
  - depends on mutter 2.31
  - includes debian/patches/02_gjs_build_fix.patch, so removing
  * debian/rules:
  - depends on clutter-1.0 >= 1.2.8

gnome-shell (2.29.0-3) unstable; urgency=low

  [ Emilio Pozuelo Monfort ]
  * debian/patches/02_gjs_build_fix.patch:
    - Backport upstream commit to fix the build with recent gjs.
  * debian/source/format,
    debian/patches/series,
    debian/rules:
    - Convert to source format 3.0 (quilt).
  * debian/rules:
    - Include gnome-get-source.mk.

gnome-shell (2.29.0-2) unstable; urgency=low

  * debian/control:
  - really fix #572718 by bumping the version in mutter's gir package name

gnome-shell (2.29.0-1) unstable; urgency=low

  [ Emilio Pozuelo Monfort ]
  * debian/rules:
    - Don't install *.la.

  [ Gustavo Noronha Silva ]
  * New upstream development release.
  - should work with the newer mutter (Closes: #572718)

gnome-shell (2.28.1~git20100129-1) unstable; urgency=low

  * New upstream snapshot.

gnome-shell (2.28.1~git20091125-1) unstable; urgency=low

  * New upstream snapshot

gnome-shell (2.28.1~git20091117-1) unstable; urgency=low

  * New upstream snapshot
  * debian/patches/02_allow_non_uri_apps.diff:
  - dropped; applied upstream
  * debian/upstream.gitlog, debian/rules:
  - ship upstream's git log as upstream changelog (Closes: #556354)

gnome-shell (2.28.1~git20091112-1) unstable; urgency=low

  * New upstream snapshot

gnome-shell (2.28.1~git20091028-2) unstable; urgency=low

  * debian/patches/01_favorite_apps.diff:
  - change the default favorite browser desktop file to be Epiphany's
    (Closes: #553054)
  * debian/control.in:
  - gnome-shell's startup script wants to run glxinfo to get information
    regarding the server's GLX support; thanks to alex bodnaru
    <alexbodn@012.net.il> for noticing this is needed
    (Closes: #553440)
  * debian/patches/02_allow_non_uri_apps.diff:
  - patch by Guido Günther <email address hidden> to drop the requirement that
    associated apps support URIs, for local files at least
    (Closes: #553618)

gnome-shell (2.28.1~git20091028-1) unstable; urgency=low

  * New upstream snapshot
  * debian/control:
  - bump Standards-Version to 3.8.3
  - python is a dependency, since the script that starts GNOME Shell
    is a python script
  - pkg-config is also a dependency (Closes: #552202)

gnome-shell (2.28.1~git20091024-1) unstable; urgency=low

  * New upstream snapshot
  * debian/control.in:
  - ok, I agree, let's recommend Xephyr for now (Closes: #552141)

gnome-shell (2.28.1~git20091020-1) unstable; urgency=low

  * Initial upload, based on the Ubuntu package (Closes: #550956)
  * debian/patches:
  - drop two unnecessary patches
  * debian/rules:
  - cleanup, and add Debian GNOME Team rules include
  * debian/control.in:
  - add Debian GNOME Team stuff
  - fix alignment
  - remove Recommends for xserver-xephyr
  - fix build-dependencies package names
  - build-depend on gnome-pkg-tools for uploaders

gnome-shell (2.28.0-0ubuntu2) karmic; urgency=low

  * Add libcroco3-dev to Build-Depends.  Fixes FTBFS.

gnome-shell (2.28.0-0ubuntu1) karmic; urgency=low

  * New upstream version
  * debian/control:
    - updated build requirement
  * debian/patches/80_git_change_fix_alt_tab_ressource_usage.patch:
    - git change to fix ressources not being freed on alt-tab

gnome-shell (2.27.3-0ubuntu1) karmic; urgency=low

  * New upstream version
  * debian/control:
    - depends on python since it's used in the wrapper 
      (lp: #413096)
    - updated gir requirement

gnome-shell (2.27.2-0ubuntu1) karmic; urgency=low

  * New upstream version

gnome-shell (2.27.1-0ubuntu1) karmic; urgency=low

  * New upstream version
  * debian/control:
    - updated build requirements

gnome-shell (2.27.0-0ubuntu3) karmic; urgency=low

  * Requires gvfs-backends now

gnome-shell (2.27.0-0ubuntu2) karmic; urgency=low

  * Require gobject-introspection-freedesktop too

gnome-shell (2.27.0-0ubuntu1) karmic; urgency=low

  * New upstream version

gnome-shell (0.0.1~git20090805-0ubuntu1) karmic; urgency=low

  * New upstream snapshot
  * debian/control:
    - require new clutter

gnome-shell (0.0.1~git20090715-0ubuntu1) karmic; urgency=low

  * New upstream snapshot
  * debian/control:
    - build-depends on libglib

gnome-shell (0.0.1~git20090702-0ubuntu0.2) karmic; urgency=low

  * debian/control:
    - recommends xserver-xephyr

gnome-shell (0.0.1~git20090702-0ubuntu0.1) karmic; urgency=low

  * New git version
  * debian/control:
    - updated the depends

gnome-shell (0.0.1~git20090701-0ubuntu0.3) karmic; urgency=low

  * debian/control:
    - build-depends on gobject-introspection-glib-2.0 and not on libdesk

gnome-shell (0.0.1~git20090701-0ubuntu0.2) karmic; urgency=low

  * debian/control: build-depends on gobject-introspection

gnome-shell (0.0.1~git20090701-0ubuntu0.1) karmic; urgency=low

  * Initial ppa upload
 -- Laurent Bigonville <email address hidden>   Sat,  28 May 2011 08:37:12 +0000

Upload details

Uploaded by:
Laurent Bigonville on 2011-05-28
Uploaded to:
Oneiric
Original maintainer:
Gustavo Noronha Silva
Architectures:
any
Section:
gnome
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
gnome-shell_3.0.1.orig.tar.bz2 1.0 MiB 01f7ae942ba9687a5e67d62423843ed404d77b35f74acc212a5f391beed8e079
gnome-shell_3.0.1-1.debian.tar.gz 134.9 KiB 2beab6a485c291bf8e4b1fbeb52cf7704fbc7442b55f0a67d9980ae5bc379a12
gnome-shell_3.0.1-1.dsc 2.5 KiB 690d6d97d2128b203d306b7d628c37d50e831ae2163b57c7c67246009af7ed86

Available diffs

View changes file

Binary packages built by this source

gnome-shell: No summary available for gnome-shell in ubuntu oneiric.

No description available for gnome-shell in ubuntu oneiric.