[edgy] gstreamer, rhythmbox won't read files over smb

Bug #60326 reported by David Mandelberg on 2006-09-13
102
Affects Status Importance Assigned to Milestone
Edgy Backports
Undecided
Unassigned
GnomeVFS
Fix Released
Medium
gnome-vfs2 (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gstreamer0.10-gnomevfs

When I try to load files over smb into rhythmbox, I get import errors "Could not read from resource." I tried using gst-launch-0.10 and it also didn't work:

david@helicon:~$ gst-launch-0.10 gnomevfssrc location="smb://<email address hidden>/Files/David's%20Extra%20Music/Beatles%2C%20The/Live%20at%20the%20BBC%20(disc%201)/01.%20The%20Beatles%20-%20Beatle%20Greetings.flac" ! testsink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
ERROR: from element /pipeline0/gnomevfssrc0: Could not read from resource.
Additional debug info:
gstgnomevfssrc.c(692): gst_gnome_vfs_src_create (): /pipeline0/gnomevfssrc0:
Failed to read data: Internal error
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
FREEING pipeline ...

David Mandelberg (dseomn) wrote :

I forgot to mention the versions:

gstreamer0.10-gnomevfs 0.10.9-1ubuntu2
libgstreamer0.10-0 0.10.9-1ubuntu3
rhythmbox 0.9.5-1ubuntu5
libgnomevfs2-0 2.16.0-0ubuntu1

Holger Bauer (umarmung-planet) wrote :

There is already a bug open upstream.

Changed in gnome-vfs:
status: Unknown → Unconfirmed
Sebastien Bacher (seb128) wrote :

Marking as confirmed since http://bugzilla.gnome.org/show_bug.cgi?id=351322 pointed upstream seems to be the same issue

Changed in gst-plugins-base0.10:
assignee: nobody → desktop-bugs
importance: Untriaged → Low
status: Unconfirmed → Confirmed
Changed in gnome-vfs2:
importance: Low → High
Changed in gnome-vfs:
status: Unconfirmed → Confirmed
finalbeta (j-greenhouse) wrote :

Hello. People on the forums using the Feisty repo's report the problem is solved on feisty. Upstream reports that upgrading the lib's solves this problem : http://bugzilla.gnome.org/show_bug.cgi?id=351322

Could a fix be backported to edgy? (Altho I know Edgy might only get security updates). This problem affects more then Rhythmbox as you can see by the duplicate bug reports.

It breaks playback for all media (movies/music) for all programs (VLC,Totem,Rhythmbox...) that use remote sources like smb and even ftp I believe.

Chris Lord (cwiiis) wrote :

I tried building gnome-vfs 2.16.3 from feisty and the problem still existed - on the other hand, building 2.14.1 from dapper fixed things. I hope this is fixed soon, this is a pretty unbelievable regression...

Le samedi 11 novembre 2006 à 13:30 +0000, FiNaLBeTa a écrit :
> Hello. People on the forums using the Feisty repo's report the problem
> is solved on feisty.

Do you have a pointer to that information? There is no change likely to
have fixed that to the new gnome-vfs, the bug is still opened upstream
and the bug is still happening on feisty on my desktop

John Stowers (nzjrs) wrote :

Well to be honest this sort of bug makes me embarissed to show Ubuntu to my family and friends.

Could someone please backport a fix to edgy?

finalbeta (j-greenhouse) wrote :

It's not fixed yet upstream.
I actually use this daily. So I know how you feel. I've been pushing them a little, but seems it stalled again.

Changed in gnome-vfs:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

Looks like it work fine on feisty now, marking fixed. Feel free to reopen if you still get the problem on feisty. We might look at backporting a fix to edgy if the feisty version works fine. If somebody wants to figure what commit fix that exactly and attach the patch to the bug to make the backport easier he's welcome

Changed in gnome-vfs2:
status: Confirmed → Fix Released
Brad Johnson (brad-bkjohnson) wrote :

It seems to me that this bug report was filed against Edgy and as there is no fix for Edgy there is no "Fix Released", which is the current status of this bug.

Am I mistaken here?

I agree with Brad: this should *not* be marked "Fix Released".

Facing with the same problem, I googled and found this bug report. I saw the "Fix Released" status and thought "Oh great that's fixed already!" :-) But I did an update/upgrade, and to my great dismay, things are still broken.

Someone mentioned on the upstream bug report (http://bugzilla.gnome.org/show_bug.cgi?id=351322) that apparently, gnome-2.16.2 fixed the problem under Gentoo (versions: totem-2.16.4, gnome-vfs-2.16.2, gstreamer-0.10.11). So maybe a fix would be to upgrade Edgy to 2.16.2?

Anyway, until this is really fixed in Edgy, please reopen this bug.

Sebastien Bacher (seb128) wrote :

There is a package fixing the bug available, the bug is fixed then. If you think a backport should be done you can open a backport task, that's the workflow we are using, that bug has not been wrongly closed

Thank you for the clarification, Sebastien. A backport request has been logged:

https://bugs.launchpad.net/edgy-backports/+bug/79370

Sebastien Bacher (seb128) wrote :

My comment was probably not clear enough, no need of a new bug, the left column from the bug page has a "Target to Release" item, you can use it to open an edgy task on the same bug page

The just released "2.16.1-0ubuntu6 (edgy-proposed)" fixes the problem for me.

Thanks to everyone involved!

PS: Sebastien, thanks for the extra explanation and sorry about the noise. Indeed, opening a new bug sounded quite inefficient. Now it makes sense.

Rouben (rouben) wrote :

Added backport task by mistake.

Changed in edgy-backports:
status: Unconfirmed → Rejected
Giuseppe Noviello (giunov) wrote :

I have the same problem with KDE, I cannot play any media over samba.

finalbeta (j-greenhouse) wrote :

@Giuseppe Noviello

If you are using a KDE application to play the media. You problem has nothing to do with this pecific bug. Please report a separate bug noting the application and it's version.

Changed in gnome-vfs:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.