Change log for gnu-efi package in Ubuntu

132 of 32 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-11-20
Deleted in disco-proposed (Reason: moved to release)
gnu-efi (3.0.9-1) unstable; urgency=medium

  * New upstream version 3.0.9
  * Update Vcs URIs to point to Salsa
  * Delete debian/source/options

 -- Julian Andres Klode <email address hidden>  Mon, 22 Oct 2018 13:44:47 +0200
Published in trusty-updates on 2018-09-13
Deleted in trusty-proposed (Reason: moved to -updates)
gnu-efi (3.0.8-0ubuntu1~14.04.1) trusty; urgency=medium

  * New upstream version 3.0.8. (LP: #1790709)
  * debian/patches: drop patches, included upstream.
  * Reinstate d/p/ARM-hide-hidden-pragma-for-hosted-build.patch; otherwise
    sbsigntool fails to build on armhf.
  * debian/patches/intptr_define.patch: include stdint.h from inc/efilink.h.

 -- Mathieu Trudel-Lapierre <email address hidden>  Tue, 04 Sep 2018 15:30:59 -0400
Published in xenial-updates on 2018-09-13
Deleted in xenial-proposed (Reason: moved to -updates)
gnu-efi (3.0.8-0ubuntu1~16.04.1) xenial; urgency=medium

  * New upstream version 3.0.8. (LP: #1790709)
  * debian/patches: drop patches, included upstream.
  * Reinstate d/p/ARM-hide-hidden-pragma-for-hosted-build.patch; otherwise
    sbsigntool fails to build on armhf.

 -- Mathieu Trudel-Lapierre <email address hidden>  Tue, 04 Sep 2018 15:28:31 -0400
Published in bionic-updates on 2018-09-12
Deleted in bionic-proposed (Reason: moved to -updates)
gnu-efi (3.0.8-0ubuntu1~18.04.1) bionic; urgency=medium

  * New upstream version 3.0.8. (LP: #1790709)
  * debian/patches: drop patches, included upstream.
  * Reinstate d/p/ARM-hide-hidden-pragma-for-hosted-build.patch; otherwise
    sbsigntool fails to build on armhf.

 -- Mathieu Trudel-Lapierre <email address hidden>  Tue, 04 Sep 2018 15:09:02 -0400
Superseded in disco-release on 2018-11-20
Published in cosmic-release on 2018-08-29
Deleted in cosmic-proposed (Reason: moved to release)
gnu-efi (3.0.8-0ubuntu1) cosmic; urgency=medium

  * New upstream version 3.0.8.
  * debian/patches: drop patches, included upstream.
  * Reinstate d/p/ARM-hide-hidden-pragma-for-hosted-build.patch; otherwise
    sbsigntool fails to build on armhf.

 -- Mathieu Trudel-Lapierre <email address hidden>  Wed, 29 Aug 2018 15:51:28 -0400
Superseded in cosmic-release on 2018-08-29
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
gnu-efi (3.0.4-2) unstable; urgency=medium

  * aarch64: Fix invalid cast from const to non-const
  * Do not build with -Werror

 -- Julian Andres Klode <email address hidden>  Thu, 30 Jun 2016 13:41:30 +0200
Obsolete in vivid-updates on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to -updates)
gnu-efi (3.0.2-1ubuntu1~15.04.1) vivid; urgency=medium

  * Backport gnu-efi to 15.04; to support fwupdate. (LP: #1512510)

 -- Mathieu Trudel-Lapierre <email address hidden>  Mon, 02 Nov 2015 16:45:49 -0600
Superseded in yakkety-release on 2016-07-16
Published in xenial-release on 2016-04-12
Superseded in xenial-release on 2016-04-12
Superseded in xenial-release on 2016-04-11
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
gnu-efi (3.0.2-1ubuntu1) wily; urgency=medium

  * Merge with Debian unstable, remaining changes:
    - debian/patches/gcc46-compatibility: don't break with old compilers
      and -DGNU_EFI_USE_MS_ABI.

 -- Mario Limonciello <email address hidden>  Thu, 04 Jun 2015 17:35:25 -0500

Available diffs

Superseded in wily-release on 2015-06-04
Deleted in wily-proposed on 2015-06-06 (Reason: moved to release)
gnu-efi (3.0v-5ubuntu1) wily; urgency=medium

  * Merge from Debian unstable (LP: #1396381), remaining changes:
    - debian/patches/gcc46-compatibility: don't break with old compilers
      and -DGNU_EFI_USE_MS_ABI.
  * Dropped changes, included in Debian:
    - pass architecture arguments when building the x86_64 code on i386

Superseded in wily-release on 2015-05-12
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
gnu-efi (3.0u+debian-4ubuntu1) utopic; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - debian/patches/gcc46-compatibility: don't break with old compilers
      and -DGNU_EFI_USE_MS_ABI.
  * Dropped changes, included in Debian:
    - pass architecture arguments when building the x86_64 code on i386

Obsolete in raring-updates on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to -updates)
gnu-efi (3.0u+debian-1ubuntu2~13.04.0) raring; urgency=low

  * Backport gnu-efi from saucy to raring to support new versions of
    shim.  LP: #1229572.

Obsolete in quantal-updates on 2015-04-24
Deleted in quantal-proposed on 2015-05-01 (Reason: moved to -updates)
gnu-efi (3.0u+debian-1ubuntu2~12.10.0) quantal; urgency=low

  * Backport gnu-efi from saucy to quantal to support new versions of
    shim.  LP: #1229572.

Published in precise-updates on 2013-11-07
Deleted in precise-proposed (Reason: moved to -updates)
gnu-efi (3.0u+debian-1ubuntu2~12.04.0) precise; urgency=low

  * Backport gnu-efi from saucy to precise to support new versions of
    shim.  LP: #1229572.

Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
gnu-efi (3.0u+debian-1ubuntu2) saucy; urgency=low

  * debian/patches/gcc46-compatibility: don't break with old compilers
    and -DGNU_EFI_USE_MS_ABI.
 -- Steve Langasek <email address hidden>   Tue, 24 Sep 2013 06:41:55 +0000
Superseded in saucy-release on 2013-09-24
Deleted in saucy-proposed on 2013-09-25 (Reason: moved to release)
gnu-efi (3.0u+debian-1ubuntu1) saucy; urgency=low

  * Merge from Debian experimental, remaining changes:
    - pass architecture arguments when building the x86_64 code on i386
  * Dropped changes, included upstream:
    - build with -fno-stack-protector.

Superseded in saucy-release on 2013-07-02
Deleted in saucy-proposed on 2013-07-03 (Reason: moved to release)
gnu-efi (3.0s+debian-3ubuntu1) saucy; urgency=low

  * Resynchronise with Debian.  Remaining changes:
    - debian/rules: pass architecture arguments when building the x86_64
      code on i386; otherwise the upstream build system wrongly assumes that
      if uname says x86_64, it doesn't have to pass -m64 to the compiler.

Superseded in saucy-release on 2013-05-04
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
gnu-efi (3.0s+debian-1ubuntu2) raring; urgency=low

  * Restore -fno-stack-protector; this is needed to build packages linked
    against gnu-efi, such as efilinux.  This change is now in a patch with a
    header explaining the reasoning, to try to avoid it being dropped in
    future.
 -- Colin Watson <email address hidden>   Wed, 09 Jan 2013 11:58:51 +0000
Superseded in raring-release on 2013-01-09
Deleted in raring-proposed on 2013-01-10 (Reason: moved to release)
gnu-efi (3.0s+debian-1ubuntu1) raring; urgency=low

  * Merge from Debian unstable, dropped changes:
    - gnuefi/elf_x86_64_efi.lds: align the .reloc section; merged upstream.
    - Build with -fno-stack-protector; no longer needed.
  * debian/rules: past architecture arguments when building the x86_64 code on
    i386; otherwise the upstream build system wrongly assumes that if uname
    says x86_64, it doesn't have to pass -m64 to the compiler.

Superseded in raring-release on 2012-12-13
Obsolete in quantal-release on 2015-04-24
gnu-efi (3.0i-3ubuntu2) quantal; urgency=low

  * gnuefi/elf_x86_64_efi.lds: align the .reloc section; otherwise the
    generated binaries may not validate correctly with Secure Boot.
 -- Steve Langasek <email address hidden>   Sun, 01 Jul 2012 21:08:10 -0700

Available diffs

Superseded in quantal-release on 2012-07-02
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
gnu-efi (3.0i-3ubuntu1) maverick; urgency=low

  * Merge from debian unstable.  Remaining changes: LP: #595499
    - Build with -fno-stack-protector.
 -- Bhavani Shankar <email address hidden>   Thu, 17 Jun 2010 18:20:21 +0530

Available diffs

Superseded in maverick-release on 2010-08-05
Obsolete in lucid-release on 2016-10-26
gnu-efi (3.0i-2ubuntu1) lucid; urgency=low

  * Merge from debian testing. (LP: #488797) Remaining changes:
    - Build with -fno-stack-protector.

Available diffs

Superseded in lucid-release on 2010-02-11
Obsolete in karmic-release on 2013-03-04
gnu-efi (3.0e-3ubuntu2) karmic; urgency=low

  * Build with -fno-stack-protector.

 -- Colin Watson <email address hidden>   Wed, 24 Jun 2009 16:20:21 +0100

Available diffs

Superseded in karmic-release on 2009-06-24
gnu-efi (3.0e-3ubuntu1) karmic; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Build package for lpia.

Available diffs

Superseded in karmic-release on 2009-06-19
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
gnu-efi (3.0e-2ubuntu1) intrepid; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Build package for lpia.
  * Use /usr/lib32 rather than /emul/ia32-linux/usr/lib, as is standard on
    Ubuntu.

Available diffs

Superseded in intrepid-release on 2008-06-12
Obsolete in hardy-release on 2015-04-24
gnu-efi (3.0d-1ubuntu1) hardy; urgency=low

  * Merge with Debian; remaining changes:
    - Build package for lpia.

Superseded in hardy-release on 2007-12-05
Obsolete in gutsy-release on 2011-09-16
gnu-efi (3.0c-1ubuntu1) gutsy; urgency=low

  * Build package for lpia.
  * Set Ubuntu maintainer address.

 -- Matthias Klose <email address hidden>   Fri, 10 Aug 2007 21:08:56 +0000
Superseded in gutsy-release on 2007-08-10
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
gnu-efi (3.0c-1) unstable; urgency=low

  * new upstream version, described as a maintenance release for 
    compatibility with current gcc and binutils versions

 -- Colin Watson <email address hidden>   Mon,  03 Jul 2006 16:59:55 +0100
Superseded in edgy-release on 2006-07-03
Obsolete in dapper-release on 2011-09-06
gnu-efi (3.0b-1ubuntu3) dapper; urgency=low

  * Updated patch for linker script, removed -march=i386

 -- Matthew Garrett <email address hidden>   Sun, 19 Mar 2006 23:59:23 +0000
Superseded in dapper-release on 2006-03-20
gnu-efi (3.0b-1ubuntu2) dapper; urgency=low

  * Include patch from H.J. Lu to fix the linker script.

 -- Matthew Garrett <email address hidden>   Fri, 17 Mar 2006 20:48:40 +0000
Superseded in dapper-release on 2006-03-17
gnu-efi (3.0b-1ubuntu1) dapper; urgency=low

  * Build with -march=i386

 -- Matthew Garrett <email address hidden>   Tue, 14 Mar 2006 11:30:43 +0000
Superseded in dapper-release on 2006-03-14
Superseded in dapper-release on 2006-02-03
gnu-efi (3.0b-1) unstable; urgency=low


  * new upstream version, closes: #341124
  * downgrade priority to optional, closes: #280646
  * fix lib/print.c to prevent printing garbage when items were passed on
    software stack, closes: #283842

 -- Bdale Garbee <email address hidden>  Wed,  7 Dec 2005 20:55:46 -0800
Obsolete in breezy-release on 2008-03-25
Obsolete in hoary-release on 2008-03-19
Obsolete in warty-release on 2008-01-09
gnu-efi (3.0a-4) unstable; urgency=low


  * fix gcc path problem in Makefile exposed by build on i386, closes: #215050
  * merge patches from upstream to address linker problems on i386

 -- Bdale Garbee <email address hidden>  Thu, 23 Oct 2003 19:53:19 -0600
132 of 32 results