Gnucash crash

Bug #55462 reported by Scott Henson
40
Affects Status Importance Assigned to Milestone
GnuCash
Fix Released
Undecided
Unassigned
gnucash (Ubuntu)
Fix Released
High
MOTU Reviewers Team

Bug Description

gnucash is crashing in edgy.

I start up gnucash and use the File->New->New File. I go through the dialogues accepting the defaults, except I add that I have renters expenses. The druid finishes and I then attempt to save the new file and gnucash crashes with a seg fault in glibc and the attached crash report.

Doing the same except importing a qif file instead of saving produces another segfault.

Also just opening up gnucash and saving the empty file causes the same thing. Its like anytime gnucash wants to access the filesystem causes it to segfault.

Tags: edgy
Revision history for this message
Scott Henson (scotth) wrote :
Revision history for this message
Vassilis Pandis (pandisv) wrote :

Thank you for your bug report. Can you please try to get a backtrace with debug symbols by following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash ? The importing situation could be possibly be a different problem - try getting a backtrace for that as well and file a second bug report (if they end up being the same problem, we will just mark them as duplicates). Once again, thanks.

Changed in gnucash:
status: Unconfirmed → Needs Info
Revision history for this message
Scott Henson (scotth) wrote :

Aparently gnucash doesn't like being run by gdb. It crashes right out of the box. But, running it regular like, I get the crash dialogue with a little bit more info. Ive attached both.

Revision history for this message
Scott Henson (scotth) wrote :
Revision history for this message
Michael S. (jellicle) wrote :

The "crash when importing data" has already been reported in bug #53904, which does not seem to have attracted any Ubuntu maintainer attention. There are clearly one (or more) bugs here.

Revision history for this message
Scott Henson (scotth) wrote :

As another tidbit, I tried 2.0.1 on both edgy and on dapper. Dapper worked, edgy did not. I have a feeling that gnucash may not be aware of some change in the edgy libraries.

Revision history for this message
Aleksander Kamil Modzelewski (aleander) wrote :

I have a very similiar problem - only, the program ocassionally hangs instead of crashing. Anyway, I have attached a backtrace (I had to gdb gnucash-bin, but I have previously sourced all variable-setting code from /usr/bin/gnucash, therefore making sure that the execution environment is ok)

Revision history for this message
Vassilis Pandis (pandisv) wrote :

Aleksander, please file a seperate bug report. It doesn't seem to be the same issue...

Changed in gnucash:
importance: Untriaged → High
Revision history for this message
Scott Henson (scotth) wrote :

This crash only occurs when the file chooser is used. If you can avoid the file chooser, gnucash works fine. Unfortunately, its kinda hard to avoid it. I'm going to try getting a back trace in the same way as the guy above.

Revision history for this message
Scott Henson (scotth) wrote :
Revision history for this message
andi5 (andi5) wrote :

I see this crash with the stock packages, but in none of my self-compiled installations. Could the packager try to remove the four lines containing gnctreemodelsort and gtktreedatalist from src/gnome-utils/Makefile.am and see whether this helps? If it does, we will probably rename gtktreedatalist (as there seems to be some linking conflict with gtk) upstream.

Changed in gnucash:
status: Needs Info → Confirmed
andi5 (andi5)
Changed in gnucash:
status: Unconfirmed → Fix Committed
Revision history for this message
Michael S. (jellicle) wrote :

I just installed the most recent gnucash version from edgy repositories, 2.0.0-1ubuntu2.

Unfortunately, the problem persists. Any usage of the file chooser results in a crash or hang.

Revision history for this message
Aleksander Kamil Modzelewski (aleander) wrote :

That was just an upgrade related to some big library change. If I understand correctly, the bug is upstream and would require UVF exception or something similiarily nice.

Revision history for this message
andi5 (andi5) wrote :

For reference: Applying http://svn.gnucash.org/trac/changeset/14761?format=diff should fix this issue.

Revision history for this message
Aleksander Kamil Modzelewski (aleander) wrote :

aleander@HumanError:~$ apt-get source gnucash
aleander@HumanError:~$ cd gnucash-2.0.0/
aleander@HumanError:~$ patch -p3 < /home/aleander/Desktop/Changeset14761.diff
aleander@HumanError:~$ dch -i
[modified the version for better synaptic experience :>]
aleander@HumanError:~$ sudo debuild
[after some time...]
aleander@HumanError:~$ sudo dpkg -i ../*.deb

And it works. Thank you. Any chance for this getting into the official packages sometime soon?

Revision history for this message
Arthur Penn (arthur-penn) wrote :

FWIW, I pulled down the 2.0.1 Gnucash source and built and the problem exists. The file browser just hangs.

Revision history for this message
Brendon Toogood (brendont) wrote :

i to started gnucash in edgy and when i went to the files chosser , it was ok, to create my accounts, but when i go to save the file save crashes and kills the application, i just re started the gnucash and got this error

Revision history for this message
Scott Henson (scotth) wrote :

I applied the above patch and produced a debdiff. Its attached.

Scott Henson (scotth)
Changed in gnucash:
assignee: nobody → motu
Revision history for this message
Brendon Toogood (brendont) wrote : Re: [Bug 55462] Re: Gnucash crash

On Sun, 2006-09-17 at 03:04 +0000, Scott Henson wrote:
> I applied the above patch and produced a debdiff. Its attached.
>
> ** Attachment added: "Patch against latest gnucash in edgy."
> http://librarian.launchpad.net/4291206/gnucash.diff
>
how is the patch applied to work around the error?
--
.......
  Brendon Toogood
  Ubuntu Linux Advocate
  Linux Registered User #417189
  The Ubuntu Counter Project - user number # 1741
  http://www.freewebs.com/wlcs/

Revision history for this message
Vassilis Pandis (pandisv) wrote :

reassigning from MOTU to motureviewers (because of the debdiff)

Changed in gnucash:
assignee: motu → motureviewers
Revision history for this message
Andrew Mitchell (ajmitch) wrote :

Patch looks fine, I'll build, test & upload soon.

Revision history for this message
Andrew Mitchell (ajmitch) wrote :

gnucash won't build until a newer version of g-wrap is synced from debian, so it may take a little while for the fix to come through

Revision history for this message
Fionn (fbe) wrote :

I can confirm the issue. I rebuilt the whole set of packages (2.0.1) with the above patch but the problem did NOT go away for me.

Revision history for this message
Fionn (fbe) wrote :

Here is another backtrace of the patched and crashed gnucash.

Revision history for this message
andi5 (andi5) wrote :

A problem I could imagine: This patch will only work on systems with automake installed, unless you actually patch Makefile.in's.

Revision history for this message
Herbert V. Riedel (hvr) wrote :

jfyi, I'm still having the file-dialog related crashes with
gnucash 2.0.1-3ubuntu2, which according to changelog.Debian is supposed to close this very malone bug ;-)

Revision history for this message
Aleksander Kamil Modzelewski (aleander) wrote :

Yep. Here too. Save as..., Cancel, the application hangs.

Revision history for this message
Aleksander Kamil Modzelewski (aleander) wrote :

Creating a new file also hangs Gnucash. Applying the patch from http://svn.gnucash.org/trac/changeset/14761?format=diff to the previous version removed the bug for me.

Revision history for this message
Herbert V. Riedel (hvr) wrote :

I can confirm that hand-editing the corresponding Makefile.in (which haven't been regenerated in 2.0.1-3ubuntu2) as well (see attached diff) and rebuilding the package fixes the crashes for me

Revision history for this message
Andrew Mitchell (ajmitch) wrote :

Sorry about that, I'll re-run automake on it & upload again.

Revision history for this message
Andrew Mitchell (ajmitch) wrote :

Could those who are able to get 2.0.1-3ubuntu3 confirm that the bug is finally fixed now? (amd64 & ppc builds are still waiting, i386 should be in the archive)

Changed in gnucash:
status: Confirmed → Fix Committed
Revision history for this message
Michael R. Head (burner) wrote :

seems OK here.

Revision history for this message
Michael S. (jellicle) wrote :

I'm happy to report that with the latest version (2.0.1-3ubuntu3), I can again import .qfx files. Bug appears to be fixed. Hurray!

Revision history for this message
Aleksander Kamil Modzelewski (aleander) wrote :

The problems with save as/open dialogs have disappeared. Therefore the bug seems to be fixed. Thank you :-)

Revision history for this message
Fionn (fbe) wrote :

I can confirm as well, that after manipulating Makefile.in and rebuilding the problems are gone.

Changed in gnucash:
status: Fix Committed → Fix Released
andi5 (andi5)
Changed in gnucash:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers