Ubuntu

Gnucash uninstallable due to dependency on libgtkhtml3.8-15 (>=3.13.6)

Reported by mvandeg on 2007-03-15
118
Affects Status Importance Assigned to Milestone
gnucash (Ubuntu)
Medium
Adrien Cunin
gtkhtml3.8 (Ubuntu)
High
Sebastien Bacher

Bug Description

Binary package hint: gnucash

Trying to install Gnucash it complains about a missing depency: libgtkhtml3.8-15 (>=3.13.6)

This package is not available in the repos. Other versions of libgtkhtml are.

Adrien Cunin (adri2000) wrote :

Thanks for your bug report, I will upload a rebuild.

Changed in gnucash:
assignee: nobody → adri2000
importance: Undecided → Medium
status: Unconfirmed → In Progress
Adrien Cunin (adri2000) wrote :

Waiting for a fix for libgtkhtml to be uploaded first.

Gunni (fgunni) wrote :

These bugs seem to deal with the same issue:

82194 gnucash crash when printing
92598 Broken dependency

libgtkhtml appears to be fixed.

Adrien, can you upload the fix for this please? Before we get more dupes?

Adrien Cunin (adri2000) wrote :

> libgtkhtml appears to be fixed.
Where have you seen this?
It still fails to build: ../../../src/gnome-utils/.libs/libgncmod-gnome-utils.so: undefined reference to `gtk_html_print'
Some API change needs to be reverted.

Matt Zimmerman (mdz) wrote :

Some background here on evolution-dev:

http://www.nabble.com/Why-is-GnomePrintContext-still-in-GtkHtml--t3061502.html

and gnucash-devel:

http://<email address hidden>/msg17426.html

This change is intentional (though they seem to have overlooked the SONAME change the first time); this function is not coming back. gnucash apparently needs to be migrated to the new API.

andi5 (andi5) wrote :

GnuCash builds perfectly against gtkhtml-3.8. It is a ubuntu packaging bug to use gtkhtml development releases leading to 3.14 and mark them as 3.8. Why that?
GnuCash 2.0.x will probably never work with gtkhtml 3.14 or some other version lacking gtk_html_print. Please consider downgrading gtkhtml to 3.12.x.

On Fri, Mar 23, 2007 at 11:30:31PM -0000, andi5 wrote:
> GnuCash builds perfectly against gtkhtml-3.8. It is a ubuntu packaging
> bug to use gtkhtml development releases leading to 3.14 and mark them as
> 3.8. Why that?

It isn't. Like other GNOME components, we track the development releases
as stepping stones to the new stable series, which happens in sync with
Ubuntu releases.

> GnuCash 2.0.x will probably never work with gtkhtml 3.14 or some other
> version lacking gtk_html_print. Please consider downgrading gtkhtml to
> 3.12.x.

Why do you think so? gtk_html_print was a trivial wrapper around functions
which are still present.

--
 - mdz

Matt Zimmerman (mdz) wrote :

Subscribing seb128 for input...

Seb:

It looks like we've been tracking gtkhtml 3.13.x is gtkhtml3.8, and that introduced an incompatible change which broke gnucash. gtkhtml 3.14.x seems to be packaged now as gtkhtml3.14, with gtkhtml3.8 still being 3.13.x.

What do you think is the best way to fix this situation? We could at least:
- Revert the API changes in gtkhtml3.8
- Backport the GTK printing support from gnucash 2.2 (andi5 says this is more complex than one might expect)
- Package gtkhtml 3.12.x separately for gnucash (are there other apps broken by this?)

Sebastien Bacher (seb128) wrote :

They changed the versionning number to have 3.8 and 3.14 installable together due to that, my idea was to a gtkhtml3.8 version without the API change when the current freeze will have lifted

Sebastien Bacher (seb128) wrote :

They changed the versionning number to have 3.8 and 3.14 installable together due to that, my idea was to upload a gtkhtml3.8 version without the API change when the current freeze will have lifted

Changed in gnucash:
assignee: adri2000 → seb128
importance: Medium → High
Sebastien Bacher (seb128) wrote :

 gtkhtml3.8 (3.13.92.is.3.13.6-0ubuntu1) feisty; urgency=low
 .
   * Upload version without the API breakage for applications which have not
     been updated yet (Ubuntu: #92477)

Changed in gnucash:
status: In Progress → Fix Released
Adrien Cunin (adri2000) on 2007-03-26
Changed in gnucash:
assignee: nobody → adri2000
importance: Undecided → Medium
status: Unconfirmed → In Progress
Adrien Cunin (adri2000) wrote :

Rejecting gnucash task, since there is nothing to fix here.
gnucash unmetdeps are fixed with gtkhtml3.8 upload.

Changed in gnucash:
status: In Progress → Rejected
andi5 (andi5) wrote :

I am sorry for reopening, but: gtkhtml3.8 3.13.6-0ubuntu1 seems to be crappy.
I will give you a few pointers and let you decide what to do.
Maybe 3.13.5 will work, I do not know...

https://bugs.launchpad.net/ubuntu/+source/gnucash/+bug/82194
gnucash crash when printing

http://svn.gnome.org/viewcvs/gtkhtml/tags/
crashes, no GTKHTML_3_13_6 tag anyway, so I will use r8356, which is probably the one used for the release

http://svn.gnome.org/viewcvs/gtkhtml/trunk/NEWS?view=markup&pathrev=8356
internally, 3.13.6 seems to be 3.13.90 already.

http://svn.gnome.org/viewcvs/gtkhtml/trunk/src/htmlengine-print.c?view=markup&pathrev=8356
html_engine_print takes a GtkPrintContext*

http://svn.gnome.org/viewcvs/gtkhtml/trunk/src/gtkhtml.c?view=markup&pathrev=8356
gtk_html_print feeds it with a GnomePrint*

http://librarian.launchpad.net/6939232/buildlog_ubuntu-feisty-amd64.gtkhtml3.8_3.13.92.is.3.13.6-0ubuntu1_FULLYBUILT.txt.gz
> gtkhtml.c:4172: warning: passing argument 2 of 'html_engine_print' from incompatible pointer type

Sebastien Bacher (seb128) wrote :

I've uploaded a new update:

 gtkhtml3.8 (1:3.13.5-0ubuntu1) feisty; urgency=low
 .
   * Upload 3.13.5 which is the correct version to get no API change
     (Ubuntu: #92477)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions