Change log for gnucash package in Ubuntu

175 of 107 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2019-01-03
Deleted in disco-proposed (Reason: moved to release)
gnucash (1:3.4-1) unstable; urgency=medium

  * New upstream release (Closes: #918059).
  * New patch to fix "test-transaction" (Closes: #918057).

 -- Dmitry Smirnov <email address hidden>  Thu, 03 Jan 2019 08:51:54 +1100
Superseded in disco-release on 2019-01-03
Deleted in disco-proposed on 2019-01-04 (Reason: moved to release)
gnucash (1:3.3-2build2) disco; urgency=medium

  * No-change rebuild for icu soname changes.

 -- Matthias Klose <email address hidden>  Tue, 13 Nov 2018 08:02:01 +0000

Available diffs

Superseded in disco-release on 2018-11-23
Deleted in disco-proposed on 2018-11-24 (Reason: moved to release)
gnucash (1:3.3-2build1) disco; urgency=medium

  * No-change rebuild to build for python3.7 as the default.

 -- Matthias Klose <email address hidden>  Wed, 31 Oct 2018 12:34:40 +0000
Superseded in disco-release on 2018-11-02
Published in cosmic-release on 2018-10-12
Deleted in cosmic-proposed (Reason: moved to release)
gnucash (1:3.3-2) unstable; urgency=medium

  * New patch to skip broken "test-qofsession".
  * Added necessary patch as per #906609.
    Thanks, Bernhard Übelacker.

 -- Dmitry Smirnov <email address hidden>  Sun, 07 Oct 2018 12:51:40 +1100
Superseded in cosmic-release on 2018-10-12
Deleted in cosmic-proposed on 2018-10-13 (Reason: moved to release)
gnucash (1:3.2-1ubuntu4) cosmic; urgency=medium

  * Revert debian/patches/avoid-broken-mktemp.patch, which had no actual
    effect on buildability.
  * debian/patches/proper-endian-handling.patch: fix detection of big-
    endianness.
  * debian/patches/missing-strptime-decl.patch: fix missing strptime()
    declaration on some platforms.
  * debian/patches/RTLD_DEFAULT.patch: ensure availability of
    RTLD_DEFAULT GNUism.
  * debian/patches/no-unaligned-access.patch: use alignment-safe
    handling.

 -- Steve Langasek <email address hidden>  Thu, 23 Aug 2018 23:37:01 -0700
Superseded in cosmic-proposed on 2018-08-24
gnucash (1:3.2-1ubuntu3) cosmic; urgency=medium

  * debian/patches/avoid-broken-mktemp.patch: use mkstemp(3) instead of
    mktemp(3).
  * Add missing build-dependency on tzdata, needed for testsuite.

 -- Steve Langasek <email address hidden>  Thu, 23 Aug 2018 16:48:43 -0700

Available diffs

Superseded in cosmic-proposed on 2018-08-24
gnucash (1:3.2-1ubuntu2) cosmic; urgency=medium

  * debian/patches/fix-cflags.patch: use -Wno-deprecated-declarations,
    not -Wno-deprecated-register.

 -- Steve Langasek <email address hidden>  Thu, 23 Aug 2018 23:13:23 +0000

Available diffs

Superseded in cosmic-proposed on 2018-08-23
gnucash (1:3.2-1ubuntu1) cosmic; urgency=medium

  * debian/patches/drop-unknown-cflags.patch: don't pass not-universally-
    supported -Wno-deprecated-register.

 -- Steve Langasek <email address hidden>  Thu, 23 Aug 2018 15:42:12 -0700

Available diffs

Superseded in cosmic-proposed on 2018-08-23
gnucash (1:3.2-1build1) cosmic; urgency=medium

  * No-change rebuild for boost soname change.

 -- Matthias Klose <email address hidden>  Tue, 17 Jul 2018 13:13:26 +0000
Superseded in cosmic-proposed on 2018-07-17
gnucash (1:3.2-1) unstable; urgency=medium

  * New upstream release [June 2018] (Closes: #897970).
  * Remove legacy "/etc/gnucash/config" (Closes: #896803).
  * Fixed warning in "About" dialog (Closes: #895256).
    Thanks, Laurent Bigonville.
  * Added Guile-2.2 related lintian-overrides.
  * Build-Depends += "libxml2-utils, swig".
  * Standards-Version: 4.1.4.
  * Vcs URLs to Salsa.
  * Upload to unstable.

 -- Dmitry Smirnov <email address hidden>  Wed, 04 Jul 2018 19:21:18 +1000
Superseded in cosmic-release on 2018-08-24
Published in bionic-release on 2018-04-09
Deleted in bionic-proposed (Reason: moved to release)
gnucash (1:2.6.19-1) unstable; urgency=medium

  * New upstream release [December 2017].

 -- Dmitry Smirnov <email address hidden>  Mon, 09 Apr 2018 01:39:23 +1000

Available diffs

Superseded in bionic-release on 2018-04-09
Deleted in bionic-proposed on 2018-04-10 (Reason: moved to release)
gnucash (1:2.6.18-1) unstable; urgency=medium

  * New upstream release [September 2017].
  * New patch to fix FTBFS "no property named 'bogus'" (Closes: #876306).
    Thanks, Steve Langasek, Micha Lenk.
  * Standards-Version: 4.1.1.
  * control: removed "dh-autoreconf" from Build-Depends.
  * Switch from "libgnome-keyring-dev" to "libsecret-1-dev" (Closes: #867932)
    Thanks to Michael Biebl, Laurent Bigonville.
  * New upstream patch to fix FTBFS with libdbi_0.9.0-5.
  * rules: removed call to `dpkg-parsechangelog`.

 -- Dmitry Smirnov <email address hidden>  Sun, 12 Nov 2017 19:34:34 +1100
Superseded in bionic-release on 2017-11-22
Published in artful-release on 2017-09-20
Deleted in artful-proposed (Reason: moved to release)
gnucash (1:2.6.17-1ubuntu1) artful; urgency=medium

  * debian/patches/fix-test-for-gobject-messages.patch: fix test case to
    work with newer gobject.

 -- Steve Langasek <email address hidden>  Wed, 20 Sep 2017 11:43:43 -0700
Superseded in artful-proposed on 2017-09-20
gnucash (1:2.6.17-1) unstable; urgency=medium

  * New upstream release [July 2017].
  * Debhelper/compat to version 10.
  * Standards-Version: 4.0.0.

 -- Dmitry Smirnov <email address hidden>  Sat, 08 Jul 2017 23:22:48 +1000
Deleted in artful-release on 2018-06-22 (Reason: lp: #1718229, remove gnucash from artful, blocking NBS re...)
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
gnucash (1:2.6.15-1) unstable; urgency=medium

  * New upstream release [December 2016].
    - removed obsolete "774238.patch".
    + fixed FTBFS in test-report-utilities (Closes: #846027).

 -- Dmitry Smirnov <email address hidden>  Thu, 22 Dec 2016 08:24:13 +1100

Available diffs

Superseded in zesty-release on 2016-12-22
Deleted in zesty-proposed on 2016-12-23 (Reason: moved to release)
gnucash (1:2.6.14-1) unstable; urgency=medium

  * New upstream release [September 2016] + "774238.patch".
  * Recommends += "dbus (>= 1.8~) | dbus-x11" (Closes: #815005).

 -- Dmitry Smirnov <email address hidden>  Sat, 12 Nov 2016 00:18:35 +1100

Available diffs

Superseded in zesty-release on 2016-11-12
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
gnucash (1:2.6.13-1) unstable; urgency=medium

  * New upstream release [June 2016].
  * Standards-Version: 3.9.8.
  * Vcs-Git URL to HTTPS.
  * dbgsym-migration: dropped -dbg package; "debhelper (>= 9.20160403~)".

 -- Dmitry Smirnov <email address hidden>  Mon, 04 Jul 2016 03:04:31 +1000

Available diffs

Superseded in yakkety-release on 2016-07-04
Deleted in yakkety-proposed on 2016-07-05 (Reason: moved to release)
gnucash (1:2.6.12-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Add build-dependency on libgwengui-gtk2-dev (closes: #824710).

 -- Micha Lenk <email address hidden>  Thu, 19 May 2016 20:47:23 +0200

Available diffs

Superseded in yakkety-release on 2016-05-23
Published in xenial-release on 2016-04-18
Deleted in xenial-proposed (Reason: moved to release)
gnucash (1:2.6.12-1) unstable; urgency=medium

  * New upstream release [March 2016].
  * Standards-Version: 3.9.7.
  * Vcs-Browser URL to HTTPS.

 -- Dmitry Smirnov <email address hidden>  Mon, 04 Apr 2016 10:03:00 +1000
Superseded in xenial-release on 2016-04-18
Deleted in xenial-proposed on 2016-04-19 (Reason: moved to release)
gnucash (1:2.6.9-1ubuntu1) xenial; urgency=medium

  * Drop unavailable "locales-all" build dependency and re-disable tests
    again.

 -- Martin Pitt <email address hidden>  Mon, 26 Oct 2015 07:49:06 +0100
Superseded in xenial-proposed on 2015-10-26
gnucash (1:2.6.9-1) unstable; urgency=medium

  * New upstream release [October 2015].
  * gnucash: Recommends += "python-gnucash" (Closes: #778999).
  * Removed obsolete "fixtest.patch", applied-upstream.

 -- Dmitry Smirnov <email address hidden>  Sat, 17 Oct 2015 19:18:35 +1100
Superseded in xenial-release on 2015-10-26
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
gnucash (1:2.6.6-2ubuntu2) wily; urgency=medium

  * No-change rebuild against libktoblzcheck1v5

 -- Martin Pitt <email address hidden>  Wed, 12 Aug 2015 12:11:07 +0200
Superseded in wily-release on 2015-08-12
Deleted in wily-proposed on 2015-08-14 (Reason: moved to release)
gnucash (1:2.6.6-2ubuntu1) wily; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Avoid apport trying to report: "gnucash crashed with ImportError in
    - /usr/share/gnucash/python/init.py: No module named gnucash". Gnucash
    - is trying to load the gnucash python module, technically a .so that
    - won't load without the gnucash-python package present. The crash, a
    - failed python import, itself does not affect user experience, but is
    - nevertheless caught by apport. Until the right fix enters Debian
    - (cf. #778999), ensure that python-gnucash is always present.
    - LP: #1369273.

Superseded in wily-release on 2015-06-17
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
gnucash (1:2.6.4-3ubuntu1) vivid; urgency=low

  * Avoid apport trying to report: "gnucash crashed with ImportError in
    /usr/share/gnucash/python/init.py: No module named gnucash". Gnucash
    is trying to load the gnucash python module, technically a .so that
    won't load without the gnucash-python package present. The crash, a
    failed python import, itself does not affect user experience, but is
    nevertheless caught by apport. Until the right fix enters Debian
    (cf. #778999), ensure that python-gnucash is always present.
    LP: #1369273.
 -- Reinhard Tartler <email address hidden>   Sun, 05 Apr 2015 20:45:37 -0400
Superseded in vivid-release on 2015-04-06
Deleted in vivid-proposed on 2015-04-07 (Reason: moved to release)
gnucash (1:2.6.4-3) unstable; urgency=medium


  * barchart.patch: incorporate upstream fix for stacked barchart graphs.
    (Closes: #767735)

 -- Sébastien Villemot <email address hidden>  Sat, 15 Nov 2014 14:59:46 +0100

Available diffs

Superseded in vivid-release on 2014-11-16
Deleted in vivid-proposed on 2014-11-17 (Reason: moved to release)
gnucash (1:2.6.4-2) unstable; urgency=medium


  * crash-missing-comma.patch: new patch, fixes random crashes.
    Thanks to Frédéric Brière for finding and fixing this issue.
    (Closes: #764510)
  * barchart.patch: new patch from upstream, fixes display problems in
    barcharts. (Closes: #765412)
  * More backports from upstream, fix various crashes:
     + crash-0000-00-00-date-mysql.patch
     + crash-reload-budget-report.patch

 -- Sébastien Villemot <email address hidden>  Sat, 18 Oct 2014 00:03:06 +0200
Superseded in vivid-release on 2014-10-25
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
gnucash (1:2.6.3-1build1) utopic; urgency=medium

  * No-change rebuild against new libofx.
 -- Logan Rosen <email address hidden>   Fri, 30 May 2014 00:55:06 -0400
Superseded in utopic-release on 2014-05-30
Deleted in utopic-proposed on 2014-05-31 (Reason: moved to release)
gnucash (1:2.6.3-1) unstable; urgency=medium


  * Imported Upstream version 2.6.3
  * Add dependency on libaqbanking34-plugins. (Closes: #725022)

 -- Sébastien Villemot <email address hidden>  Tue, 22 Apr 2014 19:11:34 +0200

Available diffs

Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2014-02-19
Deleted in trusty-proposed (Reason: moved to release)
gnucash (1:2.6.1-2) unstable; urgency=medium


  * libdbd-multiarch.patch: new patch.
    Fixes FTBFS following multiarchification of libdbi-drivers.

 -- Sébastien Villemot <email address hidden>  Sun, 09 Feb 2014 16:20:56 +0100

Available diffs

Superseded in trusty-release on 2014-02-19
Deleted in trusty-proposed on 2014-02-21 (Reason: moved to release)
gnucash (1:2.6.1-1) unstable; urgency=medium


  * New upstream release.
    + tarball now includes the source of minified javascript file
      src/report/jqplot/jquery.min.js. (Closes: #736434)
    + column widths of the list of accounts are now correctly remembered.
      (Closes: #734148)

 -- Sébastien Villemot <email address hidden>  Tue, 28 Jan 2014 20:17:00 +0100

Available diffs

Superseded in trusty-release on 2014-01-29
Deleted in trusty-proposed on 2014-01-31 (Reason: moved to release)
gnucash (1:2.6.0-1) unstable; urgency=medium


  * New upstream stable release.
  * debian/copyright: reflect upstream changes.
  * Bump Standards-Version to 3.9.5, no changes needed.

 -- Sébastien Villemot <email address hidden>  Wed, 01 Jan 2014 12:08:40 +0100
Superseded in trusty-release on 2014-01-02
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
gnucash (1:2.4.13-1ubuntu1) saucy; urgency=low

  * importer-double-free-error.patch: new patch, fixes segfault caused due to
    freeing the same memory twice when importing transactions. (LP: #1224455)
 -- Sameer Morar <email address hidden>   Sat, 14 Sep 2013 02:45:22 +1000
Superseded in saucy-release on 2013-09-16
Deleted in saucy-proposed on 2013-09-17 (Reason: moved to release)
gnucash (1:2.4.13-1) unstable; urgency=low


  [ Sébastien Villemot ]
  * Imported Upstream version 2.4.13
  * Remove version on python-dev B-D.
    The gnucash configure script is again able to deal with the absence of a
    pkg-config script for python

  [ Dmitry Smirnov ]
  * Re-format (expand) list of Build-Depends
  * removing unnecessary versioned dependencies
  * updating my email address; bumping copyright years
  * use canonical Vcs URLs

 -- Sébastien Villemot <email address hidden>  Sat, 04 May 2013 16:58:51 +0200

Available diffs

Superseded in saucy-release on 2013-05-05
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
gnucash (1:2.4.12-1) experimental; urgency=low


  * Imported Upstream version 2.4.12
    - correctly sort subaccounts when renumbering. (Closes: #472996)
  * handle-xml-parse-failure.patch: remove patch, applied upstream
  * Refresh other patches
  * Add Build-Conflicts against guile-2.0, since it does not support SLIB (yet)
    (Closes: #697720)
  * Bump build-dependency on python-dev to >= 2.7.3-13. GnuCash configure
    script needs the pkg-config script python.pc which is present in that
    version

 -- Sébastien Villemot <email address hidden>  Sun, 31 Mar 2013 14:59:43 +0200

Available diffs

Superseded in raring-release on 2013-04-02
Deleted in raring-proposed on 2013-04-03 (Reason: moved to release)
gnucash (1:2.4.11-2) experimental; urgency=low


  * Use my @debian.org email address
  * Drop obsolete DM-Upload-Allowed field
  * Bump to Standards-Version 3.9.4, no changes needed
  * regcomp-memory-leak.patch: new patch taken from upstream trunk
    (Closes: #616515)
  * Ship gnucash-env and gnucash-make-guids in /usr/bin (Closes: #691503)
  * handle-xml-parse-failure.patch: new patch, fixes potential data loss when
    XML parsing fails (Closes: #696282)

 -- Sébastien Villemot <email address hidden>  Thu, 03 Jan 2013 20:40:43 +0100

Available diffs

Superseded in raring-release on 2013-03-15
Obsolete in quantal-release on 2015-04-24
gnucash (1:2.4.11-1) experimental; urgency=low


  [ Sébastien Villemot ]
  * Imported Upstream version 2.4.11
  * debian/copyright: reflect upstream changes
  * taxi1-customization_improvements.patch: refresh patch
  * gnucash-tip.patch: remove patch, applied upstream

  [ Dmitry Smirnov ]
  * adding new hardening-fortification patch

 -- Sébastien Villemot <email address hidden>  Mon, 17 Sep 2012 20:28:03 +0000

Available diffs

Superseded in quantal-release on 2012-09-20
gnucash (1:2.4.10-5) unstable; urgency=low


  * gnucash-tip.patch: new patch, fixes tip-of-the-day window with GCC 4.7
  * Add lintian overrides for false positives on hardening flags

 -- Sébastien Villemot <email address hidden>  Wed, 27 Jun 2012 18:40:29 +0000

Available diffs

Superseded in quantal-release on 2012-06-29
gnucash (1:2.4.10-4) unstable; urgency=low


  * Remove accidentally sneaked-in patch debian-changes-1:2.4.10-3 that
    reverted all or most of the intended patches (closes: #677467).
    Thanks to Sébastien Villemot for realizing and reporting it.

 -- Micha Lenk <email address hidden>  Thu, 14 Jun 2012 22:52:30 +0200

Available diffs

Superseded in quantal-release on 2012-06-15
gnucash (1:2.4.10-3) unstable; urgency=low


  [ Dmitry Smirnov ]
  * Added following patches:
    - suppress_binreloc_warning.patch: removes start-up message "binreloc
      relocation support was disabled at configure time" (closes: #443774).
    - taxi0-presentation_options.patch and
      taxi1-customization_improvements.patch: improve taxinvoice templates
      (closes: #655951).
  * debian/rules: export BUILDING_FROM_SVN=true if 'autogen.sh' is present
    to switch automatically to 'trunk mode' when building from trunk.
  * debian/copyright: remove no longer required '©' characters.
  * debian/control: Tightening gnucash relationship to gnucash-common.

  [ Micha Lenk ]
  * Update build-deps after soname bump in libaqbanking.

 -- Micha Lenk <email address hidden>  Wed, 06 Jun 2012 21:22:18 +0200

Available diffs

Superseded in quantal-release on 2012-06-08
gnucash (1:2.4.10-2) unstable; urgency=low


  [ Dmitry Smirnov ]
  * Removing obsolete lintian override
  * Removing remnants of dh_make template to clean-up debian/rules
  * Removing useless debian/gnucash-common.dirs
  * Build-time generation of missing man pages
  * Use dh-autoreconf to update toolchain
  * Update to recommended debhelper compat level 9
  * Fix short description of gnucash-common
  * Introducing --as-needed to reduce overlinking
  * debian/copyright: rewrite from scratch using machine-readable format 1.0

  [ Sébastien Villemot ]
  * Bump to Standards-Version 3.9.3, no changes needed
  * Set myself as Maintainer. Add Dmitry Smirnov to Uploaders. (Closes: #639584)

 -- Sébastien Villemot <email address hidden>  Mon, 05 Mar 2012 20:44:44 +0100

Available diffs

Superseded in quantal-release on 2012-04-30
Published in precise-release on 2012-02-12
gnucash (1:2.4.10-1) unstable; urgency=low


  [ Sébastien Villemot ]
  * Imported Upstream version 2.4.10
  * Add Breaks/Replaces for gconf files moved from gnucash to gnucash-common
    (Closes: #656845)
  * debian/patches/hurd-ftbfs.patch: new patch, fixes FTBFS on hurd-i386
    (Closes: #408583)

  [ Dmitry Smirnov ]
  * use dpkg-provided build flags and default hardening supporting the
    Security Hardening Build Flags release goal
  * remove build-deps already fulfilled by the dependencies of other build-deps
    (libpopt-dev, libglade2-dev and libgconf2-dev). By that occasion order them
    alphabetically.

 -- Sébastien Villemot <email address hidden>  Wed, 08 Feb 2012 20:56:25 +0100

Available diffs

Superseded in precise-release on 2012-02-12
gnucash (1:2.4.9-1) unstable; urgency=low


  * Imported Upstream version 2.4.9
  * debian/patches/desktop-file.patch: remove, applied upstream
  * debian/rules: enable parallel build

 -- Sébastien Villemot <email address hidden>  Sat, 14 Jan 2012 21:00:08 +0100

Available diffs

Superseded in precise-release on 2012-02-03
gnucash (1:2.4.8-1) unstable; urgency=low

  * Imported Upstream version 2.4.8
  * debian/patches/0001_french_translation_fix.patch: remove, applied upstream
  * Add yelp to Recommends (Closes: #645773)
  * debian/python-gnucash.lintian-overrides: use a wildcard for Python version
  * No longer install files under /usr/share/gnucash/doc.
    Worarkound for a bug in the configure script (it does not honor --docdir).
    This change suppresses the `extra-license-file' warning from Lintian
  * Add -n option to dh_makeshlibs.
    We don't need to run ldconfig in maintainer scripts, nothing is installed in
    the dynamic library loader path. This change suppresses the
    `{postinst,postrm}-has-useless-call-to-ldconfig' warnings in Lintian
  * Do not ship an shlibs file with gnucash.
    The generated shlibs files creates a lot of
    `unused-shlib-entry-in-control-file' Lintian warnings, because many dynamic
    libraries do not have a correct SOVERSION
  * debian/patches/desktop-file.patch: new patch.
    Makes desktop file compliant with FreeDesktop specification and GNOME goal
    (Closes: #641022)
  * Add a few more READMEs to /usr/share/doc/gnucash/
  * Move gnucash manpage from gnucash-common to gnucash.
    This suppresses a `binary-without-manpage' warning from Lintian
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  13 Nov 2011 22:20:37 +0000

Available diffs

Superseded in precise-release on 2011-11-13
gnucash (1:2.4.7-3) unstable; urgency=low

  * debian/rules: remove override for dh_shlibdeps (Closes: #642049)

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
gnucash (1:2.4.7-1) unstable; urgency=low

  * New upstream version.
  * Switch build-dep from libdbi0-dev to 'more standard' libdbi-dev.
  * Add 0001_french_translation_fix.patch to fix case insensitivity bug in
    French locale (closes: #549479).
  * Update build dependencies to reflect transition of libwebkit-dev to
    libwebkitgtk-dev (closes: #635412).
 -- ALEFHAHMEEMDAL ALEFLAMMEEMHAHMEEMWAWDALYEH (Ahmed El-Mahmoudy) <email address hidden>   Mon, 01 Aug 2011 22:22:19 +0200

Available diffs

Superseded in oneiric-release on 2011-08-02
gnucash (1:2.4.6-3) unstable; urgency=low

  * Ship directory /usr/share/gnome also in package gnucash-common to avoid
    dangling symlink in /usr/share/gnucash/ (closes: #387981).
  * (Build-)depend on guile-1.8 at least version 1.8.8+1-4~ (closes: #630096).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  15 Jun 2011 09:35:11 +0000

Available diffs

Superseded in oneiric-release on 2011-06-15
gnucash (1:2.4.6-2) unstable; urgency=low

  * Add correct Breaks/Replaces for gnucash.desktop file moved from
    package gnucash-common to package gnucash.
  * Package is compliant to Debian Policy 3.9.2.0 (no changes needed).

Available diffs

Superseded in oneiric-release on 2011-06-06
gnucash (1:2.4.5-2) unstable; urgency=low

  * Revert (build) dependencies on Guile back from 1.8 to 1.6 (re-opens:
    #623833, closes: #624468) because Guile 1.8 isn't ready for Gnucash yet
    (see Debian bugs #622280 and #624531).

Available diffs

Superseded in oneiric-release on 2011-05-04
Obsolete in natty-release on 2013-06-04
gnucash (1:2.4.2-1ubuntu1) natty; urgency=low

  * Added fix-test.diff patch which adds $(GLIB_LIBS) to test_qof_LDADD, in
    order to fix FTBFS on natty.
 -- ALEFHAHMEEMDAL ALEFLAMMEEMHAHMEEMWAWDALYEH (Ahmed El-Mahmoudy) <email address hidden>   Mon, 14 Feb 2011 13:19:53 +0200

Available diffs

Superseded in natty-release on 2011-02-14
gnucash (1:2.4.0-5) unstable; urgency=low

  * First upload of Gnucash 2.4.0 to Debian unstable.
  * Re-worded and improved the package description (LP: #458400)
 -- ALEFHAHMEEMDAL ALEFLAMMEEMHAHMEEMWAWDALYEH (Ahmed El-Mahmoudy) <email address hidden>   Sun, 06 Feb 2011 21:18:15 +0100

Available diffs

Superseded in natty-release on 2011-02-07
gnucash (1:2.4.0-4) experimental; urgency=low

  * Add Suggests: for all known SQL driver backends of libdbd
  * Added news entry explaining the need for installing a SQL backend
    package for using the SQL datastore.
  * Switch HTML engine from gtkhtml to webkit
  * Add missing binaries and perl dependencies needed for online update
    of securities (closes: #610317, LP: #707760)
 -- ALEFHAHMEEMDAL ALEFLAMMEEMHAHMEEMWAWDALYEH (Ahmed El-Mahmoudy) <email address hidden>   Wed, 26 Jan 2011 21:56:39 +0100

Available diffs

Superseded in natty-release on 2011-01-27
gnucash (1:2.4.0-3) experimental; urgency=low

  * Enable SQL support (closes: #232334)

Available diffs

Superseded in natty-release on 2011-01-24
gnucash (2.2.9-10) unstable; urgency=low

  * Don't ship gnc-test-env, only needed at build time (closes: #603329,
    CVE-2010-3999)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  03 Dec 2010 16:46:58 +0000

Available diffs

Superseded in natty-release on 2010-12-03
gnucash (2.2.9-9build1) natty; urgency=low

  * no change rebuild for libgtkhtml3.14
 -- Jamie Strandboge <email address hidden>   Mon, 29 Nov 2010 07:58:07 -0600

Available diffs

Superseded in natty-release on 2010-11-29
gnucash (2.2.9-9) unstable; urgency=low

  * Added patch 13_fix_double_edit_segfault_bug_593856.dpatch to fix
    segfault in transaction editing (closes: #593856).
  * Increased version in build-dep on libglib2.0-dev to avoid segfault on open
    (Debian bug #587743) if gnucash is built with older libglib2.0-dev versions
    (makes backporting easier).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  02 Nov 2010 15:07:10 +0000

Available diffs

Superseded in natty-release on 2010-11-02
gnucash (2.2.9-8) unstable; urgency=low

  * Fix package name in message about missing AqBanking wizard
    (closes: #589039).
  * 12_do_not_accidentally_delete_main_account_file_bug_525549.dpatch
    added (closes: #525549).
  * Added shlibs.local entry for libgoffice-0.8-8 because this library
    provides a shlibs file unconditionally tied to the upstream version (which
    is more than required by Gnucash). This is a workaround for Debian bug
    #599225 and should facilitate transition to testing w/o upload via t-p-u.

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
gnucash (2.2.9-6) unstable; urgency=low

  * Added patch 10_fix_broken_SCIM_input_bug_587298 to fix SCIM input
    problems (closes: #587298, LP: #520976)
 -- ALEFHAHMEEMDAL ALEFLAMMEEMHAHMEEMWAWDALYEH (Ahmed El-Mahmoudy) <email address hidden>   Sun, 27 Jun 2010 20:11:53 +0200

Available diffs

Superseded in maverick-release on 2010-08-19
Obsolete in lucid-release on 2016-10-26
gnucash (2.2.9-5) unstable; urgency=low

  * Transition build-dep from libgoffice-0-8-dev to libgoffice-0.8-dev
    (Closes: #573678, #574113)
 -- Lionel Le Folgoc <email address hidden>   Mon,  22 Mar 2010 19:19:13 +0000

Available diffs

Superseded in lucid-release on 2010-03-22
gnucash (2.2.9-4build1) lucid; urgency=low

  * Rebuild against latest goffice (see Debian #570010).
 -- Lionel Le Folgoc <email address hidden>   Thu, 18 Feb 2010 19:53:00 +0100

Available diffs

Superseded in lucid-release on 2010-02-18
gnucash (2.2.9-4) unstable; urgency=low

  * Re-enabled patch 03_goffice_0-7-5_support and replaced patch
    03_disable_graphing_support contributed by Jean-Louis Dupond's patch
    03_goffice_0-8_support from Ubuntu's merge request #521217.
    This enables graphing support again (closes: #567208).
  * Package is compliant to Debian Policy 3.8.4 (no changes needed)

Available diffs

Obsolete in jaunty-backports on 2013-02-28
gnucash (2.2.9-0ubuntu4~jaunty1) jaunty-backports; urgency=low

  * Backport to Jaunty (LP: #383742), changes:
    + debian/control: Build-Depends on libgoffice-0-6-dev and
      libaqbanking20-dev since libgoffice-0.8-dev and libaqbanking29-dev
      are only in Karmic. The deps are now the same as with 2.2.9-0ubuntu1;
    + debian/patches: remove 03_goffice_0-7-5_support.dpatch from OOlist
      since we build agaisnt libgoffice-0-6-dev. Left 04_renew-gui.dpatch
      applied, it's not necessary with libaqbanking20-dev, but removing it
      doesn't seem necessary.

 -- Loic Martin <email address hidden>   Tue, 29 Sep 2009 11:29:32 +0200
Superseded in lucid-release on 2010-02-15
Obsolete in karmic-release on 2013-03-04
gnucash (2.2.9-0ubuntu4) karmic; urgency=low

  * 04_renew-gui.dpatch: Fixes problems with libaqbanking 4.x

 -- Norbert Holze <email address hidden>   Thu, 10 Sep 2009 19:32:43 +0200

Available diffs

Superseded in karmic-release on 2009-09-14
gnucash (2.2.9-0ubuntu3) karmic; urgency=low

  * Rebuild for libaqbanking20 > libaqbanking29 transition. (LP: #401344)

 -- Bhavani Shankar <email address hidden>   Fri, 31 Jul 2009 19:43:12 +0530

Available diffs

Superseded in karmic-release on 2009-08-10
gnucash (2.2.9-0ubuntu2) karmic; urgency=low

  * 03_goffice_0-7-5_support.dpatch: make gnucash build against goffice >=
    0.7.5 (fix backported for 2.3 branch, can be dropped with the next stable
    release)
  * debian/control: B-D on ligoffice-0-8-dev

 -- Gauvain Pocentek <email address hidden>   Sun, 07 Jun 2009 12:48:28 +0200

Available diffs

Superseded in karmic-release on 2009-06-08
gnucash (2.2.9-0ubuntu1) karmic; urgency=low

  * New upstream release (LP: #329298);
  * Changes in patches applied in source by the diff.gz - no more patches!:
    - src/register/register-gnome/gnucash-sheet.c dropped, @@ 2426,8 +2427,9 @@
      applied upstream, @@ -2367,7 +2367,8 @@ reverted upstream (rev. 17781);
    - src/register/register-gnome/gnucash-style.c dropped, applied upstream;
    - src/backend/file/gnc-backend-file.c dropped, applied upstream;
    - src/import-export/aqbanking/gnc-ab-utils.c dropped, applied upstream;
   * [debian/patches]:
     - 01_HBCI_r17502 dropped, patch from upstream and applied upstream;
     - 02_HBCI_r17544 dropped, patch from upstream and applied upstream.
   * [debian/watch]: create watch file.

 -- Loic Martin <email address hidden>   Sun, 31 May 2009 20:35:23 +0200

Available diffs

Superseded in karmic-release on 2009-06-04
gnucash (2.2.6-3ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes:
    - Removed gnucash-sql from suggests in gnucash package (LP: #262229)
    - debian/rules: Add dpatch patchsys.
    - debian/control: Add dpatch build-depends.
    - debian/patches: Add r17502 and r17543 upstream patches to fix current
      issues with HBCI. (LP: #269725) (LP: #269686)
    - Switched libgoffice-0 to libgoffice-0-6 dependency (LP: #270200)

Available diffs

Superseded in karmic-release on 2009-05-14
Obsolete in jaunty-release on 2013-02-28
gnucash (2.2.6-2ubuntu5) jaunty; urgency=low

  * fix double free introduced by r17761. Thanks to Saïvann Carignan for
    pointing this out and finding the fix. (LP: #305066)
    - rename debian/patches/03_segfault_r17761 to 03_segfault_r17761+r17783
      and adjust it to include both r17761 and r17783

 -- Jamie Strandboge <email address hidden>   Sun, 21 Dec 2008 09:16:44 -0600

Available diffs

Superseded in jaunty-release on 2008-12-21
gnucash (2.2.6-2ubuntu4) jaunty; urgency=low

  * fix segfault due to glib2-2.19 transition (LP: #305066)

 -- Jamie Strandboge <email address hidden>   Sat, 20 Dec 2008 13:39:55 -0600

Available diffs

Superseded in jaunty-release on 2008-12-20
Obsolete in intrepid-release on 2013-02-20
gnucash (2.2.6-2ubuntu3) intrepid; urgency=low

  * Removed gnucash-sql from suggests in gnucash package (LP: #262229).

 -- Nick Ellery <email address hidden>   Sat, 20 Sep 2008 17:20:01 -0700

Available diffs

Superseded in intrepid-release on 2008-10-02
gnucash (2.2.6-2ubuntu2) intrepid; urgency=medium

  * debian/rules: Add dpatch patchsys.
  * debian/control: Add dpatch build-depends.
  * debian/patches: Add r17502 and r17543 upstream patches to fix current
    issues with HBCI. (LP: #269725) (LP: #269686)

 -- Saivann Carignan <email address hidden>   Tue, 23 Sep 2008 21:38:39 -0400

Available diffs

Superseded in intrepid-release on 2008-09-24
gnucash (2.2.6-2ubuntu1) intrepid; urgency=low

  * Switched libgoffice-0 to libgoffice-0-6 dependency (LP: #270200)

 -- Michael Casadevall <email address hidden>   Sun, 14 Sep 2008 13:57:06 -0400

Available diffs

Superseded in intrepid-release on 2008-09-16
gnucash (2.2.6-2) unstable; urgency=medium

  * src/backend/file/gnc-backend-file.c (gnc_int_link_or_make_backup):
    Fail gracefully in case link returns ENOSYS (which it has no business
    doing, but sshfs does that instead of the proper error code.)  Thanks
    to Bas Wijnen for the bug report and Micha Lenk for the fix.  (Closes:
    #496807).

 -- Luca Falavigna <email address hidden>   Wed,  03 Sep 2008 15:06:31 +0100

Available diffs

Superseded in intrepid-release on 2008-09-03
gnucash (2.2.6-1ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable. (LP: #252099) Remaining Ubuntu changes:
    + debian/control: build-dep change from libungif4-dev to libgif-dev
    + debian/rules:
      - Don't ignore make clean errors, instead check if a Makefile exists, if
        not, don't call make clean
    + debian/control:
      - Change maintainer to MOTU.
  * new version support HBCI properly (LP: #5973, finally!)
  * Build dependencies have been cleaned up in debian (LP: #178811)
  * No longer crashes when selecting selecting SKR04 (LP: #218723)

Available diffs

Superseded in intrepid-release on 2008-08-04
gnucash (2.2.4-1ubuntu2) intrepid; urgency=low

  * debian/control: Fix missing Debian Maintainer field (LP: #230350)

 -- Saivann Carignan <email address hidden>   Wed, 14 May 2008 17:29:20 -0400
Superseded in intrepid-release on 2008-05-15
Obsolete in hardy-release on 2015-04-24
gnucash (2.2.4-1ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. Remaining Ubuntu changes: (LP: #205570)
    + debian/control: build-dep change from libungif4-dev to libgif-dev
    + debian/gnucash.desktop, src/gnome/gnucash.desktop.*:
      - Fixed according to desktop-file-validate
    + debian/rules:
      - Don't ignore make clean errors, instead check if a Makefile exists, if
        not, don't call make clean
      - Call dh_desktop and dh_icons
    + debian/control:
      - Change maintainer to MOTU.
      - Bump Standards Version to 3.7.3
    * Thx to Frédéric Lespez for taking the initial steps.

 -- Stephan Hermann <email address hidden>   Thu, 27 Mar 2008 11:10:55 +0100
175 of 107 results