Change log for gpac package in Ubuntu

144 of 44 results
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-08-21
Deleted in cosmic-proposed (Reason: moved to release)
gpac (0.5.2-426-gc5ad4e4+dfsg5-4build1) cosmic; urgency=medium

  * No-change rebuild for ffmpeg soname changes.

 -- Matthias Klose <email address hidden>  Thu, 19 Jul 2018 08:46:43 +0000
Superseded in cosmic-release on 2018-08-21
Deleted in cosmic-proposed on 2018-08-23 (Reason: moved to release)
gpac (0.5.2-426-gc5ad4e4+dfsg5-4) unstable; urgency=medium

  * Team upload.

  [ Ondřej Nový ]
  * d/copyright: Use https protocol in Format field.
  * d/control: Set Vcs-* to salsa.debian.org.
  * d/changelog: Remove trailing whitespaces.

  [ Felipe Sateler ]
  * Change maintainer address to <email address hidden>.

  [ James Cowgill ]
  * d/patches: Add patch to fix FTBFS with FFmpeg 4.0. (Closes: #888343)

 -- James Cowgill <email address hidden>  Fri, 25 May 2018 14:56:56 +0100
Superseded in cosmic-release on 2018-05-26
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
gpac (0.5.2-426-gc5ad4e4+dfsg5-3) unstable; urgency=medium

  * Team upload.
  * Drop OpenJPEG support. (Closes: #826814)
  * Enable verbose building.
  * Bump standards to 3.9.8.
  * Update debian/watch now that upstream moved to github.

 -- James Cowgill <email address hidden>  Thu, 04 Aug 2016 22:29:39 +0100
Superseded in yakkety-release on 2016-08-05
Deleted in yakkety-proposed on 2016-08-06 (Reason: moved to release)
gpac (0.5.2-426-gc5ad4e4+dfsg5-2build1) yakkety; urgency=medium

  * Rebuild for ffmpeg 3.0.

 -- Colin Watson <email address hidden>  Sat, 30 Apr 2016 18:13:44 +0100
Superseded in yakkety-release on 2016-04-27
Deleted in yakkety-proposed on 2016-04-28 (Reason: moved to release)
gpac (0.5.2-426-gc5ad4e4+dfsg5-1build2) yakkety; urgency=medium

  * No-change rebuild for libpng soname change.

 -- Matthias Klose <email address hidden>  Sat, 23 Apr 2016 00:07:47 +0000
Superseded in yakkety-release on 2016-05-05
Deleted in yakkety-proposed on 2016-05-06 (Reason: moved to release)
gpac (0.5.2-426-gc5ad4e4+dfsg5-2) unstable; urgency=medium

  * Team upload.

  [ Andreas Cadhalpun ]
  * Fix build with ffmpeg 3.0. (Closes: #803821)

  [ Sebastian Ramacher ]
  * Migrate to automatic dbg packages
  * debian/control:
    - Bump Standards-Version.
    - Update Vcs-*.
    - Drop obsolete Breaks+Replaces.

  [ Steven Chamberlain ]
  * Update symbols for hurd and kfreebsd. (Closes: #815431)

 -- Sebastian Ramacher <email address hidden>  Wed, 09 Mar 2016 23:21:23 +0100
Superseded in yakkety-release on 2016-04-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
gpac (0.5.2-426-gc5ad4e4+dfsg5-1build1) wily; urgency=medium

  * No-change rebuild against ffmpeg 2.7

 -- Rico Tzschichholz <email address hidden>  Tue, 01 Sep 2015 17:49:19 +0200
Superseded in wily-release on 2015-09-02
Deleted in wily-proposed on 2015-09-03 (Reason: moved to release)
gpac (0.5.2-426-gc5ad4e4+dfsg5-1) unstable; urgency=medium

  [ Balint Reczey ]
  * Rename library package to libgpac4 (Closes: #791490)
  * Convert to multiarch (Closes: #791492)
  * Bump standards version
  * Add symbols file
  * Pass CFLAGS and LDFLAGS to ./configure
  * Remove space from license names
  * Drop all include files in extra_lib from upstream source
  * Fix upstream version number's dfsg postfix
  * Fix symbols file for libgpac4

  [ Alessio Treglia ]
  * Fix unmanaged SONAME bump. Add Breaks/Replaces fields for a smooth
    libgpac3 -> libgpac4 migration.
  * Multiarchify libgpac-dbg
  * Fix few lintian warnings concerning debian/copyright.

 -- Alessio Treglia <email address hidden>  Wed, 08 Jul 2015 15:15:55 +0100
Superseded in wily-proposed on 2015-07-09
gpac (0.5.2-426-gc5ad4e4~dfsg4-1) unstable; urgency=medium

  [ Alessio Treglia ]
  * New upstream version 0.5.2-426-gc5ad4e4 (Closes: #776301, #783879)
  * Update repacking mechanism.
    The project moved to github.
  * Update repack.sh
  * Update compression in gbp.conf
  * Refresh patches

  [ Balint Reczey ]
  * Refresh remaining patches
  * Update passing revision to configure
  * Don't fail the build intentionally on unknown systems
  * Skip test using .swf file
  * List removed files in copyright file
  * Remove sourceless .swf from original tarball
  * Add myself to uploaders

 -- Balint Reczey <email address hidden>  Sun, 28 Jun 2015 11:44:32 -0500
Superseded in wily-release on 2015-08-16
Deleted in wily-proposed on 2015-08-18 (Reason: moved to release)
gpac (0.5.0+svn5324~dfsg1-1build1) wily; urgency=medium

  * Rebuild for new libfreenect

 -- Micah Gersten <email address hidden>  Mon, 18 May 2015 16:25:37 -0500
Superseded in vivid-release on 2014-11-11
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
gpac (0.5.0+svn5194~dfsg1-3ubuntu3) utopic; urgency=medium

  * Rebuild against libav11.
 -- Colin Watson <email address hidden>   Thu, 04 Sep 2014 21:02:47 +0100
Superseded in wily-release on 2015-05-18
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
gpac (0.5.0+svn5324~dfsg1-1) unstable; urgency=medium


  * New upstream snapshot.
  * Refresh patches.
  * debian/copyright:
    - Improve copyright and licensing information on src/utils/unicode.c.
      Thanks to bastien ROUCARIES for pointing this out. (Closes: #754732)
    - Update debian/* copyright holders's information.
    - Mention debian/copyright in debian/source/lintian-overrides to
      avoid lintian's license-problem-non-free-RFC error.

 -- Alessio Treglia <email address hidden>  Thu, 31 Jul 2014 14:13:58 +0100
Superseded in utopic-release on 2014-09-05
Deleted in utopic-proposed on 2014-09-07 (Reason: moved to release)
gpac (0.5.0+svn5194~dfsg1-3ubuntu2) utopic; urgency=medium

  * implicit-declarations.patch: Include gpac/network.h to fix implicit
    declarations of gf_url_concatenate that become pointer conversions.
 -- Adam Conrad <email address hidden>   Mon, 02 Jun 2014 21:39:21 -0600
Superseded in utopic-proposed on 2014-06-03
gpac (0.5.0+svn5194~dfsg1-3ubuntu1) utopic; urgency=low

  * Merge from debian. Remaining changes:
    - Update build-deps for the xmlrpc-c 1.33.06 transition.

Superseded in utopic-release on 2014-07-29
Deleted in utopic-proposed on 2014-07-30 (Reason: moved to release)
gpac (0.5.0+svn4288~dfsg1-4ubuntu2) utopic; urgency=high

  * No change rebuild against libopenjpeg5.
 -- Dimitri John Ledkov <email address hidden>   Sun, 27 Apr 2014 02:42:06 +0100
Superseded in utopic-release on 2014-05-01
Published in trusty-release on 2014-03-22
Deleted in trusty-proposed (Reason: moved to release)
gpac (0.5.0+svn4288~dfsg1-4ubuntu1) trusty; urgency=medium

  * Update build-deps for the xmlrpc-c 1.33.06 transition.
 -- Adam Conrad <email address hidden>   Sat, 22 Mar 2014 11:00:58 -0600
Superseded in trusty-release on 2014-03-22
Deleted in trusty-proposed on 2014-03-23 (Reason: moved to release)
gpac (0.5.0+svn4288~dfsg1-4) unstable; urgency=low


  * Compile with libfreenect support.

 -- Alessio Treglia <email address hidden>  Sun, 06 Oct 2013 21:53:29 +0100
Superseded in trusty-release on 2013-11-27
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
gpac (0.5.0+svn4288~dfsg1-1ubuntu1) raring; urgency=low

  * Loose build-dep on libav to make it build on raring.
 -- Alessio Treglia <email address hidden>   Wed, 20 Feb 2013 12:37:40 +0000
Superseded in raring-proposed on 2013-02-20
gpac (0.5.0+svn4288~dfsg1-1) experimental; urgency=low


  [ Alessio Treglia ]
  * New upstream snapshot.
  * Refresh patches.
  * Update symbols.
  * Fix Homepage URL. (Closes: #688063)
  * Set get-orig-source back to retrieve sources from SVN.
  * Strip libav stuff out of the tarball, bump DFSG versioning.
  * Don't remove include/gpac/version.h
  * Overwriting include/gpac/version.h is no longer needed as
    buildsystem works now. Upstream's buildsystem has been fixed
    so there is no need to overwrite include/gpac/version.h anymore.
  * Bump Standards.

  [ Reinhard Tartler ]
  * Build against libav 9.

 -- Alessio Treglia <email address hidden>  Wed, 30 Jan 2013 14:41:46 +0000
Superseded in raring-release on 2013-02-20
Obsolete in quantal-release on 2015-04-24
gpac (0.5.0~dfsg0-1) unstable; urgency=low


  * New stable release.
  * debian/{rules,watch}:
    - Download new stable releases from upstream's website.
  * Refresh patches.

 -- Alessio Treglia <email address hidden>  Sun, 27 May 2012 11:25:44 +0200
Superseded in quantal-release on 2012-05-27
gpac (0.4.5+svn4035~dfsg0-1) unstable; urgency=low


  * New upstream snapshot.
  * Small improvements to debian/watch.
  * debian/copyright: Group files by License, try to better organize
    stanzas.

 -- Alessio Treglia <email address hidden>  Tue, 15 May 2012 19:37:01 +0200
Superseded in quantal-release on 2012-05-24
gpac (0.4.5+svn4019~dfsg0-3) unstable; urgency=low


  * Move the header <gpac/configuration.h> into the multiarch
    path. (Closes: #669999)

 -- Alessio Treglia <email address hidden>  Mon, 23 Apr 2012 10:10:10 +0200
Superseded in quantal-release on 2012-05-04
Published in precise-release on 2012-02-13
gpac (0.4.5+svn3462~dfsg0-1) unstable; urgency=low


  * Merge upstream SVN snapshot svn3462:
    - DASH: SPTS don't need '-dash-ts-prog' option (+doc added)
    - support in the player for BaseURL as source as specified in
      latest draft and generated by MP4Box
    - Fixed bug in edit list rewrite when concatenating
    - Added simple osd module for perf monitoring (cpu/mem/fps)
    - Fixed some crashes when destroying objects/services before their
      creation is completed (stress mode)
    - Fixed event firing for secondary scenes and
      exported createVRMLfromString
    - Only notify fractionChanged when it actually changes
    - Commented full AAC file scan for duration
    - Made DX module store its YUV config (speeds up startup)
    - Added option to avoid unloading modules
    - use gf_esd_get_textual_description() instead of (incomplete) switches
    - Fixed UPnP detection and removed extension loading
  * Drop xulrunner-dev, gpac doesn't build against it.
  * Revise repackaging and debian/rules' get-orig-source target.
  * Refresh patches.
  * Configure with --enable-debug.
  * Add -O2 to CFLAGS, use -O0 when optimizations are disabled.
  * Implement DEB_BUILD_OPTIONS' noopt flag.
  * Install modules in multiarch path.
  * Split gpac and install modules into new gpac-modules-base package.
  * Add -DBG packages.

 -- Alessio Treglia <email address hidden>  Sat, 11 Feb 2012 17:35:15 +0100
Superseded in precise-release on 2012-02-13
Obsolete in oneiric-release on 2015-04-24
gpac (0.4.5-0.3ubuntu10) oneiric; urgency=low

  * debain/patches/sslv2-deprecation.diff: Disable SSLv2 code paths, OpenSSL
    1.0 doesn't include support for it any more.
 -- Stefano Rivera <email address hidden>   Sun, 10 Jul 2011 12:55:26 +0200
Superseded in oneiric-release on 2011-07-10
gpac (0.4.5-0.3ubuntu9) oneiric; urgency=low

  * debian/patches/05_warn-common-typo.diff: (LP: #749110)
    - fix typo in ld option: s/-Wl --warn-common/-Wl,--warn-common/ configure
 -- Julian Taylor <email address hidden>   Fri, 08 Jul 2011 19:59:47 +0200
Superseded in oneiric-release on 2011-07-08
gpac (0.4.5-0.3ubuntu8) oneiric; urgency=low

  * Drop xulrunner-dev build-dep. Neither Mozilla or Spidermonkey support
    has ever been enabled in the Ubuntu builds, because gpac looks in the
    wrong place for the headers
    - update debian/control
    - update debian/rules
 -- Chris Coulson <email address hidden>   Fri, 10 Jun 2011 03:28:42 +0100
Superseded in oneiric-release on 2011-06-10
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
gpac (0.4.5-0.3ubuntu7) maverick; urgency=low

  * No-change rebuild for jack transition
 -- Lorenzo De Liso <email address hidden>   Wed, 21 Jul 2010 12:56:17 +0200
Superseded in maverick-release on 2010-07-21
Obsolete in lucid-release on 2016-10-26
Superseded in lucid-release on 2010-03-26
gpac (0.4.5-0.3ubuntu6) lucid; urgency=low

  * rebuild for ffmpeg versioned symbols
 -- Reinhard Tartler <email address hidden>   Tue, 19 Jan 2010 20:57:37 +0100
Superseded in lucid-release on 2010-01-19
gpac (0.4.5-0.3ubuntu5) lucid; urgency=low

  * Xvidcore transition (LP: #486169).
  * Don't use ccache and -j option for make.
  * Add ${misc:Depends} macro to the Depends fields.
 -- Alessio Treglia <email address hidden>   Tue, 24 Nov 2009 00:04:42 +0100
Superseded in lucid-release on 2009-11-24
Obsolete in karmic-release on 2013-03-04
gpac (0.4.5-0.3ubuntu4) karmic; urgency=low

  * debian/04_glx-func-def.diff: Define a glXGetProcAddress prototype so
    that gcc doesn't assume it returns an int.  LP: #402177

 -- Michael Terry <email address hidden>   Thu, 10 Sep 2009 10:06:36 -0400
Superseded in karmic-release on 2009-09-18
gpac (0.4.5-0.3ubuntu3) karmic; urgency=low

  * Remove libmozjs-dev build dependency. Fixes FTBFS.

 -- Onkar Shinde <email address hidden>   Fri, 04 Sep 2009 01:19:48 +0530
Superseded in karmic-release on 2009-09-03
gpac (0.4.5-0.3ubuntu2) karmic; urgency=low

  * No-change rebuild to pick up new ffmpeg shlibs file.

 -- Stefan Potyra <email address hidden>   Sat, 29 Aug 2009 22:38:25 +0200
Superseded in karmic-release on 2009-08-29
gpac (0.4.5-0.3ubuntu1) karmic; urgency=low

  * Merge from debian-multimedia.org (LP: #354825).
   - Fix a double-free/heap corruption (LP: #135071).
  * Remaining Ubuntu changes :
   - Remove libamrnb-dev and libamrwb-dev build-depends. These packages don't
     exist in Ubuntu repositories.
   - Increment libgpac-dev Replaces: gpac version to 0.4.2~rc2-0ubuntu1
   - Build-depends on libxmlrpc-c3-dev because libxmlrpc-c-dev is not provided
     in the Ubuntu package.

Superseded in karmic-release on 2009-07-09
Obsolete in jaunty-release on 2013-02-28
gpac (0.4.4-0.3ubuntu4) jaunty; urgency=low

  * Add 20_memset_typo.dpatch: correct the chpl_New function to not
    overwrite memory during initialization (LP: #273075).

 -- Kees Cook <email address hidden>   Thu, 05 Mar 2009 10:56:07 -0800
Obsolete in intrepid-updates on 2013-02-20
Deleted in intrepid-proposed on 2013-02-27 (Reason: moved to -updates)
gpac (0.4.4-0.3ubuntu2.1) intrepid-proposed; urgency=low

  * Rebuild to take into account unstripped versions of libavcodec libs
    (LP: #289600)

 -- Lionel Le Folgoc <email address hidden>   Wed, 03 Dec 2008 22:43:43 +0100
Superseded in jaunty-release on 2009-03-05
gpac (0.4.4-0.3ubuntu3) jaunty; urgency=low

  * Rebuild to pickup ffmpeg's new shlibs (LP: #289600).

 -- Lionel Le Folgoc <email address hidden>   Sat, 15 Nov 2008 16:58:35 +0100
Superseded in jaunty-release on 2008-11-15
Obsolete in intrepid-release on 2013-02-20
gpac (0.4.4-0.3ubuntu2) intrepid; urgency=low

  * Rebuild for the ffmpeg -> ffmpeg-free transition (LP: #245565).

 -- Michael Bienia <email address hidden>   Tue, 08 Jul 2008 15:59:27 +0200
Obsolete in gutsy-backports on 2011-09-16
gpac (0.4.4-0.3ubuntu1~gutsy1) gutsy-backports; urgency=low

  * Automated backport upload; no source changes.

Superseded in intrepid-release on 2008-07-08
Obsolete in hardy-release on 2015-04-24
gpac (0.4.4-0.3ubuntu1) hardy; urgency=low

  * Merge with debian-multimedia (LP: #160403)
  * Ubuntu changes:
    - libav*cvs51-dev -> libav*-dev in Build-Depends
    - Increment libgpac-dev Replaces: gpac version to 0.4.2~rc2-0ubuntu1
    - Set Maintainer to MOTUs

Superseded in hardy-release on 2007-11-19
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
gpac (0.4.2~rc2-0ubuntu1) feisty; urgency=low

  * New upstream release
    * Most notably MP4 tagging support via MP4Box -itags
  * debian/patches/01_64bits.dpatch: dropped; included upstream.

 -- John Dong <email address hidden>   Wed, 24 Jan 2007 23:34:57 -0500
Superseded in feisty-release on 2007-01-26
Obsolete in edgy-release on 2008-06-19
gpac (0.4.0+rc2-0.4ubuntu1) edgy; urgency=low

  * Built for new libavcodec-dev
  * Upgraded to version 0.4.0+rc2-0.4

 -- Steven J Harms <email address hidden>   Thu, 13 Jul 2006 20:49:13 -0400
Superseded in edgy-release on 2006-07-18
Obsolete in dapper-release on 2011-09-06
gpac (0.4.0+rc2-0.0ubuntu1) dapper; urgency=low

  * libavcodeccvs-dev Build-Dep changed to libavcodec-dev. (Closes: Malone #32362)
  * Sponsored upload for Gauvain Pocentek <email address hidden>
  * debian/control: bumped debhelper version to 5.
  * debian/compat: changed to 5.

 -- Jonathan Patrick Davies <email address hidden>   Sun, 26 Feb 2006 21:38:46 +0100
Superseded in dapper-release on 2006-02-26
Superseded in dapper-release on 2006-02-03
gpac (0.4.0+rc2-0.0) unstable; urgency=low


  * New upstream release.

 -- Christian Marillat <email address hidden>  Thu, 22 Dec 2005 16:55:33 +0100
Superseded in dapper-release on 2006-01-31
Obsolete in breezy-release on 2008-03-25
Obsolete in hoary-release on 2008-03-19
Obsolete in warty-release on 2008-01-09
gpac (0.2.0-0.0) unstable; urgency=low


  * New upstream release.

 -- Christian Marillat <email address hidden>  Wed, 15 Sep 2004 16:03:58 +0200
144 of 44 results