grub doesn't boot with an usb key plugged

Bug #41677 reported by Maftoul Samuel
10
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Medium
Unassigned

Bug Description

Grub doesn't boot with an usb key plugged, it stops at Stage 1.5

Revision history for this message
Sitsofe Wheeler (sitsofe) wrote :

This sounds an awful lot like a BIOS bug. You may want to attach using the Add Attachment link at the left of the malone website the output of
dmidecode
as a text file to this bug report. It would also be useful to indicate which version of Ubuntu you have installed and what your motherboard is.

Changed in grub:
status: Unconfirmed → Needs Info
Revision history for this message
Bazon (bazonbloch) wrote :

At least not a general bug:
No problem with GRUB and my USB Keyboard...

Revision history for this message
Maftoul Samuel (samuel-maftoul) wrote : My dmidecode output

As requested by Sitsofe

Revision history for this message
Maftoul Samuel (samuel-maftoul) wrote :

grub blocks on:

'Loading Grub 1.5.' (with a leading dot, maybe this can help).

I juste noticed that if I unplug my usb key grub continues to boot

Revision history for this message
Maftoul Samuel (samuel-maftoul) wrote :

also I forget to indicate that I'm running dapper (up to date), but don't remember what version installed

Revision history for this message
Maftoul Samuel (samuel-maftoul) wrote :

Still happens on edgy

Revision history for this message
Maftoul Samuel (samuel-maftoul) wrote :

I have opened a bug at the savannah bugs reporting tool.
malone doesn't seem to be able to track it, here is the link:
https://savannah.gnu.org/bugs/?18224

Revision history for this message
Wladston Viana (wladston) wrote :

I'm having this same bug.

Here us my output :

Revision history for this message
Wladston Viana (wladston) wrote :

Oh , I forgor to say my motherboard!! P4S800D-X!

Is there any other information I can provide to help on this bug ? it's still marked as "needs info" ...

Revision history for this message
DanSmith (dan.smith) wrote :

I agree that it would be best to eliminate the possibility of a BIOS issue first. Most USB boot device issues I have been quickly resolved by updating the BIOS. A quick google search lead me to this site: http://support.asus.com/download/download_item.aspx?product=1&model=P4S800D-X

Can you please verify that the following:

1) That you have the most current BIOS revision installed.
2) That you are not using a USB hub to connect your keyboard to your PC

If the previous suggestions don't resolve the issue then this bug may be related to: https://bugs.launchpad.net/ubuntu/+source/gfxboot/+bug/35530

I'm unsure of where Grub's official upstream repository is located but I was able to locate the following: http://savannah.gnu.org/bugs/?18224

Perhaps it would be prudent to submit a bug upstream (if it has not already been done) to explore the possibilities of making a small change to ensure USB devices do not halt the boot process.

Revision history for this message
Wladston Viana (wladston) wrote :

Dan,

1) Yes, I'm running the latest beta bios

2) I don't use a USB keyboard :)

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for grub (Ubuntu) because there has been no activity for 60 days.]

Revision history for this message
Wladston Viana (wladston) wrote :

?? Can someone please re-open the bug ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers