OLD BIOS: JMicron controllers not recognised by Grub?

Bug #64574 reported by SFAOK
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Fix Released
High
Unassigned

Bug Description

*****************************************************************************
NOTE: Please update your BIOS to get grub support for the Jmicron Chipset!

Look here: http://www.jmicron.com/FAQ_20330.htm

Q10: Can JMicron chip support linux/grub boot?
Ans: Yes , JMB bios 1.06.53 or above already supported.

(edited by Thomas Hotz, Ubuntu BugSquad)
*****************************************************************************

Binary package hint: grub

I have an Asus P5B motherboard with a PATA DVD drive and a SATA HDD, both of which are attached to the JMicron controller on the motherboard. I can get an Ubuntu Edgy daily (I last tried the 7th October build) to install but upon rebooting, Grub reports an error (error 21). I believe this is because Grub can not see the drive attached to the JMicron controller or the controlelr itself.

Once the ICH8 fix is released, I hope that channel on the motherboard will work instead, however people wishing to use the JMicron controller will still face the problem.

Revision history for this message
gok (gok) wrote :

same problem here...

Daily build 7 oct. 2006 => install edgy pata-hdd@jmicron ok
upon rebooting.. grub reports an error 21.

Revision history for this message
zoolonly (zoolonly) wrote :

I confirm the bug !
Every thing is ok during install , but on next reboot, grub reports an error 21 !
I heard on this thread that they could be able to fix the bug with linux debian :
http://www.ubuntuforums.org/showthread.php?t=234706&page=13&highlight=jmicron

hope it ll help !

Revision history for this message
godot (godotcg-launchpad) wrote :

I confirm too. I have installed Edgy on a SATA drive connected to ICH8, but if I move it on Jmicron, I get grub error 21. (Well, ok, it's maybe a strange manipulation, but I think it should work?)

Revision history for this message
Daniel Torres (lolikapuxa) wrote :

Same here. Msi neo p965.
w/ jmicron gives error 21.
w/ ich8 gives another error, since ich8 isn't fixed at the moment.
result: No system running at all.

Changed in grub:
status: Unconfirmed → Confirmed
Revision history for this message
Mark Haase (mark-haase) wrote :

same problem here. No change for the last 2-3 months.

Revision history for this message
erani (jundoe) wrote :

This surely is a critical bug to be fixed...!
I wonder why this situation has not changed at all in such a long time.
I use LILO as my bootloader to boot ubuntu, but I would like to see GRUB working along with JMicron controllers.

Revision history for this message
Olli Hakala (olli-hakala) wrote :

I had same problem with P5B. I tried to install to PATA and SATA disks. PATA-drives were tested with different jumper settings, cable select/master/slave. I updated to newest beta bios version 0806 (2006/11/09 update) which solved the
problem.

Changed in grub:
importance: Undecided → High
Revision history for this message
Sam H (samjh) wrote :

Same problem with ASUS P5B series. Installed on PATA HDD (Primary) using PATA DVD/CD-RW (Secondary). Installs without a problem, but "Grub error 21" upon reboot.

Rebooting using Live CD, cannot find HDD in /media directory. Sysguard shows that both HDD and DVD/CD-RW are detected by system under the Jmicron controller, but not visible in /media.

Will try the BIOS upgrade shortly and report back.

Revision history for this message
Sam H (samjh) wrote :

OK, just tried with the latest BIOS update from ASUS, which incorporates an update to the JMicron controller's BIOS as well.

Ubuntu 6.10 installs and boots perfectly.

Revision history for this message
Thomas Hotz (thotz-deactivatedaccount) wrote :

Thanks for retesting. I would like to leave this bug _open_ for all the others who also have this problem.

description: updated
description: updated
Changed in grub:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.