kernel 2.6.19-6 does not boot

Bug #73057 reported by Alberto Milone on 2006-11-23
14
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Undecided
Unassigned
linux-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-generic

kernel 2.6.19-6 does not boot.

The bootsplash starts but the progress bar doesn't advance.

If I press ESC I get this:

Waiting for root file system

And nothing happens.

However (I tried both the generic and the 386 kernel) I've noticed that if I wait enough I get to the command line which says:

BusyBox v.1.1.3 (Debian 1:1.1.3-2ubuntu3) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

/bin/sh can't access tty; job control turned off
(initramfs)

Adam Greig (adamgreig) wrote :

I can confirm this, the -4 kernel's booting but -6 hangs on "Waiting for root file system".
-6 was working on the 22nd nov, but after updates on the 23rd nov it's stopped.

Notably, with the -4 kernel various init scripts are run between "Mounting.." and where the -6 kernel has "waiting for root". However, with -6 only one init script is being run.

You are sure that the problem is with the kernel -6?
I'm running this kernel since yesterday, without any problems.

int@int:~$ uname -a
Linux int 2.6.19-6-generic #2 SMP Tue Nov 21 07:02:59 UTC 2006 i686 GNU/Linux

I think the problems was with udev_103-0ubuntu3_i386.deb package, and the devs allready release the udev_103-0ubuntu4_i386.deb. (Possible fix?)

Alberto Milone (albertomilone) wrote :

I'm using udev version: 103-0ubuntu4

but that doesn't solve the problem.

I can only boot by using Edgy's kernel (2.6.17-10-generic).

Alberto Milone (albertomilone) wrote :

Here is my fstab

Adam Greig (adamgreig) wrote :

I'm sure it's with -6 -- this was booting fine until I installed all the updates and rebooted, and now it doesn't boot.
-4 still boots fine, however (using it now).

Expanding on my previous comment, while -6 only runs /scripts/local-bottom (I believe it's only that) before waiting for root filesystem, -4 runs several, include /scripts/local-premount, /scripts/local-top, and some others.

Emilio Pozuelo Monfort (pochu) wrote :

I haven't got this problem, and I'm using 2.6.19-6.

You can follow the ubuntuforums.org thread here:
http://ubuntuforums.org/showthread.php?t=305926

Adam Greig (adamgreig) wrote :

I'm attaching two files, one showing the -4 kernel working fine and the other showing the -6 kernel failing to boot.

Here's -4:

Adam Greig (adamgreig) wrote :

And this is -6:

Adam Greig (adamgreig) wrote :

Sorry, file didn't attach. Trying again:

this is due to the temporarily broken udev and/or coreutils of the previous day.

It has now been fixed.

You can chroot into your feisty / , either from a live cd, or from another partition on that machine.

use: sudo chroot /feisty/root/location/ su

Changed in linux-meta:
status: Unconfirmed → Rejected

after that, update your machine with apt-get as normal, and exit.

Adam Greig (adamgreig) wrote :

I'm sorry, but you're wrong. I have a fully updated system - the udev issue affected me just as it did everyone else, and I fixed that the way I gather most people did: with a chroot.
This is a different problem - or perhaps a related, but none the less still unfixed - problem.

"sudo apt-get dist-upgrade" reports no updates available, and neither -6-i386 nor -6-generic boots, and neither does either in single user mode. Same problem both times.

Seeing as -4 boots, I can't imagine it's a udev problem anyway - surely that would affect all kernels? I know I couldn't boot with any when I got that.

Meanwhile, other people, also apparently with fully updated systems, continue to have this issue. Isn't it a bit hasty to reject the bug report when you haven't heard that it's fixed?

hrm, okay, sorry. must have misread it.

Changed in linux-meta:
status: Rejected → Confirmed
Caspar Adriani (thecas) wrote :

Same problem here (AMD64, 2.6.19-6-generic and 2.6.19-5-generic kernel), It does load some parts of the kernel but it never reaches the point of mounting the root disk (XFS partition). nosplash and recovery also won't boot.
I did a upgrade from a fresh edgy and my 2.6.17-10-generic boots fine.

Ben Collins (ben-collins) wrote :

I'm pretty sure this was related to initramfs-tools not including the new pata drivers. This has been fixed in newer initramfs-tools packages.

If this does not fix your problem, then you have an issue with your grub menu.lst file. Edit it, finding the line that has kopt_2_6, and delete that line, then run "sudo update-initramfs -u".

Changed in linux-meta:
status: Confirmed → Fix Released
Caspar Adriani (thecas) wrote :

in my menu.lst is no enabled kopt_2_6 line and "update-initramfs -u" only updates the initramfs of 2.6.19-5-generic. Booting 2.6.19-5-generic now gives a new result and ends up in busybox while 2.6.19-6-generic still refuses to continue to load.

On Mon, 2006-11-27 at 03:27 +0000, Caspar Adriani wrote:
> in my menu.lst is no enabled kopt_2_6 line and "update-initramfs -u"
> only updates the initramfs of 2.6.19-5-generic. Booting 2.6.19-5-generic
> now gives a new result and ends up in busybox while 2.6.19-6-generic
> still refuses to continue to load.

The fact that it is commented out does not mean it isn't "enabled" That
line is used by update-grub to generate the menu listing.

Remove that line, and run "sudo update-initramfs -u -k
2.6.19-6-generic".

Caspar Adriani (thecas) wrote :

Deleted the line and run the update-initramfs command. Kernel still won't boot. When trying restore mode, the kernel does load, last part it loads is the usb core. It does reacts on events like adding/removing USB devices, but it does not get to the point of a shell.

Caspar Adriani (thecas) wrote :

Problem solved thanks to Ben Collins,

roundup to fix this problem:
- remove the '# kopt_2_6=root=/dev/hdaX ro' line from your menu.lst
- $ sudo update-initramfs -u -k 2.6.19-6-generic
- $ sudo grub-update
- reboot

Changed in linux-meta:
status: Unconfirmed → Rejected
Changed in linux-source-2.6.19:
status: Fix Released → Confirmed
Adam Greig (adamgreig) wrote :

One last note; it should be update-grub not grub-update. So the full set of repair instructions should be:

- remove the '# kopt_2_6=root=/dev/hdaX ro' line from your menu.lst
 - $ sudo update-initramfs -u -k 2.6.19-6-generic
 - $ sudo update-grub
 - reboot

Stefan Skotte (screemo) wrote :

The instructions for removing the 'kopt_2_6=root=/dev/hdaX ro' line and generating the initramfs again does not work for me either.

The boot sequence hangs a while after "waiting for root filesystem".

I noticed that my harddisk(sda1) is not available in the /dev filesystem either.

The harddrive in my laptop is connected using SATA.

kernel 2.6.17-10-generic boots fine however.

Nuno Ferreira (nmf) wrote :

I'm also having this problem with a fully updated system, 2.6.17-10-generic boots but 2.6.19 doesn't boot. I have root on a md (raid5) over 3 sata disks on a nforce4 mb. I think the problem is that the sata_nv modules are not being loaded so the disks are not detected, just like in the previous comment

Same problem for me with 2.6.19-7 with lilo.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers