gtk2-engines-gtk-qt causes GNOME-panel to crash upon startup and causes Gnome to look ugly

Bug #36256 reported by Scott Beamer
92
Affects Status Importance Assigned to Milestone
gtk-qt-engine (Ubuntu)
Critical
Kubuntu Bugs

Bug Description

Steps to repeat bug.

Log in to KDE. Go to System Settings--->Personal--->Appearance--->GTK Styles
and Fonts.

Make these changes:

GTK Styles: Use my KDE style in GTK applications

&

GTK Fonts: Use my KDE fonts in GTK applications.

Click on "Apply"

Close System Settings window and go on about your work. Lauch Firefox,
Thunderbird and some GTK2 applications and you'll find they nicely inherit the
KDE look and feel.

But often times you will find the settings did not take. Other times they will
take.

Sometimes logging off KDE and logging back in locks them in.

But the worst part about gtk2-engines-gtk-qt is that after having utilized them
in KDE (i.e. run some GTK2 apps or Firefox) you will find that later use of
GNOME is virtually impossible.

To continue...

Log off KDE and log into GNOME.

See splash screen as normal.

Then see gnome-panel try to start and then immediately crash.

That process repeats itself indefinently and eventually stops, giving you a
blank screen.

All you can do then is kill X (sometimes that doesn't work either and you have
to restart your computer) and log back into KDE and pretend GNOME doesn't exist. :-)

I actually like both GNOME and KDE and use both extensively but untill this gets
fixed that's going to be impossible.

gtk2-engines-gtk-qt worked far better in hoary than in breezy.

http://packages.ubuntu.com/breezy/kde/gtk2-engines-gtk-qt: http://packages.ubuntu.com/breezy/kde/gtk2-engines-gtk-qt

Revision history for this message
GonzO (gonzo) wrote :

I had a lot of problems with this package, also. It caused an inability to
resize Application Fonts in gnome, and started to render GTK widgets with QT
ones... even when logged into Gnome. It also refused to display radio buttons.

Uninstalling this package and deleting my .gnome files was the only thing that
brought me back to a proper Human desktop.

Revision history for this message
Scott Beamer (angrykeyboarder) wrote :

Hello? Is anybody home?

Revision history for this message
Oliver Grawert (ogra) wrote :

could you attach you ~/.xsession-errors file ?

Revision history for this message
Scott Beamer (angrykeyboarder) wrote :

(In reply to comment #3)
> could you attach you ~/.xsession-errors file ?

Woops! I somehow didn't get this message.

I'd gladly attach the file however, my Linux box is currently out of commision
for a while (pending reciept of a replacement for the video card that died).
Vendor estimates I should recieve it in 10-14 days. I will follow-up here ASAP.

Revision history for this message
Oliver Grawert (ogra) wrote :

this looks suspicious like https://bugs.freedesktop.org/show_bug.cgi?id=4178, if
it doesnt get solved before upstream version freeze i'll propose to demote this
package to unierse, since i see no way that we support it for 3 years in dapper

Revision history for this message
Scott Beamer (angrykeyboarder) wrote :

(In reply to comment #5)
> this looks suspicious like https://bugs.freedesktop.org/show_bug.cgi?id=4178, if
> it doesnt get solved before upstream version freeze i'll propose to demote this
> package to unierse, since i see no way that we support it for 3 years in dapper

I really hope you don't do that. It's a very important package and is a part of
every other major disributions "standard" packages.

Please note, this package was NOT a problem for me in Hoary. Only in Breezy did
it become a problem.

Revision history for this message
Oliver Grawert (ogra) wrote :

please understand that we cant ship anything for a 3 year support release that
renders the whole system unusable and where upstream didnt work on this major
bug which is not specific to ubuntu (see upstream bug) for about 4 months. feel
free to contact upstream to fix it in time, i'm only opposed to ship this
package in the current state it is in, i can verify the bug reliable on all
systems here.

Revision history for this message
Scott Beamer (angrykeyboarder) wrote :

(In reply to comment #7)
> please understand that we cant ship anything for a 3 year support release that
> renders the whole system unusable and where upstream didnt work on this major
> bug which is not specific to ubuntu (see upstream bug) for about 4 months.

I understand.

> feel free to contact upstream to fix it in time

I may do that.

>, i'm only opposed to ship this
> package in the current state it is in, i can verify the bug reliable on all
> systems here.

So you're saying you've verified the bug I reported is occurring on your systems
there as well?

As far as it rendering the system unusable is concerned, I can't help but wonder
why something so critical has only been considered "normal" severity and took so
long to address.

BTW, a few weeks after I first reported this, I found a temporary workaround.
Before logging out of KDE I'd delete the .gtk_qt_engine_rc file from my home
directory. That would solve the problem and allow me to log in to and use GNOME
as normal. When I logged back in to KDE it would just re-create the file.

In any event, thanks for your attention to this matter.

Revision history for this message
Oliver Grawert (ogra) wrote :

i guess you use KDE as your main desktop ... if you just install the engine on a
normal ubuntu you get a QT item in your theme selector. switching to is works
fine with the recent package in dapper, but switching back mkes your complete
desktop crash, kills the gnome-settings-daemon and renders the desktop nearly
unusable. removing a configuration dir/file might be a good workaround while
switching between desktops, but the solution itself must happen inside the theme
engine, if we have the engine in main it must at least work correctly on both
major desktops we ship (and i'm not concerned about cosmetic issues) ...

Revision history for this message
Scott Beamer (angrykeyboarder) wrote :

(In reply to comment #9)
> i guess you use KDE as your main desktop ...

Nope. I use both GNOME and KDE about equally.

>if you just install the engine on a
> normal ubuntu you get a QT item in your theme selector. switching to is works
> fine with the recent package in dapper, but switching back makes your complete
> desktop crash, kills the gnome-settings-daemon and renders the desktop nearly
> unusable.

Exactly.

>removing a configuration dir/file might be a good workaround while
> switching between desktops, but the solution itself must happen inside the theme
> engine,

I could not agree more. I'm just saying that I found a temporary workaround. By
no means do I consider it an acceptable/permanent solution.

>if we have the engine in main it must at least work correctly on both
> major desktops we ship (and i'm not concerned about cosmetic issues) ...

I understand and I agree with your position. I am concerned about cosmetic
issues, or I'd never have messed with the package to begin with. :-)

Revision history for this message
Scott Beamer (angrykeyboarder) wrote :

(In reply to comment #3)
> could you attach you ~/.xsession-errors file ?

Are you still interested in that? I've got my Linux box back now.

Revision history for this message
Oliver Grawert (ogra) wrote :

not really, except you find something unusual in that file, it seems there are
no gtk-qt related errors in it ...

Revision history for this message
magilus (magilus) wrote :

*push* because it is still in main.

This is a really annoying issue and it would be important to move gtk2-engines-gtk-qt over to universe or to make kubuntu-desktop not depend on it.

Revision history for this message
Oliver Grawert (ogra) wrote :

no objections at all, but since i dont have influence on teh kubuntu seeds (and metapackages), reassigning to the kubuntu team

Changed in gtk-qt-engine:
assignee: ogra → kubuntu-team
Revision history for this message
Loïc Corbasson (cnb) wrote :

May https://bugs.freedesktop.org/show_bug.cgi?id=3983 be related? Maybe we should try to contact upstream to see if there will be a bugfix release soon (as the above cited bug seems to be fixed in CVS) or if we can backport the fix to our package?

Revision history for this message
magilus (magilus) wrote :

I do not think that the bug mentioned in #3983 on Freedesktop Bugzilla is related to this problem because the patch attached there is included in Kubuntu since Breezy.

I am currently downloading Kubuntu Dapper and I will look if the problem still exists there.

This problem is also VERY important and is a major issue which makes it nearly impossible to switch between Gnome and KDE sometimes:
> if you just install the engine on a
> normal ubuntu you get a QT item in your theme selector. switching > to is works
> fine with the recent package in dapper, but switching back mkes > your complete
> desktop crash, kills the gnome-settings-daemon and renders the > desktop nearly unusable.

Revision history for this message
magilus (magilus) wrote :

So far, I can not reproduce the gnome-panel crash in Dapper but I can reproduce the thing mentioned in the second part of my last post.

After being logged in in KDE, logging out and logging in to Gnome, Gnome uses Qt instead of Clearlooks. It is not possible to change this via the Gnome Theme Chooser, you have to remove some configuration files.

The same applies for selecting Qt in the Gnome Theme Chooser. You can select it but you can not go back easily.

This bug makes it nearly impossible to switch between KDE and Gnome at the same installation and it is a must fix for Dapper. Becuase of that I will change Severity.

Changed in gtk-qt-engine:
status: Unconfirmed → Confirmed
Revision history for this message
magilus (magilus) wrote :

I was able to reproduce the gnome-panel crash, too.

Revision history for this message
Florian Zeitz (florian-zeitz) wrote :

While this packages is important for gnome apps to look good in KDE, there is a list of problems it causes in gnome when KDE and gnome are both installed.
I felt it was neccessary to list them to show how important this issue really is:
- Menu's highlights are blue in all themes
- KDE icons are used in some places in all themes
- Buttons and menus in OpenOffice are only displayed on mouse over
- Scroll bar in firefox is not the Themes one and doesn't work as expected
- Scrollwhell on mixer-applet works in reverse

Of course I can't really proof this is all related to gtk2-engines-gtk-qt, but all this issues were gone as soon as I removed it.

Revision history for this message
Rocco Stanzione (trappist) wrote :

I don't know how many of these issues have been fixed upstream, but we seem to be pretty far behind. It might be worth investigating a newer version.

Revision history for this message
Luka Renko (lure) wrote :

Rocco: are we really far behind?

Last version mentioned is 0.60 which is used in ubuntu: http://www.freedesktop.org/wiki/Software/gtk-qt

Revision history for this message
magilus (magilus) wrote :

I'd like to complete Florian's list:
- When you are lucky Gnome does not start anymore because gnome-panel crashes permanently
- It is not possible to switch off QT in the Gnome Theme Chooser

I think that kubuntu-desktop should not depend on gtk2-engines-gtk-qt. I understand that it is nice to have a GTK application integration in KDE but gtk2-engines-gtk-qt just breaks too many things.

Revision history for this message
Rocco Stanzione (trappist) wrote :

Luka, my mistake. I was looking at the cvs revision of qt_qt_wrapper.cpp, which is at 1.80.

Revision history for this message
Liz Young (liz) wrote :

Broken in Xubuntu, too (Dapper). If ~/.gtkrc-2.0 exists, xfce4-panel crashes and the system hangs at login. Deleting the file and removing the package resolves it.

Revision history for this message
Robert (ubuntu-10-rmn30) wrote :

Just to confirm that I am seeing weird rendering issues with firefox and other programs in kubuntu dapper. The package also rendered openoffice almost unsuable -- all the toolbar icons and menu items disappeared except on mouse over. Best workaround I have found is to select a different gtk theme e.g. human, in kcontrol.

Seems to me that this package causes more problems than it is worth just to have matching widgets and definately shouldn't be enabled by default. Would be more worthwhile if it would fix the real UI issues such as differing file selection and print dialogues but it doesn't as far as I can tell.

Robert

Revision history for this message
Dennis Kaarsemaker (dennis) wrote :

Setting this to critical since it breaks a lot of things in Ubuntu and Xubuntu.

Revision history for this message
Luka Renko (lure) wrote :

Can we workaround this issue in a way that login into KDE would switch to own version of ~/.gtkrc (via symlink or similar) and login into GNOME/XFCE would use own version of ~/.gtkrc?

That way we could have ~/.gtkrc.main and ~/.gtkrc.kde and would just symlink to apporiate one on login. Can we use login startup scripts for this or is this already too late in the process?

Revision history for this message
Lukas Sabota (punkrockguy318) wrote :

WORKAROUND: rm ~/.gtkrc-2.0

This is quite annoying. KDE will change the GTK theme to qt, but the GNOME theme selecter can't change it back. You can only change it back by deleting the gtkrc file.

Revision history for this message
Anthony Mercatante (tonio) wrote :

We now how to correct this, and a little scripting in startkde is required.
I'm working on that and a patch should be released tomorrow.

Changed in gtk-qt-engine:
status: Confirmed → In Progress
Revision history for this message
Anthony Mercatante (tonio) wrote :

The problem should now be resolved.
The theme will be autoconfigured by startkde in the profile only if neither gnome nore xfce are installed.

Changed in gtk-qt-engine:
status: In Progress → Fix Released
Revision history for this message
magilus (magilus) wrote :

Great, thanks! :)

Revision history for this message
Florin Herbert (florin-herbert) wrote :

I understand that this problem was solved in Breezy, but what about Dapper? I installed yesterday Ubuntu Dapper beta, then kubuntu-desktop over it. After loggin in KDE and than back in Gnome I have a blue-ish theme in menus and disappearing icons in OpenOffice.

Revision history for this message
Anthony Mercatante (tonio) wrote :

Yes, I just saw the patch wasn't in kdebase.
Just resent it, let's see what heppens.

It'll be in soon, don't mind ;)

Revision history for this message
Florin Herbert (florin-herbert) wrote :

Thanks! :)
Anyway, I changed Gtk style in KDE's System Settings from "Use my KDE style" to "Human" and that did the trick for my setup (Ubuntu with Kubuntu-desktop over it, both with default themes), now everything seems to work well and look right in both Gnome and KDE. I'll see what happens when I change the theme in Gnome, use KDE a little and go back to Gnome after your patch is in.

Revision history for this message
Anthony Mercatante (tonio) wrote :

The patch just got in

Revision history for this message
ShamrockUK (uplift) wrote :

http://ubuntuforums.org/showthread.php?t=199905

Unfortunately, it looks like this happened to Maelstrm in the last few days, was the patch definitely committed back at the beginning of May?

Revision history for this message
Florian Zeitz (florian-zeitz) wrote :

The patch has definitly been committed now.
The symptoms described in the thread don't realy sound like this bug either.

Revision history for this message
Wesley Stessens (wesley) wrote :

I had the same bug.. I fixed it temporarily by removing ~/.gtkrc-2.0

So it seems like the bug is still around!

I am running an up to date dapper system and I installed kubuntu-desktop yesterday -- only to find out a broken GNOME the next day ;)

I am happy with the temporary fix -- but this could be a big issue for other users!

Here's some info about my system:

where I get my packages from: /etc/apt/sources.list
http://rafb.net/paste/results/1c9DIB94.html

kubuntu-desktop package:

profox@lioness:~$ apt-cache policy kubuntu-desktop
kubuntu-desktop:
  Geïnstalleerd: 0.86 (installed)
  Kandidaat: 0.86 (candidate)
  Versietabel: (version table)
 *** 0.86 0
        500 http://be.archive.ubuntu.com dapper-updates/main Packages
        100 /var/lib/dpkg/status
     0.85 0
        500 http://archive.ubuntu.com dapper/main Packages

GNOME is version 2.14.2
KDE is version 3.5.2

need anything more? :)

Revision history for this message
Wesley Stessens (wesley) wrote :

Bug reopened; bug still exists

I experienced the bug a while ago, and so did my friend last night.

Changed in gtk-qt-engine:
status: Fix Released → Confirmed
Revision history for this message
Fabian Bron (phaldmmor) wrote :

Hi,

I also had the same bug, so it seems to be still around. Thanx to the help of profoX is solved the problem using the workaround by removing ~/.grkrc-2.0.

phaldmmor@PC-Phaldmmor:~$ apt-cache policy kubuntu-desktop
kubuntu-desktop:
  Geïnstalleerd: 0.86
  Kandidaat: 0.86
  Versietabel:
 *** 0.86 0
        500 http://nl.archive.ubuntu.com dapper-updates/main Packages
        100 /var/lib/dpkg/status
     0.85 0
        500 http://nl.archive.ubuntu.com dapper/main Packages

If somebody needs more information, please let me know (and how I can get the info ;-) )

Revision history for this message
Scott Beamer (angrykeyboarder) wrote :

That doesn't "solve" the bug it's just a workaround. And not practical for a new/inexperienced user.

The bug remains. Also, I've been doing that (deleting .gttkrc2.0) for months now). :-)

To be specific .gtkrc2.0 AND .gtk_qt_engine_rc.

See https://launchpad.net/distros/ubuntu/+source/gtk-qt-engine/+bug/36256/comments/8 from 30 November 2005 for details.

I experienced this bug again yesterday. So it's been ongoing for the past *year* now.. :-(

Revision history for this message
Florian Zeitz (florian-zeitz) wrote :

Actually the fix is definitely present in both dapper and edgy.
.gtkrc2.0 and .gtk_qt_engine_rc are not created by startkde if either xfce or gnome is installed.

I could imagine that those files are created by a different script or application.
Can you trace back the creation of those files to a certain action or are they actually created every time you start up KDE?

Revision history for this message
Anthony Mercatante (tonio) wrote :

The creation of those files is done directly by startkde, not an external script.
Here is the bit of code that does it :
# configuration of the gtk_qt_engine if not already set

if [ ! -x /usr/bin/startxfce4 ] && [ ! -x /usr/bin/gnome-session ]
then
        if [ ! -e $HOME/.gtk_qt_engine_rc ] && [ -e /usr/share/kubuntu-default-settings/.gtk_qt_engine_rc ]
        then
                 cp -f /usr/share/kubuntu-default-settings/.gtk_qt_engine_rc $HOME
        fi

        if [ ! -e $HOME/.gtkrc-2.0 ] && [ -e /usr/share/kubuntu-default-settings/.gtkrc-2.0 ]
        then
                 cp -f /usr/share/kubuntu-default-settings/.gtkrc-2.0 $HOME
        fi
fi

You can have the issue if you installed kubuntu and then installed gnome of xfce.
There is not issue if you install kubuntu-desktop package on xubuntu or ubuntu

Revision history for this message
Rocco Stanzione (trappist) wrote :

Looking at that helps explain why I couldn't reproduce this. I hadn't yet installed gnome-session. Looking at it closer makes me wonder if it couldn't be /usr/share/themes/Qt/gtk-2.0/gtkrc which is included by ~/.gtkrc-2.0 and which looks like this:
style "default"
{
  engine "qtengine"
  {
  }
}
class "GtkWidget" style "default"

I'd test myself whether that empty block makes any difference, but I still haven't been able to reproduce the problem. I have installed gnome-session-dbg in the hopes of catching any backtrace, but there still has been no crash (on edgy).

Revision history for this message
Florian Zeitz (florian-zeitz) wrote :

>You can have the issue if you installed kubuntu and then installed gnome of xfce.
>There is not issue if you install kubuntu-desktop package on xubuntu or ubuntu
>

Oh right, I forgot about this possiblilty.
But doesn't that basically mean that either startxfce4 and gnome-session have to remove the two files (if they are the ones from kubuntu, so user configuration isn't messed with), or starkde has to stop creating them?
Neither sounds particularly graceful to me.

Revision history for this message
Fabian Bron (phaldmmor) wrote :

To replicate the problem maby this works to "create" the problem :

Logon to GNOME
Logoff and login to KDE
Go to System Settings > Apperance > GKT-Fonts
Select Use a other fonts
Apply
Select Use my KDE fonts in GTK applications
Apply
Logoff
Try to login to GNOME....

Revision history for this message
David Sansome (me-davidsansome) wrote :

My intention was to solve this upstream by making the control center module only apply its settings to apps inside KDE. It would do this by writing a script into ~/.kde/env to set the GTK2_RC_FILES (I think) environment variable. This script would only get run on KDE startup - letting you choose your own themes to use in GNOME and XFCE.

However this still doesn't explain why GNOME crashes when using the theme engine, as it works fine for me. I'll investigate and see if I can reproduce the problem.

Revision history for this message
Christopher Monahan (foreverwatcher) wrote :

I had a similar problem with this package, I contacted upstream and they said they were working on it, the most annoying thing i found was that the colours persisted after uninstallation, to solve I had to remove the ~/.gtkrc file (or something like that) which made it all better...

Revision history for this message
Christopher Monahan (foreverwatcher) wrote :

PS:

>You can have the issue if you installed kubuntu and then installed gnome of xfce.
>There is not issue if you install kubuntu-desktop package on xubuntu or ubuntu

I installed of ubuntu and had the problem, although i didn't use the kubuntu-desktop metapackage

Revision history for this message
D. Brodzik (amyrose) wrote :

Fedora has the perfect solution to this problem:

Their version uses a file called ".gtkrc-2.0.kde" or something, so it would ONLY be used under KDE. Could we modify it to use their patch? http://download.fedora.redhat.com/pub/fedora/linux/extras/6/i386/gtk-qt-engine-0.70-4.20061211svn.fc6.i386.rpm

Or is this in the upstream SVN?

Revision history for this message
D. Brodzik (amyrose) wrote :

Just checked, and yes, it has indeed been fixed upstream in the current SVN snapshots.

Revision history for this message
magilus (magilus) wrote :

Feisty should ship with a SVN release as Fedora does then...

Revision history for this message
Anthony Mercatante (tonio) wrote :

I just packaged from SVN, and also fixed kdebase and kubuntu-default-settings to install new default config on profile creation.

For people already having the issue, once everything is updated, just reconfigure fonts and theme in gnome once and the problem should be gone.

Changed in gtk-qt-engine:
status: Confirmed → Fix Released
Revision history for this message
magilus (magilus) wrote :

Thanks :-)

Revision history for this message
Sam Bull (dreamsorcerer) wrote :

I'm using Gutsy and seem to be encountering a similar problem as above (not sure if it is exactly the same though). I seem to hit the same problems partial display crash (exact effects vary somewhat each time), it is triggered when I go to Appearances -> Controls -> Customise -> Qt. This is particulary annoying as I try out new themes, if they are above Qt, and I want to delete them, then it will automatically move me to the the one below(Qt) when I delete it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.