Change log for gtkglextmm package in Ubuntu

119 of 19 results
Published in focal-release on 2020-03-22
Deleted in focal-proposed (Reason: moved to Release)
gtkglextmm (1.2.0-8build1) focal; urgency=medium

  * No-change rebuild for libgcc-s1 package name change.

 -- Matthias Klose <email address hidden>  Sun, 22 Mar 2020 16:43:13 +0100
Superseded in focal-release on 2020-03-22
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
gtkglextmm (1.2.0-8) unstable; urgency=medium

  * d/control: 
    - New maintainer, Closes: #674875
    - Update standards version to 3.9.8 
    - Add packaging VCS urls
    - run 'dpkg fix dpkg-control'
  * d/rules: 
    - Add hardening 
    - Add CPPFLAGS -DGLIBMM_DISABLE_DEPRECATED Closes: #838808  
  * d/libgtkglextmm-x11-1.2-doc.install: don't copy useless md5 files  
  * d/ 
    - Add doc-base file 
    - Add override for missing symbols file 

 -- Gert Wollny <email address hidden>  Fri, 07 Oct 2016 10:23:33 +0200

Available diffs

Superseded in yakkety-release on 2016-10-09
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
gtkglextmm (1.2.0-7) unstable; urgency=medium

  * QA upload
  * Use dh-autoreconf to support new ports
    - drop fix_as_needed patch, we should no longer need to patch ltmain.sh
      now that we are copying in the one from libtool
    - add patch from upstream to set the correct ACLOCAL_AMFLAGS
    - add patch to fix FTBFS with modern glibmm, which has moved its
      Autoconf macros and other metadata
  * Rename library package to libgtkglextmm-x11-1.2-0v5 for libstdc++
    ABI transition
    - version the build-dependencies to ensure the g++-5-compiled versions
  * Set the Section of the new package to oldlibs since it is based
    on the deprecated Gtk 2

 -- Simon McVittie <email address hidden>  Tue, 25 Aug 2015 09:44:58 +0100
Superseded in wily-release on 2015-08-31
Deleted in wily-proposed on 2015-09-02 (Reason: moved to release)
gtkglextmm (1.2.0-6ubuntu2) wily; urgency=medium

  * No-change rebuild against libatkmm-1.6-1v5

 -- Steve Langasek <email address hidden>  Fri, 07 Aug 2015 18:19:41 +0000

Available diffs

Superseded in wily-release on 2015-08-16
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-02-23
Deleted in trusty-proposed (Reason: moved to release)
gtkglextmm (1.2.0-6ubuntu1) trusty; urgency=medium

  * Manually patch libtool files to add support for ppc64el.
 -- Logan Rosen <email address hidden>   Sat, 22 Feb 2014 22:19:55 -0500
Superseded in trusty-release on 2014-02-23
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
gtkglextmm (1.2.0-6) unstable; urgency=low


  * QA upload.
  * debian/ cleanup:
    + use dh
    + bump debhelper compat
    + use source format 3.0 (quilt)
    + remove invalid VCS headers
    + add Multi-Arch support
    + add missing dependencies of -dev package (Closes: #594187)
  * Apply patch by Andres Mejia to fix autoconf warning.
    (Closes: #580829)

 -- Frank Lichtenheld <email address hidden>  Fri, 17 May 2013 21:31:51 +0200

Available diffs

Superseded in saucy-release on 2013-05-18
Deleted in saucy-proposed on 2013-05-19 (Reason: moved to release)
gtkglextmm (1.2.0-5) unstable; urgency=low


  * QA upload. (Closes: #631783)
  * Change maintainer to QA Group.
  * Fix FTBFS with newer GTK by switching #includes around
    so that the G_DISABLE_DEPRECATED trick in glibmm still
    works (Closes: #707356)

 -- Frank Lichtenheld <email address hidden>  Thu, 16 May 2013 23:51:57 +0200

Available diffs

Superseded in saucy-release on 2013-05-17
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-18
gtkglextmm (1.2.0-4.1) unstable; urgency=low
  * Non-maintainer upload.  * Remove references to other libraries from dependency_libs field    (Closes: #620633).  * Define GdkSpanFunc (Closes: #621976). -- Luk Claes <email address hidden>  Mon, 27 Jun 2011 08:17:17 +0200
Superseded in precise-release on 2011-10-18
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
gtkglextmm (1.2.0-4ubuntu3) natty; urgency=low

  * debian/rules: clean the dependency_libs out of .la files at build
    time, per Policy 10.2
 -- Steve Langasek <email address hidden>   Sun, 03 Apr 2011 01:15:46 -0700

Available diffs

Superseded in natty-release on 2011-04-03
gtkglextmm (1.2.0-4ubuntu2) natty; urgency=low

  * Include widget.h before gtkglext.h so GdkSpanFunc is defined (LP: #662572)
 -- Krzysztof Klimonda <email address hidden>   Wed, 08 Dec 2010 13:32:57 +0100

Available diffs

Superseded in natty-release on 2010-12-08
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
gtkglextmm (1.2.0-4ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, Ubuntu remaining changes:
    - debian/control: added some Conflicts/Replaces fields to allow
      a clean upgrade from Intrepid:
      + libgtkglextmm-x11-1.2-0 conflicts/replaces libgtkglextmm-x11-1.2
      + libgtkglextmm-x11-1.2-dev conflicts/replaces libgtkglextmm-x11-dev
      + libgtkglextmm-x11-1.2-doc conflicts/replaces libgtkglextmm-x11-dev

Available diffs

Superseded in jaunty-release on 2009-04-07
gtkglextmm (1.2.0-3ubuntu1) jaunty; urgency=low

  * Merge from debian unstable (LP: #313480), Ubuntu remaining changes:
    - debian/control: added some Conflicts/Replaces fields to allow
    a clean upgrade from Intrepid:
     + libgtkglextmm-x11-1.2-dev conflicts/replaces libgtkglextmm-x11-1.2
     + libgtkglextmm-x11-1.2-dev conflicts/replaces libgtkglextmm-x11-dev
     + libgtkglextmm-x11-1.2-doc conflicts/replaces libgtkglextmm-x11-dev

Available diffs

Superseded in jaunty-release on 2009-01-03
gtkglextmm (1.2.0-2ubuntu1) jaunty; urgency=low

  * debian/control: add some Conflicts/Replaces fields to allow a clean
    upgrade from Intrepid:
    - libgtkglextmm-x11-1.2-dev conflicts/replaces libgtkglextmm-x11-1.2.
    - libgtkglextmm-x11-1.2-dev conflicts/replaces libgtkglextmm-x11-dev.
    - libgtkglextmm-x11-1.2-doc conflicts/replaces libgtkglextmm-x11-dev.

Available diffs

Superseded in jaunty-release on 2008-12-21
Obsolete in intrepid-release on 2013-02-20
Obsolete in hardy-release on 2015-04-24
gtkglextmm (1.2.0-0ubuntu1) hardy; urgency=low

  * Upgraded to version 1.2.0
  * Restored into Hardy (LP: #190175)
  * Changed package name to libgtkglextmm-x11-1.2 to match SONAME
  * Removed unrequired packaging files from debian/
  * Upgrade debian/copyright to point at GPL2 rather than GPL
  * Added Silicon Graphics Inc's copyright on files to debian/copyright
  * Added the licence for examples/trackball.c examples/trackball.h to
    debian/copyright

 -- David Morris <email address hidden>   Thu, 7 Feb 2008 20:19:40 +0000
Deleted in feisty-release on 2006-11-15 (Reason: (From Debian) RoQA: RC-buggy, no rev-deps)
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
gtkglextmm (1.0.1-3ubuntu3) dapper; urgency=low

  * Fix -dev depend on libgtkmm2.4-dev to libgtkmm-2.4-dev

 -- Trent Lloyd <email address hidden>   Fri, 10 Feb 2006 22:19:40 +0800
Superseded in dapper-release on 2006-02-10
Superseded in dapper-release on 2006-02-03
gtkglextmm (1.0.1-3ubuntu2) dapper; urgency=low


  * debian/control: adjusted build-dep to libgtkmm2.0-dev
  * debian/*.doc-base.EX: renamed to *.doc-base

 -- Stephan Hermann <email address hidden>  Thu,  1 Dec 2005 19:38:55 +0100
Obsolete in breezy-release on 2008-03-25
gtkglextmm (1.0.1-2ubuntu3) breezy; urgency=low


  * Rebuild for unmet deps

 -- Sebastian Dröge <email address hidden>  Sun, 11 Sep 2005 14:26:23 +0200
Obsolete in hoary-release on 2008-03-19
gtkglextmm (1.0.1-2) unstable; urgency=low


  * debian/control: depend on gtkglext >= 1.0.6-2 (fixes FTBFS) (closes:
    bug#264239)
  * debian/control: remove bogus dependency on libxmu-dev

 -- Marcelo E. Magallon <email address hidden>  Sat, 21 Aug 2004 21:06:43 -0600
Obsolete in warty-release on 2008-01-09
gtkglextmm (1.0.1-1) unstable; urgency=low


  * New upstream version (closes: bug#229140, bug#229521)
  * Rerun autofoo
        libtoolize (GNU libtool) 1.5.2
        aclocal (GNU automake) 1.7.9
        automake (GNU automake) 1.7.9
        autoconf (GNU Autoconf) 2.59
  * debian/control: bump dependency on libgtkglext to 1.0.6
  * debian/control: libgtkglextmm1-dev depends on libgtkglext1-dev (>> 1.0.6),
    libgtkmm2.0-dev (closes: bug#238194)

 -- Marcelo E. Magallon <email address hidden>  Sat, 03 Apr 2004 18:30:47 -0600
119 of 19 results