Change log for gunicorn package in Ubuntu

146 of 46 results
Published in xenial-updates on 2019-06-19
Published in xenial-security on 2019-06-19
gunicorn (19.4.5-1ubuntu1.1) xenial-security; urgency=medium

  * SECURITY UPDATE: Fix HTTP header splitting vulnerability
    - debian/patches/CVE-2018-1000164.patch: adds header checking and error handling
    - CVE-2018-1000164

 -- Mark Morlino <email address hidden>  Fri, 14 Jun 2019 13:51:47 -0400
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-07-08
Deleted in cosmic-proposed (Reason: moved to release)
gunicorn (19.9.0-1) unstable; urgency=medium

  * New upstream release. (Closes: #903222)

 -- Chris Lamb <email address hidden>  Sun, 08 Jul 2018 09:11:19 +0200

Available diffs

Superseded in cosmic-release on 2018-07-08
Deleted in cosmic-proposed on 2018-07-09 (Reason: moved to release)
gunicorn (19.8.1-2) unstable; urgency=medium

  * Update Vcs-* to point to salsa.debian.org.
  * Drop "ancient" X-Python-Version and X-Python3-Version headers.

 -- Chris Lamb <email address hidden>  Fri, 08 Jun 2018 17:54:56 +0100

Available diffs

Superseded in cosmic-release on 2018-06-09
Deleted in cosmic-proposed on 2018-06-10 (Reason: moved to release)
gunicorn (19.8.1-1) unstable; urgency=medium

  * New upstream release.
    - Refresh and rebase patches.
  * Bump Standards-Version to 4.1.4.

 -- Chris Lamb <email address hidden>  Wed, 02 May 2018 20:48:53 -0700

Available diffs

Superseded in cosmic-release on 2018-05-05
Published in bionic-release on 2018-02-08
Deleted in bionic-proposed (Reason: moved to release)
gunicorn (19.7.1-4) unstable; urgency=medium

  * Bump compat level to 11.
  * Update gbp.conf.
  * Update Standards-Version.
  * Bump Standards-Version to 4.1.2.
  * Use HTTPS URI in debian/copyright.
  * Remove trailing whitespace in debian/changelog.
  * Override debian-watch-does-not-check-gpg-signature.
  * Tidy debian/tests/control.

 -- Chris Lamb <email address hidden>  Wed, 07 Feb 2018 08:58:05 +0000

Available diffs

Superseded in bionic-release on 2018-02-08
Published in artful-release on 2017-08-13
Deleted in artful-proposed (Reason: moved to release)
gunicorn (19.7.1-3) unstable; urgency=medium

  * Move autopkgtests to a separate file.

 -- Chris Lamb <email address hidden>  Sat, 12 Aug 2017 12:56:56 -0400

Available diffs

Superseded in artful-release on 2017-08-13
Deleted in artful-proposed on 2017-08-14 (Reason: moved to release)
gunicorn (19.7.1-2) unstable; urgency=medium

  * Bump Standards-Version to 4.0.0.
  * Bump debhelper compatibility level to 10.
  * Drop useless ${python3:Depends} from gunicorn-examples package.
  * Set Section: python for python{,3}-gunicorn binary packages.
  * wrap-and-sort -sa.
  * Override no-upstream-changelog Lintian warnings.

 -- Chris Lamb <email address hidden>  Sun, 30 Jul 2017 22:11:27 -0400

Available diffs

Superseded in artful-release on 2017-08-01
Deleted in artful-proposed on 2017-08-02 (Reason: moved to release)
gunicorn (19.7.1-1) unstable; urgency=medium

  * New upstream release.

 -- Chris Lamb <email address hidden>  Sun, 26 Mar 2017 17:35:16 +0100

Available diffs

Superseded in artful-release on 2017-04-30
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
gunicorn (19.6.0-11) unstable; urgency=medium

  * Use ${misc:Pre-Depends} to populate Pre-Depends for
    dpkg-maintscript-helper. Thanks to Sebastian Ramacher. (Closes: #853989)

 -- Chris Lamb <email address hidden>  Fri, 03 Feb 2017 09:45:15 +1300

Available diffs

Superseded in zesty-release on 2017-02-03
Deleted in zesty-proposed on 2017-02-04 (Reason: moved to release)
gunicorn (19.6.0-10) unstable; urgency=medium

  * Move debian/README.Debian → debian/NEWS.

 -- Chris Lamb <email address hidden>  Sun, 01 Jan 2017 22:05:49 +0000

Available diffs

Superseded in zesty-release on 2017-01-02
Deleted in zesty-proposed on 2017-01-03 (Reason: moved to release)
gunicorn (19.6.0-9) unstable; urgency=medium

  * Add simple autopkgtest smoke test.

 -- Chris Lamb <email address hidden>  Sun, 13 Nov 2016 10:38:30 +0000

Available diffs

Superseded in zesty-release on 2016-11-13
Deleted in zesty-proposed on 2016-11-14 (Reason: moved to release)
gunicorn (19.6.0-8) unstable; urgency=medium

  * Correct 0004-Set-supplementary-groups-when-changing-uid.patch to be
    compatible with Python 3. (Closes: #839984)

 -- Chris Lamb <email address hidden>  Fri, 07 Oct 2016 11:12:58 +0100

Available diffs

Superseded in zesty-release on 2016-11-02
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
gunicorn (19.6.0-2) unstable; urgency=medium

  * Reload in logrotate's postrotate, otherwise gunicorn processes continue
    writing to the rotated files and not the new ones.  Thanks to Dimitris
    Bliablias <email address hidden> for the report and patch, although note
    that we call the more generic "reload" action instead of the suggested
    kill(1) call. (Closes: #832603)
  * Ensure that package short descriptions are unique to appease lintian.
  * wrap-and-sort -sa.
  * Re-order binary packages in debian/control.
  * Move to DEP-5 copyright file.

 -- Chris Lamb <email address hidden>  Mon, 01 Aug 2016 16:08:44 -0400

Available diffs

Superseded in yakkety-release on 2016-08-02
Deleted in yakkety-proposed on 2016-08-03 (Reason: moved to release)
gunicorn (19.6.0-1) unstable; urgency=medium

  * New upstream release.

 -- Chris Lamb <email address hidden>  Tue, 31 May 2016 17:25:00 +0100

Available diffs

Superseded in yakkety-release on 2016-06-01
Deleted in yakkety-proposed on 2016-06-02 (Reason: moved to release)
gunicorn (19.5.0-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 3.9.8.
  * Use https Github URL in Vcs-Git.

 -- Chris Lamb <email address hidden>  Thu, 19 May 2016 15:43:43 +0100
Superseded in yakkety-release on 2016-05-20
Published in xenial-release on 2016-04-11
Superseded in xenial-release on 2016-04-11
Deleted in xenial-proposed (Reason: moved to release)
gunicorn (19.4.5-1ubuntu1) xenial; urgency=medium

  * Merge with Debian; remaining changes:
    - Suggest libjs-jquery-flot instead of recommending it, package in universe

Superseded in xenial-release on 2016-02-17
Deleted in xenial-proposed on 2016-02-18 (Reason: moved to release)
gunicorn (19.4.1-1ubuntu1) xenial; urgency=medium

  * Merge with Debian; remaining changes:
    - Suggest libjs-jquery-flot instead of recommending it, package in universe.

Available diffs

Superseded in xenial-release on 2016-01-07
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
gunicorn (19.0-8ubuntu1) wily; urgency=medium

  * Merge with Debian; no remaining changes.
  * Suggest libjs-jquery-flot instead of recommending it, package in universe.

Available diffs

Superseded in wily-release on 2015-09-15
Deleted in wily-proposed on 2015-09-16 (Reason: moved to release)
gunicorn (19.0-6ubuntu2) wily; urgency=medium

  * Hm, somehow tox is installable in sbuild locally but not launchpad.
    However, tox is not used to run test-suites at all...

 -- Dimitri John Ledkov <email address hidden>  Sun, 16 Aug 2015 01:46:16 +0100
Superseded in wily-proposed on 2015-08-16
gunicorn (19.0-6ubuntu1) wily; urgency=medium

  * Switch to tox build-dep from python-tox.

 -- Dimitri John Ledkov <email address hidden>  Sun, 16 Aug 2015 01:21:31 +0100

Available diffs

Superseded in wily-proposed on 2015-08-16
gunicorn (19.0-6) unstable; urgency=medium

  * Correct B+R version number to 19.0-3 & add B+R to python-gunicorn. Thanks
    to Andreas Beckmann (anbe). (Closes: #790518)

 -- Chris Lamb <email address hidden>  Wed, 01 Jul 2015 18:06:45 +0100

Available diffs

Superseded in wily-proposed on 2015-07-01
gunicorn (19.0-5) unstable; urgency=medium

  * Add Replaces and Breaks to ensure upgrade path from testing.
    (Closes: #790518)

 -- Chris Lamb <email address hidden>  Tue, 30 Jun 2015 11:37:24 +0100

Available diffs

Superseded in wily-proposed on 2015-06-30
gunicorn (19.0-4) unstable; urgency=medium

  * Add entry for docs/sitemap_gen.py in debian/copyright.
    (Closes: #790314)
  * Use system jQuery libraries to appease Lintian's
    privacy-breach-may-use-debian-package.

 -- Chris Lamb <email address hidden>  Sun, 28 Jun 2015 00:34:01 +0100
Superseded in wily-release on 2015-08-17
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
gunicorn (19.0-2) unstable; urgency=low


  * Add provides: http-wsgi. Thanks to collinanderson via
    <https://github.com/lamby/pkg-gunicorn/issues/17>.
  * Install logrotate script. THanks to Collin Anderson <email address hidden>
    (Closes: #759279).
  * Remove /var/log/gunicorn when purging package. (Closes: #769333)

 -- Chris Lamb <email address hidden>  Sun, 16 Nov 2014 21:16:00 +0000

Available diffs

Superseded in vivid-release on 2014-11-17
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
gunicorn (19.0-1) unstable; urgency=low


  * New upstream release.
    - Update 0001-drop-supplemental-groups.patch.
  * Bump Standards-Version to 3.9.5.
  * Remove gaoihttp.py prior to building as it's Python 3 only.

 -- Chris Lamb <email address hidden>  Sat, 05 Jul 2014 17:09:19 +0100

Available diffs

Superseded in utopic-release on 2014-07-05
Deleted in utopic-proposed on 2014-07-07 (Reason: moved to release)
gunicorn (18.0-3) unstable; urgency=low


  * Set permissions on /var/log/gunicorn so that workers (not just the master
    running as root) can write to logfiles.

 -- Chris Lamb <email address hidden>  Fri, 11 Apr 2014 16:12:46 +0100
Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2014-02-23
Deleted in trusty-proposed (Reason: moved to release)
gunicorn (17.5-2build1) trusty; urgency=medium

  * Rebuild to drop files installed into /usr/share/pyshared.
 -- Matthias Klose <email address hidden>   Sun, 23 Feb 2014 13:47:48 +0000

Available diffs

Superseded in trusty-release on 2014-02-23
Obsolete in saucy-release on 2015-04-24
Superseded in saucy-release on 2013-09-25
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
gunicorn (17.5-2) unstable; urgency=low


  * Ignore automatic backup files (eg. "filename~") in /etc/gunicorn.d. Thanks
    to Gael Le Mignot <email address hidden>. (Closes: #715032)

 -- Chris Lamb <email address hidden>  Thu, 11 Jul 2013 20:05:04 +0100

Available diffs

Superseded in saucy-release on 2013-07-11
Deleted in saucy-proposed on 2013-07-13 (Reason: moved to release)
gunicorn (17.5-1) unstable; urgency=low


  * New upstream release.
  * Refresh and alter structure of 0001-drop-supplemental-groups.patch. Thanks
    to Randall Leeds.

 -- Chris Lamb <email address hidden>  Thu, 04 Jul 2013 17:28:14 +0100

Available diffs

Superseded in saucy-release on 2013-07-04
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
gunicorn (0.15.0-1) unstable; urgency=low


  * New upstream release.

 -- Chris Lamb <email address hidden>  Wed, 31 Oct 2012 19:44:54 +0000
Superseded in raring-release on 2012-11-01
Obsolete in quantal-release on 2015-04-24
gunicorn (0.14.5-3ubuntu1) quantal; urgency=low

  * revert undocumented broken dh_python2 conversion

Superseded in quantal-release on 2012-10-11
gunicorn (0.14.5-2) unstable; urgency=low


  * Pass through any initscript options to gunicorn-debian. Thanks to Piet
    Delport <email address hidden>. (Closes: #684299)
  * Drop unsupported 'status' argument. Thanks to Piet Delport
    <email address hidden>.

 -- Chris Lamb <email address hidden>  Wed, 08 Aug 2012 13:03:26 -0700

Available diffs

Superseded in quantal-release on 2012-09-16
gunicorn (0.14.5-1) unstable; urgency=low


  * New upstream release.

 -- Chris Lamb <email address hidden>  Mon, 02 Jul 2012 10:49:20 +0100

Available diffs

Superseded in quantal-release on 2012-07-03
gunicorn (0.14.3-1) unstable; urgency=low


  * New upstream release.
  * Don't use the upstream Makefile for building as it uses virtualenv and
    starts downloading things.
  * Bump Standards-Version to 3.9.3.

 -- Chris Lamb <email address hidden>  Mon, 21 May 2012 22:04:58 +0100

Available diffs

Superseded in quantal-release on 2012-05-24
gunicorn (0.14.2-1) unstable; urgency=low


  * New upstream version.
  * Add support for "restart" argument to gunicorn-debian.

 -- Chris Lamb <email address hidden>  Tue, 17 Apr 2012 12:07:36 +0100

Available diffs

Superseded in quantal-release on 2012-04-30
Published in precise-release on 2011-11-27
gunicorn (0.13.4-1) unstable; urgency=low

  * New upstream version.
  * Bump retry time and make it configurable. This is required so that we don't
    attempt to (re)start gunicorn when the previous instances are still running
    as the port would still be in use and would then completely fail to start.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  27 Nov 2011 16:12:15 +0000

Available diffs

Superseded in precise-release on 2011-11-27
gunicorn (0.13.1-1) unstable; urgency=low

  * New upstream release.
  * Bump Standards-Version to 3.9.2.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 Oct 2011 10:57:04 +0000

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
gunicorn (0.12.2-2) unstable; urgency=low

  * Source /etc/default/gunicorn so CONF_DIR (etc.) can be overridden.
    (via https://github.com/lamby/pkg-gunicorn/issues/8). Thanks to cbay for
    the patch.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  27 May 2011 07:44:25 +0000

Available diffs

Superseded in oneiric-release on 2011-05-27
gunicorn (0.12.2-1) unstable; urgency=low

  * New upstream release.
  * Update Python path under all Python versions, not just 2.6.
    (via https://github.com/lamby/pkg-gunicorn/issues/6)
  * Don't require configuration files to define a CONFIG dictionary.
    Thanks to cbay for the patch.
    (via https://github.com/lamby/pkg-gunicorn/issues/7)

Available diffs

Superseded in oneiric-release on 2011-05-20
gunicorn (0.12.1-2) unstable; urgency=low

  * Add option to specify the Python interpreter to use.
    (via https://github.com/lamby/pkg-gunicorn/issues/1)
  * Ignore files that begin with "_" so that we can avoid duplicated code.
    (via https://github.com/lamby/pkg-gunicorn/issues/2)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  09 May 2011 11:52:10 +0000

Available diffs

Superseded in oneiric-release on 2011-05-09
gunicorn (0.12.1-1) unstable; urgency=low

  * New upstream release.
  * Add Python 2.5 support for /etc/gunicorn.d.

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
gunicorn (0.11.2-1) unstable; urgency=low

  * New upstream release.
  * Bump Standards-Version to 3.9.1.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  02 Nov 2010 15:07:13 +0000

Available diffs

Superseded in natty-release on 2010-11-02
Obsolete in maverick-release on 2013-03-05
gunicorn (0.10.0-1) unstable; urgency=low

  * New upstream release.
  * Add python-setproctitle to Suggests. Thanks to Örjan Persson
    <email address hidden>.
  * Bump Standards-Version to 3.9.0.
 -- Mikhail Turov <email address hidden>   Fri, 16 Jul 2010 10:44:12 +0100

Available diffs

Superseded in maverick-release on 2010-07-31
gunicorn (0.9.1-2) unstable; urgency=low

  * Add python-setuptools to binary Depends.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  20 Jun 2010 03:01:18 +0100

Available diffs

Superseded in maverick-release on 2010-06-20
gunicorn (0.9.1-1) unstable; urgency=low

  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  28 May 2010 11:22:56 +0100

Available diffs

Superseded in maverick-release on 2010-05-28
gunicorn (0.8.0-3) unstable; urgency=low

  * Re-enable gunicorn_paster entry point.

146 of 46 results