gutenprint drivers installed but not seen

Bug #30178 reported by Akkana Peck on 2006-01-31
4
Affects Status Importance Assigned to Milestone
gutenprint (Ubuntu)
Medium
Matthias Klose

Bug Description

Dapper Flight 3: I go through the CUPS admin web pages to add my printer, but the list of printer types available is very short and is all stuff like generic dot-matrix, generic postscript laser printer, etc. There are no specific printers shown in the list.

cupsys-driver-gutenprint is installed and I also tried installing foomatic-db-gutenprint, which didn't change the list. /usr/share/cups/model/gutenprint/5.0/en is full of gutenprint drivers, including the one I need, stp-escp2-c86.5.0.ppd.gz. I tried uncompressing but it didn't help; I tried moving it up a few levels into /usr/share/cups/model, but that didn't help either (restarting cupsys each time).

The actual PPD file seems fine: if I uncompress it and specify the full path to /usr/share/cups/model/gutenprint/5.0/en/stp-escp2-c86.5.0.ppd when configuring the printer, it offers lots of extra color options and seems to print correctly.

Matt Zimmerman (mdz) on 2006-04-03
Changed in gutenprint:
assignee: nobody → doko
Matthias Klose (doko) wrote :

Is this on the live CD, or an installation from an install CD?

Changed in gutenprint:
status: Unconfirmed → Needs Info
Akkana Peck (akkzilla) wrote :

This was an installation from an install CD.

David Goodwin (david-codepoets) wrote :

Similar problem observed with Dapper as of 2006/04/11 (all updates applied).

The driver for my printer (Epson C46) is present on the system, in the /usr/share/cups/model/gutenprint/5.0/en/ directory, but isn't loaded into the gnome-cups-manager -> add printer -> driver listing.

gunzip'ing the .ppd.gz file, and moving it to e.g. /usr/share/cups/model/foomatic-ppds/cups-included appears to make it work again.

As far as I'm aware I have all gutenprint and cups packages installed.

Please fix it :)

David Goodwin (david-codepoets) wrote :

I should add, that if go via the gimp -> print etc then I see the driver without a problem. It just seems to be CUPS / gnome-cups-manager with problems.

Bruno Santos (bsantos) wrote :

It seems the 10/04 update messed something... Printing broke on my system too...

Matthias Klose (doko) wrote :

should be fixed with today's upgrade (including cupsys 1.1.99.b1.r4929-0ubuntu8)

Changed in gutenprint:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers