two hald-addon-storage processes per pooled device

Bug #58935 reported by didier on 2006-09-04
28
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Low
Martin Pitt
Dapper
Medium
Martin Pitt

Bug Description

Hi

because
  <device>
    <match key="storage.media_check_enabled" bool="true">
      <append key="info.addons" type="strlist">hald-addon-storage</append>
    </match>
  </device>

is defined in
/usr/share/hal/fdi/policy/10osvendor/10-storage-policy.fdi

and in
20-storage-methods.fdi

Didier

Martin Pitt (pitti) wrote :

Easy fix for edgy, thanks!

Changed in hal:
assignee: nobody → pitti
status: Unconfirmed → In Progress
importance: Untriaged → Low
Martin Pitt (pitti) on 2006-09-12
Changed in hal:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

 hal (0.5.7.1-0ubuntu10) edgy; urgency=low
 .
   * Add debian/patches/00upstream-01-music-players-fdi.patch: Update
     10-usb-music-players.fdi from GIT head to support many more music players
     (this supersedes the current 17-mp3-player-fdi.patch). Closes: LP#59022
   * debian/patches/17-mp3-player-fdi.patch: Add information for the Philips
     GoGear SA1330, thanks to Juri Pakaste! Closes: LP#58077
   * debian/10-storage-policy.fdi: Remove enabling of hal-addon-storage, since
     20-storage-methods.fdi already does that. We don't need two h-a-s
     processes for each drive. Closes: LP#58935
   * debian/hald.8: Remove --retain-privileges documentation, this option does
     not exist any more. Closes: LP#44770
   * Add debian/patches/00upstream-02-mWh-conversion.patch:
     - Properly convert mAh to mWh rather than uWh.
     - Taken from GIT head:
       http://gitweb.freedesktop.org/?p=hal.git;a=commit;h=b30d1320614564d226018b8a491ee4f70567db64
     - Closes: LP#53719
   * Add debian/patches/00upstream-03-fs-on-partitioned-devices.patch:
     - Do not probe for a file system on a device which already has partitions
       created. This fixes empty bogus mounts for somewhat unclean partition
       tables.
     - Taken from GIT head:
       http://gitweb.freedesktop.org/?p=hal.git;a=commit;h=2c98ffc8dac7ee161042355790256d836e4028f9
     - Closes: LP#19390
   * Add debian/patches/19_dont_overwrite_formfactor.patch: Do not overwrite
     the form factor as set by PMU/ACPI/DMI with an 'unknown' value from
     computer_probing_pcbios_helper_done(). Thanks to VETSEL Patrice for this
     patch! Closes: LP#59342

Changed in hal:
status: Fix Committed → Fix Released
Rob Frohne (frohro) wrote :

Can this be fixed in Dapper? I edited out the following lines:

<match key="storage.media_check_enabled" bool="true">
      <append key="info.addons" type="strlist">hald-addon-storage</append>
    </match>

in /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi

and killed the second process, and now I am able to suspend my Dell D600 laptop repeatedly, whereas before, I could only suspend it once and then the hald-addon-storage processes became uninterruptable sleep processes, which prevented suspend (or hibernate). I have an up to date Dapper release as of 9/23/2006, and this fix was not there yet.

Rob Frohne (frohro) wrote :

This also fixes a problem I was having with hotswapping the CDRW/DVD on my Dell D600 laptop in Dapper.

Martin Pitt (pitti) wrote :

Adding Dapper task. Seems worth fixing since it causes actual hardware faults instead of just an useless process.

Changed in hal:
assignee: nobody → pitti
importance: Untriaged → Medium
status: Unconfirmed → In Progress
Rob Frohne (frohro) wrote :

See my comments on bug 58935. The problem with suspend and hibernate was solved by removing the cdrom module before suspending or hibernating. See that post for the details.

Rob

Martin Pitt (pitti) wrote :

This is the dapper-proposed debdiff.

Martin Pitt (pitti) wrote :

Accepted into dapper-proposed.

Verification steps for SRU team (requires that at least one CD-ROM drive is installed (the virtual one on VMWare does fine, BTW):
 * With the current hal, "ps aux|grep hald-addon-storage" will give two processes per CD-ROM drive.
 * Update to the new hal and reboot.
 * "ps aux|grep hald-addon-storage" will only give one process per CD-ROM drive.
 * Inserting a CD will automount it and open nautilus.

If you have a laptop which actually exposes that problem, please test the packages in dapper-proposed and report whether the updated version fixes the suspend problem for you.

Thank you!

Changed in hal:
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Verification was completed successfully -

With hal version 0.5.7-1ubuntu18.2 I observed two hald-addon-storage processes per CD-ROM drive.
With hal version 0.5.7-1ubuntu18.3 I observed one hald-addon-storage proccess per CD-ROM drive.
I was also able to insert a CD and have it automounted and Nautilus open with the new version of hal.

Martin Pitt (pitti) wrote :

Thanks, Brian. Copied to dapper-updates.

Changed in hal:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers