Change log for hplip package in Ubuntu

175 of 263 results
Published in wily-release on 2015-07-30
Deleted in wily-proposed (Reason: moved to release)
hplip (3.15.6-0ubuntu5) wily; urgency=medium

  * SECURITY UPDATE: insecure use of short gpg key id
    - debian/patches/CVE-2015-0839.patch: use long key id in
      base/validation.py.
    - CVE-2015-0839

 -- Marc Deslauriers <email address hidden>  Thu, 30 Jul 2015 12:33:57 -0400

Available diffs

Published in precise-updates on 2015-07-30
Published in precise-security on 2015-07-30
hplip (3.12.2-1ubuntu3.5) precise-security; urgency=medium

  * SECURITY UPDATE: insecure use of short gpg key id
    - debian/patches/CVE-2015-0839.dpatch: use long key id in
      installer/core_install.py.
    - CVE-2015-0839

 -- Marc Deslauriers <email address hidden>  Thu, 30 Jul 2015 09:01:29 -0400
Published in trusty-updates on 2015-07-30
Published in trusty-security on 2015-07-30
hplip (3.14.3-0ubuntu3.4) trusty-security; urgency=medium

  * SECURITY UPDATE: insecure use of short gpg key id
    - debian/patches/CVE-2015-0839.patch: use long key id in
      base/validation.py, base/utils.py, installer/pluginhandler.py.
    - CVE-2015-0839
  * This package does _not_ contain the changes from 3.14.3-0ubuntu3.3 in
    trusty-proposed.

 -- Marc Deslauriers <email address hidden>  Thu, 30 Jul 2015 08:30:50 -0400
Published in vivid-updates on 2015-07-30
Published in vivid-security on 2015-07-30
hplip (3.15.2-0ubuntu4.2) vivid-security; urgency=medium

  * SECURITY UPDATE: insecure use of short gpg key id
    - debian/patches/CVE-2015-0839.patch: use long key id in
      base/validation.py.
    - CVE-2015-0839

 -- Marc Deslauriers <email address hidden>  Thu, 30 Jul 2015 08:23:47 -0400
Superseded in wily-release on 2015-07-30
Deleted in wily-proposed on 2015-07-31 (Reason: moved to release)
hplip (3.15.6-0ubuntu4) wily; urgency=medium

  * Remove wrong build-dependency on python3-all-dev, as this package only
    builds for the current python version.

 -- Steve Langasek <email address hidden>  Fri, 24 Jul 2015 22:45:01 +0000

Available diffs

Superseded in wily-release on 2015-07-24
Deleted in wily-proposed on 2015-07-26 (Reason: moved to release)
hplip (3.15.6-0ubuntu3) wily; urgency=medium

  * No-change rebuild for python3.5 transition

 -- Steve Langasek <email address hidden>  Fri, 24 Jul 2015 18:25:27 +0000

Available diffs

Superseded in wily-release on 2015-07-24
Deleted in wily-proposed on 2015-07-26 (Reason: moved to release)
hplip (3.15.6-0ubuntu2) wily; urgency=medium

  * No-change rebuild for python3.5 transition

 -- Steve Langasek <email address hidden>  Wed, 22 Jul 2015 17:12:22 +0000

Available diffs

Published in utopic-proposed on 2015-06-24
hplip (3.14.6-1ubuntu1.1) utopic; urgency=medium

  * Backport patch from vivid to allow non-JPEG scanning on the HP DeskJet 3520
    All-in-One and similar devices. Thanks to Lubos Dolezel for the patch.
    Refreshed patch against trusty package (LP: #1245578)

 -- Micah Gersten <email address hidden>  Mon, 22 Jun 2015 21:18:07 -0500
Deleted in trusty-proposed 8 hours ago (Reason: moved to -updates)
hplip (3.14.3-0ubuntu3.3) trusty; urgency=medium

  * Backport patch from vivid to allow non-JPEG scanning on the HP DeskJet 3520
    All-in-One and similar devices. Thanks to Lubos Dolezel for the patch.
    Refreshed patch against trusty package (LP: #1245578)

 -- Micah Gersten <email address hidden>  Mon, 22 Jun 2015 21:05:26 -0500
Superseded in wily-release on 2015-07-22
Deleted in wily-proposed on 2015-07-24 (Reason: moved to release)
hplip (3.15.6-0ubuntu1) wily; urgency=low

  * New upstream release
     - Added support for HP DeskJet 2130/2132/2546B/2546P/2546R/3630/3632
       All-in-One printer, HP OfficeJet 57444 e-All-in-One
     - Fixed: Error message is displayed while running "hp-diagnose_queues"
       in a terminal.
     - Fixed: UDEV rules wrongly match on monitor hub, wrong invocation of
       systemd unti, changes confi files in UDEV rules (LP: #1433557).
     - Fixed: hp-setup creates spurious cupsd process (LP: #1438456).
  * debian/patches/musb-c-do-not-crash-on-usb-failure.patch,
    debian/patches/pcardext-python3-workaround-upstream.patch,
    debian/patches/hp-plugin-download-fix.patch: Updated for new upstream
    code.

 -- Till Kamppeter <email address hidden>  Thu, 11 Jun 2015 19:08:00 -0300

Available diffs

Superseded in vivid-updates on 2015-07-30
Deleted in vivid-proposed on 2015-07-31 (Reason: moved to -updates)
hplip (3.15.2-0ubuntu4.1) vivid-proposed; urgency=low

  * debian/patches/hp-plugin-download-fix.patch: Fix download and installation
    of HP's proprietary plug-in in Python3 environments (LP: #1422004).

 -- Till Kamppeter <email address hidden>  Wed,  6 May 2015 16:50:00 -0300
Superseded in wily-release on 2015-06-12
Deleted in wily-proposed on 2015-06-13 (Reason: moved to release)
hplip (3.15.2-0ubuntu5) wily; urgency=low

  * debian/patches/hp-plugin-download-fix.patch: Fix download and installation
    of HP's proprietary plug-in in Python3 environments (LP: #1422004).

 -- Till Kamppeter <email address hidden>  Wed,  6 May 2015 16:50:00 -0300
Superseded in wily-release on 2015-05-06
Published in vivid-release on 2015-03-17
Deleted in vivid-proposed (Reason: moved to release)
hplip (3.15.2-0ubuntu4) vivid; urgency=low

  * debian/rules: Remove explicit call of /usr/bin/python when calling the
    /usr/bin/hp-config_usb_printer script so that the shebang does not get
    overridden (LP: #1425812).
 -- Till Kamppeter <email address hidden>   Tue, 17 Mar 2015 16:04:00 +0100

Available diffs

Superseded in vivid-release on 2015-03-17
Deleted in vivid-proposed on 2015-03-19 (Reason: moved to release)
hplip (3.15.2-0ubuntu3) vivid; urgency=low

  * debian/patches/hpscan-deskjet-3520-aio-allow-non-jpeg-scanning.patch:
    Allow non-JPEG scanning on the HP DeskJet 3520 All-in-One and similar
    devices. Thanks to Lubos Dolezel for the patch (LP: #1245578).
 -- Till Kamppeter <email address hidden>   Mon,  2 Mar 2015 17:48:00 +0100
Superseded in vivid-release on 2015-03-02
Deleted in vivid-proposed on 2015-03-04 (Reason: moved to release)
hplip (3.15.2-0ubuntu2) vivid; urgency=low

  * debian/patches/pcardext-python3-workaround-upstream.patch: Workaround
    patch for missing Python3 transition of the old (pre-USB-storage) photo
    memory card support (pcardext) as this part builds in Python3 environments
    but with pointer-related warnings which are fatal errors for Ubuntu's build
    servers. The patch silences the warnings but the memory card support is
    dropped in Python3 environments. This patch is supplied by the HPLIP
    upstream developers and will be replaced by a more proper solution in the
    next upstream release of HPLIP (see LP: #1275353).
 -- Till Kamppeter <email address hidden>   Wed,  6 Feb 2015 11:18:00 -0200
Superseded in vivid-proposed on 2015-02-06
hplip (3.15.2-0ubuntu1) vivid; urgency=low

  * New upstream release
    - Python3 support for HPLIP
    - Doesn't build against libjpeg-turbo 1.3.90 (LP: #1388126)
    - hpcups crashes if DEVICE_URI not set in environment (LP: #1395676)
    - Incorrect call to hpmudext.device_open (LP: #1388007)
    - plugin download fails if python links to python3 (LP: #1187055)
    - Incorrect IEEE 1284 Device IDs for many models (LP: #802999)
  * debian/patches/85_rebuild_python_ui.dpatch: Manually updated to apply to new
    upstream source code.
  * debian/patches/hp_photosmart_pro_b9100_support.dpatch,
    debian/patches/simple-scan-as-default.dpatch,
    debian/patches/hpfax-bug-function-used-before-importing-log.dpatch,
    debian/patches/hp-systray-make-menu-title-visible-in-sni-qt-indicator.dpatch,
    debian/patches/hp-systray-make-menu-appear-in-sni-qt-indicator-with-kde.dpatch,
    debian/patches/hpaio-option-duplex.diff,
    debian/patches/musb-c-do-not-crash-on-usb-failure.patch,
    debian/patches/process-events-for-systray.patch: Refreshed with quilt.
  * debian/rules: Force Python3 build using PYTHON=python3 ./configure option
  * debian/rules: Use py3versions to get system's Python3 interpreter version
  * debian/rules: Use relative symlink for /usr/sbin/hpssd, so that shebang
    correction works.
  * debian/rules: Make sure that the Python interpreter paths in all executables
    use python3.
  * debian/rules: Use dh_python3 instead of dh_python2.
  * debian/control: Replaced all Python-related dependencies by their
    Python3 equivalent.
 -- Till Kamppeter <email address hidden>   Wed,  4 Feb 2015 21:18:00 -0200

Available diffs

Superseded in vivid-release on 2015-02-06
Published in utopic-release on 2014-07-31
Deleted in utopic-proposed (Reason: moved to release)
hplip (3.14.6-1ubuntu1) utopic; urgency=medium

  * Add process-events-for-systray.patch to enable sni-qt compatiblity to
    allow hp-systray to continue working in Plasma 5.x workspaces.
 -- Harald Sitter <email address hidden>   Tue, 29 Jul 2014 22:51:04 +0200
Superseded in utopic-release on 2014-07-31
Deleted in utopic-proposed on 2014-08-02 (Reason: moved to release)
hplip (3.14.6-1) unstable; urgency=low


  * New upstream release
    - Fixed Device Communication Error on launching HP Device Manager
    - Unable to add/remove file in 'hp-sendfax' wizard
    - Fax cover page does not get changed after changing recipient second time
    - Improved scan performance for 'hp-scan' utility
    - Fixes "hplip is outdated in jessie : please upgrade" (Closes: #748132)

 -- Mark Purcell <email address hidden>  Sun, 15 Jun 2014 16:42:46 +1000
Superseded in trusty-updates on 2015-07-30
Deleted in trusty-proposed on 2015-07-31 (Reason: moved to -updates)
hplip (3.14.3-0ubuntu3.2) trusty-proposed; urgency=low

  * debian/rules: Corrected copy-and-paste error in previous release which
    deactivated hpcups printer support completely (LP: #1311697).
 -- Till Kamppeter <email address hidden>   Wed,  7 May 2014 12:40:00 +0200
Superseded in utopic-release on 2014-06-19
Deleted in utopic-proposed on 2014-06-21 (Reason: moved to release)
hplip (3.14.3-0ubuntu5) utopic; urgency=low

  * debian/rules: Corrected copy-and-paste error in previous release which
    deactivated hpcups printer support completely (LP: #1315864, LP: #1311697).
 -- Till Kamppeter <email address hidden>   Wed,  7 May 2014 12:40:00 +0200

Available diffs

Superseded in trusty-proposed on 2014-05-13
hplip (3.14.3-0ubuntu3.1) trusty-proposed; urgency=low

  * debian/rules: Remove hpcups support for the HP Officejet Pro K550 as it is
    known to not work. This way hpijs (which works) will be used (LP: #981473,
    LP: #1311697).
 -- Till Kamppeter <email address hidden>   Tue, 29 Apr 2014 12:06:00 +0200
Superseded in utopic-release on 2014-05-07
Deleted in utopic-proposed on 2014-05-08 (Reason: moved to release)
hplip (3.14.3-0ubuntu4) utopic; urgency=low

  * debian/rules: Remove hpcups support for the HP Officejet Pro K550 as it is
    known to not work. This way hpijs (which works) will be used (LP: #981473,
    LP: #1311697).
 -- Till Kamppeter <email address hidden>   Tue, 29 Apr 2014 12:06:00 +0200

Available diffs

Superseded in utopic-release on 2014-04-29
Published in trusty-release on 2014-04-07
Deleted in trusty-proposed (Reason: moved to release)
hplip (3.14.3-0ubuntu3) trusty; urgency=low

  * debian/patches/musb-c-do-not-crash-on-usb-failure.patch: Make sure that
    the HPLIP components which access the USB (especially the CUPS backends
    "hp" and "hpfax") do not crash when libusb fails to connect to the USB,
    for example on machines without USB or with the USB kernel modules not
    loaded (LP: #1302437).
 -- Till Kamppeter <email address hidden>   Fri,  4 Apr 2014 17:00:00 +0200
Superseded in trusty-release on 2014-04-07
Deleted in trusty-proposed on 2014-04-08 (Reason: moved to release)
hplip (3.14.3-0ubuntu2) trusty; urgency=low

  * debian/local/HP-LaserJet_4000-PostScript-PPD.patch, debian/rules: Patch
    PPD file for the HP LaserJet 4000 to use the same JobPatchFile as the
    LaserJet 4050. It seems that the 4000 has the same PS interpreter bug to
    work around. Note that it is not possible to use the standard mechanisms
    for patches as HP ships all PPDs compressed (Closed: #742766).
 -- Till Kamppeter <email address hidden>   Thu, 27 Mar 2014 17:20:00 +0100
Superseded in trusty-release on 2014-03-27
Deleted in trusty-proposed on 2014-03-29 (Reason: moved to release)
hplip (3.14.3-0ubuntu1) trusty; urgency=low

  * New upstream release
    - Added support for: HP Deskjet Ink Advantage 4640/4645/4646/4648
      e-All-in-One Printer, HP LaserJet Pro MFP M125/M126/M127 series.
    - printer name changes when power cycled (LP: #1273905).
    - hp-config_usb_printer is trying to configure HP keyboard and mouse
      (LP: #1266704).
    - "HP Device Manager" deletes other queues (LP: #1253432).
    - hpcups filter crash fix (LP: #1250806).
    - Error with 'hp-setup' (LP: #1273043).
    - Should run hp-firmware from udev separately (LP: #1255033).
    - Do not put static printer-independent strings like "Automatically setup
      by HPLIP" into the description field of a CUPS queue, remote clients use
      the description to identify network printers (LP: #1266011).
    - Fixed align functionality issue with HP OfficeJet 6100
    - Systray notification does not pop-up after configuring the device using
      'hp-setup' command
    - Unable to configure second fax queue in interactive mode
    - Fixed missing 'No 6 3/4 Envelope' media size for HP OfficeJet 7619 Series
    - Printer name does not change when navigate back and forward to change
      the printer queue
 -- Till Kamppeter <email address hidden>   Tue, 11 Mar 2014 22:36:00 +0100
Published in precise-backports on 2014-01-22
hplip (3.13.9-1ubuntu0.1~ubuntu12.04.1) precise-backports; urgency=low

  * No-change backport to precise

Superseded in precise-updates on 2015-07-30
Superseded in precise-security on 2015-07-30
hplip (3.12.2-1ubuntu3.4) precise-security; urgency=medium

  * SECURITY UPDATE: insecure temp file use in pkit.py
    - debian/patches/CVE-2013-6402.dpatch: remove logging to temp file in
      base/pkit.py.
    - CVE-2013-6402
 -- Marc Deslauriers <email address hidden>   Mon, 20 Jan 2014 10:59:46 -0500
Obsolete in quantal-updates on 2015-04-24
Obsolete in quantal-security on 2015-04-24
hplip (3.12.6-3ubuntu4.3) quantal-security; urgency=medium

  * SECURITY UPDATE: insecure temp file use in pkit.py
    - debian/patches/CVE-2013-6402.patch: remove logging to temp file in
      base/pkit.py.
    - CVE-2013-6402
  * SECURITY UPDATE: insecure upgrade feature
    - debian/non-shipped-files.txt, debian/hplip.install: don't ship
      hp-upgrade and upgrade.py.
    - CVE-2013-6427
 -- Marc Deslauriers <email address hidden>   Mon, 20 Jan 2014 10:56:11 -0500
Published in lucid-updates on 2014-01-21
Published in lucid-security on 2014-01-21
hplip (3.10.2-2ubuntu2.5) lucid-security; urgency=medium

  * SECURITY UPDATE: insecure temp file use in pkit.py
    - debian/patches/CVE-2013-6402.dpatch: remove logging to temp file in
      base/pkit.py.
    - CVE-2013-6402
 -- Marc Deslauriers <email address hidden>   Mon, 20 Jan 2014 11:03:10 -0500
Obsolete in saucy-updates on 2015-04-24
Obsolete in saucy-security on 2015-04-24
hplip (3.13.9-1ubuntu0.1) saucy-security; urgency=medium

  * SECURITY UPDATE: insecure temp file use in pkit.py
    - debian/patches/CVE-2013-6402.patch: remove logging to temp file in
      base/pkit.py.
    - CVE-2013-6402
  * SECURITY UPDATE: insecure upgrade feature
    - debian/non-shipped-files.txt, debian/hplip.install: don't ship
      hp-upgrade and upgrade.py.
    - CVE-2013-6427
 -- Marc Deslauriers <email address hidden>   Mon, 20 Jan 2014 10:51:43 -0500
Superseded in trusty-release on 2014-03-11
Deleted in trusty-proposed on 2014-03-13 (Reason: moved to release)
hplip (3.14.1-1) unstable; urgency=low


  * New upstream release 
    - CVE-2013-6427: hplip: insecure auto update feature
    - CVE-2013-6402: hplip: insecure temporary file handling in pkit.py

  [ Till Kamppeter ]
  * debian/control: Changed Depends/Recommends on foomatic-filters to
    "cups-filters (>= 1.0.42) | foomatic-filters" as foomatic-rip has
    moved to cups-filters from version 1.0.42 on (Closes: #734140).

  [ Mark Purcell ]
  * Ack NMU - thanks ~carnil
  * Drop CVE-2013-6402.patch - addressed upstream

 -- Mark Purcell <email address hidden>  Sun, 19 Jan 2014 13:56:10 +1100

Available diffs

Superseded in trusty-release on 2014-01-19
Deleted in trusty-proposed on 2014-01-20 (Reason: moved to release)
hplip (3.13.11-2.1) unstable; urgency=medium


  * Non-maintainer upload.
  * Add CVE-2013-6402.patch patch.
    CVE-2013-6402: Fix insecure temporary files handling in pkit.py.
    (Closes: #725876)
  * Add missing dh_bugfiles invocation in binary-indep target

 -- Salvatore Bonaccorso <email address hidden>  Sun, 12 Jan 2014 10:59:12 +0100

Available diffs

Superseded in trusty-release on 2014-01-14
Deleted in trusty-proposed on 2014-01-16 (Reason: moved to release)
hplip (3.13.11-2) unstable; urgency=medium


  * Urgency medium for CVE fix
  * Sync with ubuntu - thks ~marc.deslauriers
    - Fixes "CVE-2013-6427: insecure (undocumented) auto update feature"
    (Closes: #731480)

 -- Mark Purcell <email address hidden>  Sun, 15 Dec 2013 18:13:44 +1100
Superseded in trusty-release on 2013-12-19
Deleted in trusty-proposed on 2013-12-21 (Reason: moved to release)
hplip (3.13.11-1ubuntu1) trusty; urgency=low

  * debian/non-shipped-files.txt, debian/hplip.install: don't ship
    hp-upgrade and upgrade.py, as we want to use proper packaging, and want
    to prevent security issues.
    - CVE-2013-6427
 -- Marc Deslauriers <email address hidden>   Thu, 12 Dec 2013 14:42:33 -0500
Superseded in trusty-release on 2013-12-12
Deleted in trusty-proposed on 2013-12-14 (Reason: moved to release)
hplip (3.13.11-1) unstable; urgency=low


  * New upstream release
    - Includes fix for CVE-2013-4325:Insecure Polkit use (Closes: #723716)
    - Drop debian/patches/CVE-2013-4325.patch
    - hp-mkuri no longer ships
  * Drop hp-mkuri-take-into-account-already-installed-plugin-also-for-
    exit-value.dpatch & ubuntu-hp-mkuri-notification-text.dpatch
  * quilt refresh
  * hplip-doc.install -> hplip-doc.docs

 -- Mark Purcell <email address hidden>  Wed, 11 Dec 2013 06:12:48 +1100

Available diffs

Superseded in precise-backports on 2014-01-22
hplip (3.13.9-1~ubuntu12.04.1) precise-backports; urgency=low

  * No-change backport to precise (LP: #1241246)

Superseded in trusty-release on 2013-12-11
Deleted in trusty-proposed on 2013-12-13 (Reason: moved to release)
hplip (3.13.9-2) unstable; urgency=low


  * Build-Depends: libusb2-dev [kfreebsd-any] - Thks Petr
    - Fixes "no longer buildable on kfreebsd-*" (Closes: #725616)
  * Update X-Python-Version: >= 2.7.5 
    - Fixes "hplip-data depends on python:any (>= 2.6.6-7~)" (Closes: #724705)

 -- Mark Purcell <email address hidden>  Sat, 12 Oct 2013 22:31:35 +1100

Available diffs

Superseded in lucid-updates on 2014-01-21
Superseded in lucid-security on 2014-01-21
hplip (3.10.2-2ubuntu2.4) lucid-security; urgency=low

  * SECURITY UPDATE: arbitrary file overwrite via temp file vulnerability
    - debian/patches/CVE-2011-2722.dpatch: remove insecure code from
      prnt/hpijs/hpcupsfax.cpp.
    - CVE-2011-2722
  * SECURITY UPDATE: arbitrary file overwrite via temp file vulnerability
    - debian/patches/CVE-2013-0200.dpatch: use unpredictable temp file names
      in prnt/hpcups/HPCupsFilter.cpp, prnt/hpcups/SystemServices.cpp,
      prnt/hpijs/hpijs.cpp.
    - CVE-2013-0200
  * debian/patches/00patch-opts: remove deprecated U option so we can
    manipulate this package in saucy.
 -- Marc Deslauriers <email address hidden>   Fri, 27 Sep 2013 12:38:14 -0400
Superseded in precise-updates on 2014-01-21
Superseded in precise-security on 2014-01-21
hplip (3.12.2-1ubuntu3.3) precise-security; urgency=low

  * SECURITY UPDATE: arbitrary file overwrite via temp file vulnerability
    - debian/patches/CVE-2013-0200.dpatch: use unpredictable temp file names
      in prnt/hpcups/HPCupsFilter.cpp, prnt/hpcups/SystemServices.cpp,
      prnt/hpijs/hpijs.cpp, prnt/hpps/hppsfilter.c.
    - CVE-2013-0200
 -- Marc Deslauriers <email address hidden>   Fri, 27 Sep 2013 12:18:13 -0400
Superseded in quantal-updates on 2014-01-21
Superseded in quantal-security on 2014-01-21
hplip (3.12.6-3ubuntu4.2) quantal-security; urgency=low

  * SECURITY UPDATE: arbitrary file overwrite via temp file vulnerability
    - debian/patches/CVE-2013-0200.patch: use unpredictable temp file names
      in prnt/hpcups/HPCupsFilter.cpp, prnt/hpcups/SystemServices.cpp,
      prnt/hpijs/hpijs.cpp, prnt/hpps/hppsfilter.c.
    - CVE-2013-0200
 -- Marc Deslauriers <email address hidden>   Fri, 27 Sep 2013 11:52:29 -0400
Superseded in trusty-release on 2013-10-21
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
hplip (3.13.9-1) unstable; urgency=medium


  * New upstream release 
  * Fix CVE-2013-4325 hplip: Insecure calling of polkit
    - Apply Redhat patch (Closes: #723716)
    - Urgency medium
  * Fix "Rebuild against pyppd 1.0.1" patch from OdyX (Closes: #722695)

 -- Mark Purcell <email address hidden>  Sat, 21 Sep 2013 08:24:35 +1000
Superseded in saucy-release on 2013-09-23
Deleted in saucy-proposed on 2013-09-25 (Reason: moved to release)
hplip (3.13.9-0ubuntu2) saucy; urgency=low

  * SECURITY UPDATE: possible privilege escalation via policykit UID lookup
    race.
    - debian/patches/CVE-2013-4325.patch: pass system-bus-name as a subject
      instead of pid so policykit can get the information from the system
      bus in base/pkit.py.
    - CVE-2013-4325
 -- Marc Deslauriers <email address hidden>   Wed, 18 Sep 2013 12:41:31 -0400
Obsolete in raring-updates on 2015-04-24
Obsolete in raring-security on 2015-04-24
hplip (3.13.3-1ubuntu0.1) raring-security; urgency=low

  * SECURITY UPDATE: possible privilege escalation via policykit UID lookup
    race.
    - debian/patches/CVE-2013-4325.patch: pass system-bus-name as a subject
      instead of pid so policykit can get the information from the system
      bus in base/pkit.py.
    - CVE-2013-4325
 -- Marc Deslauriers <email address hidden>   Fri, 13 Sep 2013 11:35:06 -0400
Superseded in quantal-updates on 2013-09-30
Superseded in quantal-security on 2013-09-30
hplip (3.12.6-3ubuntu4.1) quantal-security; urgency=low

  * SECURITY UPDATE: possible privilege escalation via policykit UID lookup
    race.
    - debian/patches/CVE-2013-4325.patch: pass system-bus-name as a subject
      instead of pid so policykit can get the information from the system
      bus in base/pkit.py.
    - CVE-2013-4325
 -- Marc Deslauriers <email address hidden>   Fri, 13 Sep 2013 11:37:52 -0400
Superseded in precise-updates on 2013-09-30
Superseded in precise-security on 2013-09-30
hplip (3.12.2-1ubuntu3.2) precise-security; urgency=low

  * SECURITY UPDATE: possible privilege escalation via policykit UID lookup
    race.
    - debian/patches/CVE-2013-4325.dpatch: pass system-bus-name as a
      subject instead of pid so policykit can get the information from the
      system bus in base/pkit.py.
    - CVE-2013-4325
 -- Marc Deslauriers <email address hidden>   Fri, 13 Sep 2013 11:39:22 -0400
Superseded in lucid-updates on 2013-09-30
Superseded in lucid-security on 2013-09-30
hplip (3.10.2-2ubuntu2.3) lucid-security; urgency=low

  * SECURITY UPDATE: possible privilege escalation via policykit UID lookup
    race.
    - debian/patches/CVE-2013-4325.dpatch: pass system-bus-name as a
      subject instead of pid so policykit can get the information from the
      system bus in base/pkit.py.
    - CVE-2013-4325
 -- Marc Deslauriers <email address hidden>   Fri, 13 Sep 2013 11:43:30 -0400
Superseded in saucy-release on 2013-09-18
Deleted in saucy-proposed on 2013-09-20 (Reason: moved to release)
hplip (3.13.9-0ubuntu1) saucy; urgency=low

  [ Till Kamppeter ]
  * New upstream release
     o Bug fixes and added hardware support
     o Added support for: HP Designjet Z5400 44-in PostScript ePrinter,
       Deskjet Ink Advantage 1018 Printer, 1518/2540/2545/2546 All-in-One
       Printer, 4515/4518 e-All-in-One Printer, Envy 4504 e-All-in-One,
       LaserJet Pro MFP M435nw, Officejet 4630/4632/4635 e-All-in-One Printer,
       OfficeJet Pro 8600 Premium e-AiO N911n, Photosmart 5521 e-All-in-One
       Printer
     o HP OfficeJet G55 is not detecting through USB (LP: #1209339)
     o Collate broken under hplip-3.13.7 as hpps sends SET COPIES (LP: #1209352)
     o Fix for plugin (firmware) installation and test page in 'hp-setup -i'
  * debian/patches/10_shebang_fixes.dpatch,
    debian/patches/hp-setup-prompt-for-custom-PPD.dpatch,
    debian/patches/kbsd.dpatch,
    debian/patches/make-commafy-correctly-work-with-python-2.dpatch,
    debian/patches/black-stripes-on-pcl5c-printouts.dpatch: Removed, applied
    upstream.
  * debian/patches/hp_photosmart_pro_b9100_support.dpatch,
    debian/patches/hp-check_debian.dpatch
    debian/patches/hp-mkuri-take-into-account-already-installed-plugin-also-for-exit-value.dpatch,
    debian/patches/simple-scan-as-default.dpatch,
    debian/patches/add-lidil-two-cartridge-modes.dpatch,
    debian/patches/hp-systray-make-menu-title-visible-in-sni-qt-indicator.dpatch,
    debian/patches/hp-systray-make-menu-appear-in-sni-qt-indicator-with-kde.dpatch,
    debian/patches/hpaio-option-duplex.diff: Refreshed with quilt.
  * debian/patches/ubuntu-hp-mkuri-notification-text.dpatch: Manually adapted
    to the new source code.
  * debian/hplip.install, debian/rules: Removed hplipjs and hpcac filters, they
    are removed from HPLIP.
  * debian/hplip.dirs, debian/hplip.postinst, debian/hplip.postrm: Added
    /var/log/hp/tmp/ (775 root.lp), needed by hp-sendfax (LP: #1187132).
  * debian/printer-driver-postscript-hp.install: Some DesignJet PPDs do not
    have "ps" in their names and therefore did not get packaged.
  * debian/non-shipped-files.txt: Updated.
  * debian/rules: Remove the non-shipped files in the end of the install-stamp
    rule, as some of them get created after "make install" by this rule.
  * debian/rules: Do not create HAL .fdi file.
 -- Till Kamppeter <email address hidden>   Wed, 11 Sep 2013 21:36:00 +0200
Superseded in saucy-release on 2013-09-12
Deleted in saucy-proposed on 2013-09-13 (Reason: moved to release)
hplip (3.13.8-1) unstable; urgency=low


  * New Upstream Release 
  * Update Vcs: header
  * Fixup field "section" in package hpijs-ppds
  * Update libhpmud-dev Description: - duplicate-long-description
  * Update debian/copyright - fixes copyright-refers-to-symlink-license
  * Update Description: - fixes extended-description-is-probably-too-short

 -- Mark Purcell <email address hidden>  Sat, 17 Aug 2013 12:27:56 +1000
Superseded in saucy-release on 2013-09-05
Deleted in saucy-proposed on 2013-09-06 (Reason: moved to release)
hplip (3.13.8-0ubuntu1) saucy; urgency=low

  [ Till Kamppeter ]
  * New upstream release
     o Added support for: HP LaserJet Enterprise MFP M725/M725dn/M725dn/M725fw/
       M725z/M725z+, DesignJet T920/T1500 Postscript, Envy 4500/4502/5530/5535
       e-All-in-One, Deskjet 1010/1012, 1510/1512/1513/2540/2542 All-in-One,
       Deskjet Ink Advantage 1010/1015, 1510/1515/1516 All-in-One, 3540/3545/
       3546 e-All-in-One, Officejet Pro 3610/3620 Black and White e-All-in-One,
       Officejet 7610 Wide Format e-All-in-One
     o Added support for Avahi network printer browsing
     o Using SLP protocol by default to browse printer in hp-setup
     o Added 56-hpmud.rules and removed 56-hpmud_support, 86-hpmud_plugin,
       56-hpmud_add_printer, 55-hpmud and 40-hplip rules
     o Fixes:
        + LP: #233393  - Smart install disable popup is coming for HP pen drive
          and HP CD/DVD ROM
        + LP: #746814  - CVE-2010-4267 Remote Stack Overflow Vulnerability
        + LP: #1157701 - soapfax.py:139:setStationName:UnicodeEncodeError:
          'ascii' codec can't encode characters in position 0-3: ordinal not in
          range(128)
        + LP: #1163339 - hplip online documentation: manual tarball
          installation shows package dependancies which are out-of-date
        + LP: #1176470 - hp-setup fails with the message "ethernet cable is
          plugged in" - But it isn't
        + LP: #1179433 - cupsext/getPrinter leaks server connection on each call
        + LP: #1179454 - Cannot set filename when scanning with hp-scan from ADF
        + LP: #1186411 - Fix for firmware download during plug and play
        + LP: #1185866 - hp-config_usb_printer hangs in loop
        + LP: #1189333 - Fixed hplip markup documentation errors
        + LP: #1195221 - Unable to install plugin for network printer Laserjet
          2600n
        + LP: #1196335 - HPLIP 3.13.6 stop working after shutting down/rebooting
          the computer
        + LP: #1197306 - HP laserjet 1020 not printing on Ubuntu12.10 after
          power cycle the printer
  * debian/control: printer-driver-hpcups: Replaced dependency on
    ghostscript-cups by "cups-filters (>= 1.0.36) | ghostscript-cups" as
    Ghostscript's CUPS filters moved to cups-filters from cups-filters
    1.0.36/Ghostscript 9.08 on.
  * debian/patches/CVE-2010-4267.dpatch: Removed, included upstream.

  [ Mark Purcell ]
  * Removed 56-hpmud_support.rules suspend udev-rules-hp-mkuri-call-fix.dpatch
  * Added 56-hpmud.rules update create_hal_global_fdi_from_hpmud_rules.sh
  * Update hplip.preinst
  * Drop obsolete transitional dummy packages
 -- Till Kamppeter <email address hidden>   Tue, 13 Aug 2013 18:58:00 +0200

Available diffs

Superseded in saucy-release on 2013-08-13
Deleted in saucy-proposed on 2013-08-16 (Reason: moved to release)
hplip (3.13.4-1build1) saucy; urgency=low

  * Rebuild for libsnmp30.
 -- Colin Watson <email address hidden>   Mon, 20 May 2013 00:21:27 +0100
Superseded in saucy-proposed on 2013-05-19
hplip (3.13.4-1) unstable; urgency=low


  * New upstream release
  * Removed "KDE from long description." (Closes: #706269)
  * Clarified "[hpijs] short description" (Closes: #706057)

 -- Mark Purcell <email address hidden>  Sun, 05 May 2013 21:09:24 +1000
Superseded in saucy-release on 2013-06-02
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
hplip (3.13.3-1) experimental; urgency=low


  * New Upstream Release 
    - Fixes CVE-2013-0200 (Closes: #701185)
    - Fixes "hp-check does not find installed Xsane" (Closes: #690362)
  * Ack NMU - Thanks Sebastian Ramacher

 -- Mark Purcell <email address hidden>  Sat, 09 Mar 2013 11:29:44 +1100
Superseded in raring-release on 2013-03-09
Deleted in raring-proposed on 2013-03-10 (Reason: moved to release)
hplip (3.13.2-0ubuntu1) raring; urgency=low

  * New upstream release
     o Added support for: HP Officejet Pro X451dw, X451dn, X476dn, X476dw MFP,
       X551dn, X551dw, X576dn, X576dw, Officejet 7110 Wide Format ePrinter,
       LaserJet 400 M401dne
     o Secure Printing Support for HP LaserJet 5500 and Hp LaserJet 8150
     o Updated Media Types for HP Color LaserJet CP5520 Series
     o Bug fixes
  * debian/patches/85_rebuild_python_ui.dpatch,
    debian/patches/try_libhpmud.so.0.dpatch,
    debian/patches/hp-mkuri-libnotify-so-4-support.dpatch: Manually updated to
    apply to the new upstream source code.
  * debian/patches/87_move_documentation.dpatch,
    debian/patches/hp_photosmart_pro_b9100_support.dpatch,
    debian/patches/ubuntu-hp-mkuri-notification-text.dpatch,
    debian/patches/simple-scan-as-default.dpatch,
    debian/patches/make-commafy-correctly-work-with-python-2.dpatch,
    debian/patches/remove-duplicate-entry-for-cp1700-in-drv-files.dpatch,
    debian/patches/CVE-2010-4267.dpatch,
    debian/patches/hp-systray-make-menu-title-visible-in-sni-qt-indicator.dpatch,
    debian/patches/hp-systray-make-menu-appear-in-sni-qt-indicator-with-kde.dpatch: Refreshed with Quilt.
  * debian/patches/kde4-kdesudo-support.dpatch: Removed, not applicable any
    more.
  * debian/patches/hplip-syslog-fix-debug-messages-to-error.dpatch: Removed,
    applied upstream.
  * debian/rules: Make /usr/share/hplip/check-plugin.py executable.
  * debian/hplip.install: Added installation of new utilities hp-doctor and
    hp-logcapture.

Available diffs

Superseded in raring-release on 2013-03-08
Deleted in raring-proposed on 2013-03-09 (Reason: moved to release)
hplip (3.12.11-0ubuntu1) raring-proposed; urgency=low

  [ Till Kamppeter ]
  * New upstream release
     o Added support for: HP LaserJet Pro 500 color MFP M570dw,
       Pro 500 color MFP M570dn, LaserJet Enterprise flow MFP M525,
       color flow MFP M575, 700 M712n, 700 M712dn, 700 M712xh,
       700 color MFP M775dn, 700 color MFP M775f, 700 color MFP M775z,
       700 color MFP M775z+
     o Secure Printing support for HP LaserJet P3010 Series
     o Job storage support with postscript finishing filter
  * debian/patches/hplip-release-parport.patch: Removed, fixed upstream.

  [ Dmitry Shachnev ]
  * debian/patches/kde4-kdesudo-support.dpatch: Use "which" instead of
    "utils.which", to fix a NameError (LP: #1069324).
 -- Till Kamppeter <email address hidden>   Fri, 30 Nov 2012 11:34:00 +0100

Available diffs

Superseded in raring-release on 2012-11-30
Obsolete in quantal-release on 2015-04-24
Deleted in quantal-proposed on 2015-05-01 (Reason: moved to release)
hplip (3.12.6-3ubuntu4) quantal-proposed; urgency=low

  * debian/patches/hplip-release-parport.patch: libsane-hpaio does not close
    /dev/parport* after checking for a scanner (LP: #1065582, Red Hat bug
    #1065582).
 -- Till Kamppeter <email address hidden>   Thu, 11 Oct 2012 21:40:00 +0200
Superseded in quantal-proposed on 2012-10-12
hplip (3.12.6-3ubuntu3) quantal-proposed; urgency=low

  * debian/patches/crash-fixes-of-hplip-3-12-10a.patch: Fixed crash in HP
    Device Manager and System Tray due to ValueError exception in HPLIP upgrade
    functionality (LP: #1064889).
  * debian/hplip.install, debian/hplip-gui.install: Added some missing program
    file links.
 -- Till Kamppeter <email address hidden>   Wed, 10 Oct 2012 20:32:00 +0200
Superseded in quantal-release on 2012-10-12
hplip (3.12.6-3ubuntu2) quantal; urgency=low

  * debian/rules: Removed dependency of the "clean" rule on the "configure"
    rule. This prevented from a clean source package being generated.
  * debian/hplip.dirs: Create empty /var/lib/hp/ directory when installing so
    that HPLIP can annotate that it installed the plugin (LP: #1055521).
  * debian/rules: Made HPLIP build with CUPS 1.6.1 and later by overriding a
    new conditional to hide the private ipp_t data structure in cups/ipp.h by
    adding "-D_IPP_PRIVATE_STRUCTURES=1" to CFLAGS (Problem reported upstream
    to HPLIP as LP: #1056214).
 -- Till Kamppeter <email address hidden>   Tue, 25 Sep 2012 20:58:00 +0200

Available diffs

Superseded in precise-updates on 2013-09-18
Deleted in precise-proposed on 2013-09-19 (Reason: moved to -updates)
hplip (3.12.2-1ubuntu3.1) precise-proposed; urgency=low

  * debian/control: Let hplip recommend printer-driver-postscript-hp
    (LP: #1014478).
 -- Till Kamppeter <email address hidden>   Tue, 26 Jun 2012 20:55:00 +0200
Superseded in quantal-release on 2012-09-25
hplip (3.12.6-3ubuntu1) quantal; urgency=low

  * debian/control: Let hplip recommend printer-driver-postscript-hp
    (LP: #1014478).
 -- Till Kamppeter <email address hidden>   Tue, 26 Jun 2012 20:55:00 +0200
Superseded in quantal-release on 2012-06-28
hplip (3.12.6-0ubuntu1) quantal; urgency=low

  * New upstream release
     o Added PIN to PRINT support for HP Color LaserJet CM4540 MFP
     o libusb-1.0 support added
     o Added support for: HP DeskJet Ink Advantage 2510, 3525, 4610, 4620,
       5525, 2510, 3520, OfficeJet 4610, 4620, Photosmart 5520, LaserJet 400
       M401, 400 MFP M425, LaserJet Enterprise 500 MFP M525, 500 Color MFP
       M575, LaserJet Professional P 1102w, P1107w, P1107, P1109w, P1109,
       M1137, M1138, M1139, P1567, P1568, P1569, P1607dn, P1608dn, P1609dn
  * debian/patches/hp-check-groups.dpatch: Removed, problem solved upstream.
  * debian/patches/fax-support-hp-laserjet-m1522nf-mfp.dpatch: Removed,
    applied upstream.
  * debian/patches/hp-check_debian.dpatch,
    debian/patches/hpaio-option-duplex.diff: Updated.
  * debian/patches/simple-scan-as-default.dpatch,
    debian/patches/make-commafy-correctly-work-with-python-2.dpatch,
    debian/patches/hp-systray-make-menu-title-visible-in-sni-qt-indicator.dpatch,
    debian/patches/hp-systray-make-menu-appear-in-sni-qt-indicator-with-kde.dpatch:
    Refreshed with quilt.
  * debian/control: Switch over to libusb 1.0.x.
  * debian/control: Added build dependency on dh_autoreconf.
  * debian/rules, debian/printer-driver-hpcups.install,
    debian/printer-driver-postscript-hp.install,
    debian/printer-driver-hpijs.install, debian/hpijs-ppds.install: Install
    ppd-updater files with .ppd-updater extension, as the other packages do.
 -- Till Kamppeter <email address hidden>   Wed, 20 Jun 2012 20:19:00 +0200
Superseded in quantal-release on 2012-06-20
hplip (3.12.4-2) unstable; urgency=low


  * hplip-gui Replaces: hplip  (<< 3.12.4-2)
    - Fixes "fails to upgrade from 'squeeze'" (Closes: #675307)
    - Add specific package.bug-script files

 -- Mark Purcell <email address hidden>  Sun, 10 Jun 2012 22:59:08 +1000

Available diffs

Superseded in quantal-release on 2012-06-11
hplip (3.12.4-1) unstable; urgency=low


  * New upstream release
  * Switch to source/format 3.0 (quilt) - drop dpatch
  * Refreshed debian/patches
  * dh_autoreconf debian/autogen.sh & set local-options single-debian-patch
  * Update to debian/compat -> 9
  * Fix "hardened build flags" patch from Moritz - thanks (Closes: #667828)
  * Fix "duplex descriptor uninitialized" patch from Matej (Closes: #583273)
  * Fix "please migrate to kde-runtime" patch from Pino (Closes: #666544)

 -- Mark Purcell <email address hidden>  Sat, 26 May 2012 11:20:39 +1000
Superseded in quantal-release on 2012-05-27
Published in precise-release on 2012-04-04
hplip (3.12.2-1ubuntu3) precise; urgency=low

  * debian/patches/fax-support-hp-laserjet-m1522nf-mfp.dpatch: Fixed fax
    sending support for the HP LaserJet M1522nf MFP (LP: #790238).
 -- Till Kamppeter <email address hidden>   Wed,  4 Apr 2012 13:59:00 +0200

Available diffs

Superseded in precise-release on 2012-04-04
hplip (3.12.2-1ubuntu2) precise; urgency=low

  * debian/control: Added Replaces/Breaks on hplip-data (<< 3.10.5-4ubuntu1)
    to the libsane-hpaio binary package, to make update from Ubuntu Lucid LTS
    to Precise LTS working (LP: #954847).
 -- Till Kamppeter <email address hidden>   Wed, 14 Feb 2012 18:49:00 +0100

Available diffs

Superseded in precise-release on 2012-03-14
hplip (3.12.2-1ubuntu1) precise; urgency=low

  * debian/local/scripts/hp-plugin-ubuntu, debian/hplip-gui.install: Return
    from HPLIP's own automatic plugin installation to the Ubuntu method,
    HP's method installs the plugin when an arbitrary HP LaserJet printer is
    detected on the USB.
  * debian/patches/hp-mkuri-libnotify-so-4-support.dpatch: Let hp-mkuri use
    libnotify.so.4.
 -- Till Kamppeter <email address hidden>   Mon, 27 Feb 2012 16:13:00 +0100
Superseded in precise-release on 2012-03-01
hplip (3.12.2-1) unstable; urgency=low


  * New Upstream Release
  * Fixup Replaces: for squeeze security updates (Closes: #658056)
    - Fixes "obsolete conffiles not removed on upgrades" (Closes: #645848)
  * Cleanup Obsolete Replaces: Depends: Breaks: - support upgrades squeeze+
  * Obtain user consent before running hp-check in reportbug
    - Fixes "bug script starts /usr/share/hplip/systray.py" (Closes: #623627)
  * Drop legacy Uploaders
  * Add hplip Depends: python-gobject-2
    - Fixes "missing dependency causes hp-plugin to fail" (Closes: #600360)

 -- Mark Purcell <email address hidden>  Sat, 18 Feb 2012 13:56:10 +1100
Superseded in precise-release on 2012-02-18
hplip (3.12.2-0ubuntu1) precise; urgency=low

  * New upstream release
     o Added support for: HP LaserJet Pro 300 color MFP M375nw, 400 color
       MFP M475dn, 400 color MFP M475dw, 300 color M351a, 400 color M451nw,
       400 color M451dn, 400 color M451dw, P1108, P1106, P1102s, Color
       LaserJet CP1217
     o Bug fixes.
  * debian/patches/hplip-systray-longer-timeout-for-system-tray-start.dpatch:
    Removed, fixed upstream.
 -- Till Kamppeter <email address hidden>   Thu,  9 Feb 2012 16:29:00 +0100
Superseded in precise-release on 2012-02-09
hplip (3.11.12-2) unstable; urgency=low


  * Reinstate printer-driver-{hpcups,hpijs}.install
    - Fixes "File "/usr/lib/cups/filter/hpcups" not available: No such file
    or directory" (Closes: #655424)

 -- Mark Purcell <email address hidden>  Thu, 12 Jan 2012 08:12:58 +1100
Superseded in precise-release on 2012-01-12
hplip (3.11.12-0ubuntu1) precise; urgency=low

  * New upstream release
     o Auto-detection and installation of missing plug-ins
     o Added support for: HP LaserJet Enterprise 600 M601n, M601dn, M602n,
       M602dn, M602x, M603n, M603dn, M603xh, LaserJet 200 color MFP M275nw,
       M275s, M275t, M275u, Photosmart 5510d e-All-in-One
     o Bug fixes.
  * debian/patches/add_missing_newline_for_error_log.dpatch,
    debian/patches/hpcups-top-margins-not-respected.dpatch: Removed, fixed
    upstream.
  * debian/patches/udev-rules-use-attrs-not-sysfs-and-hp-mkuri-call-fix.dpatch,
    debian/patches/udev-rules-hp-mkuri-call-fix.dpatch: SYSFS issue is fixed
    upstream, replaced the patch by one for only the hp-mkuri part.
  * debian/patches/hplip-syslog-fix-debug-messages-to-error.dpatch: Regenerated.
  * debian/hplip-gui.install: Added new files for automatic plugin installation.
  * debian/hplip.dirs: Install new /var/log/hp/ directory.
  * debian/control: printer-driver-postscript-hp needs hpps CUPS filter, which
    is in the hplip package, therefore depend on hplip.
  * debian/local/scripts/hp-plugin-ubuntu: Only do the automatic installation
    of the plugin if the HPLIP GUI is not installed, otherwise HPLIP does
    the installation on its own.
 -- Till Kamppeter <email address hidden>   Fri,  6 Jan 2012 12:53:00 +0100
Superseded in precise-release on 2012-01-06
hplip (3.11.10-1ubuntu4) precise; urgency=low

  * debian/rules: Use "#!/usr/bin/python" instead of "#!/usr/bin/env python"
    to specify the path to the Python interpreter, to assure that always
    the system's interpreter is used and never a possibly incompatible
    alternative Python interpreter (LP: #912625).
 -- Till Kamppeter <email address hidden>   Fri,  6 Jan 2012 09:37:00 +0100
Superseded in precise-release on 2012-01-06
hplip (3.11.10-1ubuntu3) precise; urgency=low

  * debian/hplip.install: Added entry for /usr/lib/cups/filter/hpps.
 -- Till Kamppeter <email address hidden>   Fri,  6 Jan 2012 01:13:00 +0100
Superseded in precise-release on 2012-01-06
hplip (3.11.10-1ubuntu2) precise; urgency=low

  * debian/control, debian/rules, debian/hpijs.README.Debian,
    debian/hpijs.docs, debian/hpijs.install, debian/hpijs.lintian,
    debian/hpijs.manpages, debian/hpijs.ppd-updater,
    debian/hplip-cups.NEWS, debian/hplip-cups.install,
    debian/hplip-cups.lintian, debian/hplip-cups.ppd-updater,
    debian/hplip-data.install, debian/hplip.install,
    debian/hplip.ppd-updater, debian/printer-driver-hpcups.NEWS,
    debian/printer-driver-hpcups.install,
    debian/printer-driver-hpcups.lintian,
    debian/printer-driver-hpcups.ppd-updater,
    debian/printer-driver-hpijs.README.Debian,
    debian/printer-driver-hpijs.docs,
    debian/printer-driver-hpijs.install,
    debian/printer-driver-hpijs.lintian,
    debian/printer-driver-hpijs.manpages,
    debian/printer-driver-hpijs.ppd-updater,
    debian/printer-driver-postscript-hp.install,
    debian/printer-driver-postscript-hp.ppd-updater: Updated to follow Debian's
    new printer driver package naming policy, naming printer driver binary
    packages starting with "printer-driver-...": renamed the "hplip-cups"
    package to "printer-driver-hpcups" and "hpijs" to "printer-driver-hpijs",
    moved the PostScript printer PPDs from "hplip-data" to the newly introuced
    "printer-driver-postscript-hp" package. Moved PPD updater for the
    PostScript PPDs which was (wrongly) packaged in "hplip" also to
    "printer-driver-postscript-hp". Added transitional packages. Thanks
    to Didier Raboud (odyx at debian dot org) for the patch (Closes: #649991).
 -- Till Kamppeter <email address hidden>   Thu,  5 Jan 2012 22:49:00 +0100
Deleted in oneiric-proposed on 2015-04-26 (Reason: moved to -updates)
Obsolete in oneiric-updates on 2015-04-24
Deleted in oneiric-proposed on 2015-04-26 (Reason: moved to -updates)
hplip (3.11.7-1ubuntu3.1) oneiric-proposed; urgency=low

  * debian/patches/hpcups-top-margins-not-respected.dpatch: Reverted upstream
    change which caused a regression in handling the upper margin by monochrome
    laser printers in hpcups (LP: #890684, Red Hat bug #738089).
 -- Till Kamppeter <email address hidden>   Thu,  1 Dec 2011 12:26:00 +0100
Superseded in precise-release on 2012-01-05
hplip (3.11.10-1ubuntu1) precise; urgency=low

  * debian/patches/hpcups-top-margins-not-respected.dpatch: Reverted upstream
    change which caused a regression in handling the upper margin by monochrome
    laser printers in hpcups (LP: #890684, Red Hat bug #738089).
 -- Till Kamppeter <email address hidden>   Thu,  1 Dec 2011 12:26:00 +0100
Superseded in precise-release on 2011-12-01
hplip (3.11.10-0ubuntu1) precise; urgency=low

  * New upstream release
     o Added support for: HP DeskJet 3070 B611 series, Envy 110 e-All-in-One,
       LaserJet Enterprise 500 Color M551, OfficeJet Pro 8100 N811, Pro 8600,
       PhotoSmart 5510 e-All-in-One, 6510 e-All-in-one, 7510 e-All-in-One
     o Bug fixes.
 -- Till Kamppeter <email address hidden>   Wed, 26 Oct 2011 21:31:00 +0200
175 of 263 results