hplip 2.7.7.dfsg.1-0ubuntu5.2 source package in Ubuntu

Changelog

hplip (2.7.7.dfsg.1-0ubuntu5.2) gutsy-security; urgency=low

  * SECURITY UPDATE: privilege escalation using the hplip alert-mailing
    functionality.
    - debian/patches/91_SECURITY_CVE-2008-2940.dpatch: fix handle_event()
      in hpssd.py to validate device-uri parameter and disable
      handle_setalerts(). This fix alters hplip behaviour by preventing
      users from setting alerts and by moving alert configuration to a
      root-controlled /etc/hp/alerts.conf file.
    - CVE-2008-2940
  * SECURITY UPDATE: denial of service in hpssd message parser.
    - debian/patches/92_SECURITY_CVE-2008-2941.dpatch: fix handle_event()
      in hpssd.py to correctly validate parameters.
    - CVE-2008-2941

 -- Marc Deslauriers <email address hidden>   Thu, 20 Nov 2008 09:46:21 -0500

Upload details

Uploaded by:
Marc Deslauriers on 2008-11-20
Uploaded to:
Gutsy
Original maintainer:
Ubuntu Development Team
Architectures:
any
Section:
utils
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
hplip_2.7.7.dfsg.1.orig.tar.gz 13.7 MiB 072a617f6df5c94d99342b8ca17df6196e773fc97e3676a197c3be89fc15e62d
hplip_2.7.7.dfsg.1-0ubuntu5.2.diff.gz 146.0 KiB b01bf2434e95de528ba98f383ccbb223bf8f97341239a94744c6279cd6894763
hplip_2.7.7.dfsg.1-0ubuntu5.2.dsc 1.0 KiB e714c0881880f399909765656d141ab4cdf60ebc6d5464a2b6060b26da54c221

View changes file

Binary packages built by this source

hpijs: No summary available for hpijs in ubuntu gutsy.

No description available for hpijs in ubuntu gutsy.

hpijs-ppds: No summary available for hpijs-ppds in ubuntu gutsy.

No description available for hpijs-ppds in ubuntu gutsy.

hplip: No summary available for hplip in ubuntu gutsy.

No description available for hplip in ubuntu gutsy.

hplip-data: No summary available for hplip-data in ubuntu gutsy.

No description available for hplip-data in ubuntu gutsy.

hplip-dbg: No summary available for hplip-dbg in ubuntu gutsy.

No description available for hplip-dbg in ubuntu gutsy.

hplip-doc: No summary available for hplip-doc in ubuntu gutsy.

No description available for hplip-doc in ubuntu gutsy.

hplip-gui: No summary available for hplip-gui in ubuntu gutsy.

No description available for hplip-gui in ubuntu gutsy.