Change log for ia32-libs package in Ubuntu

175 of 123 results
Deleted in saucy-release (Reason: obsolete transitional package)
Obsolete in raring-release on 2015-04-24
Published in precise-updates on 2012-05-23
Obsolete in quantal-release on 2015-04-24
Deleted in precise-proposed (Reason: moved to -updates)
ia32-libs (20090808ubuntu36) precise-proposed; urgency=low

  * Drop gstreamer0.10-fluendo-mp3 from the dependencies of
    ia32-libs-multiarch; this was a late addition solely for the benefit of
    wine, which according to Scott Ritchie no longer needs it in precise,
    and the fact that there are multiple packages providing this package
    name (across universe, partner archive, and commercial ppas) means that
    trying to install one of these other packages incorrectly causes
    ia32-libs to be removed.  LP: #1000541.
 -- Steve Langasek <email address hidden>   Wed, 16 May 2012 21:20:21 -0700
Superseded in quantal-release on 2012-05-17
Published in precise-release on 2012-03-18
ia32-libs (20090808ubuntu35) precise; urgency=low

  * Fix a typo in debian/control that prevented the package from building
    on i386.
 -- Steve Langasek <email address hidden>   Sun, 18 Mar 2012 13:35:33 -0700
Superseded in precise-release on 2012-03-18
ia32-libs (20090808ubuntu34) precise; urgency=low

  * Re-add libxtst6 (LP: #946381) and libgconf-2-4 (LP: #953404), since these
    libs are still needed by some packages that use ia32-libs.
 -- Steve Langasek <email address hidden>   Mon, 12 Mar 2012 14:55:36 -0700
Superseded in precise-release on 2012-03-12
ia32-libs (20090808ubuntu33) precise; urgency=low

  * Demote libnss-ldap, libpam-ldap, libpam-winbind from Depends to Suggests,
    so that an upgrade doesn't by default either pull in an additional
    daemon (winbind) or introduce debconf questions (ldap-auth-config).
    LP: #912704.
 -- Steve Langasek <email address hidden>   Wed, 11 Jan 2012 16:43:22 +0100
Superseded in precise-release on 2012-01-11
ia32-libs (20090808ubuntu32) precise; urgency=low

  * debian/control: libsdl1.2debian-pulseaudio (NBS) → libsdl1.2debian.
 -- Martin Pitt <email address hidden>   Mon, 05 Dec 2011 14:57:05 +0100
Superseded in precise-release on 2011-12-05
ia32-libs (20090808ubuntu31) precise; urgency=low

  * Depend on libpulsedsp in place of pulseaudio-utils.
 -- Steve Langasek <email address hidden>   Thu, 27 Oct 2011 17:00:49 -0700
Superseded in precise-release on 2011-10-28
ia32-libs (20090808ubuntu30) precise; urgency=low

  * Er, actually update debian/control, not just debian/changelog, for
    libpam-winbind.
 -- Steve Langasek <email address hidden>   Mon, 24 Oct 2011 11:41:26 -0700
Superseded in precise-release on 2011-10-24
ia32-libs (20090808ubuntu29) precise; urgency=low

  * Depend on libpam-winbind, not on winbind, now that it's split.
 -- Steve Langasek <email address hidden>   Mon, 24 Oct 2011 10:04:40 -0700
Superseded in precise-release on 2011-10-24
ia32-libs (20090808ubuntu28) precise; urgency=low

  * Depend on libgettextpo0 (already existing virtual package), not on
    gettext.
 -- Steve Langasek <email address hidden>   Thu, 20 Oct 2011 11:11:52 -0700
Superseded in precise-release on 2011-10-20
ia32-libs (20090808ubuntu27) precise; urgency=low

  * ia32-libs-multiarch has no reason to Pre-Depends: mulitarch-support.
  * Completely empty ia32-libs, moving everything to ia32-libs-multiarch.
    This makes ia32-libs uninstallable in precise until all of these packages
    are made multiarch co-installable, but that's the point.  We need to
    finish off ia32-libs for precise.
  * Switch to dh(1) for the now-trivial packaging.
 -- Steve Langasek <email address hidden>   Sun, 16 Oct 2011 23:54:11 -0700
Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
ia32-libs (20090808ubuntu26) oneiric; urgency=low

  * Final freshening of packages for Oneiric
  * ia32-libs-multiarch also recommends libgl1-mesa-dri
    - Should be pulled in already by libgl1-mesa-glx, but this will
      hit upgrading beta users
 -- Scott Ritchie <email address hidden>   Thu, 06 Oct 2011 22:37:59 -0700
Superseded in oneiric-release on 2011-10-07
ia32-libs (20090808ubuntu25) oneiric; urgency=low

  * Create an ia32-libs-multiarch package to depend on i386 versions of
    libraries that were dropped over the last cycle
    - Should ease transitional issues
    - Recommended (but not depended by) ia32-libs
    - Makes it less likely to have no handler for 32 bit (LP: #852101)
  * Libraries for ia32-libs-multiarch are:
    - qt4-x11: libqtcore4, libqtgui4, libqt4-dbus, libqt4-network,
      libqt4-opengl, libqt4-qt3support, libqt4-script, libqt4-scripttools,
      libqt4-sql, libqt4-svg, libqt4-test, libqt4-xml, libqt4-xmlpatterns
    - acl: libacl1
    - attr: libattr1
    - libcupsimage2: libcups2, libcupsimage2
    - curl: libcurl3
    - gdbm: libgdbm3
    - nss: libnss3
    - nspr: libnspr4
    - openssl: libssl1.0.0
    - libxss: libxss1
  * ia32-libs-multiarch also recommends libgl1-mesa-glx (LP: #821100)
  * debian/rules: create special dh_gencontrol for i386 to avoid build failure
  * Readd libqtwebkit4 to ia32-libs
    - while qtwebkit-source was Multi-Arched, it still depends on libgstreamer
      which has not yet been multiarched and resides in ia32-libs
 -- Scott Ritchie <email address hidden>   Wed, 28 Sep 2011 23:47:04 -0700
Superseded in oneiric-release on 2011-09-29
ia32-libs (20090808ubuntu24) oneiric; urgency=low

  * Remove libllvm2.9 and DRI driver manual symlinks (LP: #851947)
  * Freshen packages
 -- Scott Ritchie <email address hidden>   Wed, 28 Sep 2011 17:37:52 -0700
Superseded in oneiric-release on 2011-09-29
ia32-libs (20090808ubuntu23) oneiric; urgency=low

  * Declare a Provides: lib32v4l-0 since we've subsumed that library, and
    there are third-party packages that depend on this name.
 -- Steve Langasek <email address hidden>   Wed, 21 Sep 2011 13:45:24 -0700
Superseded in oneiric-release on 2011-09-22
ia32-libs (20090808ubuntu22) oneiric; urgency=low

  * Create some manual symlinks for DRI drivers (LP: #821100)
    - Also add libllvm2.9
 -- Scott Ritchie <email address hidden>   Thu, 15 Sep 2011 16:52:17 -0700
Superseded in oneiric-release on 2011-09-16
ia32-libs (20090808ubuntu21) oneiric; urgency=low

  * Remove SSL packages from source since they're in the archive;
    packages will be acquired with fetch-and-build like others
  * Add libssl1.0.0 to match the version needed by ssl-dev (for Wine)
 -- Scott Ritchie <email address hidden>   Tue, 13 Sep 2011 18:17:27 -0700
Superseded in oneiric-release on 2011-09-15
ia32-libs (20090808ubuntu20) oneiric; urgency=low

  * Replaces on libv4l32-dev is also needed.  LP: #836835.
  * Re-add libxp6 to the package; not yet multiarched, and needed for things
    like ICA Client.  LP: #836397.
  * Add libpciaccess0, needed for accelerated 3d for 32-bit programs.
    LP: #836672.
 -- Steve Langasek <email address hidden>   Tue, 30 Aug 2011 10:15:59 -0700
Superseded in oneiric-release on 2011-09-01
ia32-libs (20090808ubuntu19) oneiric; urgency=low

  * Add missing replaces on libv4l32-0.  LP: #835132.
 -- Steve Langasek <email address hidden>   Fri, 26 Aug 2011 16:07:58 -0700
Superseded in oneiric-release on 2011-08-27
ia32-libs (20090808ubuntu18) oneiric; urgency=low

  * Add libv4l and libjpeg8 to ia32-libs, since lib32v4l-0 has been dropped,
    and drop the dependency on the separate package.  LP: #808064.
  * Freshen packages.
 -- Steve Langasek <email address hidden>   Fri, 26 Aug 2011 12:14:52 -0700
Superseded in oneiric-release on 2011-08-26
ia32-libs (20090808ubuntu17) oneiric; urgency=low

  * Declare Breaks: on flashplugin-installer (<< 10.3.183.4ubuntu4) and
    nspluginwrapper (<< 1.4.4-0ubuntu2) since we are no longer shipping all
    the libraries needed by the amd64 version of the package.
 -- Steve Langasek <email address hidden>   Thu, 25 Aug 2011 14:14:06 -0700
Superseded in oneiric-release on 2011-08-26
ia32-libs (20090808ubuntu16) oneiric; urgency=low

  * Drop gstreamer0.10-plugins-{bad,ugly} and all the libraries pulled in as
    dependencies; after checking with wine upstream, the consensus is that
    wine gstreamer support only needs the 'good' and 'base' plugins.  This
    drops the following libraries:
      liba52-0.7.4, libass4, libcdaudio1, libcdio10, libcelt0-0, libdca0,
      libdirac-encoder0, libdirectfb-1.2-9, libdvdnav4, libdvdread4,
      libenca0, libfaad2, libfftw3-3, libgme0, libgsm1, libid3tag0,
      libkate1, libmad0, libmimic0, libmms0, libmodplug1, libmp3lame0,
      libmpcdec6, libmpeg2-4, libmusicbrainz4c2a, libofa0,
      libopencore-amrnb0, libopencore-amrwb0, librtmp0,
      libschroedinger-1.0-0, libsidplay1, libtwolame0, libvpx0,
      libwildmidi1, libx264-116, libzbar0
 -- Steve Langasek <email address hidden>   Fri, 19 Aug 2011 22:03:52 -0700
Superseded in oneiric-release on 2011-08-20
ia32-libs (20090808ubuntu15) oneiric; urgency=low

  * Readd libssl0.9.8, needed by adobereader-deu and acroread in partner.
  * Freshen other packages.
 -- Steve Langasek <email address hidden>   Thu, 18 Aug 2011 15:16:43 -0700
Superseded in oneiric-release on 2011-08-19
ia32-libs (20090808ubuntu14) oneiric; urgency=low

  * Update sources.list for oneiric.
  * Set [arch=i386] in the sources.list, so ia32-libs can be built from a
    system with multiarch enabled ;)
  * Freshen packages:
    - s/libibus2/libibus-1.0-0/
    - s/libssl0.9.8/libssl1.0.0/
    - s/libx264-106/libx264-116/
    - /libxcb-atom1/d
    - s/libxcb-render-util0/libxcb-util0/
    - s/libdb4.7/libdb5.1/
    - /libgvfscommon0/d
    - /libpulse-browse0/d
  * Pull in new library deps:
    - libjson0, needed by pulseaudio
    - libglapi-mesa, needed by libgl1-mesa-glx
  * Add lib32ffi6 to the package dependencies
  * Begin dropping libraries from the package that have been converted for
    multiarch:
    - qtwebkit-source
    - qt4-x11
    - acl
    - attr
    - libcupsimage2
    - curl
    - gdbm
    - nss
    - nspr
    - openssl
    - libxss
  * gtk2-engines-qtcurve: dropped in favor of gtk2-engines-oxygen, per
    LP 719568
  * freeglut3: drop; added for wine, which no longer uses it
  * coreutils, gettext-base: drop; never should have been included, only
    shipping private libraries
  * libsepol1: drop; no interesting binary-only reverse-deps, shouldn't
    have been included
  * human-theme, xcursor-themes: drop, contain no libraries.
  * lesstif2: hasn't been a standard Unix toolkit in a decade or more.  No
    known current revdeps.
  * libegl1-mesa, libopenvg1-mesa: drop.  gdk-pixbuf doesn't need this, so
    presumably whatever postinst error caused it to be added has now been
    resolved.
  * gstreamer0.10-ffmpeg: was never included in usable form, dependencies
    are missing - and no one complained.  Drop.
  * libproxy0, libexempi3, libiptcdata0, libopenjpeg2, libva1, libxvidcore4:
    drop.  No longer needed by gstreamer.
  * libbluetooth3, libgsf-1-114, libglade2-0, libgnomecanvas2-0, liblzo2-2,
    libssh2-1, libwmf0.2-7, libxmuu1: drop.  No revdeps within ia32-libs, no
    mention in changelog, unlikely to be used by binary software.
  * libfltk1.1: the emulator for which this was added is no longer in the
    archive; drop.
  * libgsl0ldbl: unlikely to be needed by binary software; ia32-libs not a
    substitute for a 32-bit build chroot.  Drop.
  * libhal1: obsolete library, no longer used by wine.  Drop.
  * libsmbios2: included as a dependency of hal.  Drop.
  * libflite1: drop: this library is used by gstreamer0.10-plugins-bad, but
    only for an uncommonly-used plugin; and the dependencies of all the
    current plugins aren't satisfied in ia32-libs anyway.  And this library
    alone accounts for a quarter of the remaining size of ia32-libs.
  * replace at-spi, libatspi1.0-0 with at-spi2-core, libatspi2.0-0; this lets
    us drop the deprecated libbonobo, libgconf, liborbit, libidl, libxtst.
  * pulseaudio: contains no libraries, only plugins for the server which
    doesn't need a 32-bit copy.  Drop.
  * libpython2.6: libpython was added for a binary-only application, glGo,
    which is only available linked to libpython2.5 - *not* to any later
    version.  Drop.
  * Replace libsdl1.2debian-alsa with libsdl1.2debian-pulseaudio, the
    current default.
  * libsigc++-2.0-0c2a: drop; no longer needed for skype.
  * libsvga1, libx86-1: drop; no longer needed for SDL.
  * libtag1c2a: empty transitional package, drop.
  * libxcb-glx0, libxcb-util0: not used, drop.
 -- Steve Langasek <email address hidden>   Wed, 17 Aug 2011 02:34:26 -0700
Deleted in lucid-proposed on 2013-05-25 (Reason: Verification failed (LP: #619293))
ia32-libs (2.7ubuntu26.2) lucid-proposed; urgency=low

  * Freshen packages
  * Add libgvfscommon0 (LP: #619293)
 -- Scott Ritchie <email address hidden>   Tue, 28 Jun 2011 01:14:06 -0700

Available diffs

Superseded in oneiric-release on 2011-08-18
Obsolete in natty-release on 2013-06-04
ia32-libs (20090808ubuntu13) natty; urgency=low

  * Freshen packages (LP: #755720)
  * Remove dummy package libglu1-xorg (libglu1-mesa remains)
 -- Scott Ritchie <email address hidden>   Wed, 20 Apr 2011 23:28:04 -0700
Obsolete in maverick-updates on 2013-03-05
Obsolete in maverick-security on 2013-03-05
ia32-libs (20090808ubuntu9.1) maverick-security; urgency=low

  * SECURITY UPDATE: Refresh packages to pull in security fixes,
    including:
    - lcms buffer overflow, CVE-2009-0793 (LP: #700198)
    - openssl: multiple issues, including CVE-2009-3555, CVE-2009-3245,
      and CVE-2010-2939
    - libpango1.0: multiple DoS, possible code execution issues:
      CVE-2010-0421, CVE-2011-0020, CVE-2011-0064
    - libfreetype: multiple DoS, possible code execution issues
    - nss: many issues
 -- Steve Beattie <email address hidden>   Tue, 12 Apr 2011 12:17:45 -0700
Obsolete in lucid-updates on 2016-10-26
Obsolete in lucid-security on 2016-10-26
ia32-libs (2.7ubuntu26.1) lucid-security; urgency=low

  * SECURITY UPDATE: Refresh packages to pull in security fixes,
    including:
    - lcms buffer overflow, CVE-2009-0793 (LP: #700198)
    - openssl: multiple issues, including CVE-2009-3555, CVE-2009-3245,
      and CVE-2010-2939
    - libpango1.0: multiple DoS, possible code execution issues:
      CVE-2010-0421, CVE-2011-0020, CVE-2011-0064
    - nss: many issues
 -- Steve Beattie <email address hidden>   Tue, 12 Apr 2011 11:26:47 -0700
Obsolete in karmic-updates on 2013-03-04
Obsolete in karmic-security on 2013-03-04
ia32-libs (2.7ubuntu17.1) karmic-security; urgency=low

  * SECURITY UPDATE: Refresh packages to pull in security fixes,
    including:
    - lcms: buffer overflow, CVE-2009-0793 (LP: #700198)
    - openssl: multiple issues, including CVE-2009-3555, CVE-2009-3245,
      and CVE-2010-2939
    - libpango1.0: multiple DoS, possible code execution issues:
      CVE-2010-0421, CVE-2011-0020, CVE-2011-0064
    - libfreetype: multiple DoS, possible code execution issues:
      CVE-2010-3311, CVE-2010-3814, CVE-2010-3855, CVE-2010-1797,
      CVE-2010-2541, CVE-2010-2805, CVE-2010-2806, CVE-2010-2807,
      CVE-2010-2808, CVE-2010-2498, CVE-2010-2499, CVE-2010-2500,
      CVE-2010-2519, CVE-2010-2520, CVE-2010-2527
    - nss: many issues
 -- Steve Beattie <email address hidden>   Tue, 12 Apr 2011 02:08:26 -0700
Superseded in natty-release on 2011-04-21
ia32-libs (20090808ubuntu12) natty; urgency=low

  * Set LDCONFIG_NOTRIGGER=y to cope with the ldconfig cache not being up to
    date (LP: #746758). Thanks Colin Watson!
 -- Evan Dandrea <email address hidden>   Mon, 11 Apr 2011 11:33:48 +0100
Superseded in natty-release on 2011-04-11
ia32-libs (20090808ubuntu11) natty; urgency=low

  * Add libqtwebkit4 (LP: #677397)
  * Add ibus-gtk, libibus2 (LP: #646954)
  * Another manual libpng link, libpng.so.3 (LP: #707770)
  * Add gtk2-engines-oxygen (LP: #719568)
  * Add libopenvg1-mesa (LP: #693969)
  * Add libwbclient0, winbind (LP: #694953)
  * Change some libraries that are now just symlink packages (should fix Flash)
    - libnss3-1d to libnss3
    - libnspr4-0d to libnspr4
 -- Scott Ritchie <email address hidden>   Tue, 29 Mar 2011 18:44:49 -0700
Superseded in natty-release on 2011-03-30
ia32-libs (20090808ubuntu10) natty; urgency=low

  * Steve Langasek <email address hidden>:
    - debian/rules: move contents of multiarch directories to the
      ia32-libs directory, to maintain compatibility while the multiarch
      rollout is still in progress.
  * Scott Ritchie <email address hidden>:
    - Freshen packages (should close many issues, especially with mesa)
    - Add gstreamer codecs and their dependencies (Wine, others):
      gstreamer0.10-plugins-good, libaa1, libgpm2, libslang2, libavc1394-0,
      libraw1394-11, libbz2-1.0, libcaca0, libdv4, libgudev-1.0-0,
      libiec61883-0, liborc-0.4-0, libshout3, libspeex1, libtheora0,
      libsoup-gnome2.4-1, libproxy0, libsoup2.4-1, libtag1c2a, libtag1-vanilla,
      libwavpack1, gstreamer0.10-plugins-ugly, libass4, libenca0, libcdaudio1,
      libdc1394-22, libusb-1.0-0, libdca0, libdirac-encoder0, libexempi3,
      libdvdnav4, libdvdread4, libmms0, libflite1, libfaad2, libgme0,
      libiptcdata0, libkate1, libmimic0, libmodplug1, libmpcdec6,
      libmusicbrainz4c2a, libofa0, libfftw3-3, librtmp0, libschroedinger-1.0-0,
      libvpx0, libwildmidi1, libzbar0, gstreamer0.10-plugins-bad, liba52-0.7.4,
      libcdio10, libid3tag0, libmpeg2-4, libopencore-amrnb0, libopencore-amrwb0,
      libsidplay1, libtwolame0, gstreamer0.10-ffmpeg, gstreamer0.10-fluendo-mp3,
      libmp3lame0, libopenjpeg2, libva1, libx264-106, libxvidcore4
    - Add gettext, gettext-base for Wine as well
    - Add libunistring0, libxcb-glx0 for xorg
    - Depend on lib32ncursesw5 and remove it
    - Use natty sources.list.deb.good
    - Change libdrm-nouveau1 to libdrm-nouveau1a
    - Add libegl1-mesa (fixes an error in gdk-pixbuf found at postinst)
 -- Scott Ritchie <email address hidden>   Tue, 29 Mar 2011 00:09:44 -0700

Available diffs

Obsolete in hardy-updates on 2015-04-24
Obsolete in hardy-security on 2015-04-24
ia32-libs (2.2ubuntu11.3) hardy-security; urgency=low

  * SECURITY UPDATE: Refresh packages to pull in security fixes
  * Added libs for flashplugin-nonfree upgrade to version 10:
    - fetch-and-build: added libcurl3, libnspr4-0d, libnss3-1d. Removed
      libflashsupport.
    - debian/rules: added symlinks for new libs
 -- Marc Deslauriers <email address hidden>   Tue, 15 Feb 2011 10:28:14 -0500
Superseded in natty-release on 2011-03-29
Obsolete in maverick-release on 2013-03-05
ia32-libs (20090808ubuntu9) maverick; urgency=low

  * Final package freshening for Maverick
 -- Scott Ritchie <email address hidden>   Fri, 08 Oct 2010 01:31:46 -0700
Superseded in maverick-release on 2010-10-08
ia32-libs (20090808ubuntu8) maverick; urgency=low

  * Add libjasper1 (LP: #190227)
  * Add libtalloc2 (LP: #653982)
  * fetch-and-build: use --only-source when getting source packages to avoid
    getting wrong source package for libjasper1
 -- Scott Ritchie <email address hidden>   Mon, 04 Oct 2010 07:33:32 -0700
Superseded in maverick-release on 2010-10-05
ia32-libs (20090808ubuntu7) maverick; urgency=low

  * Freshen packages (LP: #653982)
 -- Scott Ritchie <email address hidden>   Sun, 03 Oct 2010 13:32:20 -0700

Available diffs

Superseded in maverick-release on 2010-10-04
ia32-libs (20090808ubuntu6) maverick; urgency=low

  * Fix LP: #646862 - Skype crashes after signing in. Add libx11-xcb1 and
    libxcb-atom1 now that Pulse seems to need them
 -- Chris Coulson <email address hidden>   Sun, 26 Sep 2010 13:16:47 +0000

Available diffs

Superseded in maverick-release on 2010-09-26
ia32-libs (20090808ubuntu5) maverick; urgency=low

  * Fix LP: #641056 - Loader chooses 64-bit instead of 32-bit library.
    Update the gdk-pixbuf version, and create a loaders.cache on instally
  * Refresh packages
 -- Chris Coulson <email address hidden>   Fri, 24 Sep 2010 14:33:49 +0000
Superseded in maverick-release on 2010-09-24
ia32-libs (20090808ubuntu4) maverick; urgency=low

  * Add libgvfscommon0 (LP: #619293)
 -- Scott Ritchie <email address hidden>   Mon, 06 Sep 2010 16:35:59 -0700
Superseded in maverick-release on 2010-09-07
ia32-libs (20090808ubuntu3) maverick; urgency=low

  * Freshen packages
  * sources.list.deb: use archive.ubuntu.com instead of za.archive.ubuntu.com
 -- Scott Ritchie <email address hidden>   Mon, 06 Sep 2010 01:25:49 -0700
Superseded in maverick-release on 2010-09-07
ia32-libs (20090808ubuntu2) maverick; urgency=low

  * Add libgdk-pixbuf2.0-0, libxcb-shm0: Required by flashplayer (LP: #618787)
 -- Stefano Rivera <email address hidden>   Mon, 16 Aug 2010 23:16:26 +0200
Superseded in maverick-release on 2010-08-16
ia32-libs (20090808ubuntu1) maverick; urgency=low

  * Merge with Debian unstable. (LP: #618666) Remaining Ubuntu changes:
    - sources.list.deb: Debian -> Ubuntu archive apt sources.
    - Add debian/pango.modules and install them in debian/rules.
    - debian/rules:
      + Depend on lib32bz2-1.0 on amd64 instead of shipping it.
      + Depend on lib32v4l package
      + Automatically create all missing .so symlinks in /lib32
        and /usr/lib32 as the manual list of links was always out of sync and
        incomplete (LP: #277772, #309841).
      + Remove the automatically created libstdc++.so symlink, it's not needed.
        g++-4.3-multilib provides the right symlink (LP: #360870)
      + Add gvfs and symlinks for gio (LP: #369498)
      + Add symlink to libGL.so for Wine building (LP: #513554)
      + Compress packages with LZMA
    - debian/rules, debian/ia32-libs.conf: Add /lib32 and /usr/lib32 to ld
      search path.
    - fetch-and-build:
      + fetch-and-build: Add packages we want/need in Ubuntu. This also
        includes SDL and GTK, which are in separate source packages in Debian.
      + fetch-and-build: Do not die on source/binary version mismatch when
        defining $SOURCE_VER_MISMATCH. Useful right after opening a new Ubuntu
        release, when the archive is in heavy flux.
      + Dropped:
        > libartsc0 (which is now obsolete)
        > libxtrap6 (package seems to be gone from the archive)
      + Added:
        > libgsl0ldbl (LP: #130058)
        > libsmbios2 (dependency for libhal1)
        > libcelt0-0 (dependency for libjack0)
        > libmad0 (LP: #249794)
        > libvorbis0a (LP: #249794)
        > libvorbisfile3 (LP: #249794)
        > libwrap0 (LP: #290533)
  * debian/control: Don't Conflict/Replace lib32bz2-1.0, as we depend on it.
  * debian/rules: Bump GCC 4.3 to 4.5 to match new lib32gcc1
  * fetch-and-build:
    - Added: gtk2-engines-qtcurve. Thanks to Craig Magina (LP: #574476)
    - Dropped: libesd-alsa0 (replaced by libesd0)
    - Bumped:
      + libdirectfb to 1.2-9 from 1.2-0
      + libao2 to libao4
      + odbcinsta1debian1 to odbcinsta1debian2
 -- Stefano Rivera <email address hidden>   Mon, 16 Aug 2010 14:37:51 +0200

Available diffs

Superseded in lucid-updates on 2011-04-19
Deleted in lucid-proposed on 2011-04-20 (Reason: moved to -updates)
ia32-libs (2.7ubuntu26) lucid-proposed; urgency=low

  * Freshen packages (LP: #601499)
    - Contains multiple updates of 32 bit versions of previously updated packages
 -- Scott Ritchie <email address hidden>   Sat, 03 Jul 2010 17:27:55 -0700

Available diffs

Superseded in maverick-release on 2010-08-16
Obsolete in lucid-release on 2016-10-26
ia32-libs (2.7ubuntu25) lucid; urgency=low

  * Readd libpng symlinks, except to the right targets
  * Remove libv4l (there is a lib32v4l package instead)
  * Freshen packages
 -- Scott Ritchie <email address hidden>   Fri, 16 Apr 2010 10:47:37 -0700

Available diffs

Superseded in lucid-release on 2010-04-16
ia32-libs (2.7ubuntu24) lucid; urgency=low

  * Freshen packages
  * Actually remove fix the libpng symlink (LP: #554293)
 -- Scott Ritchie <email address hidden>   Tue, 13 Apr 2010 09:35:46 -0700

Available diffs

Superseded in lucid-release on 2010-04-13
ia32-libs (2.7ubuntu23) lucid; urgency=low

  * Freshen packages as the new mesa now uses the correct path for 32 bit
    compatibility on 64 bit systems (LP: #248392).
 -- Alberto Milone <email address hidden>   Sun, 11 Apr 2010 13:44:57 +0000

Available diffs

Superseded in lucid-release on 2010-04-11
ia32-libs (2.7ubuntu22) lucid; urgency=low

  * Freshen packages
  * Add libgnome-keyring0 (LP: #534197)
  * Remove manual ln -s libpng12.so.0 libpng.so in rules (LP: #554293)
 -- Scott Ritchie <email address hidden>   Tue, 06 Apr 2010 11:06:11 -0700

Available diffs

Superseded in lucid-release on 2010-04-06
ia32-libs (2.7ubuntu21) lucid; urgency=low

  * Freshen packages (LP: #522916)
  * Remove libxtrap6 (package seems to be gone from the archive)
  * Change gtk2-engines-ubuntulooks to human-theme (replacement package)
  * Change libcelt0 to libcelt0-0
 -- Scott Ritchie <email address hidden>   Fri, 19 Feb 2010 13:47:16 -0800

Available diffs

Superseded in lucid-release on 2010-02-20
ia32-libs (2.7ubuntu20) lucid; urgency=low

  * Freshen packages.
  * Add libdrm-nouveau1, libdrm-radeon1 (LP: #514299)
  * Add libqt4-opengl, libqt4-script, libqt4-scripttools, libqt4-sql,
      libqt4-qt3support, libqt4-svg, libqt4-test, libqt4-webkit,
      libqt4-xmlpatterns (LP: #490735)
 -- Scott Ritchie <email address hidden>   Thu, 04 Feb 2010 11:18:19 -0800

Available diffs

Superseded in lucid-release on 2010-02-05
ia32-libs (2.7ubuntu19) lucid; urgency=low

  * Freshen packages.
  * Add symlink to libGL.so for Wine building (LP: #513554)
 -- Scott Ritchie <email address hidden>   Tue, 02 Feb 2010 13:58:28 -0800

Available diffs

Superseded in lucid-release on 2010-02-02
ia32-libs (2.7ubuntu18) lucid; urgency=low

  * Freshen packages (LP: #506437). This will also make sure that the mesa
    libraries are installed in /usr/lib32/mesa (LP: #506435).
 -- Alberto Milone <email address hidden>   Wed, 27 Jan 2010 09:30:39 +0000

Available diffs

Superseded in lucid-release on 2010-01-27
Obsolete in karmic-release on 2013-03-04
ia32-libs (2.7ubuntu17) karmic; urgency=low

  * Re-add libfltk1.1 as it builds now (LP: #445560)
  * Freshen packages

 -- Scott Ritchie <email address hidden>   Sun, 25 Oct 2009 17:57:55 -0700

Available diffs

Superseded in karmic-release on 2009-10-26
ia32-libs (2.7ubuntu16) karmic; urgency=low

  * Freshen packages
  * Add gvfs and symlinks for gio (LP: #369498)
  * Remove libfltk1.1 as it is FTBFS and we can't update it in time for karmic

 -- Scott Ritchie <email address hidden>   Mon, 12 Oct 2009 16:01:06 -0700

Available diffs

Superseded in karmic-release on 2009-10-24
ia32-libs (2.7ubuntu15) karmic; urgency=low

  * Add a conflict against lib32asound2-plugins, as this package is being removed
    in maric. The conflict also ensures the package goes away with an upgrade from
    jaunty
  * Freshen packages

 -- Luke Yelavich <email address hidden>   Tue, 29 Sep 2009 12:09:44 +1000

Available diffs

Superseded in karmic-release on 2009-09-29
ia32-libs (2.7ubuntu14) karmic; urgency=low

  * Re-add libasound2-plugins (LP: #408615)
  * Remove libstdc++5, no longer in karmic
  * Freshen packages

 -- Luke Yelavich <email address hidden>   Mon, 14 Sep 2009 16:55:00 +1000

Available diffs

Superseded in karmic-release on 2009-09-14
ia32-libs (2.7ubuntu13) karmic; urgency=low

  * debian/rules:
    - add symbolic links for gtk-2.0, remove atk-bridge (LP: #369498)
  * Add libmpg123-0
  * Add libgstreamer0.10-0 and libgstreamer-plugins-base0.10-0 (LP: #244952)
  * Freshen packages (hopefully fixes LP: #425863)

 -- Scott Ritchie <email address hidden>   Sat, 12 Sep 2009 08:42:21 -0700

Available diffs

Superseded in karmic-release on 2009-09-12
ia32-libs (2.7ubuntu12) karmic; urgency=low

  * SECURITY UPDATE: refresh packages for libssl0.9.8, libqt4-network,
    libnss3-1d regression fix, libvorbis and libgnutls26

 -- Jamie Strandboge <email address hidden>   Fri, 11 Sep 2009 13:06:33 +0000

Available diffs

Superseded in karmic-release on 2009-09-11
ia32-libs (2.7ubuntu11) karmic; urgency=low

  * Add bluez-alsa (LP: #240666)

 -- Scott Ritchie <email address hidden>   Tue, 11 Aug 2009 22:34:08 -0700

Available diffs

Superseded in karmic-release on 2009-08-12
ia32-libs (2.7ubuntu10) karmic; urgency=low

  * debian/rules: bump GCC 4.3 to 4.4 to match new lib32gcc1

 -- Scott Ritchie <email address hidden>   Tue, 11 Aug 2009 19:12:28 -0700

Available diffs

Superseded in karmic-release on 2009-08-12
ia32-libs (2.7ubuntu9) karmic; urgency=low

  * Refresh packages
  * Add libgsm1 (LP: #411747)
  * Add libdrm-intel1 (LP: #352455)
  * Add libgail-common (LP: #190227)

 -- Scott Ritchie <email address hidden>   Mon, 10 Aug 2009 21:11:53 -0700

Available diffs

Superseded in hardy-updates on 2011-02-17
Superseded in hardy-security on 2011-02-17
Superseded in hardy-security on 2009-08-07
ia32-libs (2.2ubuntu11.2) hardy-security; urgency=low

  * SECURITY UPDATE: Refresh packages which pulls in glib2 and a whole bunch
    of other security fixes (LP: #400791)

 -- Jamie Strandboge <email address hidden>   Fri, 07 Aug 2009 09:28:54 +0000

Available diffs

Obsolete in intrepid-updates on 2013-02-20
Obsolete in intrepid-security on 2013-02-20
Superseded in intrepid-security on 2009-08-07
ia32-libs (2.2ubuntu18.1) intrepid-security; urgency=low

  * SECURITY UPDATE: Refresh packages which pulls in recent NSS fixes
    and a whole bunch of other security fixes

 -- Jamie Strandboge <email address hidden>   Thu, 06 Aug 2009 14:02:57 +0000
Obsolete in jaunty-updates on 2013-02-28
Obsolete in jaunty-security on 2013-02-28
Superseded in jaunty-security on 2009-08-07
ia32-libs (2.7ubuntu6.1) jaunty-security; urgency=low

  * SECURITY UPDATE: Refresh packages which pulls in recent NSS fixes and a
    whole bunch of other security updates

 -- Jamie Strandboge <email address hidden>   Thu, 06 Aug 2009 13:57:04 +0000
Superseded in karmic-release on 2009-08-12
ia32-libs (2.7ubuntu8) karmic; urgency=low

  * SECURITY UPDATE: Refresh packages which pulls in recent NSS fixes

 -- Jamie Strandboge <email address hidden>   Thu, 06 Aug 2009 13:51:09 +0000

Available diffs

Superseded in karmic-release on 2009-08-06
ia32-libs (2.7ubuntu7) karmic; urgency=low

  * Update sources.list.deb for karmic.
  * Revert gtk+2.0 change from 2.7ubuntu6, as the underlying bug was fixed
    in gtk+2.0 2.16.1-0ubuntu3.
  * fetch-and-build:
    - Add pulseaudio, since libpulsecore moved there.
    - Drop libcap1, which is now obsolete.
    - Replace libdirectfb-1.0-0 with libdirectfb-1.2-0.
    - Replace libkrb53 with libgssapi-krb5-2, libk5crypto3, libkrb5-3, and
      libkrb5support0.
    - Replace gcc-4.3-base with gcc-4.4-base.
    - Replace python2.5 with libpython2.6.
    - Replace libdb4.6 with libdb4.7.
    - Add libvorbisenc2 for libsndfile1/pulseaudio/pulseaudio-utils.
    - Add libv4l-0 for libsane (but just depend on lib32v4l-0 on amd64).
    - Add libudev0 for pulseaudio.
  * Depend on lib32asound2-plugins on amd64 instead of shipping it (LP:
    #305860).
  * Depend on lib32bz2-1.0 on amd64 instead of shipping it.
  * Freshen packages (LP: #277069, #389510, #393503).

 -- Colin Watson <email address hidden>   Fri, 17 Jul 2009 15:20:02 +0000

Available diffs

Superseded in karmic-release on 2009-08-03
Obsolete in jaunty-release on 2013-02-28
ia32-libs (2.7ubuntu6) jaunty; urgency=low

  * debian/rules: gtk+2.0 has a bug in jaunty that builds it with
    --host=i686-pc-linux-gnu; to mitigate this we ship a
    /usr/lib/gtk-2.0/2.10.0/i686-pc-linux-gnu link instead of the i486 one
    previously used; this change should be reverted in karmic (LP: #364074)

 -- Alexander Sack <email address hidden>   Mon, 20 Apr 2009 11:58:42 +0000

Available diffs

Superseded in jaunty-release on 2009-04-20
ia32-libs (2.7ubuntu5) jaunty; urgency=low

  * Remove the automatically created libstdc++.so symlink, it's not needed.
    g++-4.3-multilib provides the right symlink (LP: #360870)
  * Freshen packages (as of Jaunty RC) (LP: #362939)
  * Drop libfusionsound-1.0-0 which is now obsolete
  * Fix typo in the symlink creation code

 -- Fabien Tassin <email address hidden>   Fri, 17 Apr 2009 18:40:13 +0200

Available diffs

Superseded in jaunty-release on 2009-04-17
ia32-libs (2.7ubuntu4) jaunty; urgency=low

  * fetch-and-build:
    - add libsqlite3-0, needed as a dependency of libnss3-1d (LP: #326311).
    - add libmikmod2 and libsmpeg0 needed as dependencies of libsdl-mixer1.2
      (LP: #154883).
    - add libcanberra-gtk-module and its dependencies (libcanberra-gtk0,
      libcanberra0 and libtdb1)
    - add libsdl-image1.2 and python2.5 (LP: #277454)
    - add missing dependencies:
      - libcelt0 for libjack0
      - libsmbios2 for libhal1
      - libspeexdsp1 and liboil0.3 for libpulsecore9
      - libavahi-common3 and libavahi-client3 for libpulse-browse0
      - libgail18 for libgnomecanvas2-0
    - drop libartsc0, which is now obsolete.
  * debian/rules:
    - automatically create all missing .so symlinks in /lib32 and /usr/lib32 as
      the manual list of links was always out of sync and incomplete
      (LP: #277772, #309841).
  * Freshen packages (as of Jaunty beta1) (LP: #338145, #325098, #337210)

 -- Fabien Tassin <email address hidden>   Fri, 20 Mar 2009 23:48:50 +0100

Available diffs

Superseded in jaunty-release on 2009-03-21
ia32-libs (2.7ubuntu3) jaunty; urgency=low

  * fetch-and-build:
    - add libgdbm3, needed as a dependency of libpulse.  LP: #314739.
    - drop libxcb-xlib0, which is now obsolete.
    - replace libpulsecore8 with libpulsecore9

 -- Steve Langasek <email address hidden>   Tue, 27 Jan 2009 00:34:20 +0000

Available diffs

Superseded in jaunty-release on 2009-01-27
ia32-libs (2.7ubuntu2) jaunty; urgency=low

  * fetch-and-build: (LP: #298611)
    - Added (LP: #249794)
      + libmad0
      + libvorbis0a
      + libvorbisfile3
      + libuuid1
      + libwrap0 (LP: #290533)
      + libgsl0ldbl (LP: #130058)
    - Updated
      - libpulsecore8
  * This (or the last merge) upload closes as well:
    - Provide library symlinks for building 32-bit code (LP: #277772)

 -- Stephan Hermann <email address hidden>   Tue, 16 Dec 2008 09:33:10 +0000

Available diffs

Superseded in jaunty-release on 2008-12-16
ia32-libs (2.7ubuntu1) jaunty; urgency=low

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - fetch-and-build: Add packages we want/need in Ubuntu. This also includes
      SDL and GTK, which are in separate source packages in Debian.
    - fetch-and-build: Do not die on source/binary version mismatch when
      defining $SOURCE_VER_MISMATCH. Useful right after opening a new Ubuntu
      release, when the archive is in heavy flux.
    - sources.list.deb: Debian -> Ubuntu archive apt sources.
    - Compress packages with LZMA:
      + debian/rules: Supply lzma option to dh_builddeb.
      + debian/control: Set appropriate dpkg Pre-Depends.
    - Add debian/{gdk-pixbuf.loaders.32,gtk.immodules.32,pango.modules} and
      install them in debian/rules.
    - debian/rules: Add locale symlink. (LP #126044)
    - debian/rules, debian/ia32-libs.conf: Add /lib32 and /usr/lib32 to ld
      search path.
    - debian/rules: Add rule to autogenerate debian/copyright.
    - debian/copyright: Autogenerated with "debian/rules copyright".

Available diffs

Superseded in jaunty-release on 2008-11-13
Obsolete in intrepid-release on 2013-02-20
ia32-libs (2.2ubuntu18) intrepid; urgency=low

  * fetch-and-build.sh:
    - libcupsys2 -> libcups, unbreaks printing (LP: #276816)
    - Add libdbus-glib-1-2 (LP: #253430)
    - libbluetooth2 -> libbluetooth3 (recent bluez transition).
    - Drop libgnutls13 and libopencdk10, they do not exist any more.

 -- Martin Pitt <email address hidden>   Sun, 26 Oct 2008 20:26:52 +0000

Available diffs

Superseded in intrepid-release on 2008-10-26
ia32-libs (2.2ubuntu17) intrepid; urgency=low

  * fetch-and-build:
    - added libgnutls26 (LP: #277175)

 -- Stephan Hermann <email address hidden>   Wed, 08 Oct 2008 11:56:43 +0000

Available diffs

Superseded in intrepid-release on 2008-10-08
ia32-libs (2.2ubuntu16) intrepid; urgency=low

  * fetch-and-build: (LP: #271550)
    - Skype needs libqt4-xml, here it comes

 -- Stephan Hermann <email address hidden>   Thu, 02 Oct 2008 09:17:58 +0000

Available diffs

Superseded in intrepid-release on 2008-10-02
ia32-libs (2.2ubuntu15) intrepid; urgency=low

  * fetch-and-build.sh: (LP: #271550)
    - replaced libqt4-gui with libqtgui4
    - replaced libqt4-core with libqtcore4

 -- Stephan Hermann <email address hidden>   Wed, 01 Oct 2008 16:16:26 +0000

Available diffs

Superseded in intrepid-release on 2008-10-02
ia32-libs (2.2ubuntu14) intrepid; urgency=low

  * Re-bringing back libqt4
  * fetch-and-build:
    - added libqt4-dbus (LP: #271550)
    - added libqt4-network
    - added libqt4-qt3support (LP: #222934)

 -- Stephan Hermann <email address hidden>   Fri, 26 Sep 2008 18:51:16 +0000

Available diffs

175 of 123 results