Ubuntu

Change log for “ibus” package in Ubuntu

161 of 61 results
Published in trusty-release on 2014-03-27
Deleted in trusty-proposed (Reason: moved to release)
ibus (1.5.5-1ubuntu3) trusty; urgency=medium

  * debian/patches/ubuntu-forward-panel-properties.patch:
    - Augment the panel service D-Bus interface so that external consumers can
      detect when the panel service properties are changed. (LP: #1290881)
 -- William Hua <email address hidden>   Wed, 19 Mar 2014 14:08:29 +1300

Available diffs

Superseded in trusty-release on 2014-03-27
Deleted in trusty-proposed on 2014-03-29 (Reason: moved to release)
ibus (1.5.5-1ubuntu2) trusty; urgency=medium

  * debian/patches/ubuntu-disable-trigger.patch:
    - Disable input method switching under Unity; it's handled by
      gnome-settings-daemon. (LP: #1278511)
 -- William Hua <email address hidden>   Thu, 13 Feb 2014 18:33:46 -0500

Available diffs

Superseded in trusty-release on 2014-02-20
Deleted in trusty-proposed on 2014-02-21 (Reason: moved to release)
ibus (1.5.5-1ubuntu1) trusty; urgency=medium

  * Merge with Debian (LP: #1276143); remaining changes:
    - debian/rules:
      + Build with dh_translations. Add dh-translations build dependency.
    - Add 02_title_update.patch: Rename "IBus Preferences" to "Keyboard Input
      Methods"
    - debian/patches/ibus-no-notification.patch: Don't show the notification
      if not actually upgrading from a previous version. (LP: #1255542).
  * debian/patches/03_dont_run_dconf_update.patch: added
    -  Don't run "dconf update" if $(DESTDIR) is set
      + https://github.com/ibus/ibus/commit/e6ec45d64a32d16245770f8b80e795a63e6ad553
 -- Ikuya Awashiro <email address hidden>   Mon, 03 Feb 2014 22:34:56 +0900

Available diffs

Superseded in trusty-release on 2014-02-08
Deleted in trusty-proposed on 2014-02-09 (Reason: moved to release)
ibus (1.5.4-1ubuntu1) trusty; urgency=medium

  * Merge with Debian; remaining changes:
    - debian/rules:
      + Build with dh_translations. Add dh-translations build dependency.
    - Add 02_title_update.patch: Rename "IBus Preferences" to "Keyboard Input
      Methods"
    - debian/patches/ibus-no-notification.patch: Don't show the notification
      if not actually upgrading from a previous version. (LP: #1255542).

Available diffs

Published in saucy-updates on 2013-12-12
Deleted in saucy-proposed (Reason: moved to -updates)
ibus (1.5.3-6ubuntu2.1) saucy; urgency=low

  * debian/patches/ibus-no-notification.patch: Don't show the notification
    if not actually upgrading from a previous version. (LP: #1255542)
 -- Marc Deslauriers <email address hidden>   Wed, 27 Nov 2013 09:58:12 -0500

Available diffs

Superseded in trusty-release on 2014-01-07
Deleted in trusty-proposed on 2014-01-09 (Reason: moved to release)
ibus (1.5.3-6ubuntu4) trusty; urgency=low

  * debian/patches/ibus-no-notification.patch: Don't show the notification
    if not actually upgrading from a previous version. (LP: #1255542)
 -- Marc Deslauriers <email address hidden>   Wed, 27 Nov 2013 09:07:43 -0500

Available diffs

Superseded in trusty-release on 2013-11-27
Deleted in trusty-proposed on 2013-11-28 (Reason: moved to release)
ibus (1.5.3-6ubuntu3) trusty; urgency=low

  * Use <Ctrl>Space as the shortcut of switching IME forward in ibus,
    avoiding the conflict with g-s-d shortcut handling (LP: #1249208).
 -- Aron Xu <email address hidden>   Fri, 08 Nov 2013 14:32:13 +0800

Available diffs

Superseded in trusty-release on 2013-11-08
Published in saucy-release on 2013-09-11
Deleted in saucy-proposed (Reason: moved to release)
ibus (1.5.3-6ubuntu2) saucy; urgency=low

  * Really run dh_translations
 -- Jeremy Bicha <email address hidden>   Wed, 11 Sep 2013 16:35:29 -0400
Superseded in saucy-proposed on 2013-09-11
ibus (1.5.3-6ubuntu1) saucy; urgency=low

  * Sync with Debian. Remaining changes:
    - debian/rules:
      + Build with dh_translations. Add dh-translations build dependency.
    - Add 02_title_update.patch: Rename "IBus Preferences" to "Keyboard Input
      Methods"

Available diffs

Superseded in saucy-release on 2013-09-11
Deleted in saucy-proposed on 2013-09-13 (Reason: moved to release)
ibus (1.5.3-0ubuntu1) saucy; urgency=low

  [ Jeremy Bicha ]
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + Recommend ibus-gtk | ibus-qt4, ibus-gtk3 | ibus-qt4 instead of
        recommending all of them
      + Suggest ibus-clutter instead of recommending it
      + Depend on dconf-cli instead of dconf-tools
    - debian/rules:
      + Build with dh_translations. Add dh-translations build dependency.
      + Use --disable-silent-rules
    - Add 02_title_update.patch: Rename "IBus Preferences" to "Keyboard Input
      Methods"
    - add ibus-530711-preload-sys.patch: Set default IMEngine.
    - debian/libibus-1.0-5.symbols: Add symbols for above patch
  * New upstream release. Applied patches dropped:
    - the 0001 - 0017 backport patches
    - the format-security patches
  * Dropped changes:
    - debian/patches/05_appindicator.patch and python-appindicator recommends:
      + For Saucy, we'll be using indicator-keyboard instead.

  [ William Hua ]
  * debian/patches/ibus-541492-xkb.patch:
    - Patch from Fedora, needed for the 530711 patch to apply cleanly
  * debian/patches/ibus-530711-preload-sys.patch: Refreshed (from Fedora)
  * debian/patches/disable-input-trigger.patch:
    - Prevent IBus from capturing input source key bindings.

Available diffs

Superseded in saucy-release on 2013-07-29
Published in raring-release on 2013-04-05
Deleted in raring-proposed (Reason: moved to release)
ibus (1.4.2-0ubuntu2) raring; urgency=low

  * Configure with --disable-silent-rules.
  * Fix build failure with -Werror. LP: #1163777.
 -- Matthias Klose <email address hidden>   Wed, 03 Apr 2013 10:24:38 +0200

Available diffs

Superseded in raring-release on 2013-04-05
Deleted in raring-proposed on 2013-04-06 (Reason: moved to release)
ibus (1.4.2-0ubuntu1) raring; urgency=low

  * New upstream release (LP: #1072172)
  * debian/libibus2.symbols:
    - Updated
  * debian/patches/0003-Fix-typoes-in-gtk-doc-comments.patch:
  * debian/patches/0007-Fix-the-coordinate-in-languagebar-when-dual-monitors.patch:
  * debian/patches/0008-Fix-not-to-send-preedit-changed-signal-when-the-pree.patch:
  * debian/patches/0012-Fix-double-unref-when-looping-over-attachment.patch:
  * debian/patches/0013-Fix-a-typo.patch:
  * debian/patches/g-ir-scanner-pkg-export.patch:
    - Applied upstream
 -- Robert Ancell <email address hidden>   Fri, 23 Nov 2012 09:28:43 +1300

Available diffs

Superseded in raring-release on 2012-11-22
Deleted in raring-proposed on 2012-11-24 (Reason: moved to release)
ibus (1.4.1-9ubuntu1) raring; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/control: Install im-switch instead of im-config by default.
    - debian/rules: Build with dh_translations. Add dh-translations build
      dependency.
    - Add 02_title_update.patch: Rename "IBus Preferences" to "Keyboard Input
      Methods"
    - Add 05_appindicator.patch: Use an indicator rather than a notification
      icon. Add python-appindicator recommends.
    - debian/control: Recommends on ibus-gtk, ibus-qt4, ibus-clutter need to
      be alternatives, because we want derivatives to be able to pick the ones
      they need.
    - add ibus-530711-preload-sys.patch: Set default IMEngine.

Available diffs

Superseded in raring-release on 2012-11-19
Published in quantal-release on 2012-07-30
ibus (1.4.1-7ubuntu1) quantal; urgency=low

  * Merge from Debian unstable (LP: #854333), remaining changes:
    - debian/control: Install im-switch instead of im-config by default.
    - debian/rules: Build with dh_translations. Add dh-translations build
      dependency.
    - Add 02_title_update.patch: Rename "IBus Preferences" to "Keyboard Input
      Methods"
    - Add 05_appindicator.patch: Use an indicator rather than a notification
      icon. Add python-appindicator recommends.
    - debian/control: Recommends on ibus-gtk, ibus-qt4, ibus-clutter need to
      be alternatives, because we want derivatives to be able to pick the ones
      they need.
    - add ibus-530711-preload-sys.patch: Set default IMEngine.
      Taken from Fedora:
      https://bugzilla.redhat.com/show_bug.cgi?id=530711

Available diffs

Superseded in quantal-release on 2012-07-30
Published in precise-release on 2012-03-21
ibus (1.4.1-3ubuntu1) precise; urgency=low

  * Merge from Debian unstable (LP: #961145), remaining changes:
    - debian/control: Install im-switch instead of im-config by default.
    - debian/rules: Build with dh_translations. Add dh-translations build
      dependency.
    - Add 02_title_update.patch: Rename "IBus Preferences" to "Keyboard Input
      Methods"
    - Add 05_appindicator.patch: Use an indicator rather than a notification
      icon. Add python-appindicator recommends.
    - debian/control: Recommends on ibus-gtk, ibus-qt4, ibus-clutter need to
      be alternatives, because we want derivatives to be able to pick the ones
      they need.
    - add ibus-530711-preload-sys.patch: Set default IMEngine (LP: #944035).
      Taken from Fedora:
      https://bugzilla.redhat.com/show_bug.cgi?id=530711

Available diffs

Superseded in precise-release on 2012-03-21
ibus (1.4.1-1ubuntu3) precise; urgency=low

  * debian/patches/ibus-530711-preload-sys.patch:
    - Set default IMEngine (LP: #944035).
    - Taken from Fedora.
      https://bugzilla.redhat.com/show_bug.cgi?id=530711
 -- Ikuya Awashiro <email address hidden>   Fri, 16 Mar 2012 17:18:35 +0900

Available diffs

Superseded in precise-release on 2012-03-16
ibus (1.4.1-1ubuntu2) precise; urgency=low

  * debian/patches/05_appindicator.patch: tweak the id so the fallback icon
    gets the same name as the normal gtkstatusicon (lp: #885080)
 -- Sebastien Bacher <email address hidden>   Fri, 09 Mar 2012 22:23:18 +0100

Available diffs

Superseded in precise-release on 2012-03-09
ibus (1.4.1-1ubuntu1) precise; urgency=low

  * Merge from Debian unstable, remaining changes:
    - debian/control: Install im-switch instead of im-config by default.
    - debian/rules: Build with dh_translations. Add dh-translations build
      dependency.
    - Add 02_title_update.patch: Rename "IBus Preferences" to "Keyboard Input
      Methods"
    - Add 05_appindicator.patch: Use an indicator rather than a notification
      icon. Add python-appindicator recommends.
    - debian/control: Recommends on ibus-gtk, ibus-qt4, ibus-clutter need to
      be alternatives, because we want derivatives to be able to pick the ones
      they need.

Available diffs

Superseded in precise-release on 2012-03-06
ibus (1.4.0-3ubuntu4) precise; urgency=low

  * debian/patches/02_title_update.patch: update to be in line with new Ubuntu
    interface. (LP: #941645)
 -- Jan Simon <email address hidden>   Fri, 02 Mar 2012 09:16:38 +0100

Available diffs

Superseded in precise-release on 2012-03-02
ibus (1.4.0-3ubuntu3) precise; urgency=low

  [ Gabor Kelemen ]
  * Drop 01_ubuntu_desktop, dh-translations will handle this. LP: #907322
 -- Martin Pitt <email address hidden>   Mon, 23 Jan 2012 16:06:39 +0100

Available diffs

Superseded in precise-release on 2012-01-23
ibus (1.4.0-3ubuntu2) precise; urgency=low

  [ Gabor Kelemen ]
  * debian/control, debian/rules:
    - Use dh-translations to build transition template.  LP: #902500
 -- Michael Terry <email address hidden>   Thu, 19 Jan 2012 11:27:04 -0500

Available diffs

Superseded in precise-release on 2012-01-19
ibus (1.4.0-3ubuntu1) precise; urgency=low

  * Merge from Debian unstable, remaining changes:
    - Indicator support:
      + Add 05_appindicator.patch: Use an indicator rather than a notification
        icon.
      + debian/control: Recommend python-appindicator.
    - debian/control: Install im-switch instead of im-config by default.
    - debian/patches/01_ubuntu_desktop: Fix "Desktop entry needs the
      X-Ubuntu-Gettext-Domain key"
    - debian/patches/02_title_update.patch: Rename "IBus Preferences" to
      "Keyboard Input Methods"
    - debian/patches/git_fix_async_key_events.patch: upstream git patch to
      fix some input issues in korean and some other languages where entering
      a character and space leads to misplaced space
    - Recommends on ibus-gtk, ibus-qt4, ibus-clutter need to be alternatives,
      because we want derivatives to be able to pick the ones they need.
    - drop obsolete debian/pyversions
  * Dropped changes, included in Debian:
    - debian/README.source: Removed, it was outdated and no longer correct
    - debian/xinput/ibus: check for GTK2+ and GTK3+ IMModules separately,
      otherwise the file globbing fails us.
    - mark ibus-gtk Multi-Arch: same.  It won't be coinstallable yet without
      a multiarch libibus, but it doesn't hurt.
    - debian/gtk-ibus.install: look for the gtk module in the multiarch path.
    - configure.ac: look at the gtk+2.0 pkg-config settings for the directory
      we should install the im module to, not our own configured libdir
      setting.
    - debian/control: build-depend on the multiarched gtk+2.0.

Available diffs

Superseded in precise-release on 2011-12-19
ibus (1.4.0-1ubuntu3) precise; urgency=low

  * debian/patches/git_fix_async_key_events.patch:
    - upstream git patch to fix some input issues in korean and some other
      languages where entering a character and space leads to misplaced space
      (lp: #880876)
 -- Sebastien Bacher <email address hidden>   Fri, 16 Dec 2011 15:45:54 +0100

Available diffs

Superseded in precise-release on 2011-12-16
ibus (1.4.0-1ubuntu2) precise; urgency=low

  * debian/patches/05_appindicator.patch: Fix "ibus indicator icon
    does not respect 'show in system tray' preference" (LP: #539057).
 -- Viktor Asklund <email address hidden>   Wed, 26 Oct 2011 01:02:54 +0200

Available diffs

Superseded in precise-release on 2011-10-28
ibus (1.4.0-1ubuntu1) precise; urgency=low

  * Merge from Debian unstable, remaining changes:
    - Indicator support:
      + Add 05_appindicator.patch: Use an indicator rather than a notification
        icon.
      + debian/control: Recommend python-appindicator.
    - debian/control: Install im-switch instead of im-config by default.
    - debian/README.source: Removed, it was outdated and no longer correct
    - debian/patches/01_ubuntu_desktop: Fix "Desktop entry needs the
      X-Ubuntu-Gettext-Domain key"  (LP: #457632)
    - debian/patches/02_title_update.patch: Rename "IBus Preferences" to
      "Keyboard Input Methods"
    - debian/xinput/ibus: check for GTK2+ and GTK3+ IMModules separately,
      otherwise the file globbing fails us.
    - configure.ac: look at the gtk+2.0 pkg-config settings for the directory
      we should install the im module to, not our own configured libdir
      setting.
    - debian/control: build-depend on the multiarched gtk+2.0.
    - debian/gtk-ibus.install: look for the gtk module in the multiarch path.
    - mark ibus-gtk Multi-Arch: same.  It won't be coinstallable yet without
      a multiarch libibus, but it doesn't hurt.
  * Dropped changes, included upstream:
    - debian/patches/06_locale_parser.patch

Superseded in precise-release on 2011-10-18
Published in oneiric-release on 2011-08-20
ibus (1.3.99.20110419-1ubuntu3) oneiric; urgency=low

  * debian/xinput/ibus: check for GTK2+ and GTK3+ IMModules separately,
    otherwise the file globbing fails us.  Thanks to Ikuya Awashiro
    <email address hidden> for the initial patch.  LP: #823202.

  [ Ikuya Awashiro ]
  * debian/patches/05_appindicator.patch: fix crash issue.  LP: #828833.
 -- Steve Langasek <email address hidden>   Sat, 20 Aug 2011 11:07:06 -0700
Superseded in oneiric-release on 2011-08-20
ibus (1.3.99.20110419-1ubuntu2) oneiric; urgency=low

  * configure.ac: look at the gtk+2.0 pkg-config settings for the directory
    we should install the im module to, not our own configured libdir
    setting.
  * debian/control: build-depend on the multiarched gtk+2.0.
  * debian/gtk-ibus.install: look for the gtk module in the multiarch path.
    LP: #646954.
  * mark ibus-gtk Multi-Arch: same.  It won't be coinstallable yet without
    a multiarch libibus, but it doesn't hurt.
 -- Steve Langasek <email address hidden>   Thu, 18 Aug 2011 22:46:53 +0000
Superseded in oneiric-release on 2011-08-19
ibus (1.3.99.20110419-1ubuntu1) oneiric; urgency=low

  * Merge with Debian unstable.  Remaining Ubuntu changes:
    - Indicator support:
      + Add 05_appindicator.patch: Use an indicator rather than a notification
        icon.
      + debian/control: Recommend python-appindicator.
    - debian/control: Install im-switch instead of im-config by default.
    - debian/README.source: Removed, it was outdated and no longer correct
    - debian/patches/01_ubuntu_desktop: Fix "Desktop entry needs the
      X-Ubuntu-Gettext-Domain key"  (LP: #457632)
    - debian/patches/02_title_update.patch: Rename "IBus Preferences" to
      "Keyboard Input Methods"
    - debian/patches/06_locale_parser.patch: Cherry-picked from upstream.
 -- Barry Warsaw <email address hidden>   Thu, 11 Aug 2011 17:00:57 -0400
Superseded in oneiric-release on 2011-08-12
ibus (1.3.9-2ubuntu2) oneiric; urgency=low

  * Switch to dh_python2. (LP: 788514)
 -- Barry Warsaw <email address hidden>   Thu, 21 Jul 2011 16:55:49 -0400

Available diffs

Superseded in oneiric-release on 2011-07-21
ibus (1.3.9-2ubuntu1) oneiric; urgency=low

  * Merge with Debian unstable to get GTK 3 support (LP: #789882). Remaining
    Ubuntu changes:
    - Indicator support:
      + Add 05_appindicator.patch: Use an indicator rather than a notification
        icon.
      + debian/control: Recommend python-appindicator.
    - debian/control: Install im-switch instead of im-config by default.
    - debian/README.source: Removed, it was outdated and no longer correct
    - debian/patches/02_title_update.patch: Rename "IBus Preferences" to
      "Keyboard Input Methods"
    - debian/patches/06_locale_parser.patch: Cherry-picked from upstream.

Available diffs

Superseded in oneiric-release on 2011-07-11
ibus (1.3.9-1ubuntu1) oneiric; urgency=low

  * Resynchronize on Debian
  * debian/control:
    - recommends python-appindicator.
    - re-order recommends on ibus to install im-switch by default.
  * debian/README.source
    - Removed, it was outdated and no longer correct
  * debian/patches/02_title_update.patch:
    - rename "IBus Preferences" to "Keyboard Input Methods"
  * debian/patches/05_appindicator.patch:
    - use an indicator rather than a notification icon
  * debian/patches/06_locale_parser.patch:
    - cherry-picked from upstream
 -- Sebastien Bacher <email address hidden>   Mon, 23 May 2011 17:49:35 +0200

Available diffs

Superseded in oneiric-release on 2011-05-23
Obsolete in natty-release on 2013-06-04
ibus (1.3.9-0ubuntu3) natty; urgency=low

  * Re-order recommends on ibus to install im-switch by default.
    This only affects flavours building with universe enabled.
 -- Stephane Graber <email address hidden>   Thu, 03 Mar 2011 23:36:10 -0500

Available diffs

Superseded in natty-release on 2011-03-04
ibus (1.3.9-0ubuntu2) natty; urgency=low

  * debian/patches/06_locale_parser.patch:
    - cherry-picked from upstream
    - use LC_CTYPE instead of LC_ALL in
      bus_ibus_impl_set_default_preload_engines (LP: #716314)
 -- Nobuto MURATA <email address hidden>   Sat, 19 Feb 2011 23:20:33 +0900

Available diffs

Superseded in natty-release on 2011-02-21
ibus (1.3.9-0ubuntu1) natty; urgency=low

  * New upstream release
  * debian/patches/05_appindicator.patch:
    - Refresh to apply
 -- Michael Terry <email address hidden>   Fri, 07 Jan 2011 10:33:02 -0500

Available diffs

Superseded in natty-release on 2011-01-07
ibus (1.3.8-1ubuntu1) natty; urgency=low

  * Resynchronize on Debian
  * debian/control:
    - recommends python-appindicator.
  * debian/README.source
    - Removed, it was outdated and no longer correct
  * debian/patches/02_title_update.patch:
    - rename "IBus Preferences" to "Keyboard Input Methods"
  * debian/patches/05_appindicator.patch:
    - use an indicator rather than a notification icon
  * debian/patches/06_show_menuitem.patch:
    - dropped this Ubuntu patch since the bug seems to indicate the issue is
      solved in the new upstream versions, reopen a bug if that's not the case

Available diffs

Superseded in natty-release on 2010-11-17
ibus (1.3.7-1ubuntu5) natty; urgency=low

  * Version bump for natty upload
 -- Ken VanDine <email address hidden>   Tue, 16 Nov 2010 13:21:39 -0500

Available diffs

Obsolete in maverick-updates on 2013-03-05
Deleted in maverick-proposed on 2013-03-05 (Reason: moved to -updates)
ibus (1.3.7-1ubuntu4) maverick-proposed; urgency=low

  [ Karl Lattimer ]
  * debia/patches/05_appindicator.patch
    - Fixed unresponsive menu, (LP: #645724)
    - Fixed 100% cpu usage properly, (LP: #637671)
    - Fixed focus tracking issue, (LP: #522079)

  [ Ikuya Awashiro ]
  * debian/patches/03_fix1104.patch: added.
    - http://code.google.com/p/ibus/issues/detail?id=1104
    - This patch fixed (LP: #637671) finally.

  [ Ken VanDine ]
  * debian/README.source
    - Removed, it was outdated and no longer correct
 -- Ken VanDine <email address hidden>   Tue, 16 Nov 2010 09:57:35 -0500

Available diffs

Superseded in natty-release on 2010-11-16
Obsolete in maverick-release on 2013-03-05
ibus (1.3.7-1ubuntu3) maverick; urgency=low

  * debian/patches/05_appindicator.patch:
    - updated by Karl Lattimer to fix issues with the previous version...
      (lp: #564034)
  * clean other changes creating issues
 -- Sebastien Bacher <email address hidden>   Fri, 20 Aug 2010 16:52:18 +0200

Available diffs

Superseded in maverick-release on 2010-08-20
ibus (1.3.7-1ubuntu2) maverick; urgency=low

  * debian/patches/05_appindicator.patch:
    - updated by Karl Lattimer, the icon reflect the input method now
      (lp: #564034)
  * debian/patches: rename the changes, dpatch has been replaced with quilt now
 -- Sebastien Bacher <email address hidden>   Fri, 13 Aug 2010 13:48:19 +0200

Available diffs

Superseded in maverick-release on 2010-08-13
ibus (1.3.7-1ubuntu1) maverick; urgency=low

  * Merge from Debian unstable (LP: #611224), remaining changes:
    - debian/control: Add python-appindicator recommends.
    - Patches (adjusted, to work with the new version):
      + 02_title_update.dpatch
      + 05_appindicator.dpatch
      + 06_show_menuitem.dpatch

Superseded in maverick-release on 2010-08-12
ibus (1.2.0.20091215-1ubuntu5) maverick; urgency=low

  * debian/patches/02_title_update.dpatch:
    - rename "IBus Preferences" to "Keyboard Input Methods",
      thanks Joel Auterson for the change (lp: #429986)
 -- Sebastien Bacher <email address hidden>   Wed, 04 Aug 2010 18:19:17 +0200
Superseded in maverick-release on 2010-08-04
Published in lucid-release on 2010-03-27
ibus (1.2.0.20091215-1ubuntu4) lucid; urgency=low

  * 06_show_menuitem.dpatch: show languagebar correctry (LP: #533636)
 -- Ikuya Awashiro <email address hidden>   Sat, 27 Mar 2010 18:57:12 +0100
Superseded in lucid-release on 2010-03-27
ibus (1.2.0.20091215-1ubuntu3) lucid; urgency=low

  * 05_appindicator.dpatch: Updated to show the default icon when there
    is only an icon by absolute path provided by the selected input
    method (lp: #528213)
 -- Jan Arne Petersen <email address hidden>   Fri, 05 Mar 2010 15:03:20 +0100
Superseded in lucid-release on 2010-03-05
ibus (1.2.0.20091215-1ubuntu2) lucid; urgency=low

  * 05_appindicator.dpatch: update from Jan Arne Petersen to fix the application
    indicator menu not being displayed (lp: #528406)
 -- Sebastien Bacher <email address hidden>   Fri, 26 Feb 2010 19:44:25 +0100
Superseded in lucid-release on 2010-02-26
ibus (1.2.0.20091215-1ubuntu1) lucid; urgency=low

  * Add 05_appindicator.dpatch: Add support for Application indicators. Patch
    by Jan Arne Petersen, thanks! (LP: #497878)
  * debian/control: Add python-appindicator recommends.
 -- Martin Pitt <email address hidden>   Mon, 15 Feb 2010 12:24:28 +0100
Superseded in lucid-release on 2010-02-15
ibus (1.2.0.20091215-1) unstable; urgency=low

  * New upstream release.
  * debian/libibus1.symbols: updated
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  01 Jan 2010 10:09:27 +0000
Superseded in lucid-release on 2010-01-01
ibus (1.2.0.20091204-1) unstable; urgency=low

  * New upstream release.
  * debian/libibus1.symbols: updated. 

Superseded in lucid-release on 2009-12-18
ibus (1.2.0.20091024-1) unstable; urgency=low

  * new upstream release.
    - Fix "notification icon should be optional" (LP: #422253)
  * Fix "move im-switch from depends to recommends" (Closes: #551157)
    - debian/control: updated.
  * debian/rules: rewrited.
  * debian/clean: updated.
  * Fix "Desktop entry needs the X-Ubuntu-Gettext-Domain key"  (LP: #457632)
    - debian/control: add dpatch to build-depends.
    - debian/patches/*: added.
    - debian/README.source: added. 
  * debian/rules: ignore test.

Obsolete in karmic-updates on 2013-03-04
Superseded in lucid-release on 2009-12-05
Deleted in karmic-proposed on 2013-03-04 (Reason: moved to -updates)
ibus (1.2.0.20090927-2ubuntu2) karmic-proposed; urgency=low

  * Desktop entry needs the X-Ubuntu-Gettext-Domain key (LP: #457632)
    - bus/ibus.desktop.in: updated.
    - setup/ibus-setup.desktop.in: updated.
 -- LI Daobing <email address hidden>   Sun, 25 Oct 2009 09:40:59 +0800
Superseded in lucid-release on 2009-11-09
Obsolete in karmic-release on 2013-03-04
ibus (1.2.0.20090927-2ubuntu1) karmic; urgency=low

  * debian/control: Turn ANDed ibus-{gtk,qt4} dependency into an OR, to avoid
    installing both. (LP: #449966)

 -- Martin Pitt <email address hidden>   Tue, 13 Oct 2009 21:57:21 +0200
Superseded in karmic-release on 2009-10-13
ibus (1.2.0.20090927-2) unstable; urgency=low

  * create po template when build (LP: #188690)
    - debian/rules: updated.
    - debian/clean: remove pot file when clean.
  * debian/control: build depends on python-rsvg (LP: #432375)

Superseded in karmic-release on 2009-10-12
ibus (1.2.0.20090723-1ubuntu1) karmic; urgency=low

  * remove ibus.desktop (LP: #420282)

 -- LI Daobing <email address hidden>   Tue, 08 Sep 2009 20:54:53 +0800
Superseded in karmic-release on 2009-09-10
Superseded in karmic-release on 2009-08-26
ibus (1.2.0.20090723-1) unstable; urgency=low

  * new upstream release.

Superseded in karmic-release on 2009-07-30
ibus (1.1.0.20090612-1) unstable; urgency=low

  * new upstream release.
  * Fix "python-ibus should depends on iso-codes" (Closes: #532163)
  * debian/libibus0.symbols: update symbols

Superseded in karmic-release on 2009-06-15
ibus (1.1.0.20090508-0ubuntu1) karmic; urgency=low

  * new upstream release (LP: #373976)
  * debian/libibus0.symbols: update symbols

 -- LI Daobing <email address hidden>   Sat, 09 May 2009 13:52:29 +0800
Superseded in karmic-release on 2009-05-09
ibus (1.1.0.20090423-0ubuntu1) karmic; urgency=low

  * new upstream release (LP: #325740)
  * debian/patches/01_typo_in_Makefile_am.dpatch: merged by upstream, removed.
  * no patch needed, remove dpatch from debian/*
  * debian/rules:
    - add "--list-missing --fail-missing" to dh_install, refactor other to make
      this works.
  * debian/xinput/ibus: change XIM_PROGRAM from ibus to ibus-daemon, add
    "--xim" to XIM_ARGS
  * debian/xinput/ibus-qt4: removed.
  * debian/ibus.install: install gconf schemas, lib and autostart.
  * debian/rules: add dh_gconf
  * debian/control:
    - build depends: add intltool, python-dbus, python-gobject-dev,
      libgconf2-dev. remove libqt4-dev, dpatch.
    - package libibus-gtk0 renamed to libibus0.
    - change maintainer's email.
    - bump standards version to 3.8.1.
    - use simple depends on python-dbus.
    - depends of ibus: add python-xdg.
    - package ibus-qt4 removed. (no longer supported)
    - new package libibus-dev.
  * debian/libibus0.symbols: update symbols
  * debian/docs: added

 -- LI Daobing <email address hidden>   Fri, 01 May 2009 10:41:09 +0800
Superseded in karmic-release on 2009-05-04
Obsolete in jaunty-release on 2013-02-28
ibus (0.1.1.20081023-0ubuntu5) jaunty; urgency=low

  * debian/control: Add depends on python-gconf as ibus needs this to run
    correctly. (LP: #358770)

 -- LI Daobing <email address hidden>   Sun, 12 Apr 2009 10:58:27 +0800
Superseded in jaunty-release on 2009-04-19
ibus (0.1.1.20081023-0ubuntu4) jaunty; urgency=low

  * port to python2.6 (LP: #336525)
    - debian/pyversions: change from "2.5" to "2.5-"
    - debian/rules: fix dh_pysupport
  * debian/rules: change "dh_clean -k" to "dh_prep"

 -- LI Daobing <email address hidden>   Mon, 02 Mar 2009 13:03:03 +0800
Superseded in jaunty-release on 2009-03-03
ibus (0.1.1.20081023-0ubuntu3) jaunty; urgency=low

  * debian/rules: add dh_gtkmodules (LP: #314375)
  * debian/control: depends on ${misc:Depends}

 -- LI Daobing <email address hidden>   Tue, 06 Jan 2009 22:29:46 +0800
Superseded in jaunty-release on 2009-01-09
ibus (0.1.1.20081023-0ubuntu2) jaunty; urgency=low

  * ibus should depends on python-ibus (LP: #312428)

 -- LI Daobing <email address hidden>   Tue, 30 Dec 2008 21:26:16 +0800
Superseded in jaunty-release on 2008-12-31
ibus (0.1.1.20081023-0ubuntu1) jaunty; urgency=low

  [ LI Daobing ]
  * Initial release (LP: #292616)

  [ Zhengpeng Hou ]
  * Add myself as an uploader. :)
  * Add im-switch's support, stole it from scim-bridge. :)

 -- Zhengpeng Hou <email address hidden>   Sun, 30 Nov 2008 10:41:05 +0000
161 of 61 results