Unicode support is broken in id3lib.

Bug #54136 reported by TomasHnyk
36
Affects Status Importance Assigned to Milestone
id3lib3.8.3 (Debian)
Fix Released
Unknown
id3lib3.8.3 (Ubuntu)
Undecided
Unassigned
Dapper
Undecided
Unassigned
Edgy
Undecided
Unassigned

Bug Description

Easytag uses id3lib for manipulation mp3 tags. As of version 1.99.12, it checks whether unicode support in id3lib works. It does not work in latest release. Unfortunately, id3lib is unmaintained for some time, s oonly a patch exist, that repairs unicode support. It can be downloaded from easytag sourceforge download page alongside with id3lib: http://easytag.sourceforge.net/ - patch is called patch_id3lib_3.8.3_UTF16_writing_bug.diff. I think it would be great if this patch would be included in Ubuntu - it is so not now, because I compiled latest version of easytag and it complained about it, so I had to compile id3lib with that patch, which was not exactly easy.
Otherwise, I was unable to save tags properly with local chars of my language.

Revision history for this message
PtOLU8zjbZxlgNOiyGyd (lkgdx5kefrptmd7ccufa-deactivatedaccount) wrote :

I confirm the bug as existing in both Dapper and Edgy.

In Dapper, id3lib corrupted several tags that were originally in Chinese and Japanese created under Windows XP, when rewritng the tags and saving the files. Tthe version of EasyTag in Dapper doesn't give you any warning watsoever it just writes happily whatever garbage id3lib spits out.

Revision history for this message
Peter Chabada (ubuntu-chabada) wrote :

[uptodate dapper]

It seems the same (or similar) bug covers many applications (easytag, banshee, rhythmbox, totem...). None of them cannot correctly show non ASCII characters. E.g. in banshee I edit metadata and everything seems ok until I try to play it - than it's again bad. The tag is correctly written, but is not correctly read back (or vice versa). In easytag I have the same problem. Saved id3 tag I can correctly read in e.g. in quotlibet but not in application that saves it!

I think it's serious, because id3lib is widely used and in many countries people wants to use id3 tags with non-ascii characters and they cann't. I have many songs with strange characters and it's very annoying. It's called mojibake - look on http://en.wikipedia.org/wiki/Mojibake. E.g.: Antonín Dvořák -> Antonín Dvořák; or Strážca pečatí -> Strážca pečatÃ.­

Changed in id3lib3.8.3:
status: Unconfirmed → Confirmed
Revision history for this message
Andreas Lloyd (lloydinho) wrote :

Bug has been forwarded to the Debian maintainer. If it is fixed in Debian, it will definitely be added to Ubuntu next time we merge from Debian in Edgy+1. If you want the fix in Edgy, you need to ask a Universe maintainer to add the fix or resync the fixed package from Debian.

Revision history for this message
TomasHnyk (sup) wrote :

THe bug still exists in Edgy, but now it at least warns the user. Let's hope this gets fixed for Feisty...

Revision history for this message
Jeldert (jeldert) wrote :

User "sup" from Ubuntuforums.org wrote a howto about how to solve it: http://ubuntuforums.org/showthread.php?t=287811

Revision history for this message
TomasHnyk (sup) wrote :

That user would be me, I hope the howto will work for someone else beside me. Any response will be apreciated on the forums. Howevr, it is only a workaround, this bug needs more neat and less workdemanding solution, at least I think.

Changed in id3lib3.8.3:
status: Unknown → Unconfirmed
Revision history for this message
Mila Kuchta (kuchta) wrote :

If someone interested I've built the library for edgy with the patch applied.

Revision history for this message
Mila Kuchta (kuchta) wrote :

I've forgotten to increase version number so here is a revised package.

Changed in id3lib3.8.3:
status: Unconfirmed → Fix Released
Revision history for this message
Mila Kuchta (kuchta) wrote :

I've noticed this packages misses the library itself. Therefore this is the correct one.

Revision history for this message
PtOLU8zjbZxlgNOiyGyd (lkgdx5kefrptmd7ccufa-deactivatedaccount) wrote :

This bug is already fixed in Feisty. I think this is a perfect candidate for backporting to Edgy *and* Dapper (please open a new ticket for that). Tagging as closed.

Revision history for this message
PtOLU8zjbZxlgNOiyGyd (lkgdx5kefrptmd7ccufa-deactivatedaccount) wrote :

Fixed in Feisty. Needs backporting (that's a different matter).

Changed in id3lib3.8.3:
status: Confirmed → Fix Released
Revision history for this message
towsonu2003 (towsonu2003) wrote :

> please open a new ticket for that

opened, thanks

Revision history for this message
David Planella (dpm) wrote :

>> please open a new ticket for that

>opened, thanks

Could we have a link to the new bug, please?

Revision history for this message
David Planella (dpm) wrote :

Or do you mean you've created a new "Affects"?

Revision history for this message
David Planella (dpm) wrote :

Confirming, as it is pretty obvious by now that this is happening in Edgy.

I haven't confirmed it on Dapper, since I do not have Dapper installed anymore and cannot verify this.

Changed in id3lib3.8.3:
status: Unconfirmed → Confirmed
Revision history for this message
PtOLU8zjbZxlgNOiyGyd (lkgdx5kefrptmd7ccufa-deactivatedaccount) wrote :

Forgot to include the backporting request number for the record: Bug #72187

Revision history for this message
Colin Watson (cjwatson) wrote :

This seems like more of a candidate for the stable release update process (http://wiki.ubuntu.com/MOTU/SRU) than for backporting.

Michal Ingeli (xyzz)
Changed in id3lib3.8.3:
status: Unconfirmed → Confirmed
Revision history for this message
Michal Ingeli (xyzz) wrote :

this bug still remains in dapper, and because it's LTS, i think, it should be fixed. and there is also a patch available ...
after using patch from easytag project page, noted in the bug description, everything woks just fine

TomasHnyk (sup)
Changed in id3lib3.8.3:
status: Confirmed → Invalid
status: Confirmed → Invalid
Revision history for this message
sunmaker@paran.com (sunmaker-paran) wrote :

<email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.