No indication that a resume from hibernation has begun

Bug #41137 reported by Matt Zimmerman on 2006-04-24
34
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
initramfs-tools (Ubuntu)
Medium
Matt Zimmerman

Bug Description

When resuming from hibernation, I see "Mounting root filesystem..." and then a long pause as hibernation gets into swing.

Instead, it should display a message indicating that a resume is in progress, so that the reason for the delay is explained to the user.

Matt Zimmerman (mdz) on 2006-04-24
Changed in initramfs-tools:
assignee: nobody → adconrad
KarlGoetz (kgoetz) on 2006-05-10
Changed in initramfs-tools:
status: Unconfirmed → Confirmed
Clemens (clast) wrote :

fixed in:

Changes:
 initramfs-tools (0.40ubuntu31) dapper; urgency=low
 .
   * scripts/local-premount/resume: Print a message when a resume is about to
     begin (LP#41137)

Changed in initramfs-tools:
status: Confirmed → Fix Released
Matt Zimmerman (mdz) wrote :

Unfixed in:

initramfs-tools (0.40ubuntu32) dapper; urgency=low

  * Revert 0.40ubuntu31. This isn't as trivial as it should be.

 -- Matt Zimmerman <email address hidden> Sun, 21 May 2006 10:17:50 -0700

Some additional logic is needed to check whether there is actually a hibernated image to resume; with 0.40ubuntu31 the message ended up being printed unconditionally.

Unfortunately, this bug simply didn't get attention early enough, and it's now too late to fix for 6.06LTS.

Changed in initramfs-tools:
status: Fix Released → Confirmed
Tormod Volden (tormodvolden) wrote :

Couldn't the message be changed to something like "Attempting to resume"? It was very nice in -31 to see that the boot was actually come to the resume part, and not being stuck on finding the root partition.

Neither of -31 or -32 are perfect, but with a modified wording, the -31 style would be a little bit better than -32.

On Sun, May 21, 2006 at 09:20:04PM -0000, Tormod Volden wrote:
> Couldn't the message be changed to something like "Attempting to
> resume"? It was very nice in -31 to see that the boot was actually come
> to the resume part, and not being stuck on finding the root partition.
>
> Neither of -31 or -32 are perfect, but with a modified wording, the -31
> style would be a little bit better than -32.

Any such message would be confusing to users, especially on desktop systems
which are very rarely hibernated.

We'll fix it properly the next time around.

--
 - mdz

Adam Conrad (adconrad) wrote :

Dropping the 6.06 milestone, since we're deferring this.

KeithCu (keithcu) wrote :

It would be nice to show status bar as well or % done, because it gives confidence that it is working and making progress during this long operation. SUSE does and it looks professional. I also see my monitor flicker to 3 different sets of horizontal lines and it would be nice to minimize this UI noise.

I run Ubuntu on my laptop and I almost always hibernate, simply because the system "boots" so much faster that way. As for the UI noise, it's not critical in terms of system stability, but it's one of the first things you get to see when resuming the system; probably not the best first impression...

Wladston Viana (wladston) wrote :

I confirm this, and I would also like to add that my monitor display a weird orange pattern when resuming from hibernation.

When I first saw this, I was very scared and thought the system had colapsed :)

Also, I would like to mention this : https://features.launchpad.net/distros/ubuntu/+spec/usplash-hibernation

Matt Zimmerman (mdz) wrote :

This is actually less of an issue now on my laptop, since the sleep light flashes during the resume, but it would still be nice.

Matthew Garrett (mjg59) wrote :

It's supported in uswsusp.

Adam Conrad (adconrad) on 2008-01-23
Changed in initramfs-tools:
assignee: adconrad → nobody
Daniel T Chen (crimsun) wrote :

Resuming from suspend-to-disk with usplash enabled (as per default) gives some sort of a visual indicator (by way of "frozen" progress bar!). Certainly suboptimal, but...

Changed in initramfs-tools:
importance: Medium → Wishlist
Matt Zimmerman (mdz) wrote :

The "frozen" progress bar is indistinguishable from a fault which interrupts the boot sequence, and this is the same problem which was originally reported (though usplash displayed text progress messages at that time).

We already check for the existence of a swsusp image for other reasons, and should be able to communicate to usplash (as a simple text message to start) that a resume is being attempted (and a further indication if it fails).

Changed in initramfs-tools:
importance: Wishlist → Medium
status: Confirmed → Triaged
Matt Zimmerman (mdz) wrote :

I'm attaching a patch showing how I think this old bug could be fixed easily now. I haven't tested it yet.

Changed in initramfs-tools:
assignee: nobody → mdz
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.92bubuntu11

---------------
initramfs-tools (0.92bubuntu11) intrepid; urgency=low

  * scripts/local-premount/resume: Display a message indicating that a resume
    has begun. This is non-localized text, but is better than nothing until
    we can display a graphical indicator. (LP: #41137)

 -- Matt Zimmerman <email address hidden> Thu, 11 Sep 2008 09:26:31 +0100

Changed in initramfs-tools:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers