dapper fails to boot on ITE 8211 based ide controler

Bug #47197 reported by simcha
36
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

Lack of it821x module in initrd.img causes boot failure after instalation of Daper Drake RC (amd64).
One can still fix it:
1. boot from cd
and in terminal type
2. sudo mount /dev/your_pratition /mnt
3. sudo chroot /mnt
4. echo it821x >> /etc/mkinitramfs/modules
5. dpkg-reconfigure linux-image-`uname -r`
6. reboot
In my case partition names changed after reboot so I also needed to change hdg to hdc in /etc/fstab and /boot/grub/menu/lst
Could you include it821x module in default initrd.img file please.
Thx
simcha

Revision history for this message
Ian Levesque (ephemeron) wrote :

I can confirm this bug on an intel i945 chipset, remaking a kernel image is a lot of trouble. The it821x module is also only present on the Desktop CD, not the Alternate, so RAID/LVM installs on systems with this ide controller are very difficult.

Revision history for this message
Donk (donk) wrote : Re: dapper fails to boot on ITE 8212 based ide controler

I have the same problem with my PCI card, the initrd.img doesn't include the it821x module.
And I have test with the alternate CD, the installer doesn't contain the it821x module, and if you want to install a hd plug to an ITE 8211/8212, you must load the it821x module from an USB Drives at the beginning of the install.

Revision history for this message
uk_dave (launchpad-uk-dave) wrote :

I can confirm this as well. I have an ITE8212 PCI card. The Ubuntu 6.06 AMD64 Live CD booted fine and detected my disks, but after installing the system failed to boot. Performing the instructions provided by simcha fixed it for me and it now boots. I also found that my drive letters changed andi needed to update my grub config and /etc/fstab file.

- David

Revision history for this message
MBursill (mik-dccnet) wrote :

I can also confirm this bug.

Due to the popularity of this controller card, I have no doubt that this issue is probably the source to many of the "Mounting root file system" hangs people are seeing.

I was able to resolve the issue following the steps provided by Simcha, however, upon doing an apt-get dist-upgrade, my kernel was updated and my grub menu.lst was reset.

Please fix this bug! It's incredibly annoying!

Revision history for this message
ilcorvo77 (davpan) wrote :

Hi, i have the same problem installing from an Ubuntu 6.06 Live CD. I tried the instructions from Simcha but i still have the problem. You said that, after reboot, the partition names changed. It seems they are the same for me so i don't know what to do. Someone can help me ?

Sorry for my english, i am italian

Revision history for this message
simcha (jtopinski) wrote : Re: [Bug 47197] Re: dapper fails to boot on ITE 8211 based ide controler

Hi,
I can :) Probably something went wrong. Can you:
1. boot from cd
and in terminal type
2. sudo mount /dev/your_pratition /mnt
4. cat /mnt/etc/mkinitramfs/modules | grep it821x
to see if it is there for sure.
if not make steps 3-5 from orginal instruction again watching for errors.
If it module is there and you sure that dpkg step was successful and sure
that you have it821x based card (if not please send me output of lspci)
reboot take cd out and watch carefully for disk controller initialization
I'm not at home right now so I can't tell you exact string to look for.
Hope it helps
simcha
2006/11/6, ilcorvo77 <email address hidden>:
>
> Hi, i have the same problem installing from an Ubuntu 6.06 Live CD. I
> tried the instructions from Simcha but i still have the problem. You
> said that, after reboot, the partition names changed. It seems they are
> the same for me so i don't know what to do. Someone can help me ?
>
> Sorry for my english, i am italian
>
> --
> dapper fails to boot on ITE 8211 based ide controler
> https://launchpad.net/bugs/47197
>

Revision history for this message
ilcorvo77 (davpan) wrote : R: [Bug 47197] Re: dapper fails to boot on ITE 8211 based idecontroler

Hi,

thanks for your reply. At last I tried the livecd of 6.10 version and it
worked !

Bye and thanks again.

-----Messaggio originale-----
Da: <email address hidden> [mailto:<email address hidden>] Per conto di simcha
Inviato: martedì 7 novembre 2006 15.30
A: <email address hidden>
Oggetto: Re: [Bug 47197] Re: dapper fails to boot on ITE 8211 based
idecontroler

Hi,
I can :) Probably something went wrong. Can you:
1. boot from cd
and in terminal type
2. sudo mount /dev/your_pratition /mnt
4. cat /mnt/etc/mkinitramfs/modules | grep it821x
to see if it is there for sure.
if not make steps 3-5 from orginal instruction again watching for errors.
If it module is there and you sure that dpkg step was successful and sure
that you have it821x based card (if not please send me output of lspci)
reboot take cd out and watch carefully for disk controller initialization
I'm not at home right now so I can't tell you exact string to look for.
Hope it helps
simcha
2006/11/6, ilcorvo77 <email address hidden>:
>
> Hi, i have the same problem installing from an Ubuntu 6.06 Live CD. I
> tried the instructions from Simcha but i still have the problem. You
> said that, after reboot, the partition names changed. It seems they are
> the same for me so i don't know what to do. Someone can help me ?
>
> Sorry for my english, i am italian
>
> --
> dapper fails to boot on ITE 8211 based ide controler
> https://launchpad.net/bugs/47197
>

--
dapper fails to boot on ITE 8211 based ide controler
https://launchpad.net/bugs/47197

Donk (donk)
Changed in initramfs-tools:
status: Unconfirmed → Confirmed
Revision history for this message
Christoph Bier (christoph-bier) wrote :

This is still true for Edgy. Will it be fixed in Feisty?

Best wishes
Christoph

Revision history for this message
ilcorvo77 (davpan) wrote : Re: [Bug 47197] Re: dapper fails to boot on ITE 8211 based ide controler

Well, with the Live version of Edgy I solved the problem.

Bye
Davide

----- Original Message -----
From: "Christoph Bier" <email address hidden>
To: <email address hidden>
Sent: Saturday, February 24, 2007 10:06 PM
Subject: [Bug 47197] Re: dapper fails to boot on ITE 8211 based ide
controler

This is still true for Edgy. Will it be fixed in Feisty?

Best wishes
Christoph

--
dapper fails to boot on ITE 8211 based ide controler
https://launchpad.net/bugs/47197

Revision history for this message
Christoph Bier (christoph-bier) wrote :

What did you solve with the live CD? An installation using LVM on a ITE 8211 IDE controller?!

Revision history for this message
ilcorvo77 (davpan) wrote :

----- Original Message -----
From: "Christoph Bier" <email address hidden>
To: <email address hidden>
Sent: Wednesday, February 28, 2007 2:08 PM
Subject: [Bug 47197] Re: dapper fails to boot on ITE 8211 based ide
controler

What did you solve with the live CD? An installation using LVM on a ITE
8211 IDE controller?!

I launched the live then I simply clicked on the "Install" Icon and, on my
system, it worked.

Bye
Davide

Revision history for this message
Christoph Bier (christoph-bier) wrote :

But you're are not using LVM because this is only supported by the alternate cd. And the alternate cd lacks support for ITE 8211 based ide controllers.

Revision history for this message
Christoph Bier (christoph-bier) wrote :

The feisty alternate cd contains the it821x driver (tested with herd 5).

Revision history for this message
Xylo (rey-thom) wrote :

Hi

I tested feisty too.
Mount manualy the it821x module with console mode to install, it's another
age...
(for example opensuse 10.1,10.2 mount automaticaly the raid(s) modules
before start installation)
It's easyer so, more attractive.

Thanks

2007/3/6, Christoph Bier <email address hidden>:
>
> The feisty alternate cd contains the it821x driver (tested with herd 5).
>
> --
> dapper fails to boot on ITE 8211 based ide controler
> https://launchpad.net/bugs/47197
>

Revision history for this message
Christoph Bier (christoph-bier) wrote :

For me there was no need to mount the module manually. It worked out of the box!

Revision history for this message
blackfoxt (blackfoxt) wrote :

I was not able to initialize my ite 8212 raid controller (pci card) with the gutsy gibbon desktop cd. :(

Revision history for this message
maximilian attems (maks-debian) wrote :

Newer initramfs-tools no longer hardcodes list of ata modules, thus shipps it821x inside of the initramfs.
This got fixed from jaunty on.

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers