Change log for jackd2 package in Ubuntu

138 of 38 results
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-03-02
Deleted in bionic-proposed (Reason: moved to release)
jackd2 (1.9.12~dfsg-2) unstable; urgency=medium

  * Source-only re-upload to avoid pre-built amd64 binary

 -- Adrian Knoth <email address hidden>  Sun, 25 Feb 2018 20:41:33 +0100
Superseded in bionic-proposed on 2018-02-28
jackd2 (1.9.12~dfsg-1) unstable; urgency=medium

  * New upstream version 1.9.12~dfsg
  * Drop gcc7 FTBFS patch
  * Drop packed structs patch
  * Drop gcc6 FTBFS patch
  * Refresh/forward-port debian/patches/reproducible-build.patch
  * Bump standards version
  * Update Vcs tags in control.in, too
  * Add missing replaces to debian/control.in
  * Add debian/patches/spelling.patch
  * Add missing build-dependency dh-python to control.in
  * Regenerate control

 -- Adrian Knoth <email address hidden>  Sun, 25 Feb 2018 19:15:44 +0100
Superseded in bionic-release on 2018-03-02
Deleted in bionic-proposed on 2018-03-04 (Reason: moved to release)
jackd2 (1.9.10+20150825git1ed50c92~dfsg-6) unstable; urgency=medium

  * Team upload.

  [ Ondřej Nový ]
  * d/copyright: Use https protocol in Format field.
  * d/control: Set Vcs-* to salsa.debian.org.

  [ Mattia Rizzolo ]
  * Fix FTBFS with GCC 7.  Closes: #853461
  * Revert "libjackserver is a private library and does not need to be exported"
    It may even be a private library, but it's in a public namespace, so it
    needs to be dealt with as public.
    This reverts commit f1b2acff8fc96b2692206ecc2c0ac57043410569.
    Closes: #872831

 -- Mattia Rizzolo <email address hidden>  Thu, 22 Feb 2018 11:51:02 +0100
Superseded in bionic-release on 2018-02-23
Published in artful-release on 2017-10-11
Deleted in artful-proposed (Reason: moved to release)
jackd2 (1.9.10+20150825git1ed50c92~dfsg-5ubuntu1) artful; urgency=medium

  * Merge with Debian; remaining changes:
    - libjacknet strict shlibs that don't claim compatibility with anything
      but the current version of the package.
  * Fix FTBFS with GCC 7.

Superseded in artful-release on 2017-10-11
Published in zesty-release on 2016-10-18
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
jackd2 (1.9.10+20150825git1ed50c92~dfsg-2ubuntu2) yakkety; urgency=medium

  * No-change rebuild for readline soname change.

 -- Matthias Klose <email address hidden>  Sat, 17 Sep 2016 12:04:38 +0000
Superseded in yakkety-release on 2016-09-18
Deleted in yakkety-proposed on 2016-09-20 (Reason: moved to release)
jackd2 (1.9.10+20150825git1ed50c92~dfsg-2ubuntu1) yakkety; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - libjacknet strict shlibs that don't claim compatibility with anything
      but the current version of the package.

Superseded in yakkety-release on 2016-07-28
Published in xenial-release on 2015-10-29
Deleted in xenial-proposed (Reason: moved to release)
jackd2 (1.9.10+20150825git1ed50c92~dfsg-1ubuntu1) xenial; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - libjacknet strict shlibs that don't claim compatibility with anything
      but the current version of the package.
  * Dropped changes:
    - conflicts/replaces against the reverted g++5 package name, no longer
      needed after wily release.

Superseded in xenial-release on 2015-10-29
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
jackd2 (1.9.10+20140719git3eb0ae6a~dfsg-3ubuntu1) wily; urgency=medium

  * Merge from Debian unstable, remaining changes:
    - libjacknet strict shlibs that don't claim compatibility with anything
      but the current version of the package.
    - retain conflicts/replaces against the reverted g++5 package name.

Superseded in wily-release on 2015-08-13
Deleted in wily-proposed on 2015-08-14 (Reason: moved to release)
jackd2 (1.9.10+20140719git3eb0ae6a~dfsg-2ubuntu4) wily; urgency=medium

  * Reintroduce libjacknet shlibs, required to fix a build failure; but make
    sure they don't claim compatibility with anything but the current version
    of the package.

 -- Steve Langasek <email address hidden>  Tue, 11 Aug 2015 19:07:52 +0000
Superseded in wily-proposed on 2015-08-11
jackd2 (1.9.10+20140719git3eb0ae6a~dfsg-2ubuntu3) wily; urgency=medium

  * Revert the package rename; the C++ library is not exposed as part of the
    API, it's only used internally and Debian omitted this transition.
  * Drop shlibs for libjacknet added in previous release, this is a private
    library deliberately omitted by the shlibs upstream and there is already
    a lintian override for this.

 -- Steve Langasek <email address hidden>  Tue, 11 Aug 2015 16:22:30 +0000
Superseded in wily-proposed on 2015-08-11
jackd2 (1.9.10+20140719git3eb0ae6a~dfsg-2ubuntu2) wily; urgency=medium

  * Build using GCC 5.
  * Rename libjack-jackd2-0 to libjack-jackd2-0v5. Addresses: #791080.
  * Add Breaks/Replaces to the old library.

 -- Matthias Klose <email address hidden>  Wed, 15 Jul 2015 11:20:40 +0200
Superseded in wily-release on 2015-08-12
Deleted in wily-proposed on 2015-08-14 (Reason: moved to release)
jackd2 (1.9.10+20140719git3eb0ae6a~dfsg-2ubuntu1) wily; urgency=medium

  * Add libjacknet to the shlibs file. Closes: #788973.

 -- Matthias Klose <email address hidden>  Wed, 15 Jul 2015 11:16:34 +0200
Superseded in wily-release on 2015-07-15
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
jackd2 (1.9.10+20140719git3eb0ae6a~dfsg-2) unstable; urgency=medium


  * Fix FTBFS with clang (Closes: #757820)
  * Add Turkish translation (Closes: #760066)
  * Pass dpkg-buildflags to waf (Closes: #756174)

 -- Adrian Knoth <email address hidden>  Wed, 24 Sep 2014 21:48:32 +0200
Superseded in vivid-release on 2014-11-14
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
jackd2 (1.9.10+20140610git97e0e80b~dfsg-1ubuntu1) utopic; urgency=medium

  * Fix debian/rules to pass dpkg-buildflags through.
 -- Steve Langasek <email address hidden>   Sat, 26 Jul 2014 22:40:42 -0700
Superseded in utopic-release on 2014-07-27
Deleted in utopic-proposed on 2014-07-28 (Reason: moved to release)
jackd2 (1.9.10+20140610git97e0e80b~dfsg-1) unstable; urgency=low


  * Imported Upstream version 1.9.10+20140610git97e0e80b~dfsg

 -- Adrian Knoth <email address hidden>  Tue, 10 Jun 2014 13:35:58 +0000
Superseded in utopic-release on 2014-06-10
Deleted in utopic-proposed on 2014-06-12 (Reason: moved to release)
jackd2 (1.9.9.5+20140404git3d7c67dc~dfsg-1) unstable; urgency=low


  * Enable ffado on all Linux platforms (Closes: #727248)
  * Imported Upstream version 1.9.9.5+20140404git3d7c67dc
  * Fix startup problems on newer ARM kernels

 -- Adrian Knoth <email address hidden>  Fri, 04 Apr 2014 14:04:15 +0200
Superseded in utopic-release on 2014-05-05
Published in trusty-release on 2013-10-21
Deleted in trusty-proposed (Reason: moved to release)
jackd2 (1.9.9.5+20130622git7de15e7a-1ubuntu1) trusty; urgency=low

  * Build-depend on libffado on any linux architecture.
 -- Matthias Klose <email address hidden>   Sat, 19 Oct 2013 18:03:16 +0200
Superseded in trusty-release on 2013-10-21
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
jackd2 (1.9.9.5+20130622git7de15e7a-1) unstable; urgency=low


  [ Jonas Smedegaard ]
  * Add README.source emphasizing control.in file as *not* a show-stopper for contributions, referring to wiki page for details.

  [ Adrian Knoth ]
  * Don't fail in postinst after skipping debconf dialog (Closes: #688202)
  * Imported Upstream version 1.9.9.5+20130622git7de15e7a
  * Recompiling fixes netone backend (Closes: #709550)
  * Drop no-selfconnect.patch
  * Drop obsolte DMUA flag
  * Bump standards version to 3.9.4

 -- Adrian Knoth <email address hidden>  Sat, 22 Jun 2013 12:38:35 +0200
Published in precise-updates on 2013-04-09
Deleted in precise-proposed (Reason: moved to -updates)
jackd2 (1.9.8~dfsg.1-1ubuntu2) precise-proposed; urgency=low

  * Add jackdbus-stop-fix.patch: Fix jackdbus being left unresponsively in the
    background, when attempting to stop it. (LP: #956438)
 -- Kaj Ailomaa <email address hidden>   Mon, 18 Mar 2013 16:25:32 +0100
Obsolete in quantal-updates on 2015-04-24
Deleted in quantal-proposed on 2015-05-01 (Reason: moved to -updates)
jackd2 (1.9.8~dfsg.4+20120529git007cdc37-2ubuntu2) quantal-proposed; urgency=low

  * Add jackdbus-stop-fix.patch: Fix jackdbus being left unresponsively in the
    background, when attempting to stop it. (LP: #956438)
 -- Kaj Ailomaa <email address hidden>   Mon, 18 Mar 2013 17:05:45 +0100
Superseded in saucy-proposed on 2013-06-25
jackd2 (1.9.9.5+20130306git47f3a68c-1) experimental; urgency=low


  [ upstream ]
  * New upstream release.

  [ Jonas Smedegaard ]
  * Update and improve get-orig-source target:
    + Update to use github.com URLs in watch file and CDBS hints.
    + Simplify to strip all *.a, .dll and *.Lib files (i.e. catch *.a
      files also below windows dir, and skip lower-case *.lib files).
    + Extend to strip waf file.
    + Update copyright file Source and Excluded-Files fields.
    + Add comment in rules file on how to do git snapshots.
    + Drop obsolete make_tarball.sh script.
  * Add patch to reapply stripped-from-source waflib as unpacked source
    and add waf-light.
  * Build-depend on libopus-dev.
  * Use anonscm.debian.org for Vcs-Browser field.
  * Drop pre-squeeze conffile cleanup in preinst.
  * Tidy bash-completion file:
    + Use tab indentation.
    + Strip excess space.
  * Remove debian/source/local-options: abort-on-upstream-changes and
    unapply-patches are default in dpkg-source since 1.16.1.
  * Rewrite copyright file using file format 1.0.
    + Cover new/changed files, and extend some copyrights.

  [ Adrian Knoth ]
  * Imported Upstream version 1.9.9.5+20130306git47f3a68c
  * Invoke ./waf-light instead of ./waf

 -- Adrian Knoth <email address hidden>  Wed, 06 Mar 2013 14:44:55 +0100
Superseded in saucy-release on 2013-10-09
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
jackd2 (1.9.9.5+20130127git15950eb1-1) experimental; urgency=low


  * Imported Upstream version 1.9.9.5+20130127git15950eb1
  * Refresh no-selfconnect.patch

 -- Adrian Knoth <email address hidden>  Sun, 27 Jan 2013 13:50:55 +0100
Superseded in raring-release on 2012-12-22
Deleted in raring-proposed on 2012-12-23 (Reason: moved to release)
jackd2 (1.9.8~dfsg.4+20120529git007cdc37-4.1ubuntu2) raring; urgency=low

  * debian/patches/jackdbus_stop-fix.patch: fix an issue where jackdbus is
    left unresponsively running in the background when stopped (LP: #956438)
 -- Kaj Ailomaa <email address hidden>   Thu, 15 Nov 2012 12:41:09 +0100
Superseded in raring-release on 2013-02-25
Deleted in raring-proposed on 2013-02-27 (Reason: moved to release)
jackd2 (1.9.8~dfsg.4+20121110git67ac4440-1) experimental; urgency=low


  * Imported Upstream version 1.9.8~dfsg.4+20121110git67ac4440
    (Closes: #682792)
  * Fix FTBFS on ppc64 (Closes: #684470)
  * Switch to dh_python2 (Closes: #676922)
  * Refresh no-selfconnect.patch

 -- Adrian Knoth <email address hidden>  Sat, 10 Nov 2012 11:01:03 +0100
Superseded in raring-release on 2012-11-20
Deleted in raring-proposed on 2012-11-21 (Reason: moved to release)
jackd2 (1.9.8~dfsg.4+20120529git007cdc37-4.1ubuntu1) raring; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Mangle wscript to make the build work with --as-needed
    - Build using dh_python2
  * Include pointer to upstream commit of the above accepted patch.

Superseded in raring-release on 2012-10-29
Obsolete in quantal-release on 2015-04-24
jackd2 (1.9.8~dfsg.4+20120529git007cdc37-2ubuntu1) quantal; urgency=low

  * Merge from Debian, remaining changes:
    - Mangle wscript to make the build work with --as-needed
    - Build using dh_python2
  * Clean up --as-needed patch to be more upstreamable
 -- Adam Conrad <email address hidden>   Fri, 03 Aug 2012 00:16:40 -0600
Superseded in quantal-release on 2012-08-03
jackd2 (1.9.8~dfsg.4+20120529git007cdc37-1ubuntu2) quantal; urgency=low

  * Mangle wscript to make the build work with --as-needed
 -- Adam Conrad <email address hidden>   Sun, 22 Jul 2012 07:16:07 -0600
Superseded in quantal-release on 2012-07-22
jackd2 (1.9.8~dfsg.4+20120529git007cdc37-1ubuntu1) quantal; urgency=low

  * Resynchronize on Debian, remaining diff:
    - Build using dh_python2

Superseded in quantal-release on 2012-07-19
Published in precise-release on 2012-02-10
jackd2 (1.9.8~dfsg.1-1ubuntu1) precise; urgency=low

  * Merge from debian unstable (LP: #911342), remaining changes:
    - Drop libcelt build dependency
    - debian/gbp.conf: Set debian-branch to ubuntu
    - Drop dh-buildinfo build-dependency; this creates conflicting
      per-architecture buildinfo.gz files that prevent multiarch
      co-installability, and all this information is already available in the
      build logs.
    - Build for multiarch. LP: #861025.
    - Build using dh_python2
 -- Artem Popov <email address hidden>   Fri, 10 Feb 2012 18:50:04 +0700
Superseded in precise-release on 2012-02-10
jackd2 (1.9.7~dfsg-1ubuntu3) precise; urgency=low

  * Build using dh_python2
 -- Matthias Klose <email address hidden>   Sat, 17 Dec 2011 12:33:33 +0000
Superseded in precise-release on 2011-12-17
Obsolete in oneiric-release on 2015-04-24
jackd2 (1.9.7~dfsg-1ubuntu2) oneiric; urgency=low

  * Drop dh-buildinfo build-dependency; this creates conflicting
    per-architecture buildinfo.gz files that prevent multiarch
    co-installability, and all this information is already available in the
    build logs.
  * Build for multiarch.  LP: #861025.
 -- Steve Langasek <email address hidden>   Wed, 28 Sep 2011 05:55:59 +0000
Superseded in oneiric-release on 2011-09-28
jackd2 (1.9.7~dfsg-1ubuntu1) oneiric; urgency=low

  * Merge from debian experimental, remaining changes:
    - Drop libcelt build dependency
    - debian/gbp.conf: Set debian-branch to ubuntu

Superseded in oneiric-release on 2011-08-08
Obsolete in natty-release on 2013-06-04
jackd2 (1.9.6~dfsg.1-5ubuntu1) natty; urgency=low

  * Merge from debian experimental, remaining changes:
    - Drop libcelt build dependency
    - debian/gbp.conf: Set debian-branch to ubuntu
 -- Luke Yelavich <email address hidden>   Mon, 14 Feb 2011 20:28:17 +1100
Superseded in natty-release on 2011-02-14
jackd2 (1.9.6~dfsg.1-3ubuntu1) natty; urgency=low

  * Merge from debian unstable, remaining changes:
    - Drop libcelt build dependency
    - debian/gbp.conf: Set debian-branch to ubuntu

Superseded in natty-release on 2010-11-23
jackd2 (1.9.6~dfsg-1ubuntu1) natty; urgency=low

  * Merge from debian unstable, remaining changes:
    - Drop libcelt build dependency
    - debian/gbp.conf: Set debian-branch to ubuntu

Superseded in natty-release on 2010-10-27
Obsolete in maverick-release on 2013-03-05
Superseded in maverick-release on 2010-09-06
jackd2 (1.9.5~dfsg-19ubuntu1) maverick; urgency=low

  * Merge from debian unstable, remaining changes:
    - Drop libcelt build dependency
  * debian/gbp.conf: Set debian-branch to ubuntu

Superseded in maverick-release on 2010-08-09
jackd2 (1.9.5~dfsg-17ubuntu1) maverick; urgency=low

  * debian/control: Drop libcelt build dependency, in preparation for jackd2
    moving to main
 -- Luke Yelavich <email address hidden>   Tue, 20 Jul 2010 16:39:44 +0200
Superseded in maverick-release on 2010-07-20
jackd2 (1.9.5~dfsg-17) unstable; urgency=low

  * Augment sigsegv.c patch to support SH4 CPUs (Closes: #588124)
  * Make RTPRIO handling more robust (allow users to delete audio.conf)

138 of 38 results