jackd2 1.9.5~dfsg-17 source package in Ubuntu

Changelog

jackd2 (1.9.5~dfsg-17) unstable; urgency=low

  * Augment sigsegv.c patch to support SH4 CPUs (Closes: #588124)
  * Make RTPRIO handling more robust (allow users to delete audio.conf)

jackd2 (1.9.5~dfsg-16) experimental; urgency=low

  * reupload to experimental

jackd2 (1.9.5~dfsg-15) unstable; urgency=low

  [ Adrian Knoth ]
  * Also provide the shlibs file for libjack-jackd2-0
  * Fix FTBFS on sparc64 (Closes: #586257)

  [ Reinhard Tartler ]
  * jackd must not be a virtual package, use 'jack-daemon' for that
  * add breaks/replaces on old libjack0
  * change shlibsfile to prefer jackd2's libjack
  * use conflicts instead of breaks. libjack-jackd2-0 has file conflicts
    with libjack0 and will keep it

  [ Jonas Smedegaard ]
  * Update control file.

jackd2 (1.9.5~dfsg-14) unstable; urgency=low

  * Rename source package to jackd2
  * Don't provide libjack-dev anymore
  * Don't compile libjack0, use libjack-jackd2-0 instead
  * Move inprocess clients from libjack0 into jackd2 package
  * Update to upstream SVN revision 4024

jack-audio-connection-kit (1.9.5~dfsg-13) unstable; urgency=low

  * Fix FTBFS on hppa (Closes: #580824)

jack-audio-connection-kit (1.9.5~dfsg-12) unstable; urgency=low

  * Add -fvisibility=hidden to build flags.
  * Fix FTBFS on hurd

jack-audio-connection-kit (1.9.5~dfsg-11) unstable; urgency=low

  * Don't use Debian provided waf anymore. (Closes: #580363)
  * Drop doxygen build dependency.
  * Update to upstream SVN revision 4008. (uses semaphores on Linux now)

jack-audio-connection-kit (1.9.5~dfsg-10) unstable; urgency=low

  * Fix FTBFS on armel (Closes: #580618)

jack-audio-connection-kit (1.9.5~dfsg-9) unstable; urgency=low

  * Provide fix for GNU/kFreeBSD (Closes: #579465)
  * Conditionally include audioadapter.so on ALSA platforms only.

jack-audio-connection-kit (1.9.5~dfsg-8) unstable; urgency=low

  * Fix endif placement in ia64/alpha patch.

jack-audio-connection-kit (1.9.5~dfsg-7) unstable; urgency=low

  * Update to upstream SVN version 4003
  * Dropping local Debian patches, they are included upstream
  * Add local patch for IA64 and alpha (Closes: #580089)

jack-audio-connection-kit (1.9.5~dfsg-6) unstable; urgency=low

  * Fix more varargs issues on armel and alpha

jack-audio-connection-kit (1.9.5~dfsg-5) unstable; urgency=low

  * Fix FTBFS on alpha and ia64 (Closes: #580089)
  * Fix FTBFS on armel (Closes: #580088)

jack-audio-connection-kit (1.9.5~dfsg-4) unstable; urgency=low

  * Upgrade to svn version r3995. (Closes: bug#548537)
  * Fix FTBFS on kFreeBSD (conditionally enable ALSA) (Closes: bug#579465)
  * Fix FTBFS on powerpc (Closes: bug#579479)
  * Fix FTBFS caused by missing atomic operations (Closes: #579464)
  * Remove outdated documentation (Closes: #577444)

jack-audio-connection-kit (1.9.5~dfsg-3) unstable; urgency=low

  * Fix restructure configure options to only add --firewire on
    supported architectures.
    Closes: bug#579237, thanks to Bastian Blank.
  * Handle library ABI through generalized packaging variable.
  * Bump API to 0.118.0 (from 9.116.2): Jackd2 1.9.4 declared compliance
    this newer version of jackd1, and does not promise backwards
    compatibility.
  * Tighten symbols older than API version to instead follow API: Future
    alternative implementations potentially of older version themselves
    are not assured to be binary compatible.
  * Have libjack-dev provide virtual libjack0.100.0-dev (...again - was
    apparently lost at some point upgrading to jackd2).

jack-audio-connection-kit (1.9.5~dfsg-2) unstable; urgency=low

  * Fix relax shlibs file to libjack0 0.116.2 or newer: library API
    promised upstream to not have changed since.
    Closes: bug#579134, thanks to Reinhard Tartler.
  * Fix rename symbols file to get properly handled by dh_makeshlibs.
  * Fix tighten symbols file to depend at minimum 0.116.2 (not 0.116.0).
  * Suppress lintian error about newly added symbols: Any library
    symbols changing since 0.116.2 supposedly are outside public API.

jack-audio-connection-kit (1.9.5~dfsg-1) unstable; urgency=low

  [ Adrian Knoth ]
  * New upstream version 1.9.5
  * Remove FreeBoB support. Use the FFADO firewire backend instead.
  * Build against FFADO-2.0.0
  * Enable jackdbus
  * Rename jack_rec to jackrec (as done in jackd1)
  * Include (updated) manpages from jackd1

  [ Jonas Smedegaard ]
  * Repackage source:
    + Strip binary code (shared libraries for MacOS X and Windows).
    + Strip unneeded sources copyright-protected without licence.
    + Isolate as patch 0000 changes between tarball release and upstream
      SVN trunk as of revision 3968.
  * Sync control.in with latest hand-edited changes to control.
  * Add myself as uploader.
  * Drop old Vcs-Bzr stanza from control.
  * Fix tighten libasound-dev build-dependency to at least 1.0.18.
  * Lower debhelper build-dependency to 6, to ease backporting (we need
    no newer features anyway).
    Fix bump debhelper compat level to match build-dependency.
  * Update patch handling:
    + Use source format "3.0 (quilt)" (not CDBS simple-patchsys.mk).
    + Unfuzz.
    + Refresh, compacting with quilt --no-timestamps --no-index -pab.
    + Rename with leading number, and add README to source documenting
      micro naming scheme.
    + Add DEP3 header to patch 1001 "earlier connect.diff").
    + Unpatch as last clean target to please both git-buildpackage and
      source format 3.0 (quilt).
  * Update watch file:
    + Track jackd2 releases.
    + Handle DFSG mangling.
    + Add usage hint.
  * Fix non-unix line-ends in PO files.
  * Tidy build routines:
    + Drop install hints automagically handled by CDBS already.
    + Separate configure from build in rules file.
    + Avoid unneeded ifeq construct in rules file.
    + Use single space in multi-line fields of control file.
    + Mention use of 'waf distclean' when upstream ships cleaned source.
    + Fix avoid remove man subdir (clash with dpkg unpatch routine).
  * Drop file user-howto (7 years old, newest version 4 years old, and
    is apparently included in jackd.1 manpage already).
  * Use d-shlibs to resolve development library dependencies.
    Build-depend on d-shlibs.
  * Stop build-depending on scons (upstream use waf now).
  * Use system waf. Build-depend on waf.
      - Strip binary waf file (too risky to blindly invoke, and too much
        hassle unpacking and inspecting properly).
    Stop build-depending on python (only used by local waf now dropped).
  * Recursively-expand a variable and avoid a linewrap in rules file.
  * Enable waf verbose mode (easing porter work).
  * Setup get-orig-source routine:
    + include cdbs snippet upstream-tarball (suppressing its build-
      dependencies unneeded for normal builds, to ease backporting).
    + Repackage source, stripping DFSG-violating files.
  * Rewrite debian/copyright using draft DEP5 rev. 135 format.
  * Track symbols, but relaxed due to uncertainty on public library ABI.

jack-audio-connection-kit (1.9.4+svn3842-2) experimental; urgency=low

  * Fix a problem with jack_connect using a hard coded JACK client name
    and when calling jack_connect or jack_disconnect multiple times in a
    fast sequence, then the subsequent jack_(dis)connect calls fail.

jack-audio-connection-kit (1.9.4+svn3842-1) experimental; urgency=low

  * New upstream release

jack-audio-connection-kit (0.118+svn3796-1) unstable; urgency=low

  [ Jonathan Wiltshire ]
  * Debconf templates and debian/control reviewed by the debian-l10n-
    english team as part of the Smith review project. Closes: #550036
  * Debconf translation updates:
    - Swedish (closes: #550493)
    - Czech (closes: #550499)
    - Vietnamese (closes: #550563)
    - Finnish (closes: #550573)
    - Portugese (closes: #546645, #550574)
    - Italian (closes: #551924)
    - Spanish (closes: #551977)
    - Russian (closes: #552005)
    - French (closes: #552072)

  [ Adrian Knoth ]
  * New upstream release (see NEWS, cmdline args have changed)
  * Drop versioned build dependency for libreadline. (Closes: #553791)
  * Remove Guenter Geiger from Uploaders (Closes: #546951)
  * Build with celt-0.7.0 (Closes: #556821)
  * Debconf translation updates:
    - Japanese (Closes: #552230)
    - German (Closes: #550986)
    - Galician (Closes: #554228)

jack-audio-connection-kit (0.116.2+svn3592-3) unstable; urgency=low

  [ Adrian Knoth ]
  * Include Russian translation (Closes: #539460)
  * Include Czech translation (Closes: #538955)
  * Include Italian translation (Closes: #543514)
  * Actively remove /etc/init.d/jackd (Closes: #538963)
  * Explain new realtime default in the NEWS file (Closes: #539581)
  * Move FreeBoB and FFADO drivers to new package jackd-firewire, so users
    without 1394 devices have fewer dependencies. (Closes: #540891) 
  * Fix FTBFS caused by double-installing the manpages (Closes: #543077)
  * Fix 24bit little endian problem on BE CPUs (Closes: #486308)

jack-audio-connection-kit (0.116.2+svn3592-2) unstable; urgency=low

  [ Adrian Knoth ]
  * Only include alsa_in and alsa_out on Linux kernels. (Closes: #537976)
  * Remove /etc/init.d/jackd. (Closes: #527642, #528851)
  * Remove obsolete jackstart manpage (Closes: 491120)
  * Allow db_input to fail (Closes: #538051)

jack-audio-connection-kit (0.116.2+svn3592-1) unstable; urgency=low

  [ Adrian Knoth ]
  * New upstream version 0.116.2+svn3592. Fixes:
      - segfault in jack_impulse_grabber (Closes: #432208)
      - jack_connect, jack_disconnect error case (Closes: #465073)
      - Fix build issues on Hurd (Closes: #320736)
  * Include updated upstream manpages (Closes: #386466, #521771)
  * Fix lintian warning about libjack-dev's doc-base
  * Include new alsa_in and alsa_out binaries
  * Prompt the user for realtime priority settings (Closes: #507248)
  * Include armel in dependency arch list (Closes: #460084)
  * Update upstream location in control files (Closes: #511239)
  * Enable FFADO firewire audio driver (Closes: #519797)
  * Remove notes about fetchmail in /etc/init.d/jackd (Closes: #530380)
  * Fix building jackd twice in a row (Closes: #527335)
  * Add myself to Uploaders

jack-audio-connection-kit (0.116.1-4) unstable; urgency=low

  * Bugfix: FTBFS on kFreeBSD (Closes: #510127)
  * Remove obsolete debian/control.in file
  * debian/control: Reformat Build-Depends field
  * remove libcap-dev from Build-Depends and Build-Conflits. It was only
    useful for 2.4 kernels, that we don't want to support anymore
    anyways. (Closes: #492628)
  * Redirect stderr in bash completion (Closes: #504488) (LP: #139995)
  * use ${binary:Version} / ${source:Version} in debian/control instead of
    the deprecated ${Source-Version} substvar

jack-audio-connection-kit (0.116.1-3) unstable; urgency=low

  * Don't install *.la files in libjack-dev. (Closes: #510673)
  * Add myself to Uploaders

jack-audio-connection-kit (0.116.1-2) unstable; urgency=low

  * Build-Depend on libsamplerate-dev and libcelt-dev (Closes: #509579)
  * Use su to start jackd from the init script, because start-stop-daemon
    is not pam-aware and doesn't honor the settings of /etc/security/limits.conf
  * Maintainer is now pkg-multimedia, set control field accordingly

jack-audio-connection-kit (0.116.1-1) unstable; urgency=low

  [ Asheesh Laroia ]
  * 11_fix_varargs_to_fix_ftbfs_on_alpha.patch: Add patch to fix alpha 
    build failure by using var args correctly (earlier versions of Jack
    improperly passed the va_list around). The issue is fixed in upstream
    svn r3205. (Closes: #508114)

  [ Free Ekanayaka ]
  * New upstream release

jack-audio-connection-kit (0.115.6-1) unstable; urgency=low

  * New Upstream Version
  * Drop kbsd patch, merged upstream
  * Not using tarball.mk anymore
  * Update synopsis-spelling patch
  * Drop path-max patch, fixed upstream

jack-audio-connection-kit (0.109.2-4) unstable; urgency=low

  * Added init script to start jackd at system startup

jack-audio-connection-kit (0.109.2-3) unstable; urgency=low

  * Included patches and changelog entry from NMU 0.109.2-1.1

jack-audio-connection-kit (0.109.2-2) unstable; urgency=low

  * Support DEB_BUILD_OPTIONS=dopot for optmised re-builds

jack-audio-connection-kit (0.109.2-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Don't use lib64 and so avoid setting the rpath in other packages
    (Closes: #430961)
  * Don't create a debian/tmp/usr/lib/lib64 that points to itself.
  * There is no need to remove rpath's from binaries anymore so
    drop the build dependency on chrpath.

jack-audio-connection-kit (0.109.2-1) unstable; urgency=low

  * New upstream release

jack-audio-connection-kit (0.109.0-1) unstable; urgency=low

  * New upstream release
  * Conflicts with libjack0.80.0-0, removed reference to the
    non existing linux-patch-realtime-preempt (Closes: #445528)
  * Downgraded Recommends jackd to Suggests (Closes: #442814)
  * Fixed broken chunks in debian/patches/09_kbsd.patch

jack-audio-connection-kit (0.103.0-6) unstable; urgency=low

  * debian/jackd.README.Debian:
     - added note about using PAM to jack grant realtime
       privileges (Closes: #425180, #269661)
     - added note about using the realtime-preempt patch
  * debian/control:
     - added libpam-modules to Recommends:
     - moved qjackctl from Suggests: to Recommends:
  * debian/rules:
     - pass --enable-static=yes to ./configure (Closes: #425265)
     - don't enable -m3dnow and -msse on i386 (Closes: #426144)
  * rebuilt against flac 1.1.4 (Closes: #426648)

jack-audio-connection-kit (0.103.0-5) unstable; urgency=low

  * debian/control:
     - build-depend on libfreebob0-dev only on Linux systems, to
       solve FTBFS on GNU/kFreeBSD (closes: #423895)
  * debian/patches:
     - added 09_kbsd.patch, thanks to Petr Salinger
  * debian/rules:
     - removed enable-capabilities, as it was causing excessive
       CPU load when using audacity 1.3.0 with jack via portaudio

jack-audio-connection-kit (0.103.0-4) unstable; urgency=low

  * debian/rules:
     - enable -m3dnow and -msse on i386 and amd64
     - include simple-patchsys.mk before tarball.mk (closes: #422588)
    

jack-audio-connection-kit (0.103.0-3.1) unstable; urgency=low

  * Non-maintainer upload.
  * Drop i386 specific CFLAGS. (closes: #422289)

jack-audio-connection-kit (0.103.0-3) unstable; urgency=low

  * We are not depending anymore from automake (see changelog entry for
    version 0.103.0-1), and now the package builds corretly on a plain
    etch system (Closes: #328133)
  * Enable dynsimd only for amd64 (Closes: #422076)

jack-audio-connection-kit (0.103.0-2) unstable; urgency=low

  * Enabled dynsimd

jack-audio-connection-kit (0.103.0-1) unstable; urgency=low

  * New upstream release
  * Drop patches 04_configure_in_jack_version and 02_release-in-libjack-name
    as suggested by the upstream developers, they will take are of
    possible ABI changes and add the relevant runtime checks
  * Drop patch 11_configure.ac, fixed the lib64 path in debian/rules
  * Drop build-dependency on automake
  * Rename the library and the headers binary packages to reflect
    the fact that they are not anymore version-specific, add dummy
    binary package libjack0.100.0 to provide an upgrade path
  * Bug fix: "libjack0.100.0-0: 04_configure_in_jack_version.patch makes
    add-on installation complicated", thanks to Mario Lang (Closes: #353680).
  * Remove rpath from the binary programs using chrpath
  * Enabled SSE (see http://ardour.org/node/820)

jack-audio-connection-kit (0.102.20-1) experimental; urgency=low

  * New upstream release
  * Deleted patches 10_freebob.patch and 09_jack-ia64.diff, as
    they are part of the new upstream
  * Build-Depend on libfreebob0-dev, thanks to Marcio Roberto
    Teixeira (Closes: #399246).
  * Added myself to Uploaders
  * Updated standards to 3.7.2

jack-audio-connection-kit (0.101.1-2) unstable; urgency=low

  * incorporated patch to fix ia64 atomic operations (closes: #394021)
  * prepared for freebob support by backporting the freebob driver from
    jack svn version. 

jack-audio-connection-kit (0.101.1-1) unstable; urgency=low

  * new upstream release
    + no freebob support since libfreebob is not yet packaged

jack-audio-connection-kit (0.100.7-1) unstable; urgency=low

  * new upstream release

jack-audio-connection-kit (0.100.0-5) unstable; urgency=low

  * debian/bash-completion.d/jackd: updated; see Bug#329806
  * dont depend on libglib1.2-dev; closes: Bug#326212
  * debian/watch: update

jack-audio-connection-kit (0.100.0-4) unstable; urgency=low

  * debian/bash_completion.d/jackd, debian/jackd.install: closes: #319764
    (jackd: bash completion for jack_connect)

jack-audio-connection-kit (0.100.0-3) unstable; urgency=low

  * debian/rules: build with tmpdir=/dev/shm again;
    closes: Bug#321149 (jackd not using /dev/shm as tmpdir)
  * debian/patches/07_path-max.patch: closes: Bug#320736 (Patch to handle
    PATH_MAX-less systems)
  * debian/patches/08_synopsis-spelling.patch: closes: #311465 ('man
    jack_bufsize' typo: "SYNOPSYS")
  * debian/copyright: mention authors as copyright holders and license as
    license and not as copyright; closes: #290186 (Improper copyright file)

jack-audio-connection-kit (0.100.0-2) unstable; urgency=low

  * upload 0.100.0-1 unchanged to unstable

jack-audio-connection-kit (0.100.0-1) experimental; urgency=low

  * new upstream release
  * new SONAME again. noone was using that 0.99.61 from experimental and it
    confuses people.

jack-audio-connection-kit (0.99.61-1) experimental; urgency=low

  * intermediate snapshot release
    + new jack_client_open() interface requiring a new SONAME: 0.99.61
      (although the first incompatible change happened at least in
      0.99.14)
    + debian/patches/04_configure_in_jack_version.patch: updated
  * debian/FAQ: updated from webpage

jack-audio-connection-kit (0.99.0-6) unstable; urgency=high

  * do not use the "[system: linux]" stuff for "Depends"; patch from Daniel
    Schepler <email address hidden>; closes: Bug#295804
  * urgency high due to things in 0.99.0-5
  * debian/control: build against libreadline5-dev

jack-audio-connection-kit (0.99.0-5) unstable; urgency=high

  * debian/patches/01a_force-copy-autogen.sh.patch:
    dont make symlinks for config.{guess,sub}; let cdbs play with it;
    closes: Bug#295284
  * urgency high because the bug is present in testing and will surface as
    soon as the next cdbs gets there
  * debian/control.in, rules: use cdbs' new crazy mechanism of mangling
    control; closes: Bug#272307

jack-audio-connection-kit (0.99.0-4) unstable; urgency=low

  * debian/control.in: added a Recommends: jackd (= ${Source-Version})
    to libjack to express the need to install jackd in order to get a 
    working libjack.

jack-audio-connection-kit (0.99.0-3) unstable; urgency=low

  * moved Junichi to Uploaders and me to Maintainer in debian/control. Thanks,
    Junichi, for your great work reagrding this package!
  * debian/control.in, debian/rules: added kfreebsd-gnu handling;
    thanks to Robert Millan <email address hidden>; closes: Bug#272307
  * debian/control.in: convert "Depends: jackd" into a two-sided conflicts;
    closes: Bug#248665 

jack-audio-connection-kit (0.99.0-2) unstable; urgency=medium

  * upload unchanged to unstable;
  * urgency medium because of important fixes for i586 users (Bug#266975) 
    and NPTL workaround (Bug#266507)

jack-audio-connection-kit (0.99.0-1) experimental; urgency=low

  * new upstream release
    + works around pthread-create bug in glibc (Bug#266507)
    + debian/patches/03_remove-cpp-atomicity.patch,
      debian/patches/07_dont_add_readline_to_LIBS.patch: removed since applied
      upstream
    + --disable-iec61883 since it doesn't compile
  * uplod to experimental to not hinder the other version entering
    testing
  * debian/rules: don't optimize for i686 on i386; closes: Bug#266975

jack-audio-connection-kit (0.98.1-5) unstable; urgency=medium

  * debian/patches/03_remove-cpp-atomicity.patch: use a regular patch for
    removing the atomicity files for sparc and hppa
  * debian/patches/07_dont_add_readline_to_LIBS.patch: added; add a noop to
    prevent linking libjack0.80.0-0 against libreadline4;
    closes: Bug#260954, Bug#260961; urgency medium because this breaks other
    packages' builds
  * correct spelling error in debian/jackd.README.Debian: powerful
  * debian/watch: added

jack-audio-connection-kit (0.98.1-4) unstable; urgency=low

  * debian/rules: remove atomicity.h for hppa and sparc to 
    work around the FTBS; closes: Bug#256221 for now

jack-audio-connection-kit (0.98.1-3) unstable; urgency=low

  * upload experimental version unchanged to unstable

jack-audio-connection-kit (0.98.1-2) experimental; urgency=low

  * debian/shlibs.local: use ${Source-Version}, thanks to Elimar Riesebieter
    <email address hidden>

jack-audio-connection-kit (0.98.1-1) experimental; urgency=low

  * new upstream release
    + fulfills whishes for init.d scripts or other ways of automatically
      starting jackd if applications need it (analogy to esd); 
      set JACK_START_SERVER in your environment to enable it; closes: Bug#169776
    + non-existent function has been removed from the header; closes: Bug#245742
  * debian/FAQ: updated from webpage
  * debian/README.developers: updated from webpage
  * debian/user-howto: updated from webpage

jack-audio-connection-kit (0.96.2-1) experimental; urgency=low

  * new upstream snapshot from CVS branch EXP to test new autoconf structure.
    + also contains new features, does not break binary compatibility
    + probably won't compile on arm because the generic atomicity.h
      implementation is broken.
  * debian/patches/20-check-rc-from-initialize-shm.diff: integrated upstream

jack-audio-connection-kit (0.94.0-4) unstable; urgency=low

  * the "you are never entirely done" release
  * forgot to update debian/shlibs.local

jack-audio-connection-kit (0.94.0-3) unstable; urgency=low

  * libjack0.80.0-dev should indeed be Section: libdevel. I don't know, where
    the actual change disapeared.

jack-audio-connection-kit (0.94.0-2) unstable; urgency=low

  * debian/control: libjack0.80.0-dev is Section: libdevel
  * debian/jackd.README.Debian, debian/rules: 
    + add a lot of documentation and support for setuid jackstart; addresses 
      our part of Bug#229709, which can then be reassigned to wnpp
    + manpages, FAQ, a user-howto and a extensive README.Debian are there;
      closes: Bug#148933
    + add documentation and support for /dev/shm as tmpdir; needs 
      libc6 >= 2.3.2.ds1-11 because they create and mount the tmpfs; 
      closes: Bug#229374
    + added hints to the lowlatency and preempt patches in Debian and to 
      the givertcap patch in AGNULA.
    + add information and pointers to the realtime LSM
  * debian/control:
    + jackd "Suggests: qjackctl, jack-tools, meterbridge, libjackasyn0"
      which create a sufficient and extended toolkit and environment for jackd
    + libjack0.80.0-0: Depends: jackd (= ${Source-Version}), for discussion
      see l.d.o/debian-multimedia
  * debian/patches/20-check-rc-from-initialize-shm.diff: added; addresses the
    remaining notes and finally closes: Bug#234072

jack-audio-connection-kit (0.94.0-1) unstable; urgency=low

  * new upstream release
    + fixes command-line parsing
  * rewrote urls as <http://...> as recommended in RFC 2396, Appendix E
  * JACK 0.75.0 entered testing; uploading to unstable

jack-audio-connection-kit (0.91.1-1) experimental; urgency=low

  * New upstream release
    + does not break binary compatibility
    + enable experimental firewire drivers
      - debian/control: Build-Depends: libraw1394-dev
      - debian/patches/06_iec61883_headers.patch add files missing 
        from tarball
    + obsoletes debian/patches/03_cpuinfo_other_archs.patch
  * debian/FAQ: updated from webpage
  * debian/libjack0.80.0-dev.install: don't install *.la files for
    jack plugins
  * debian/shlibs.local: added: remove duplicate depends on libjack 
    for jackd
  * debian/jack_freewheel.1, debian/jack_bufsize.1: wrote manpages

jack-audio-connection-kit (0.80.0-1) experimental; urgency=low

  * new upstream release; binary compatibility mostly remains, source
    compatibility breaks, chose the new soname; upload to experimental
  * debian/patches/03_cycles-h-other-archs.patch: partially integrated 
    upstream
  * debian/patches/03_cpuinfo_other_archs.patch: parses cpuinfo on other
    architectures by Junichi Uekawa; closes: #207435
  * debian/control: changed <email address hidden> to <email address hidden>

jack-audio-connection-kit (0.75.0-2) unstable; urgency=low

  * Add replaces libjack0.71.2-0 (<< 0.75.0-1), 
    due to moved 'development binaries for plugins'.  
  (closes: #207731)
  * Standards-Version: 3.6.1

jack-audio-connection-kit (0.75.0-1) unstable; urgency=low

  * new upstream release
  * debian/rules: switched to cdbs
    + tarball.mk: great way to ensure the autotools horror doesn't
      pollute the diff
    + simple-patchsys.mk: works great with the dpatches renamed.
    + debian/rules: builds optimized for i386: closes: #202589
      have a nonoptimized version with DEB_BUILD_OPTIONS=noopt as per policy
  * debian/control:
    + use dh-buildinfo
    + new comaintainers Guenter Geiger <email address hidden> and
      Robert Jordens <email address hidden>
    + Standards-Version: 3.6.0: no changes
    + won't change the package name (and release of libjack) again because
      binary compatibility didn't break. JACK_API_CURRENT will be set to 1
      as soon as the new era of binary compatibility starts upstream.
      Then libjack0.71.2 will be named libjack1.
      closes: #205552
    + Build-Depends: libreadline4-dev to build jack_transport
  * debian/lib*.install: moved the jack plugins' development versions
    to libjack0.71.2-dev
  * debian/libjack0.71.2-dev.docs: added README.developers to libjack0.71.2-dev
    and ship it as a file, not as a patch
  * debian/FAQ: updated from webpage
  * 03_cycles-h-other-archs.patch: updated with code from the kernel headers
    that works well for ardour, thus reducing the number of archs where the
    workaround is used to: arm, sparc, m68k
  * debian/jack_load.1, debian/jack_unload.1, debian/jack_transport.1,
    debian/jack_monitor_client.1, debian/jack_simple_client.1: wrote the
    missing manpages.
  * debian/user-howto: added to jackd documentation and updated from webpage

jack-audio-connection-kit (0.71.2-1) unstable; urgency=low

  * New upstream release
  * Update patches:
   04_configure_in_jack_version: update for 0.71.2
   02_version-soname: update.
  * debian/*: manually edit for 0.71.2
   debian/jackd.manpages: use upstream manpages for jackd and jackstart
  * add rules to build jack_md5.h before jackstart
  * FAQ update rules fixed to add changelog entry
  * build in a subdir
  * debian/FAQ: updated from webpage
  * debian/rules: use patch-stamp instead of patch
  * [05_jack_md5h.dpatch] fix jack_md5.h dependency
  * run autoconf2.5/automake1.7 over source

jack-audio-connection-kit (0.50.0-2) UNRELEASED; urgency=low

  * Use dpatch to manage patches.
   01_readme-developers
   02_version-soname
   03_cycles-h
   04_configure_in_jack_version
   - autoconf/automake needs to be re-ran after applying those patches,
  added a rule to do that to debian/rules (auto-run)
  * debian/rules: fix to properly handle autoconf 2.57-generated 
    configure, instead of 2.13

jack-audio-connection-kit (0.50.0-1) unstable; urgency=low

  * New upstream release, new maintainer.
  * Use DESTDIR instead of prefix= in install target.
  * Misc updating, forward-porting of patches, etc.
  * I am keeping the soname convention as it is, since upstream 
    is still not decided on a stable interface.
  * re-run aclocal/autoconf/automake.
  * use w3m instead of lynx to get the FAQ

jack-audio-connection-kit (0.44.0-1) unstable; urgency=low

  * New upstream release (CVS)
  * Re-add some missing binaries and manpages that got lost somehow.

jack-audio-connection-kit (0.40.1-1) unstable; urgency=low

  * New upstream release (CVS)
  * Keep library versioning based on package version although upstream
    doesn't anymore, as long as different "releases" (CVS snapshots
    actually) aren't guaranteed to be binary compatible.
  * JACK now doesn't depend on glib anymore (closes: #154773).

jack-audio-connection-kit (0.38.0-1) unstable; urgency=low

  *  New upstream release (CVS).

jack-audio-connection-kit (0.37.2-1) unstable; urgency=low

  * New upstream release (CVS). 
    
    As there doesn't seem to be a release in sight, and cvs has been on
    it's current status for a while i decided to switch to the cvs
    version. Unfortunately this means recompiling for packages depending
    on libjack again...
  
  * Ship a changelog generated by cvs2cl from the upstream sources.
    Upstream doesn't unfortunately.

jack-audio-connection-kit (0.34.0-6) unstable; urgency=low

  * Added patch for jackrec to build with libsndfile1.
  * debian/control: build-dep on libsndfile1-dev

jack-audio-connection-kit (0.34.0-5) unstable; urgency=low

  * Change address in debian/control as well... 

jack-audio-connection-kit (0.34.0-4) unstable; urgency=low

  * New maintainer email address
  * Applied patch by Junichi Uekawa to remove the unconditional error from
    cycles.h to hopefully enable build on more architectures 
    (closes: #148699).

jack-audio-connection-kit (0.34.0-3) unstable; urgency=low

  * Small manpage updates
  * Added ALSA-related URLs to debian/asound.rc
  * Renamed libjack0 to libjack0.34.0-0 and relaxed shlibs dependency
    (closes: #149687)
  * Removed jack_alsa from shlibs file
  * Fixed FAQ line-length
  * Removed autogen.sh from the diff.gz  
  * debian/rules
    - Avoid stripping of the jackd binary if DEB_BUILD_OPTIONS=nostrip is set
    - Made configure a phony target again
    - Added faq target to fetch the FAQ from the website
  * libjack0.34.0-dev: added dependency on pkg-config (closes: #150089)
  * Removed some of the less useful example clients, upstream will do the
    same in the next release, build-dep on libfltk could be dropped

jack-audio-connection-kit (0.34.0-2) unstable; urgency=low

  * Added more documentation (first step to address #148933)
    - added manpages
    - added w3m -dump'ed version of the FAQ from the website
    - added example .asoundrc
    - remove rather pointless upstream README
  * Applied patch by Junichi Uekawa to enable build on ppc
  * Removed maintainer-only rules from debian/rules

jack-audio-connection-kit (0.34.0-1) unstable; urgency=low

  * Repackaged from scratch. Thanks to Junichi Uekawa for his previous
    work on jack packaging and for useful hints how to get my package into a
    releasable state! (closes: #141450)
  * New upstream release

jack (0.8.0.cvs) unstable; urgency=low

  * cvs update

jack (0.6.0.cvs) unstable; urgency=low

  * CVS Checkout source, packaging it.

jack (0.4.7-1) unstable; urgency=low

  * Initial attempt to create a Debian package out of the Sourceforge
    file release.
 -- ????? ????? <email address hidden>   Wed,  14 Jul 2010 11:22:39 +0100

Upload details

Uploaded by:
Artem Popov on 2010-07-14
Uploaded to:
Maverick
Original maintainer:
Debian Multimedia Maintainers
Architectures:
any
Section:
sound
Urgency:
Very Urgent

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
jackd2_1.9.5~dfsg.orig.tar.gz 2.5 MiB 8be44a0ff6658261c9f221e78128453e6e774e8427fa8c3f83437ecc75ae0701
jackd2_1.9.5~dfsg-17.debian.tar.gz 131.8 KiB 60121ac900d366c4f7fa41429376119a92f6ae5333e5482c9449ca73608dc0f0
jackd2_1.9.5~dfsg-17.dsc 2.4 KiB b8808c69b2f0c14b9f7492fcb60df455626a8bef4cd32b8b6b33655976ce1b8e

View changes file

Binary packages built by this source

jackd2: No summary available for jackd2 in ubuntu maverick.

No description available for jackd2 in ubuntu maverick.

jackd2-firewire: No summary available for jackd2-firewire in ubuntu maverick.

No description available for jackd2-firewire in ubuntu maverick.

libjack-jackd2-0: No summary available for libjack-jackd2-0 in ubuntu maverick.

No description available for libjack-jackd2-0 in ubuntu maverick.

libjack-jackd2-dev: No summary available for libjack-jackd2-dev in ubuntu maverick.

No description available for libjack-jackd2-dev in ubuntu maverick.