junit4 4.12-8 source package in Ubuntu

Changelog

junit4 (4.12-8) unstable; urgency=medium

  * Fixed the build failure with Java 11 (Closes: #912474)
  * Standards-Version updated to 4.2.1

 -- Emmanuel Bourg <email address hidden>  Thu, 01 Nov 2018 12:14:37 +0100

Upload details

Uploaded by:
Debian Java Maintainers on 2018-11-01
Uploaded to:
Sid
Original maintainer:
Debian Java Maintainers
Architectures:
all
Section:
java
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Focal release on 2019-10-18 universe devel
Eoan release on 2019-04-18 universe devel
Disco release on 2018-11-10 universe devel

Builds

Disco: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
junit4_4.12-8.dsc 2.2 KiB 4ae32ffa43a96fa3aa64da2306bbecd04035dbf7f485bef319072dd96e857da2
junit4_4.12.orig.tar.xz 274.1 KiB 88ceb79bafd6871adb1b149712926d6334bd33473c36a7da1c79bb857eeda682
junit4_4.12-8.debian.tar.xz 12.2 KiB db77567d7c40986b113b9a52cfaed9f4dbe568b371902da1d7c369e1deef5b67

Available diffs

No changes file available.

Binary packages built by this source

junit4: JUnit regression test framework for Java

 JUnit is a simple framework to write repeatable tests. It is an
 instance of the xUnit architecture for unit testing frameworks.
 .
 JUnit 4 uses Java 5 features such as generics and annotations. If
 you need compatibility with previous Java versions, you should use
 the junit package (version 3) instead.

junit4-doc: JUnit regression test framework for Java - documentation

 JUnit is a simple framework to write repeatable tests. It is an
 instance of the xUnit architecture for unit testing frameworks.
 .
 JUnit 4 uses Java 5 features such as generics and annotations. If
 you need compatibility with previous Java versions, you should use
 the junit package (version 3) instead.
 .
 This package contains Javadoc API documentation of JUnit 4.