[SRU] kdbus (edgy)

Bug #73780 reported by ville palo
4
Affects Status Importance Assigned to Milestone
kdbus (Ubuntu)
Won't Fix
Low
ville palo

Bug Description

Original bug report: bug #71967 kdbus crashes right away.

kdbus segfaulted always on startup so it wasn't usable at all on edgy.
In order to make kdbus work again on edgy this patch should be uploaded.

Patch has been committed to upstream svn as you can see:
http://websvn.kde.org/trunk/playground/utils/kdbus/src/dbusobject.cpp?rev=605502&view=rev
It is not released yet, though.

The bug was caused by recursive function which didn't properly handle memory de-allocation.

Revision history for this message
ville palo (vi64pa) wrote :
  • - Edit (2.2 KiB, text/plain)
ville palo (vi64pa)
Changed in kdbus:
assignee: nobody → motu-sru
Daniel T Chen (crimsun)
Changed in kdbus:
importance: Undecided → Low
status: Unconfirmed → Needs Info
Revision history for this message
ville palo (vi64pa) wrote :

Added bug number 73780 to changlog

description: updated
Revision history for this message
StefanPotyra (sistpoty) wrote :

The patch in question doesn't look sane, but a closer look (been digging through the code for an hour now) reveals, that it should indeed fix the bug.
The debdiff looks sane though.

+1 from me.

StefanPotyra (sistpoty)
Changed in kdbus:
assignee: motu-sru → vi64pa
Revision history for this message
Reinhard Tartler (siretart) wrote :

+1 - let's test it in -proposed

Revision history for this message
Daniel T Chen (crimsun) wrote :

Looks sane, +1.

Revision history for this message
ville palo (vi64pa) wrote :

Needs sponsor for uploading

Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Wed, 29 Nov 2006 17:59:00 +0200
Source: kdbus
Binary: kdbus
Architecture: source
Version: 0.8.6-0ubuntu2.1
Distribution: edgy-proposed
Urgency: low
Maintainer: Anthony Mercatante <email address hidden>
Changed-By: ville palo <email address hidden>
Description:
 kdbus - D-BUS service browser for KDE
Changes:
 kdbus (0.8.6-0ubuntu2.1) edgy-proposed; urgency=low
 .
   * Added debian/patches/kubuntu_02_fix_segfault.diff. Closes
     malone #71967 and #73780 (segfault on startup)
Files:
 c02df407d55fb8860ceb2d6e054c38fc 617 kde optional kdbus_0.8.6-0ubuntu2.1.dsc
 3788564ff49dfbdcd099ce91d299fed6 4775 kde optional kdbus_0.8.6-0ubuntu2.1.diff.gz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFFgqVa7/o1b30rzoURAtbHAJ4gGCIJuSSVVvmaW7AKzxqh8yJSAwCgta3k
DDcm4Cx95ypt/cMSUkLKPEk=
=7OFC
-----END PGP SIGNATURE-----

Changed in kdbus:
status: Needs Info → In Progress
Revision history for this message
Tollef Fog Heen (tfheen) wrote :

Accepted into edgy-proposed; please solicit testing as perhttps://wiki.ubuntu.com/MOTU/SRU

Changed in kdbus:
status: In Progress → Fix Committed
Revision history for this message
finalbeta (j-greenhouse) wrote :

Before kdbus crashed right away and a KDE bug track window came up.
Now kdbus starts without crashing like that. But freezes up right away.

finalbeta@finalbeta-desktop:~$ kdbus
X Error: BadDevice, invalid or uninitialized input device 168
  Major opcode: 148
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 168
  Major opcode: 148
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
Link points to "/tmp/ksocket-finalbeta"
Link points to "/tmp/kde-finalbeta"
X Error: BadDevice, invalid or uninitialized input device 168
  Major opcode: 148
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 168
  Major opcode: 148
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!

Revision history for this message
ville palo (vi64pa) wrote :

I only get:
ville@ville-desktop:~$ kdbus
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!

and kdbus works just fine, so most probably culprit are those Failed to open device lines.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Ville, can you please try to look into this and either see if it's not the fault of the update or provide a fix for this as well?

Changed in kdbus:
status: Fix Committed → In Progress
Revision history for this message
ville palo (vi64pa) wrote :

Unfortunately I have no means to look into this, because kdbus works perfectly on my PC, so I'm afraid that we have to reject this one?

Revision history for this message
finalbeta (j-greenhouse) wrote :

Hello, I was reading the motu list today. This topic came up. I ran kdbus again.

And it works, on the terminal I'm no longer receiving this part of the error:
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!

So this issue is now fixed for me. (I was the reported that said it was not).
I have no idea why it crashed before. I even rebooted the machine after the update. Thanks for the fix.

Revision history for this message
finalbeta (j-greenhouse) wrote :

I changed status to fixed. I was the only one to report it as still broken, and now it does work for me.

Changed in kdbus:
status: In Progress → Fix Released
Revision history for this message
StefanPotyra (sistpoty) wrote :

Thanks for testing again.
Setting back to Fix committed, since we still need more testers to get it into -updates ;).

Changed in kdbus:
status: Fix Released → Fix Committed
finalbeta (j-greenhouse)
Changed in kdbus:
status: Fix Committed → Fix Released
Revision history for this message
StefanPotyra (sistpoty) wrote :

Hi,

please don't set the status of this bug to fix released, see my last comment.

Thanks,
    Stefan.

Changed in kdbus:
status: Fix Released → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote :

This did not get proper testing for more than 10 months, and I guess nobody cares about edgy universe any more, so I removed the edgy-proposed package.

Changed in kdbus:
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments