kpartsaver segfaults

Bug #35605 reported by Tomasz Brzezina on 2006-03-19
Affects Status Importance Assigned to Milestone
kdeartwork (Ubuntu)
Kubuntu Bugs

Bug Description

adding simple movie (.mpg) causes segfault.

Kenny Duffus (kduffus) on 2006-03-19
Changed in kdeartwork:
assignee: nobody → kubuntu-team
Yuriy Kozlov (yuriy-kozlov) wrote :

Please provide more information about what application you are using and what you are trying to do, what version of ubuntu you are running, and a backtrace.

Changed in kdeartwork:
status: Unconfirmed → Needs Info

Fresh install of Breezy, fully updated (all deb in source.list uncommented).
xterm: kpartsaver.kss --setup opens window, where I click add and select mpg. movie. Pressed Ok.
xterm: kpartsaver.kss => Segmentation Fault

You can download this short movie here: (3.8MB)

Cannot reproduce. I don't get a segfault, but I get a double-free corruption at when closing the window. Not sure if it's related.

kpartsaver: KMPlayerFactory::createPartObject KParts::ReadOnlyPart
kpartsaver: KMPlayerPart(0x65f7f0)::KMPlayerPart ()
kpartsaver: View 48234725
kpartsaver: KMPlayerPart::openURL file:///home/neumann/zubr_zapasy.mpg
kpartsaver: KMPlayerHRefSource::setURL
kpartsaver: PartBase::openURL file:///home/neumann/zubr_zapasy.mpgtrue
kpartsaver: processState Not Running -> Ready
kpartsaver: Source::currentMrl src:
kpartsaver: resolveURL file:///home/neumann/zubr_zapasy.mpg
kpartsaver: document Mrl::activate
kpartsaver: Source::currentMrl document src:file:///home/neumann/zubr_zapasy.mpg
kpartsaver: getPath /home/neumann/zubr_zapasy.mpg
mplayer -wid 48234725 -slave -vo xv -framedrop -contrast 0 -brightness 0 -hue 0 -saturation 0 '/home/neumann/zubr_zapasy.mpg' -identify
kpartsaver: processState Ready -> Buffering
kpartsaver: Reference mrl /home/neumann/zubr_zapasy.mpg
kpartsaver: processState Buffering -> Playing
kpartsaver: KMPlayerPart::processStartedPlaying
eval quit
kpartsaver: KMPlayerPart::~KMPlayerPart
kpartsaver: PartBase::~PartBase
kpartsaver: ~Document
kpartsaver: KMPlayerLiveConnectExtension::~KMPlayerLiveConnectExtension()
kpartsaver: ~Document
Double QObject deletion detected.
*** glibc detected *** double free or corruption (!prev): 0x0000000000664dc0 ***

John Vivirito (gnomefreak) wrote :

Is this still a problem for you?

After installing Dapper Drake everything changes, but still segfault is a problem. Now the problem is in next movie (not first). It plays perfectly first movie, then when tries next movie:
28667 stat64("/home/uzytkownik/Desktop/debowe_luk.mpg", {st_mode=S_IFREG|0644, st_size=2670596, ...}) = 0
28667 --- SIGSEGV (Segmentation fault) @ 0 (0) ---
28667 rt_sigaction(SIGABRT, {SIG_DFL}, {0xb7bcc214, [ABRT], SA_RESTART}, 8) = 0
28667 rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
28667 tgkill(28667, 28667, SIGABRT) = 0
28667 --- SIGABRT (Aborted) @ 0 (0) ---
28667 +++ killed by SIGABRT +++

[FileDialog Settings]


after great war i found the problem. I don't understand why it's a problem, but when i workaround it - the problem disappears:

changes are commented:
void KPartSaver::closeURL()
    if( m_part ) {
        delete m_part;
        m_part = 0;

// delete m_factory;
// m_factory = 0;
bool KPartSaver::openURL( KURL url )
//added by TB
    if (!m_factory) {
// end by TB
            // load kpart library
            QString lib = offers.first()->library();
            m_factory = KLibLoader::self()->factory( lib.latin1() );
            if( !m_factory ) {
                    kdDebug() << "Library " << lib << " not found." << endl;
                    return false;

// added by TB
// end by TB

Guldberg (casper-guldberg) wrote :

Similiar symptoms in mandriva 2007. Complete newb to linux, but have been trying too make this work for a while now and finally found this site. If you need more info from me please be gentle ;) (or at least tell me EXACTLY what to do).

Need this for a project I'm working on. Will the fix (if any) be posted here? - if the above is a fix, help please!

Yuriy Kozlov (yuriy-kozlov) wrote :

I can't reproduce this on Feisty, kpartsaver works fine with some avi's and the provided mpg. Tomasz, can you try Edgy or Feisty?

Yuriy Kozlov napisał(a):
> I can't reproduce this on Feisty, kpartsaver works fine with some avi's
> and the provided mpg. Tomasz, can you try Edgy or Feisty?
Edgy works fine!


Guldberg (casper-guldberg) wrote :

I changed to Edgy and still get the error. Here's my dump similar to Tomasz':

4609 futex(0xb7a53824, FUTEX_WAKE, 2147483647) = 0
4609 stat64("/home/casper/Desktop/PORSCHE4.MPG", {st_mode=S_IFREG|0644, st_size=3790444, ...}) = 0
4609 --- SIGSEGV (Segmentation fault) @ 0 (0) ---
4609 rt_sigaction(SIGABRT, {SIG_DFL}, {0xb7b5df90, [ABRT], SA_RESTART}, 8) = 0
4609 rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
4609 tgkill(4609, 4609, SIGABRT) = 0
4609 --- SIGABRT (Aborted) @ 0 (0) ---
4609 +++ killed by SIGABRT +++

[KFileDialog Settings]
Recent Files=$HOME/Desktop/PORSCHE4.MPG,$HOME/Desktop/PORSCHE2.MPG,$HOME/Desktop/,$HOME/Desktop/foralle_no.mpeg


(get same result with other files, and with random=true btw)

Might be related to
Closing Kaffeine part causes crashes.

Is this still an issue with feisty/gutsy with kde 3.5.7? With the new kaffeine in there too?

Sarah Hobbs pisze:
> Is this still an issue with feisty/gutsy with kde 3.5.7? With the new
> kaffeine in there too?
no, in feisty there are no more problems.


Changed in kdeartwork:
status: Incomplete → Fix Released
Brian Murray (brian-murray) wrote :

I'm closing the Mandriva affects as Invalid as a bug watch was never added fro this affects.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers