Launchpad pages grab focus when they finish loading

Bug #39312 reported by Didier Raboud on 2006-04-12
38
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Matthew Paul Thomas
Ubuntu
Medium
Unassigned
kdebase (Ubuntu)
Low
Unassigned

Bug Description

In Konqueror and Opera, every Launchpad page jumps to the front when it finishes loading. This is most noticable when opening windows or tabs behind the current one.

In Safari this also happens sometimes (it doesn't happen when the newly-loaded page was opened from a link in the currently-focused page).

This seems to be a problem with Launchpad's menu JavaScript.

Christian Reis (kiko) wrote :

I believe this is a browser bug.

Christian Reis (kiko) wrote :

Oh, I hadn't noticed this bug /was/ reported on the konqueror package. Bummer.

Changed in konqueror:
status: Unconfirmed → Rejected
Didier Raboud (odyx) wrote :

So this stays "Unconfirmed" and no "Rejected" (which make that bug disappear from search results).

Changed in konqueror:
status: Rejected → Unconfirmed
Breuil Cyril (cyrilb856) wrote :

have this comportment too. Not only with launchpad.

Changed in kdebase:
status: Unconfirmed → Confirmed
Didier Raboud (odyx) on 2006-04-12
Changed in kdebase:
assignee: nobody → kubuntu-team
Dennis Kaarsemaker (dennis) wrote :

No, this is rejected - only one task neds to be open.

Changed in konqueror:
status: Unconfirmed → Rejected
Didier Raboud (odyx) wrote :

After discussion on #launchpad with some Launchpad's admins, this appear to be a bug of the JavaScript used by the new menu. I sent a correction and it should be corrected rapidly. The fact is this menu seems to be "ad interim" and will be changed soon. So status changed to "In Progress", even if nothing will touch Konqueror (Any more advanced user to set this bug more correctly ?)

In fact, for curiosity, Konqueror was acting exactly as excepted : giving the focus when asked, but the script should not ask for it.

Changed in kdebase:
assignee: kubuntu-team → nobody
status: Confirmed → In Progress
description: updated
Changed in launchpad:
assignee: nobody → mpt
status: Unconfirmed → Confirmed
description: updated
Rocco Stanzione (trappist) wrote :

this chunk of javascript from https://launchpad.net/@@/dynarch/hmenu.js:
if(config.setFocus)config.frames.popups.focus();
makes me think a small tweak to launchpad could configure that "feature" right out.

Le Mardi 18 Avril 2006 14:38, Rocco Stanzione a écrit :
> this chunk of javascript from https://launchpad.net/@@/dynarch/hmenu.js:
> if(config.setFocus)config.frames.popups.focus();
> makes me think a small tweak to launchpad could configure that "feature"
> right out.

It is exactly the "patch" [1] I sent to Launchpad's admins yesterday.

[1] Funny to speak of a patch when the file is one line of ~30kiB

Changed in launchpad:
status: Confirmed → In Progress
Matthew Paul Thomas (mpt) wrote :

Fix applied, and should appear on launchpad.net in about a week. Thanks to Didier for finding the bug.

Changed in launchpad:
status: In Progress → Fix Committed
Didier Raboud (odyx) wrote :

Marking as "Rejected" for kdebase, because it's not related to konqueror, which was acting as the Javascript asked to.

Bug definitively closed. Please re-open if needed.

Changed in kdebase:
status: In Progress → Rejected
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers