edgy: Cannot open theme file /usr/share/apps/kdm/themes/kubuntu

Bug #58639 reported by Henry Jensen
28
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

Binary package hint: kdm

I installed xubuntu-desktop and kdm afterwards on edgy-server.
When I launch kdm the a message box appears with the error message
"Cannot open theme file /usr/share/apps/kdm/themes/kubuntu".

I guess a dependency to kubuntu-default-settings is missing?

Revision history for this message
Yuriy Kozlov (yuriy-kozlov) wrote :

Thank you for filing this bug.
Confirmed on IRC and by duplicates.

The fix is to not use a theme by default, which is the case in Dapper according to the bug 41720, but it seems was broken in Edgy.

The solution, as posted in bug 72320:
"The easiest solution seems to be to edit /etc/kde3/kdm/kdmrc and change the line beginning with Theme to what should be the default according to the comment before that line:
Theme=

This will do the same effect as
UseTheme=false
but without the error popup."

Changed in kdebase:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Revision history for this message
Frode M. Døving (frode) wrote :

kdebase re-introduces this problem with kubuntu_05_kdm_theme_config.diff
that patch should be removed.

Revision history for this message
Anthony Mercatante (tonio) wrote :

Fixed with latest kdebase and kubuntu-default-settings upload.

Changed in kdebase:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers