Ubuntu

(edgy) SRU: KDE crashes when logout is canceled

Reported by Fernando Díaz on 2006-10-24
34
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Medium
Luka Renko

Bug Description

If the default options of the Session Manager are changed trough the System Settings dialog, unchecking the "Offer shutdown options" checkbox, KDE crashes if the cancel button is pressed in the "Log Out..." dialog, going back to the login screen (kdm).

Luka Renko (lure) wrote :

I have reproduced this with up-to-date Edgy.

Luka Renko (lure) wrote :

The above crash is side effect of the root cause. The real crash is from ksmserver:
[KCrash handler]
#6 0xb6790b25 in libhal_ctx_shutdown () from /usr/lib/libhal.so.1
#7 0xb67b0607 in KSMShutdownDlg::~KSMShutdownDlg ()
   from /usr/lib/libkdeinit_ksmserver.so
#8 0xb67b1ba5 in KSMShutdownDlg::confirmShutdown ()
   from /usr/lib/libkdeinit_ksmserver.so
#9 0xb67baa9d in KSMServer::shutdown () from /usr/lib/libkdeinit_ksmserver.so
#10 0xb67bacfd in KSMSaveYourselfRequestProc ()
   from /usr/lib/libkdeinit_ksmserver.so
#11 0xb6995ae3 in _SmsProcessMessage () from /usr/lib/libSM.so.6
#12 0xb698940e in IceProcessMessages () from /usr/lib/libICE.so.6
#13 0xb67b561a in KSMServer::processData ()
   from /usr/lib/libkdeinit_ksmserver.so
#14 0xb67bb980 in KSMServer::qt_invoke ()
   from /usr/lib/libkdeinit_ksmserver.so
#15 0xb72c4957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#16 0xb72c526e in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb7651cdb in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#18 0xb72e7516 in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#19 0xb725bb88 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#20 0xb725d9b7 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#21 0xb7951db2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#22 0xb71ee389 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#23 0xb724df81 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#24 0xb7202ea7 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#25 0xb727625e in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#26 0xb727606e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#27 0xb725d731 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#28 0xb67b7590 in kdemain () from /usr/lib/libkdeinit_ksmserver.so
#29 0xb67d3524 in kdeinitmain () from /usr/lib/kde3/ksmserver.so

According to this stack trace it is clear that the root cause is my patch in Edgy that provides hibernate/suspend buttons to Logout dialog.
A will work on the proper fix and I hope we can push it into -updates.

Changed in kdebase:
assignee: nobody → lure
status: Confirmed → In Progress
Luka Renko (lure) wrote :

I have fixed this and hope we can get this released on edgy-updates.

Luka Renko (lure) wrote :

Fernio, if you would like to test my test binary, then please install the following .deb file:
http://lure.homelinux.net/kubuntu/ksmserver_3.5.5-0ubuntu3~lure_i386.deb

Luka Renko (lure) wrote :

Marking as fix committed as debdiff with simple change is attached.

Changed in kdebase:
status: In Progress → Fix Committed
Fernando Díaz (fernio) wrote :

Luka, the .deb you posted does solve the problem. Thanks for the fast response. Hope the fix goes into the updates soon.

Anthony Mercatante (tonio) wrote :

That's too late for edgy.
I'm preparing feisty initial kdebase packages.
I will probably try to provide an update for edgy.

Matt Zimmerman (mdz) wrote :

Please fix the changelog to describe the changes made, not only the symptoms which they fix.

Otherwise, OK for -proposed

Travis Salisbury (tsalisbury) wrote :

This seems to have also fixed a related bug.
https://launchpad.net/distros/ubuntu/+source/kdebase/+bug/67809

It works great for me, but it's not working for everyone, apparently.

Risto H. Kurppa (risto.kurppa) wrote :
Download full text (3.7 KiB)

I installed Lukas fix deb.

First time I clicked cancel it died and I got this:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
[repeated rows removed..]
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1240229696 (LWP 8363)]
(no debugging symbols found)
[repeated rows removed..]
(no debugging symbols found)
[KCrash handler]
#6 0xb5c25e68 in JabberCapabilitiesManager::capabilitiesEnabled ()
   from /usr/lib/kde3/kopete_jabber.so
#7 0xb5c04f49 in JabberResource::setResource ()
   from /usr/lib/kde3/kopete_jabber.so
#8 0xb5c06450 in JabberResourcePool::addResource ()
   from /usr/lib/kde3/kopete_jabber.so
#9 0xb5c0178f in JabberAccount::setPresence ()
   from /usr/lib/kde3/kopete_jabber.so
#10 0xb5c019c8 in JabberAccount::disconnect ()
   from /usr/lib/kde3/kopete_jabber.so
#11 0xb5c02fd0 in JabberAccount::~JabberAccount ()
   from /usr/lib/kde3/kopete_jabber.so
#12 0xb7e88df4 in Kopete::Protocol::~Protocol () from /usr/lib/libkopete.so.1
#13 0xb5bf6652 in JabberProtocol::~JabberProtocol ()
   from /usr/lib/kde3/kopete_jabber.so
#14 0xb7e94f8c in Kopete::PluginManager::~PluginManager ()
   from /usr/lib/libkopete.so.1
#15 0xb7e92e9e in Kopete::PluginManager::availablePlugins ()
   from /usr/lib/libkopete.so.1
#16 0xb619454f in __cxa_finalize () from /lib/tls/i686/cmov/libc.so.6
#17 0xb7e7dccb in ?? () from /usr/lib/libkopete.so.1
#18 0xb7f2cdc0 in ?? () from /usr/lib/libkopete.so.1
#19 0xb7f2ab9c in ?? () from /usr/lib/libkopete.so.1
#20 0xbfc3da68 in ?? ()
#21 0xb7f1757b in _fini () from /usr/lib/libkopete.so.1
#22 0xb7f1757b in _fini () from /usr/lib/libkopete.so.1
#23 0xb7f8c4ce in _dl_rtld_di_serinfo () from /lib/ld-linux.so.2
#24 0xb6194299 in exit () from /lib/tls/i686/cmov/libc.so.6
#25 0xb63cd091 in _IceDefaultIOErrorHandler () from /usr/lib/libICE.so.6
#26 0xb6fa8937 in KApplication::iceIOErrorHandler ()
   from /usr/lib/libkdecore.so.4
#27 0xb6fa897d in KApplication::iceIOErrorHandler ()
   from /usr/lib/libkdecore.so.4
#28 0xb63d4bf6 in _IceRead () from /usr/lib/libICE.so.6
#29 0xb63d914f in IceProcessMessages () from /usr/lib/libICE.so.6
#30 0xb685e6d6 in QSmSocketReceiver::socketActivated ()
   from /usr/lib/libqt-mt.so.3
#31 0xb685e731 in QSmSocketReceiver::qt_invoke () from /usr/lib/libqt-mt.so.3
#32 0xb6946957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#33 0xb694726e in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#34 0xb6cd3cdb in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#35 0xb6969516 in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#36 0xb68ddb88 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#37 0xb68df9b7 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#38 0xb708edb2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#39 0xb6870389 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#40 0xb68cff81 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#41 0xb6884ea7 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#42 0xb68f825e in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#4...

Read more...

Luka Renko (lure) wrote :

Risto, thanks for testing this again. Yes, you need to restart KDE session in order for the patch to take effect.

Risto H. Kurppa (risto.kurppa) wrote :

Great, thank's once more Luka!

Is there a way to make our ksmserver.deb stay in the system and not be overwritten by apt (it claims your version is older than the one available at repos..) whenever I try to install something.. (or do I have to install your version again after every update?).

What's the cycle before it gets to edgy-updates?

r

Luka Renko (lure) wrote :
Johnny Levai (digistyl3) wrote :

Hi, thanks for the deb file, it fixed the problem :)
I hope this get's into edgy-updates.

Travis Salisbury (tsalisbury) wrote :

When is this getting into updates? I can't do dist-upgrades without ksmserver reverting to the broken version.

Luka, is there a way to make your package stick as a later version than what's in the repos?

Matt Zimmerman (mdz) wrote :

As I explained in https://launchpad.net/distros/ubuntu/+source/kdebase/+bug/67889/comments/8 this is already approved for edgy-proposed. There is no need to provide any further opinions about whether or not it should be released as an official update.

Once it is accepted into edgy-proposed, you should all test that version and confirm that it works for you, and then it can proceed into edgy-updates.

http://wiki.ubuntu.com/StableReleaseUpdates

Jonathan Riddell (jr) wrote :

Uploaded to -proposed, appologies for the delay.

Colin Watson (cjwatson) wrote :

Accepted into edgy-proposed. Per StableReleaseUpdates, once it's built, please notify the QA team via Simon Law to verify that this bug has been fixed and there are no regressions.

Luka Renko (lure) wrote :

I have tested the packages from edgy-proposed (version: 3.5.5-0ubuntu3.1) and it fixes the problem for me. I have also not seen any obvious regression when running standard kde apps for last 4 hours.

It would be good if some of the initial reporters (Fernio, Travis, Johnny, Risto) also confirm that this fixes the problem for them (and that there are no regressions).

Risto H. Kurppa (risto.kurppa) wrote :

Is it this here:
http://mirrors.nic.funet.fi/ubuntu/pool/main/k/kdebase/ksmserver_3.5.5-0ubuntu3.1_i386.deb

I got this - did I miss something..?

rhk@ribantu:~$ sudo dpkg --install ksmserver_3.5.5-0ubuntu3.1_i386.deb
(Reading database ... 161612 files and directories currently installed.)
Preparing to replace ksmserver 4:3.5.5-0ubuntu3.1 (using ksmserver_3.5.5-0ubuntu3.1_i386.deb) ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fi_FI:fi:en_GB:en",
        LC_ALL = (unset),
        LC_CTYPE = "fi_FI@euro",
        LC_MONETARY = "fi_FI@euro",
        LANG = "fi_FI.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fi_FI:fi:en_GB:en",
        LC_ALL = (unset),
        LC_CTYPE = "fi_FI@euro",
        LC_MONETARY = "fi_FI@euro",
        LANG = "fi_FI.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Unpacking replacement ksmserver ...
Setting up ksmserver (3.5.5-0ubuntu3.1) ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fi_FI:fi:en_GB:en",
        LC_ALL = (unset),
        LC_CTYPE = "fi_FI@euro",
        LC_MONETARY = "fi_FI@euro",
        LANG = "fi_FI.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
rhk@ribantu:~$

I suppose it still installed it.. I'll report any problems here.

Will the release version number be greater than this -> will apt understand that it's supposed to follow the version at repository, not this -proposed version?

Risto H. Kurppa (risto.kurppa) wrote :

Seems to work! Cancel really cancels the logout and logout saves session & logs out OK!

Thanks!

Travis Salisbury (tsalisbury) wrote :

It's working great. No problems here.

Thanks you!

Simon Law (sfllaw) wrote :

The patch in edgy-proposed resolves the problem with the crasher. I have no concerns about this package, since it regression tests fine.

Approved for upload to edgy-updates immediately.

Adam Conrad (adconrad) wrote :

Upload verified and accepted for edgy-updates.

Changed in kdebase:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers