kcontrol is empty

Bug #80444 reported by Bogdan Butnaru on 2007-01-18
16
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kde

OK, this is one of the weirdest issues I had with Ubuntu. I'm not sure where to put it, I though I'd place it in "kde" and see if anyone can suggest a better spot. Bear with me:

I use Ubuntu Feisty (all repositories including multiverse; I installed Dapper and updated from there), with the Gnome interface, on a Dell Latitude D620 laptop. (I'll fill in with more details if asked.)

The only KDE thing I use is Amarok (well, Qt, anyway). My problems all started when I noticed that the fonts in Amarok got rendered uglier than those in the other applications. As far as I can tell, they were (and still are) rendered with anti-aliasing (grayscale, I think) without hinting.

(I had fonts set-up to my taste, using the default Gnome applet, when I installed Ubuntu, with full hinting and sub-pixel AA. It worked just right in both Gnome apps and Amarok.)

I don't know what triggered the change, it was probably an update of some Qt thing. I didn't notice this right away, so I'm not sure.

I tried looking for info on the forums -- http://ubuntuforums.org/showthread.php?t=336229 -- because I'm not really familiar with KDE. A few guys tried to help me by suggesting I install kcontrol and use it to change KDE's font settings. (That's what I wanted to do, I just didn't know the name of the package.)

For some reason, the kcontrol window did not display any actual settings pages. I tried installing kde-core, kdebase, and finally the whole kde package. After any number of restarts/logins, I still didn't find any controls in kcontrol. I also tried qt3-qtconfig, but it only allows picking fonts, not the rendering options.

Any idea what I can do? I'm really only interested about fixing the font rendering, but if I can help with tracing the kcontrol problem (and it doesn't involve reinstalling the entire OS), I'm willing to try.

Bogdan Butnaru (bogdanb) wrote :

This is a screenshot showing both issues:

(1) kcontrol has nothing in it (the screenshot is taken in a KDE session, btw).

(2) Note how hinting is not correctly used -- for example the menu of kcontrol. Notice how the i and l letters (lowercase L) are thickened (try zooming a lot) and look dirty or blurry. Compare with the piece of the Gimp window visible in the background, where all vertical lines are very clean.

Bogdan Butnaru (bogdanb) wrote :

I just noticed that the fonts have the same (or a very similar) problem in Open Office. I thought OO uses Java, but neither Azureus nor Eclipse have this problem.

Brian Murray (brian-murray) wrote :

Thanks for your bug report. Could you please let us know what version of kcontrol and kdebase-data you have installed? You can find this out by running the command 'dpkg -l kcontrol' and 'dpkg -l kdebase-data' in a terminal.

Changed in meta-kde:
assignee: nobody → brian-murray
status: Unconfirmed → Needs Info
Bogdan Butnaru (bogdanb) wrote :

Hmm, it does seem that there's a problem somewhere, but I don't know how to fix it.

I had previously purged everything from kde, so the output below was just after a "sudo aptitude update; sudo aptitude install kdebase", which should be as clean as it can be.

Otherwise, I'm running up-to-date Feisty from the official repositories (including universe and multiverse).

************************************

$ dpkg -l kdebase
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-======================-======================-============================================================
ii kdebase 3.5.6-0ubuntu3 base components from the official KDE release

***********************************

$ dpkg -l kcontrol
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-======================-======================-============================================================
ii kcontrol 3.5.6-0ubuntu3 control center for KDE

***********************************

Changed in kdebase:
assignee: brian-murray → nobody
importance: Undecided → Low
status: Needs Info → Confirmed
Brian Murray (brian-murray) wrote :

There was a new version of kdebase that was released yesterday that should resolve your issue. Please update to the latest version and let us know if that resolves your issue. Thanks.

Changed in kdebase:
assignee: nobody → brian-murray
status: Confirmed → Needs Info
Bogdan Butnaru (bogdanb) wrote :
Download full text (3.3 KiB)

I just updated everything, and I still get nothing in the kcontrol window.

$ dpkg -l kdebase
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==================-==================-====================================================
ii kdebase 3.5.6-0ubuntu4 base components from the official KDE release
bogdanb@bogdanb-laptop:~$ dpkg -l kcontrol
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==================-==================-====================================================
ii kcontrol 3.5.6-0ubuntu4 control center for KDE

********************************

kcontrol also throws several warnings/errors on the command line when run. (Though the windows shows up, empty.) Perhaps they can help:

*******************************
$ kcontrol
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
kcontrol: WARNING: No K menu group with X-KDE-BaseGroup=settings found ! Defaulting to Settings/
bogdanb@bogdanb-laptop:~$ sudo kcontrol
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
kcontrol: WARNING: No K menu group with X-KDE-BaseGroup=settings found ! Defaulting to Settings/
ERROR: Communication problem with kcontrol, it probably crashed.
*************************
Here I was returned to the shell (the console process stopped), but the window was shown and remained there. Several other errors continued popping up in the console.
*************************
bogdanb@bogdanb-laptop:~$
kdeinit: Shutting down running client.
---------------------------------
It looks like dcopserver is already running. If you are sure
that it is not already running, remove /root/.DCOPserver_bogdanb-laptop__0
and start dcopserver again.
---------------------------------

X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database av...

Read more...

Changed in kdebase:
assignee: brian-murray → nobody
status: Needs Info → Confirmed
Bogdan Butnaru (bogdanb) wrote :

OK, I got a suggestion on a forum -- http://ubuntuforums.org/showthread.php?t=336229 -- and with a bit of twiddling I got kcontrol to show the menus.

I don't know what caused it. I suspect a malformed package or some conflict, I don't know. This machine was updated using apt-get from dapper through edgy to feisty, so I wouldn't be surprised if the package manager somehow got confused. (It happened before.)

According to the suggestion, I was supposed to have a file /etc/xdg/menus/kde-applications-merged/kde-essential.menu on my system. After a bit of searching, I realized on my system there was /etc/xdg/menus/kde-applications-merged/kde-essential.menu/kde-essential.menu (the file was in a same-named directory). I renamed the directory and moved the file in its stead, and now kcontrol works.

By works I mean it shows the various applets and they seem to do stuff. I've still got the problem with the fonts, but I'll file a different bug for that.

If anyone wants to try and diagnose the issue with kcontrol -- it seems it happened to others, too -- let me know. I can post an archive with the /etc/xdg/menus/ directory and whatever other info you might need.

By the way, I noticed there's also a file called "kde-essential.menu.dpkg-new" that's identical to the file I needed. I suppose the package manager tried to create it and couldn't because of the directory of the same name.

I don't know enough of apt's internals to trace the issue to the source, but I'm quite sure now it's an update issue. If you need anything, don't hesitate to ask.

Anthony Mercatante (tonio) wrote :

Works with latest version.

If kcontrol is still empty for you :
sudo apt-get remove --purge kdebase-data && sudo rm -rf /etc/xdg/menus/kde-* && sudo apt-get install kubuntu-desktop

That will resolve your issue.

Changed in kdebase:
status: Confirmed → Fix Released
Bogdan Butnaru (bogdanb) wrote :

Like I said, right now I fixed it. I think it was an update issue, which should be fixed if possible. But your fix is better, in case anyone has the same problem :)

Nikola Čakelić (ncake) wrote :

This bug is not fixed for me. I have tried to do:

sudo apt-get remove --purge kdebase-data && sudo rm -rf /etc/xdg/menus/kde-*

and later reinstall kdebase-data, but still kcontrol is empty. And I have tried moving around the file kde-essential.menu, but it still not working.

emikaadeo (emikaadeo) wrote :

I don't know how to reopen the bug so i'm writing here.
Yesterday i did a clean install of Kubuntu Feisty Beta. Then i install all upgrades with multiverse and universe repo enabled.
Kcontrol is empty when i run it from console: sudo kcontrol
This is what i get:
edzior@linux:~$ sudo kcontrol
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 145
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kdeinit: Can't connect to the X Server.
kdeinit: Might not terminate at end of session.
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kded: cannot connect to X server :0.0
DCOP aborting call from 'anonymous-6582' to 'kded'
kded: ERROR: Communication problem with kded, it probably crashed.
kio (KSycoca): ERROR: No database available!
kcontrol: WARNING: No K menu group with X-KDE-BaseGroup=settings found ! Defaulting to Settings/
ERROR: Communication problem with kcontrol, it probably crashed.
edzior@linux:~$ kcontrol: ERROR: : couldn't create slave : Unknown protocol 'file'.
kcontrol: ERROR: : couldn't create slave : Unknown protocol 'file'.

After this messages a pop-up window is showing with: can't find type MIME application/octet-stream

I tried a solution that was mention above but it didn't help.
Now, today i did a clean install of Kubuntu Feisty Daily-Build 04-04-2007 and the bug still exist.
I get the same message and kcontrol is stil empty.

emikaadeo (emikaadeo) on 2007-04-04
Changed in kdebase:
status: Fix Released → Confirmed
emikaadeo (emikaadeo) wrote :

Ok, i think the problem is solved.
From console i run : 'kdesu kcontrol' and kcontrol starts as it should.
After this i run : 'sudo kcontrol' and kcontrol also starts fine.

Daniel Hahler (blueyed) wrote :

WARNING:
I've tried
  sudo apt-get remove --purge kdebase-data && sudo rm -rf /etc/xdg/menus/kde-* && sudo apt-get install kubuntu-desktop
but that borked my whole KDE (no known applications at all).
The problem has been that /etc/xdg/menus/kde-applications.menu was missing (because of the "rm -rf" above) and resides in kdelibs-data. Therefor I had to "sudo dpkg -x /var/cache/apt/archives/kdelibs-data_4%3a3.5.6-0ubuntu13_all.deb /" to extract all files of this package again.

So I would not recommend this way to fix this problem, if it exists, but rather try fixing the directory/file issue with /etc/xdg/menus/kde-applications-merged/kde-essential.menu directly (see also above).

At least, now "kcontrol" isn't empty anymore for me.

I've dist-upgraded from from Dapper/Edgy to Feisty, some time ago already.

royqh (royqh1979) wrote :

I have the same problem.
If I run kcontorl/kcmshell with "sudo" , it's just ok:
roy@roy-laptop:/etc/xdg/menus/kde-applications-merged$ sudo kcmshell --list
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 148
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 148
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kdeinit: Can't connect to the X Server.
kdeinit: Might not terminate at end of session.
下列模块可用:
kcmcgi - 配置 CGI KIO 仆人
cookies - 配置 cookies 相关设置
khtml_java_js - 配置 Java 和 JavaScript 的行为
khtml_behavior - 配置浏览器行为
kcmhistory - 配置任务侧边栏
khtml_fonts - 配置网页所使用的字体
khtml_filter - 配置 Konqueror 的广告拦截过滤器
khtml_plugins - 配置浏览器插件
kcmcss - 配置用来渲染网页的样式表
……

but, if I run kcmshell without "sudo", it can't find obex modules:
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 148
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode: 148
  Minor opcode: 3
  Resource id: 0x0
Failed to open device
下列模块可用:
obex - OBEX device configuration tool

deepdraft (dimitar.nedev) wrote :

I do no know is this bug is still active, but I have the same issue.
I am running Hardy Alpha 1 and I've tired everything mentioned above and it still does not work.

Mikael Nilsson (mini) wrote :

Same here - this is a clean installation of gutsy upgraded to Hardy (never checked in gutsy though).

I had the same problem after a clean installation of Hardy. After googling a lot a found the solution was:

cd /etc/xdg/menus/applications-merged
ln -s ../kde-applications-merged/kde-essential.menu .

It seems that some program is searching for kde-essential.menu at the wrong place ;-)

Of course, what I have said before has to be executed as root (a "sudo" before "ln" is enough)...

Daniel Hahler (blueyed) wrote :

kde-essential.menu gets installed into /etc/xdg/menus/kde-applications-merged/kde-essential.menu for Hardy, although it should not get done like this since 3.5.7-1ubuntu5 (Gutsy).
It's OK in Gutsy (3.5.8-0ubuntu2), but regressed in Hardy (3.5.8-2ubuntu9).
The attached debdiff should fix this for Hardy.

Changed in kdebase:
importance: Low → Medium
status: Confirmed → Triaged

On Thursday December 27 2007 12:18:48 pm José Antonio Becerra Permuy wrote:
> cd /etc/xdg/menus/applications-merged
> ln -s ../kde-applications-merged/kde-essential.menu .

I also submitted this bug:
https://bugs.launchpad.net/ubuntu/+source/kdebase/+bug/178472

The problem is, on a fresh Hardy install with updates, I don't have a
kde-essential.menu file anywhere.

I've got kde-information.menu, kde-applications.menu, kde-settings.menu,
kde-applications-merged, and kde-screensavers.menu

I've never had a kde-essential.menu.

-Jared Schlicht

Gary Greene (greeneg-google) wrote :

This is still occurring on Hardy. The install I'm on is based off the tree as of the 22nd of January. I can confirm that the kde-essential.menu is not present.

Daniel Hahler (blueyed) wrote :

Re-based debdiff for current kdebase version in Hardy.

Daniel Hahler (blueyed) wrote :

Should be fixed in kdebase 4:3.5.8-2ubuntu16:
kdebase (4:3.5.8-2ubuntu16) hardy; urgency=low

  * Move kde-applications-merged/kde-essential.menu to
    applications-merged/, apparantly the prefix doesn't get used for merge
    directories
  * Make kdesktop depend on xdg-user-dirs

 -- Jonathan Riddell < <email address hidden>> Mon, 28 Jan 2008 18:29:54 +0000

Changed in kdebase:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers