Change log for kdeedu package in Ubuntu

175 of 137 results
Obsolete in natty-updates on 2013-06-04
Obsolete in natty-security on 2013-06-04
kdeedu (4:4.6.5-0ubuntu1.1) natty-security; urgency=low

  * No change rebuild for security. This is needed to build kdeutils in
    the security pocket.
  * debian/control: relax build-dependency on kde-sc-dev-latest so this
    is actually buildable in the security PPA
 -- Jamie Strandboge <email address hidden>   Tue, 08 Nov 2011 17:36:54 -0600
Obsolete in maverick-updates on 2013-03-05
Obsolete in maverick-security on 2013-03-05
kdeedu (4:4.5.5-0ubuntu2.1) maverick-security; urgency=low

  * No change rebuild for security. This is needed to build kdeutils in
    the security pocket.
 -- Jamie Strandboge <email address hidden>   Tue, 08 Nov 2011 16:51:42 -0600
Superseded in natty-updates on 2011-11-22
Deleted in natty-proposed on 2011-11-23 (Reason: moved to -updates)
kdeedu (4:4.6.5-0ubuntu1) natty-proposed; urgency=low

  * Upload to natty-proposed for SRU testing (LP: #859562)
 -- Scott Kitterman <email address hidden>   Mon, 26 Sep 2011 07:37:57 -0400
Deleted in oneiric-release on 2011-08-03 (Reason: LP: #809611)
kdeedu (4:4.6.3-2ubuntu2) oneiric; urgency=low

  * Re-add and refresh kubuntu_opengl.diff, accidentally dropped in
    the last upload.
  * Switch kdeedu to arch-any and drop step from dependencies on armel.
 -- Felix Geyer <email address hidden>   Tue, 07 Jun 2011 13:27:51 +0200
Superseded in oneiric-release on 2011-06-07
kdeedu (4:4.6.3-2ubuntu1) oneiric; urgency=low

  [ Rohan Garg ]
  * Merge from debian, remaining changes,
      - Drop from build-deps: r-base-core (in universe)
      - Keep in build-deps: libgmm-dev, libsbigudrv-dev, libindi-dev,
        libx11-dev
      - kdeedu doesn't depend on kiten and blinken
      - cantor-backend-sage doesn't recommend sagemath
      - kstars doesn't suggest indi
      - kstars recommends xplanet
      - Drop python marble bindings since they don't build right now
        + Drop python-sip-dev, python-support, python-dev, python-qt4,
          python-kde4, python-qt4-dev, python-kde4-dev from build depends
      - Don't build cantor-backend-r as we don't have the right build-depends
      - Parley recommends python-kde4, krossruby and libkde4-ruby
      - Add a dummy package for kalgebra-mobile
      - Add kalzium.install.armel which doesn't include compound viewer
      - Don't build step for ARM
      - Keep kalgebra-common
      - Keep dependency on OpenBabel (is only temporarily removed in Debian)

  [ Philip Muškovac ]
  * Update Vcs- links as the branch is owned by kubuntu-packagers now

Superseded in maverick-updates on 2011-11-22
Deleted in maverick-proposed on 2011-11-23 (Reason: moved to -updates)
kdeedu (4:4.5.5-0ubuntu2) maverick-proposed; urgency=low

  * Update to final 4.5 version per micro-release exception (LP:  #757065)
 -- Scott Kitterman <email address hidden>   Mon, 11 Apr 2011 01:38:51 -0400
Superseded in oneiric-release on 2011-06-06
Obsolete in natty-release on 2013-06-04
kdeedu (4:4.6.2-0ubuntu2) natty; urgency=low

  [ Tarun Kumar Mall ]
  * New upstream release

  [ Jonathan Riddell ]
  * Don't build opengl compontents on ARM
  * Add kubuntu_01_opengl.diff to stop building step which requires opengl
  * Build step on non-arm arches only
  * Add kalzium.install.armel which doesn't include compound viewer
  * Add build-dep on libx11-dev
 -- Tarun Kumar Mall <email address hidden>   Mon, 04 Apr 2011 18:12:13 +0000
Superseded in natty-release on 2011-04-06
kdeedu (4:4.6.1a-0ubuntu2) natty; urgency=low

  * Split kalgebra-mobile and kalgebra-common packages. (LP: #683439)
 -- Tarun Kumar Mall <email address hidden>   Wed, 16 Mar 2011 11:20:06 +0000
Superseded in natty-release on 2011-03-17
kdeedu (4:4.6.1a-0ubuntu1) natty; urgency=low

  * New upstream release
 -- Philip Muskovac <email address hidden>   Thu, 03 Mar 2011 16:50:17 +0100
Superseded in natty-release on 2011-03-04
kdeedu (4:4.6.0-0ubuntu2) natty; urgency=low

  [ Jonathan Riddell ]
  * Update kde-sc-dev-latest version

  [ Scott Kitterman ]
  * Drop obsolete build-depends on sip4
  * Drop unneeded build-depends on python-sip4
 -- Scott Kitterman <email address hidden>   Wed, 26 Jan 2011 20:54:41 -0500
Superseded in natty-release on 2011-01-27
kdeedu (4:4.6.0-0ubuntu1) natty; urgency=low

  * New upstream release
  * Remove cdbs version from build-depends for easier backporting
 -- Jonathan Riddell <email address hidden>   Fri, 21 Jan 2011 13:01:24 +0000
Superseded in natty-release on 2011-01-26
kdeedu (4:4.5.95-0ubuntu1) natty; urgency=low

  [ Jonathan Riddell ]
  * New upstream release

  [ Benedict Stein ]
  * debian/control: add python-kde4 as recommends for parley (LP:#698056)

  [ Harald Sitter ]
  * Also recommend krossruby and libkde4-ruby as plugins can be anything and
    Parley currently does not handle missing frameworks (at all)
 -- Harald Sitter <email address hidden>   Thu, 06 Jan 2011 18:23:11 +0100
Superseded in natty-release on 2011-01-07
kdeedu (4:4.5.90-0ubuntu2) natty; urgency=low

  * Add a build-depend on libgps-dev to enable GPS support in marble, now
    that libgps is in main. (LP: #409104)
 -- Jonathan Thomas <email address hidden>   Tue, 28 Dec 2010 17:06:46 -0500
Superseded in natty-release on 2010-12-29
kdeedu (4:4.5.90-0ubuntu1) natty; urgency=low

  * New upstream RC release
 -- Jonathan Riddell <email address hidden>   Wed, 22 Dec 2010 16:22:08 +0000
Obsolete in lucid-updates on 2016-10-26
Deleted in lucid-proposed on 2016-11-01 (Reason: moved to -updates)
kdeedu (4:4.4.5-0ubuntu1) lucid-proposed; urgency=low

  * Upload to lucid-proposed for 10.04.2 (LP: #691068)
    - No SRU/security upload to verify
 -- Scott Kitterman <email address hidden>   Thu, 16 Dec 2010 09:59:17 -0500
Superseded in natty-release on 2010-12-23
kdeedu (4:4.5.85-0ubuntu2) natty; urgency=low

  * Fix double/qreal issue in rocs/src/Core/Data.h to fix FTBFS on armel
    - Fix thanks to Harald Sitter (and already committed upstream)
 -- Scott Kitterman <email address hidden>   Mon, 13 Dec 2010 15:26:52 -0500
Superseded in natty-release on 2010-12-13
kdeedu (4:4.5.85-0ubuntu1) natty; urgency=low

  * New upstream release
 -- Jonathan Riddell <email address hidden>   Tue, 07 Dec 2010 13:27:15 +0000
Superseded in natty-release on 2010-12-09
kdeedu (4:4.5.80-0ubuntu1) natty; urgency=low

  * New upstream beta release
  * Remove kstars_unswap_fields_in_wizard.diff now upstream
  * Don't use -DEXPERIMENTAL_PYTHON_BINDINGS currently broken
 -- Jonathan Riddell <email address hidden>   Wed, 24 Nov 2010 13:48:35 +0000
Superseded in natty-release on 2010-11-28
kdeedu (4:4.5.3-0ubuntu1) natty; urgency=low

  * New upstream release
  * Add DEB_DH_SCOUR_ARGS := -Xflag, scour does not like these svg files
  * Build-dep on cdbs 0.4.89ubuntu4 required for the above
 -- Jonathan Riddell <email address hidden>   Thu, 04 Nov 2010 16:12:30 +0000
Superseded in natty-release on 2010-11-05
kdeedu (4:4.5.2-0ubuntu2) natty; urgency=low

  * Bump python-kde4 build-dep to 4:4.5.2+svn1188326-0ubuntu1
 -- Alessandro Ghersi <email address hidden>   Fri, 22 Oct 2010 22:52:49 +0200
Superseded in natty-release on 2010-10-22
kdeedu (4:4.5.2-0ubuntu1) natty; urgency=low

  [ Jonathan Riddell ]
  * New upstream release

  [ Felix Geyer ]
  * Merge with Debian git, remaining changes:
    - Drop from build-deps: openbabel, r-base-core (are in universe)
    - Keep in build-deps: libgmm-dev, libsbigudrv-dev, python-kde4-dev,
      python-qt4-dev, sip4, libindi-dev
    - kdeedu doesn't depend on kiten and blinken
    - cantor-backend-sage doesn't recommend sagemath
    - kstars doesn't suggest indi
    - kstars recommends xplanet
    - Keep python marble bindings and set -DEXPERIMENTAL_PYTHON_BINDINGS=TRUE
      in debian/rules
    - Don't build cantor-backend-r as we don't have the right build-depends
    - Add kubuntu_01_arm_needs_qreal.diff
  * Drop librocslib4 and librocslib-dev packages and move the libs to rocs.
  * Move GpsdPositionProviderPlugin.so from marble to marble-plugins.
  * Move python-marble to section python.

  [ Alessandro Ghersi ]
  * Build against kdelibs5-dev 4.5.2-0ubuntu1 for libkutils4 transition

Superseded in natty-release on 2010-10-22
Obsolete in maverick-release on 2013-03-05
kdeedu (4:4.5.1-0ubuntu2) maverick; urgency=low

  * Restore debian/patches/kubuntu_01_arm_needs_qreal.diff lost during the
    update to the new upstream release in order to fix FTBFS on armel
  * Update symbols (debian/libmarblewidget10.symbols) for 4.5.1
 -- Scott Kitterman <email address hidden>   Sun, 05 Sep 2010 01:57:30 -0400
Superseded in maverick-release on 2010-09-06
kdeedu (4:4.5.1-0ubuntu1) maverick; urgency=low

  * New upstream release
    - Bump build-depends
    - Update libmarblewidget10.install
    - Update python-marble.install
 -- Alessandro Ghersi <email address hidden>   Tue, 31 Aug 2010 01:06:47 +0200
Superseded in maverick-release on 2010-09-03
kdeedu (4:4.5.0b-0ubuntu3) maverick; urgency=low

  * In debian/rules set -
    DPYTHON_SITE_PACKAGES_INSTALL_DIR:PATH=/usr/lib/python2.6/dist-
    packages, dunno why this is suddently needed
 -- Jonathan Riddell <email address hidden>   Thu, 26 Aug 2010 13:51:59 +0100
Superseded in maverick-release on 2010-08-26
kdeedu (4:4.5.0b-0ubuntu1) maverick; urgency=low

  * New tar from upstream
 -- Jonathan Riddell <email address hidden>   Wed, 04 Aug 2010 23:20:05 +0100
Superseded in maverick-release on 2010-08-10
kdeedu (4:4.5.0-0ubuntu1) maverick; urgency=low

  * New upstream release
    - Bump kde-sc-dev-latest to 4.5.0
 -- Rohan Garg <email address hidden>   Fri, 30 Jul 2010 22:59:48 +0530
Superseded in maverick-release on 2010-08-02
kdeedu (4:4.4.92-0ubuntu2) maverick; urgency=low

  * Build with kde4libs 4.4.92-0ubuntu3 for qtwebkit transition
 -- Jonathan Riddell <email address hidden>   Wed, 21 Jul 2010 09:38:36 +0100
Superseded in maverick-release on 2010-07-21
kdeedu (4:4.4.92-0ubuntu1) maverick; urgency=low

  [ Alessandro Ghersi ]
  * New upstream rc release
    - Bump kde-sc-dev-latest to 4.4.92

  [ Jonathan Riddell ]
  * Build with libgmm-dev instead of libgmm++-dev, that's the version
    in main
 -- Alessandro Ghersi <email address hidden>   Fri, 09 Jul 2010 04:23:24 +0200
Superseded in maverick-release on 2010-07-11
kdeedu (4:4.4.90-0ubuntu1) maverick; urgency=low

  * New upstream rc release
    - Bump kde-sc-dev-latest to 4.4.90
    - Update install files
    - Add ${misc:Depends} to python-marble and kstars dependencies
    - Add python-dev, python-sip, python-qt4, python-kde4 to build-deps
      to build python-marble
    - Use dh_pysupport -p$(cdbs_curpkg) in rules for python-marble
    - Update not-installed file
    - Remove TODO.source no longer need
    - Remove README.source
 -- Alessandro Ghersi <email address hidden>   Thu, 24 Jun 2010 01:14:40 +0200
Superseded in maverick-release on 2010-06-28
kdeedu (4:4.4.85-0ubuntu4) maverick; urgency=low

  * Build-dep on libindi >= 0.6.1-0ubuntu2 for pkg-config fix
  * Add libgps-dev build-depends
  * Update symbol files
  * Re-enable python-marble
  * Use dh_sip and dh_pysupport for python-marble
  * add python-sip-dev, python-support build-depends
  * Swap libgmm-dev build-dep for libgmm++-dev
  * Add build-dep on libavogadro-dev
  * Add build-dep on xplanet and kstars recommends xplanet
 -- Jonathan Riddell <email address hidden>   Fri, 11 Jun 2010 12:17:03 +0100
Superseded in maverick-release on 2010-06-22
kdeedu (4:4.4.85-0ubuntu3) maverick; urgency=low

  * Remove usr/lib/libcompoundviewer.so.4 and libcompoundviewer.so.4.5.0 from
    debian/kalzium.install to fix FTBFS
 -- Scott Kitterman <email address hidden>   Fri, 11 Jun 2010 00:11:03 -0400
Superseded in maverick-release on 2010-06-11
kdeedu (4:4.4.85-0ubuntu2) maverick; urgency=low

  * libmarblewidget10 conflicts/replaces on libmarblewidget4
 -- Alessandro Ghersi <email address hidden>   Wed, 09 Jun 2010 20:26:20 +0200
Superseded in maverick-release on 2010-06-09
kdeedu (4:4.4.85-0ubuntu1) maverick; urgency=low

  * New upstream beta release:
    - Bump kde-sc-dev-latest build-dep version to 4.4.85
    - Rename libmarblewidget4 to libmarblewidget10
    - Rename libmarblewidget4.install to libmarblewidget10.install
      - Change lib version to 0.10.0 and bump lib soversion to 10
    - Rename libmarblewidget4.symbols to libmarblewidget10.symbols
    - libmarble-dev depends on libmarblewidget10
    - Update install files
 -- Alessandro Ghersi <email address hidden>   Tue, 08 Jun 2010 03:46:44 +0200
Superseded in maverick-release on 2010-06-09
kdeedu (4:4.4.80-0ubuntu2) maverick; urgency=low

  * Drop build-depend on libavagadro-dev (forgot to push to bzr last time)
 -- Jonathan Thomas <email address hidden>   Tue, 01 Jun 2010 08:50:20 -0400
Superseded in maverick-release on 2010-06-01
kdeedu (4:4.4.80-0ubuntu1) maverick; urgency=low

  * New upstream beta release:
    - Bump kde-sc-dev-latest build-dep version to 4.4.80
    - Update various .install files
    - Add build-depends on libxrender-dev and libglew1.5-dev
    - Add new librocslib4 and librocslib-dev binary packages
  * Switch to source format 3.0 (quilt)
    - Bump debhelper build-depend version to 7.3.16 or greater
 -- Jonathan Thomas <email address hidden>   Tue, 25 May 2010 11:29:28 -0400
Superseded in maverick-release on 2010-05-30
kdeedu (4:4.4.3-1ubuntu1) maverick; urgency=low

  * Merge with Debian unstable, remaining changes:
      - Build against liboost-python1.42-dev
      - remove indi from kdeedu (external package)
      - Drop from build-deps libgps-dev, xplanet (are in Universe)
      - Keep in build-deps libgmm-dev, libsbigudrv-dev, python-kde4-dev,
        python-qt4-dev, sip4, libindi-dev
      - Kdeedu not depend on kiten, blinken (in universe), indi
        (kstars conflict)
      - kturtle description - change to be more reflective of pseudo-logo
        language
      - Keep python marble bindings, we should try to build python-marble
        in KDE 4.4 packaging and keep -DEXPERIMENTAL_PYTHON_BINDINGS=FALSE in
        rules for switching easily to TRUE when we want try to build it
      - keep docs path in usr/share/doc/kde/HTML
      - cantor-backend-sage not recommends sagemath
      - Don't build cantor-backend-r we don't have the right build-depends
 -- Alessandro Ghersi <email address hidden>   Thu, 20 May 2010 05:54:23 +0200
Superseded in maverick-release on 2010-05-22
Obsolete in lucid-release on 2016-10-26
kdeedu (4:4.4.2-0ubuntu2) lucid; urgency=low

  * Add kubuntu_02_fix_cantor_part_destination.diff (LP: #554865)
    - Update cantor.install
 -- Alessandro Ghersi <email address hidden>   Sun, 04 Apr 2010 01:23:54 +0200
Superseded in lucid-release on 2010-04-09
kdeedu (4:4.4.2-0ubuntu1) lucid; urgency=low

  * New upstream release
    - Bump build-depends
    - Update cantor.install
 -- Alessandro Ghersi <email address hidden>   Mon, 29 Mar 2010 01:12:11 +0200
Superseded in lucid-release on 2010-03-30
kdeedu (4:4.4.1-0ubuntu3) lucid; urgency=low

  * debian/control: fixing typo in rocs description (LP: #538212)
 -- <email address hidden> (Richard A. Johnson)   Sun, 28 Mar 2010 13:10:09 -0500
Superseded in lucid-release on 2010-03-28
kdeedu (4:4.4.1-0ubuntu2) lucid; urgency=low

  * Build-dep on libreadline-dev not libreadline5-dev
 -- Jonathan Riddell <email address hidden>   Mon, 08 Mar 2010 13:43:50 +0000
Superseded in lucid-release on 2010-03-08
kdeedu (4:4.4.1-0ubuntu1) lucid; urgency=low

  * New upstream release
    - Bump build dep versions
 -- Alessandro Ghersi <email address hidden>   Sun, 28 Feb 2010 05:22:21 +0100
Superseded in lucid-release on 2010-03-02
kdeedu (4:4.4.0-0ubuntu1) lucid; urgency=low

  [ Alessandro Ghersi ]
  * New upstream release candidate
    - Bump build dep versions

  [ Jonathan Thomas ]
  * Update kross dependency for parley to reflect the new package name, krosspython
 -- Alessandro Ghersi <email address hidden>   Fri, 05 Feb 2010 00:14:28 +0100
Superseded in lucid-release on 2010-02-10
kdeedu (4:4.3.98-0ubuntu1) lucid; urgency=low

  [ Christian Mangold ]
  * New upstream release candidate
    - Bump build dep versions

  [ Alessandro Ghersi ]
  * Bump Qt to 4.6.1
 -- Christian Mangold <email address hidden>   Tue, 02 Feb 2010 01:50:39 +0100
Obsolete in karmic-backports on 2013-03-04
kdeedu (4:4.3.5-0ubuntu1~karmic1) karmic-backports; urgency=low

  * New upstream release
    - Bump KDE build dependencies to >= 4.3.5
 -- Christian Mangold <email address hidden>   Fri, 22 Jan 2010 20:04:11 +0100
Superseded in lucid-release on 2010-02-03
kdeedu (4:4.3.95-0ubuntu1) lucid; urgency=low

  * New upstream release
    - Bump build-deps
    - Update marble-data.install
    - Update cantor.install
 -- Alessandro Ghersi <email address hidden>   Wed, 20 Jan 2010 18:33:49 +0100
Superseded in lucid-release on 2010-01-23
kdeedu (4:4.3.90-0ubuntu1) lucid; urgency=low

  * New upstream RC release
 -- Jonathan Riddell <email address hidden>   Thu, 07 Jan 2010 13:36:24 +0000
Superseded in karmic-backports on 2010-01-27
kdeedu (4:4.3.4-0ubuntu1~karmic1) karmic-backports; urgency=low

  * New upstream release
    - Bump build-deps

Superseded in lucid-release on 2010-01-08
kdeedu (4:4.3.85-0ubuntu1) lucid; urgency=low

  * New upstream release
    - Bump build-deps
    - Drop cancel_docs.diff no longer need
    - Add libattica-dev to build-deps
    - Update install files to readd docs
 -- Alessandro Ghersi <email address hidden>   Sat, 19 Dec 2009 21:52:54 +0100
Superseded in lucid-release on 2009-12-21
kdeedu (4:4.3.80-0ubuntu3) lucid; urgency=low

  * Removing r-base-core from deps because it is in universe. This needs to be
    in main!
 -- <email address hidden> (Richard A. Johnson)   Tue, 15 Dec 2009 11:17:38 -0600
Superseded in lucid-release on 2009-12-15
kdeedu (4:4.3.80-0ubuntu2) lucid; urgency=low

  * Fixed previous TODO
    - Add new packages - see list-missing output in bzr
  * control: Added 2 new binary packages, cantor and rocs
    - cantor: added libspectre-dev and r-base-core to Build-Depends
      time.
    - rocs: added info in control file, no new deps
    - Added cantor and rocs to kdeedu depends
  * cantor.install: Added new package and all files
  * rocs.install: Added new package and all files
  * marble-data.install: Added new weather data images
  * kalzium.install: Added 3 new plasma widgets
    - concentrationCalculator
    - gasCalculator
    - nuclearCalculator
  * not-installed: all work under "Devel symlinks without devel headers"
    section:
    - Added ./usr/lib/libanalitza.so
    - Moved ./usr/lib/libanalitzagui.so up for aesthetic purposes
    - Added ./usr/lib/libcantorlibs.so
  * Added kubuntu_02_fix_cantor_r_backend_kio_ftbfs.diff - adds KDE4 REQUIRED
    KIO to backends/R/rserver/CMakeLists.txt file. Stops cantor from FTBFS due
    to undefined reference to KIO::NetAccess::del in rserver.cpp. Contacted
    upstream providing them information on this.
 -- <email address hidden> (Richard A. Johnson)   Tue, 15 Dec 2009 00:05:42 -0600
Superseded in lucid-release on 2009-12-15
kdeedu (4:4.3.80-0ubuntu1) lucid; urgency=low

  [ Mackenzie Morgan ]
  * New upstream release (4.4 beta 1)
  * Removed 00_kfreebsd.diff and kubuntu_03_fix_kstars_buffer_overrun.diff
    as already upstream
  * cancel_docs.diff:
    - Don't build docs this time since it hangs the build
  * Commented out docs from debian/*.install files due to above

  [ Scott Kitterman ]
  * Remove usr/share/kde4/apps/parley/parleypracticeui.rc from
    parley-data.install (dropped upstream)
  * Bump .so version from 4.3.0 to 4.4.0 for libanalitza.so,
    libcompoundviewer.so, libSatLib.so, libkdeeduui.so,
    libkeduvocdocument.so, libscience.so, libkiten.so, and
    libmarblewidget.so
  * Add usr/liblibanalitzagui.so.4/4.4.0 to kalgebra.install
  * Tighten up Qt build-depends (> 4.6.0)

  * TODO: Add new packages - see list-missing output in bzr
 -- Scott Kitterman <email address hidden>   Tue, 08 Dec 2009 05:32:00 +0000
Superseded in lucid-release on 2009-12-08
kdeedu (4:4.3.3-0ubuntu3) lucid; urgency=low

  * Add missing epoch to Qt build-depends version
 -- Jonathan Riddell <email address hidden>   Wed, 25 Nov 2009 13:47:00 +0000
Superseded in lucid-release on 2009-11-25
kdeedu (4:4.3.3-0ubuntu2) lucid; urgency=low

  * Rebuild against Qt 4.6 rc 1, which is binary incompatible with 4.6
    beta
 -- Jonathan Riddell <email address hidden>   Tue, 24 Nov 2009 08:59:53 +0000
Obsolete in karmic-updates on 2013-03-04
Deleted in karmic-proposed on 2013-03-04 (Reason: moved to -updates)
kdeedu (4:4.3.2-0ubuntu1.1) karmic-proposed; urgency=low

  * Now Parley recommends libkrosspython0 (Closes LP: #484802)
  * Do not install wiktionary_sound.{py,desktop} in parley-data.install,
    it does not work.
 -- Michal Zajac <email address hidden>   Fri, 20 Nov 2009 18:15:37 +0100
Superseded in lucid-release on 2009-11-24
kdeedu (4:4.3.3-0ubuntu1) lucid; urgency=low

  * New upstream release
  * Merge with Debian testing remaining changes:
    - debian/control:
      - Build against liboost-python1.38-dev
      - remove indi from kdeedu (external package)
      - Drop from build-deps libgps-dev, xplanet (are in Universe)
      - Keep in build-deps libgmm-dev, libsbigudrv-dev, python-kde4-dev,
        python-qt4-dev, sip4, libindi-dev
      - Keep our Conflict/Replace on -kde4 packages
      - Kdeedu not depend on kiten, blinken (in universe), indi
        (kstars conflict)
      - kturtle description - change to be more reflective of pseudo-logo
        language
      - Keep python marble bindings, we should try to build python-marble
        in KDE 4.4 packaging and keep -DEXPERIMENTAL_PYTHON_BINDINGS=FALSE in
        rules for switching easily to TRUE when we want try to build it
    - debian/step.install:
      - step.desktop go in usr/share/applications/kde4/step.desktop
      - keep docs path in usr/share/doc/kde/HTML
    - Add kubuntu_01_marble_desktop_tryexec.diff:
      - Adds TryExec statement to marble.desktop as libmarble4 depends
        on marble-data containing the .desktop but not the binary.

  [Michal Zajac]
   * Parley now recommends libkrosspython0 (closes LP: #484802)
   * Added few lines to parley-data.install to prevent
     wiktionary_sound.{py,desktop} from installing since it does not work.
 -- Alessandro Ghersi <email address hidden>   Thu, 12 Nov 2009 03:44:27 +0100
Superseded in lucid-release on 2009-11-20
Obsolete in karmic-release on 2013-03-04
kdeedu (4:4.3.2-0ubuntu1) karmic; urgency=low

  * New upstream release
    - Bump buil-deps

 -- Alessandro Ghersi <email address hidden>   Sat, 03 Oct 2009 18:35:43 +0200
Obsolete in jaunty-backports on 2013-02-28
kdeedu (4:4.2.4-0ubuntu1~jaunty1) jaunty-backports; urgency=low

  [ Steve Stalcup ]
  * New upstream release:
    - bump KDE versions to 4.2.4

  [ Andreas Wenning ]
  * debian/rules: Bump libs version of kalgebra

  [ Scott Kitterman ]
  * Source backport (LP: #437015)

 -- Scott Kitterman <email address hidden>   Fri, 25 Sep 2009 23:13:46 -0400
Superseded in karmic-release on 2009-10-06
kdeedu (4:4.3.1-0ubuntu1) karmic; urgency=low

  * New upstream release
  * Bump version of KDE build-deps to 4.3.1

 -- Christian Mangold <email address hidden>   Sat, 29 Aug 2009 11:35:30 +0200
Superseded in karmic-release on 2009-09-01
kdeedu (4:4.3.0-0ubuntu1) karmic; urgency=low

  * New upstream release
  * Bump version of kdelibs5-dev build-dep to 4.3.0
  * Change libboost-python1.35-dev build-dep to libboost-python1.38-dev
  * Move /usr/share/icons/oxygen/22x22/actions/pointer.png from step.install
    to not-installed, because of file conflict with oxygen-icons

 -- Christian Mangold <email address hidden>   Fri, 31 Jul 2009 00:34:16 +0200
Superseded in karmic-release on 2009-08-04
kdeedu (4:4.2.98-0ubuntu2) karmic; urgency=low

  * Rebuild with new pkg-kde-tools to build translation templates

 -- Jonathan Riddell <email address hidden>   Wed, 29 Jul 2009 18:11:58 +0100
Superseded in karmic-release on 2009-07-29
kdeedu (4:4.2.98-0ubuntu1) karmic; urgency=low

  * New upstream release
  * debian/control: Bump Build-Depends versions

 -- Nathan Handler <email address hidden>   Wed, 22 Jul 2009 14:20:09 +0000
Superseded in karmic-release on 2009-07-23
kdeedu (4:4.2.96-0ubuntu1) karmic; urgency=low

  * New upstream release
    - Bump Build-Depends versions

 -- Alessandro Ghersi <email address hidden>   Fri, 10 Jul 2009 14:04:47 +0200
Superseded in karmic-release on 2009-07-11
kdeedu (4:4.2.95-0ubuntu1) karmic; urgency=low

  * New upstream release:
    - debian/control: Bump Build-Depends versions

 -- Nathan Handler <email address hidden>   Fri, 26 Jun 2009 19:03:14 +0000
Superseded in karmic-release on 2009-07-01
kdeedu (4:4.2.90-0ubuntu1) karmic; urgency=low

  * New upstream release:
    - update KDE versions to 4.2.90 (KDE 4.3 beta 2)
  * debian/control:
    - bump standards version to 3.8.1, no change
  * Update various .install files:
    - kalzium.install

 -- Steve Stalcup <email address hidden>   Fri, 05 Jun 2009 20:20:48 -0400
Superseded in karmic-release on 2009-06-08
kdeedu (4:4.2.85-0ubuntu2) karmic; urgency=low

  * Update build-deps: libqt4-phonon-dev, pkg-kde-tools

 -- <email address hidden> (Roderick B. Greening)   Thu, 21 May 2009 15:19:33 -0230
Superseded in karmic-release on 2009-05-21
kdeedu (4:4.2.85-0ubuntu1) karmic; urgency=low

  * New upstream beta release
  * Set EXPERIMENTAL_PYTHON_BINDINGS=FALSE, currently broken

 -- Jonathan Riddell <email address hidden>   Fri, 15 May 2009 09:10:45 +0000
Superseded in karmic-release on 2009-05-15
kdeedu (4:4.2.2-1ubuntu2) karmic; urgency=low

  * Remove unused build-dependency on eigen
  * Add kubuntu_02_qt_phonon.diff to compile with Qt's Phonon

 -- Jonathan Riddell <email address hidden>   Mon, 11 May 2009 09:07:33 +0000
Superseded in karmic-release on 2009-05-11
kdeedu (4:4.2.2-1ubuntu1) karmic; urgency=low

  * Merge from Debian Unstable

  +++ Changes by Richard A. Johnson

  * Merge debian/changelog

  +++ Changes by Jonathan Thomas

  * Merge everything else, remaining changes:
    - Conflict/Replace on -kde4 packages
    - Build-Depends: cdbs (>= 0.4.52ubuntu7), libgmm-dev,
      libqalculate-dev, libsbigudrv-dev
    - kdeedu not depend on kiten, blinken (in universe), indi (kstars conflict).
    - kturtle description - change to be more reflective of pseudo-logo language
    - remove indi from kdeedu (external package)
    - Drop openbabel, libgsl0-dev and libgps-dev build-deps (they are in universe)
    - Keep python marble bindings
  * Update KUBUNTU-DEBIAN-DIFFERENCES

  +++ Changes by Josh Stewart

  * debian/control:
    - Add libindi-dev to build-depends
    - Update kstars depends, replaced indi with libindi0 (LP: #359517)

Obsolete in intrepid-backports on 2013-02-20
kdeedu (4:4.2.2-0ubuntu1~intrepid1) intrepid-backports; urgency=low

  * Intrepid backport

 -- Jonathan Riddell <email address hidden>   Mon, 27 Apr 2009 16:40:57 +0000
Superseded in karmic-release on 2009-05-11
Obsolete in jaunty-release on 2013-02-28
kdeedu (4:4.2.2-0ubuntu1) jaunty; urgency=low

  * New upstream release
  * debian/rules: Bump libs version of kalgebra
  * debian/control:
    - Bump build-depends and depends on kdelibs5-dev
    - Add build-depends on libgsl0-dev

 -- Andreas Wenning <email address hidden>   Sun, 29 Mar 2009 13:27:41 +0200
Superseded in jaunty-release on 2009-04-02
kdeedu (4:4.2.1-0ubuntu1) jaunty; urgency=low

  * New upstream release
  * debian/control:
    - Update -dev depends and build-depends to (>= 4:4.2.1).
    - Update build-depends on libphonon-dev to 4.3.1
    - Correct typo in libkiten4 description.
  * debian/rules:
    - Update kalgebra version.
  * Remove patch kubuntu_02_python_marble.diff - applied upstream
  * debian/python-marble.install:
    - Update to reflect new default python version being python2.6
  * Rename plasmoid-worldclock.install to plasma-widget-worldclock.install

 -- Andreas Wenning <email address hidden>   Sat, 28 Feb 2009 21:50:21 +0100
Superseded in jaunty-release on 2009-03-04
kdeedu (4:4.2.0-0ubuntu7) jaunty; urgency=low

  [ Jonathan Thomas ]
  * Bump conflictsversion/add a replace on kanagram (<< 4:4.1.80) to accomodate
    upgrades from intrepid-updates (LP: #332625)

 -- Scott Kitterman <email address hidden>   Thu, 26 Feb 2009 18:49:39 -0500
Superseded in intrepid-backports on 2009-04-27
kdeedu (4:4.2.0-0ubuntu7~intrepid1) intrepid-backports; urgency=low

  [ Jonathan Thomas ]
  * Bump conflictsversion/add a replace on kanagram (<< 4:4.1.80) to accomodate
    upgrades from intrepid-updates (LP: #332625)

  [ Scott Kitterman ]
  * Drop unneeded/conflicting/intrusive changes for updated backport
    - Do not build new python-marble extensions
    - Drop doc path changes
    - Drop plasmoid-*/plasma-widget-* renaming
    - Drop transition from boost (1.34) to boost1.35

 -- Scott Kitterman <email address hidden>   Wed, 25 Feb 2009 22:56:47 -0500
Superseded in intrepid-backports on 2009-02-26
kdeedu (4:4.2.0-0ubuntu1~intrepid1) intrepid-backports; urgency=low

  * Intrepid backport

 -- Jonathan Riddell <email address hidden>   Mon, 16 Feb 2009 22:40:54 +0000
Superseded in jaunty-release on 2009-02-27
kdeedu (4:4.2.0-0ubuntu6) jaunty; urgency=low

  * Add missing build-dep on sip4

 -- Jonathan Riddell <email address hidden>   Fri, 13 Feb 2009 11:09:54 +0000
175 of 137 results