kdelibs 4:3.5.9-0ubuntu7.1 source package in Ubuntu

Changelog

kdelibs (4:3.5.9-0ubuntu7.1) hardy-security; urgency=low

  * SECURITY UPDATE: integer overflow in start_kdeinit. The start_kdeinit
    processing of user-influenceable input is faulty.  A local user
    might be able to send unix signals to other processes, cause
    a denial of service or even possibly execute arbitrary code.
  * Add kubuntu_9903_kinit_integer_overflow.diff, edits
    kinit/start_kdeinit.c, patch from upstream KDE
  * References
    http://www.kde.org/info/security/advisory-20080426-2.txt
    CVE-2008-1671

 -- Jonathan Riddell <email address hidden>   Tue, 22 Apr 2008 16:01:13 +0100

Upload details

Uploaded by:
Jonathan Riddell on 2008-05-05
Uploaded to:
Hardy
Original maintainer:
Ubuntu Development Team
Architectures:
any
Section:
kde
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
kdelibs_3.5.9.orig.tar.gz 17.7 MiB 7220fdf43ba5955777520dd0e7c4fdeba0c960c0bd06b02d387c0886fb34e22e
kdelibs_3.5.9-0ubuntu7.1.diff.gz 679.3 KiB 7c03bd71d23d0aefb60c2ca8bc2f741902a2bff0404994f60f4f540fecc7d319
kdelibs_3.5.9-0ubuntu7.1.dsc 1.7 KiB a2f81c29b710b829cb25eadc4ee47f27dde5eec800912fa0db99e80b48b49b49

View changes file

Binary packages built by this source

kdelibs: No summary available for kdelibs in ubuntu hardy.

No description available for kdelibs in ubuntu hardy.

kdelibs-data: No summary available for kdelibs-data in ubuntu hardy.

No description available for kdelibs-data in ubuntu hardy.

kdelibs-dbg: No summary available for kdelibs-dbg in ubuntu hardy.

No description available for kdelibs-dbg in ubuntu hardy.

kdelibs4-dev: No summary available for kdelibs4-dev in ubuntu hardy.

No description available for kdelibs4-dev in ubuntu hardy.

kdelibs4-doc: No summary available for kdelibs4-doc in ubuntu hardy.

No description available for kdelibs4-doc in ubuntu hardy.

kdelibs4c2a: No summary available for kdelibs4c2a in ubuntu hardy.

No description available for kdelibs4c2a in ubuntu hardy.