Calendar does not synch with palm device

Bug #66313 reported by Sébastien on 2006-10-15
66
Affects Status Importance Assigned to Milestone
KDE PIM
Fix Released
High
kdepim (Debian)
Fix Released
Unknown
kdepim (Ubuntu)
Undecided
Frode M. Døving

Bug Description

Binary package hint: kpilot

Since the last kdelib update in edgy, the calendar is no longer synchronized with my Palm T|X.

Just after the edgy update it was working pretty well. The problem happend just after the last kdelib update.

In fact, the ICS file is not modified, and the palm integrated calendar is not modified, and some information is lost.

Related branches

Andres Mujica (andres.mujica) wrote :

Hi, can you provide us the output for:

dpkg -l | grep kdepim

Sébastien (sesteve) wrote :

$ dpkg -l | grep kdepim
ii kdepim 3.5.5-0ubuntu1 KDE Personal Information Management metapack
ii kdepim-kfile-plugins 3.5.5-0ubuntu1 KDE File dialog plugins for palm and vcf fil
ii kdepim-kio-plugins 3.5.5-0ubuntu1 KDE pim I/O Slaves
ii kdepim-kresources 3.5.5-0ubuntu1 KDE pim resource plugins
ii kdepim-wizards 3.5.5-0ubuntu1 KDE server configuration wizards
ii libkdepim1a 3.5.5-0ubuntu1 KDE PIM library

Andres Mujica (andres.mujica) wrote :

this bug can be confirmed, there are two reporters with the same issue, same packages.

Seems to be something related with kdepim

Andres Mujica (andres.mujica) wrote :

it's confirmed via a duplicate

Changed in kdepim:
status: Unconfirmed → Confirmed
Sylvain (lebon) wrote :

Indeed I also have the same problem. And I would be very happy to be able to use my palm again.

Thks for your times

I can confirm this bug - here is my setup:

$ dpkg -l | grep kdepim
ii kdepim-kio-plugins 3.5.5-0ubuntu1 KDE pim I/O Slaves
ii kdepim-kresources 3.5.5-0ubuntu1 KDE pim resource plugins
ii kdepim-wizards 3.5.5-0ubuntu1 KDE server configuration wizards
ii libkdepim1a 3.5.5-0ubuntu1 KDE PIM library

would be happy to send more debug info

Coplan Toulouse (jean-guardia) wrote :

Hi, I can confirm this bug too. My Zire 31 losts all calendar datas when i sync it with kubuntu Edgy

dpkg -l | grep kdepim
ii kdepim-kfile-plugins 3.5.5-0ubuntu1 KDE File dialog plugins for palm and vcf fil
ii kdepim-kio-plugins 3.5.5-0ubuntu1 KDE pim I/O Slaves
ii kdepim-kresources 3.5.5-0ubuntu1 KDE pim resource plugins
ii kdepim-wizards 3.5.5-0ubuntu1 KDE server configuration wizards
ii libkdepim1a 3.5.5-0ubuntu1 KDE PIM library

Thanks a lot Jean

As an aid in debugging, installing kpilot from source fixes the problem.

Ylan (ylan-segal) wrote :

I also have the same problem after upgrading to edgy.

It would be greatly appreciated if someone posted the steps to install from source to work around this problem.

Thanks,

Coplan Toulouse (jean-guardia) wrote :

Hi every body,

i just download the sources from
http://cvs.codeyard.net/kpilot/develop.php#sources
untar it and compile it, but warning, warning it doesn't work too.
I lost every data on my zire 31. fortunately i've saved them before on another computer.
Excuse me for my poor english, i'm french.
Maybe the better is to get the source from edgy ?
is that what you meant George ?

thanks a lot Jean

I used the source from codeyard, _not_ the source deb from edgy. My steps:

1) apt-get remove --purge kpilot

2)apt-get build-dep kpilot
apt-get install kdepim-dev

(kpilot depends on kdepim-dev but the dependency is not enforced, so you need to install it separately)

2) download, compile, install following the instructions in codeyard.net

and vcal syncing worked.

--george

On Tuesday 31 October 2006 1:39 pm, George Bourozikas wrote:
> I used the source from codeyard, _not_ the source deb from edgy. My
> steps:

George, I got stuck along the way, I would appreciate some help:

> 1) apt-get remove --purge kpilot

OK

>
> 2)apt-get build-dep kpilot

ylan@ylan-laptop:~$ sudo apt-get build kpilot
E: Invalid operation build
ylan@ylan-laptop:~$ sudo apt-get build-dep kpilot
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Build-dependencies for kpilot could not be satisfied.

> apt-get install kdepim-dev

ylan@ylan-laptop:~$ sudo apt-get install kdepim-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  kdepim-dev: Depends: libkcal2-dev (= 4:3.5.5-0ubuntu1) but it is not going
to be installed
              Depends: libkdepim1-dev (= 4:3.5.5-0ubuntu1) but it is not going
to be installed
              Depends: libkgantt0-dev (= 4:3.5.5-0ubuntu1) but it is not going
to be installed
              Depends: libkleopatra1-dev (= 4:3.5.5-0ubuntu1) but it is not
going to be installed
              Depends: libkpimexchange1-dev (= 4:3.5.5-0ubuntu1) but it is not
going to be installed
              Depends: libksieve0-dev (= 4:3.5.5-0ubuntu1) but it is not going
to be installed
              Depends: libktnef1-dev (= 4:3.5.5-0ubuntu1) but it is not going
to be installed
E: Broken packages

>
> (kpilot depends on kdepim-dev but the dependency is not enforced, so you
> need to install it separately)
>
> 2) download, compile, install following the instructions in codeyard.net
>
> and vcal syncing worked.

Didn't get that far. Can you help me with the above?

I appreciate our help,

--
Ylan

Ylan (ylan-segal) wrote :

On Tuesday 31 October 2006 1:39 pm, George Bourozikas wrote:
> I used the source from codeyard, _not_ the source deb from edgy. My
> steps:

George,

Please disregard my previous message. I got it working. Apparently my sources
where out of whack. I was missing:

--
Ylan

Ylan (ylan-segal) wrote :

On Tuesday 31 October 2006 1:39 pm, George Bourozikas wrote:
> I used the source from codeyard, _not_ the source deb from edgy. My
> steps:

George,

Please disregard my previous message. I got it working. Apparently my sources
where out of whack. I was missing:

deb http://kubuntu.org/packages/kde-latest/ edgy main

After I added it and ran apt-get update all sorted itself out.

Kpilot seems to be running fine, except for knotes.

--
Ylan

Coplan Toulouse (jean-guardia) wrote :

Thanks a lot for the response. It worked but on my machine all my rendez-vous are repeated twice. i let it down. i will synchronize with dapper.

Best regards Jean

Sébastien (sesteve) wrote :

Still does not work for me sadly, even with the kubuntu repository !

2006/11/1, Coplan Toulouse <email address hidden>:
>
> Thanks a lot for the response. It worked but on my machine all my
> rendez-vous are repeated twice. i let it down. i will synchronize with
> dapper.
>
> Best regards Jean
>
> --
> Calendar does not synch with palm device
> https://launchpad.net/bugs/66313
>

Sokraates (sokraates) wrote :

Same problem here on my desktop and laptop, both fresh Edgy Final installs.

On both machines:
$ dpkg -l | grep kdepim
ii kdepim 3.5.5-0ubuntu1 KDE Personal Information Management metapack
ii kdepim-kfile-plugins 3.5.5-0ubuntu1 KDE File dialog plugins for palm and vcf fil
ii kdepim-kio-plugins 3.5.5-0ubuntu1 KDE pim I/O Slaves
ii kdepim-kresources 3.5.5-0ubuntu1 KDE pim resource plugins
ii kdepim-wizards 3.5.5-0ubuntu1 KDE server configuration wizards
ii libkdepim1a 3.5.5-0ubuntu1 KDE PIM library

fgosse (fabien-gosse) wrote :

Hi,

I've the same problem and it still does not work with
deb http://kubuntu.org/packages/kde-latest/ edgy main

Thanks a lot

F.G

fgosse (fabien-gosse) wrote :

Hi,

Do you know when can I find a package for edgy ?

Thanks

F.G

Ylan (ylan-segal) wrote :

On Wednesday 15 November 2006 5:23 am, fgosse wrote:
> Hi,
>
> Do you know when can I find a package for edgy ?

I don't know of any packages that work for edgy. I built kpilot myself with
the steps described by George and it's working on my laptop.

--
Ylan

fgosse (fabien-gosse) wrote :

Hi,

with : apt-get build-dep kpilot
I need to install many packages (105) for 500 Mo.
So, i prefer a lovely package for kpilot.

F.G

JM Barbier (jm-barbier) wrote :

Hi,

same problem for me, building from sources as explained by Georges solved it. I had the same problem on Debian (Unstable) one month ago, maybe #394534 bug... don't know if it is solved now..

J.M.B.

I am seeing this bug as well. Never used KDEPIM before Edgy so I have no idea if my issue could be longer standing. I tried installing from the subversion source at Codeyard and it installed fine, but the problem is not fixed with that. My device is a Clie N610C if that makes a difference.

Any ideas for me? Anything I can do to help get this solved?

Thanks,
Mike

Changed in kdepim:
status: Unknown → Fix Released
Changed in kdepim:
status: Unknown → Confirmed
Frode M. Døving (frode) on 2006-11-24
Changed in kdepim:
assignee: nobody → frode
Frode M. Døving (frode) wrote :

Hello.
Anyone with Feisty and a palm able to test kpilot from http://ubuntu.lnix.net/feisty/kdepim/

Please post feedback as comments to this bug.

I'm also working on fixing this for edgy.
Thanks.

Frode M. Døving (frode) wrote :

Edgy packages for testing available at
http://ubuntu.lnix.net/edgy/updates/kdepim-proposed/

Please post feedback as comments to this bug.

I can confirm the those new packages sync the agenda. todo's (one way though) and addressbook.

fgosse (fabien-gosse) wrote :

Thanks,

The new package for kpilot works now : Kalendar synchs with palm device.

F.G

Frode M. Døving (frode) wrote :

Fixed kdepim is now available in feisty.

Changed in kdepim:
status: Confirmed → Fix Released
Download full text (3.9 KiB)

Using the Edgy proposed package referenced above (kpilot_3.5.5-0ubuntu1.1~proposed_i386.deb), when it starts synchronizing the datebook, the KPilot daemon crashes. Backtrace follows below:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1234319696 (LWP 16886)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0xb6ebd128 in QShared::ref () from /usr/lib/libqt-mt.so.3
#7 0xb72ac52f in QString::QString () from /usr/lib/libqt-mt.so.3
#8 0xb6aab9be in KCal::Incidence::summary () from /usr/lib/libkcal.so.2
#9 0xb6209ab1 in PCToHHState::handleRecord ()
   from /usr/lib/kde3/conduit_vcal.so
#10 0xb6208ed0 in VCalConduitBase::slotProcess ()
   from /usr/lib/kde3/conduit_vcal.so
#11 0xb6208ff2 in VCalConduitBase::qt_invoke ()
   from /usr/lib/kde3/conduit_vcal.so
#12 0xb61fc7cb in VCalConduit::qt_invoke () from /usr/lib/kde3/conduit_vcal.so
#13 0xb6f94957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0xb7320f44 in QSignal::signal () from /usr/lib/libqt-mt.so.3
#15 0xb6fb48ea in QSignal::activate () from /usr/lib/libqt-mt.so.3
#16 0xb6fbc300 in QSingleShotTimer::event () from /usr/lib/libqt-mt.so.3
#17 0xb6f2bb88 i...

Read more...

Eric Biven (ebiven) wrote :

I just installed kpilot_3.5.5-0ubuntu1.1~proposed_i386.deb from http://ubuntu.lnix.net/edgy/updates/kdepim-proposed/ and it fixed my issues with Edgy and a Palm Treo 650.

Lothar (lothar-tradescape) wrote :

Is there a place where I can download a prebuildt amd64 package?

Frode M. Døving (frode) wrote :

Not that i'm aware of.

Inigo Montoya (a9601252) wrote :

I just installed kpilot_3.5.5-0ubuntu1.1~proposed_i386.deb from http://ubuntu.lnix.net/edgy/updates/kdepim-proposed/ and it fixed my issues with Kubuntu 6.10 Edgy (with latest updates) and a Palm Tungsten C. THANK YOU!!!!

Confirmed. The deb from http://ubuntu.lnix.net/edgy/updates/kdepim-proposed/ fixes kpilot's data loss under Edgy.

Using a Palm Tungsten E. Thanks!

Scott (firecat53) wrote :

I'm experiencing the same crash of Kpilot that Avdi Grimm did back in November. When the date book is synchronizing, kpilot crashes. I've attached the backtrace log it generated, but I believe it's the same as Avdi had. I tried this both the proposed edgy updates noted above and with kpilot compiled from the most recent source.

Thanks, Scott

Scott (firecat53) wrote :

Sorry, I forgot to add that I'm using a Palm Tungsten T3.
Thanks, Scott

I'll just add that I never found a way to make this crash go away, so
I haven't been able to use calendar synch.

On 1/16/07, firecat53 <email address hidden> wrote:
> I'm experiencing the same crash of Kpilot that Avdi Grimm did back in
> November. When the date book is synchronizing, kpilot crashes. I've
> attached the backtrace log it generated, but I believe it's the same as
> Avdi had. I tried this both the proposed edgy updates noted above and
> with kpilot compiled from the most recent source.
>
> Thanks, Scott

Simon Gordon (linux-sgordon) wrote :

Just in case this helps at all:

I just installed kpilot_3.5.5-0ubuntu1.1~proposed_i386.deb from http://ubuntu.lnix.net/edgy/updates/kdepim-proposed/ and it fixed my sync issues with Kubuntu 6.10 Edgy (with latest updates) and a Palm Tungsten E.

  S

Changed in kdepim:
status: Confirmed → Fix Released
Felipe Figueiredo (philsf) wrote :

Can anyone confirm that kpilot works in feisty final?

I may still be experiencing these crashes, not sure exactly why.

I can confirm that kpilot works fine on feisty final.

Changed in kdepim:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.