Ubuntu

[Kino] needs latest package

Reported by Mantas Kriaučiūnas on 2006-12-23
30
Affects Status Importance Assigned to Milestone
kino (Baltix)
High
Mantas Kriaučiūnas
kino (Debian)
Fix Released
Unknown
kino (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kino

Kino is very old in Ubuntu - several new upstream versions (0.9.3, 0.9.4, 0.9.5 and 1.0.0) with important bugfixes and lots of improvements has been released, please package ver. 1.0.x
For improvements list look at the Release Notes at http://www.kinodv.org :

1.0.0:
    * New http://blip.tv/ uploading feature for movies and still frames! Watch a screencast for more information.
    * Fixed audio handling on big endian CPU architectures (thanks, Pavel Fedin)
    * Improved generic video import script when using mencoder: faster, no bulky intermediate file, less compatibility problem between mencoder and ffmpeg, and retains interlacing in ITU-R 601 sources
    * Added support for X-Keys Editor USB Jog/Shuttle (thanks, Shawn Rutledge)
    * Added support for Jog/Shuttle to FX (jog wheel and button actions that scrub only--no shuttle ring support)
    * The USB Jog/Shuttle hotplug integration was changed to use udev. The new configure option is --enable-udev-rules-dir, which defaults to $sysconfdir/udev/rules.d/ The following configure options were removed: --enable-hotplug-script-dir, --enable-hotplug-usermap-dir
    * Added private copy of ffmpeg source code for static linking with new configure options: --enable-local-ffmpeg(=yes by default), or --disable-local-ffmpeg NOTE: This option builds a statically linked, kino-specific version of the ffmpeg transcode utility named 'ffmpeg-kino' that is invoked by the Kino import script. ffmpeg-kino contains a bugfix for reading the audio on imported files. However, when --enable-local-ffmpeg=no, then the import script uses the normal ffmpeg found in the PATH.
    * Updated Italian translation
    * bugfixes, of course

0.9.5:
    * New Levels video filter replaces Gamma with keyframing of brightness, contrast, gamma, hue, saturation, value, and white balance (colour temperature with colour picker and green cast).
    * Updated translations: French, Czech, Danish.
    * Debut of French online help created using new web-based collaborative docbook authoring system.
    * bugfixes

0.9.4:
    * New KinoPlus-based FX plugins: Colour Average, Charcoal, Gamma, Jerky, Pan & Zoom, Pixelate, Composite Transition, Blue and Green Chroma Key
    * New Fade In and Fade Out video filters
    * Added non-WAV file support to audio filters Dub and Mix when you have ffmpeg and oggdec installed
    * New Audio Gain filter with curve control
    * Added curve controls to audio filters Dub and Mix
    * Improved FX preview with multithreaded frame dropping (much better audio)
    * Improved playback in Edit with frame dropping enabled
    * Improved consistency and usability of FX user interface through tooltips, labels, and percentage-oriented widgets
    * Added recent files (projects only) to File menu
    * New docbook-based manual with collaboration website: http://www.kinodv.org/docbook/
    * Internationalisation support for online help (translations pending)
    * Online help now uses Yelp under GNOME to view docbook XML and Konqueror under KDE to view docbook-converted HTML
    * New crash auto-recover feature that restores undo history (stored in $HOME/.kino-history)
    * Updated translations: French, Spanish, Danish, Swedish, Czech, Hungarian, Russian.
    * Added automatic widescreen and proper PAL support to Export/Other scripts

0.9.3:
    * Bugfix SMIL 2.0 parsing on numeric locales not using period as decimal point.
    * Update FFMPEG export scripts to support latest version.
    * Added SRT subtitle SaveAs option that supports user metadata.
    * FX/Audio Transitions Dub and Mix now under Audio Filter.
    * Improved Type 2 AVI parser.
    * Automatically stop capture at end-of-tape (when AV/C enabled).
    * Russian translation update.
    * various bugfixes and cleanups.

please update Ubuntu packages - bugfixes and improvements from 1.0 must be included in Ubuntu !

Changed in kino:
status: Unknown → Unconfirmed
Changed in kino:
status: Unconfirmed → Confirmed
zolly (zolly-2004) wrote :

where can I download the .deb file of kino 0.9.3 ?
I don't see any link in kinodv.org

Duncan Lithgow (duncan-lithgow) wrote :

Kino 0.9.3, 0.9.4, 0.9.5 and now 1.0.0 have been released. Ubuntu 7.04 (Feisty Fawn) still uses 0.9.2.

Mattias, can you request an update?

description: updated
Shaved Wookie (shavedwookie) wrote :

We're all willing to beg if need be...

I'm just beyond being a newbie myself, but I looked into creating .deb packages to see if I could do it myself and save you guys some time. From the looks of it I'd take me about 10 hours to do what would probably take anyone competent (like you guys) 15 minutes... so I guess I'm back to the begging part. ;-) One day though!

Until then, praise be to devs from one more likely to supply art / documentation. :)

Duncan Lithgow (duncan-lithgow) wrote :

I'd happily create a package if someone could take me through the process. I've looked at the docs too , and they're very long and mysterious.

Changed in kino:
status: Unconfirmed → Fix Released

Just want to inform, that Debian already has Kino 1.0 package in experimental (can Ubuntu sync packages from Debian experimental repositories?), also there is a package for Ubuntu 7.04 "Feisty" at www.getdeb.net software repository: http://www.getdeb.net/app.php?name=Kino

Maia Everett (sikon) wrote :

I concur, you should probably sync 1.0.0 from Debian experimental.

Steve Kowalik (stevenk) on 2007-07-09
Changed in kino:
status: New → Invalid
Mantas Kriaučiūnas (mantas) wrote :

Please, don't close Baltix bugs, which are reported or assigned to Baltix by main Baltix developer (me ;) )

Changed in kino:
assignee: nobody → mantas
importance: Undecided → High
status: Invalid → Confirmed

Kino 1.0 packages and sources for Ubuntu Edgy/Feisty are available at ftp.akl.lt/Linux/Baltix/Baltix-Ubuntu-packages/edgy/kino/

These packages are based on Kino 1.0 packages from Debian experimental but contains several important improvements:
  * Translated menu launcher (Kino.desktop) to Lithuanian
  * fixed help location bug - in debian/rules install section added
    ln -s ../../kino/help $(CURDIR)/debian/kino/usr/share/doc/kino/help
  * used upstream udev rules (kino.rules) file instead of outdated debian's one
  * Changed --without-dv1394 to --with-dv1394 in debian/rules - Ubuntu still
    prefers dv1394 module for DV capturing (user has no access to /dev/raw1394)

Sikon said on 2007-06-19:
> I concur, you should probably sync 1.0.0 from Debian experimental.

Packages from Debian experimental contains several bugs (for example help doesn't work, look at list of my improvements above) - please, use my improved packages instead of Debian's one.

I'm attaching kino_1.0.0-1ubuntu1.diff.gz file with changes, described above, to this bugreport, please accept my improvements in Ubuntu.

0.9.2 - released 2006-08-31
1.1.0 - released 2007-07-23
(http://sourceforge.net/project/showfiles.php?group_id=14103&package_id=11668)

I was hoping 1.1.x could be included as well as I asked the question here: https://answers.launchpad.net/ubuntu/+source/kino/+question/10955

I think it will be very beneficial not just for regular Ubuntu users, but since UbuntuStudio uses the Ubuntu repositories, video editors will be crying for the most bleeding edge software.

Steve Kowalik (stevenk) wrote :

Kino 1.1.0-3ubuntu1 has hit Ubuntu Gutsy.

Changed in kino:
status: Confirmed → Fix Released
Cesare Tirabassi (norsetto) wrote :

kino (1.1.0-3ubuntu1) gutsy; urgency=low

  * Merge from Debian unstable.
  * Remaining Ubuntu changes:
    - Dropped dependency on libavcodec, libavformat and liba52-dev
    - Set Ubuntu maintainer address.
  * Ubuntu changes dropped:
    - Keep udev rules according to Ubuntu policy
  * Move where the udev rules are installed to, as per Ubuntu policy, since
    Debian have moved from hotplug to udev as well.

 -- Steve Kowalik <email address hidden> Mon, 6 Aug 2007 16:46:24 +1000

Andrew Hunter (rexbron) wrote :

New upstream point release.

1.1.1 Release Notes

    * bugfix segfault on crash recovery with gtk+ version < 2.11

Also, could the maintainer please look at https://bugs.launchpad.net/ubuntu/+source/dvgrab/+bug/131561

Changed in kino:
status: Fix Released → New
status: New → Confirmed
Cesare Tirabassi (norsetto) wrote :

What is the point in adding this to a fix released bug report?
The correct procedure is to file a new upgrade request opening a new bug report instead of adding it to older/obsolete bug reports.

Changed in kino:
status: Confirmed → Fix Released
Changed in kino (Baltix):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.