Change log for kiwi package in Ubuntu

119 of 19 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-12-15
Deleted in xenial-proposed (Reason: moved to release)
kiwi (1.9.22-4) unstable; urgency=medium

  [ Jelmer Vernooij ]
  * Depend on newer version of pydoctor that supports SOURCE_DATE_EPOCH,
    drop custom specification of --buildtime to pydoctor.
  * Add debian/.gitignore file.

 -- Debian Python Modules Team <email address hidden>  Mon, 07 Dec 2015 23:44:36 +0000

Available diffs

Superseded in xenial-release on 2015-12-15
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
kiwi (1.9.22-3) unstable; urgency=medium

  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

  [ Jelmer Vernooij ]
  * Bump standards version to 3.9.6.
  * Migrate to 3.0 (quilt).
  * Drop empty patch 02_disable_pydoctor.patch.
  * Add patch 05_pydoctor_build_time.diff: Pass package change time to
    pydoctor, to create reproducible builds. Closes: #784586
  * Migrate to dh_python2.

 -- Debian Python Modules Team <email address hidden>  Wed, 06 May 2015 22:39:09 +0000

Available diffs

Superseded in wily-release on 2015-05-07
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
kiwi (1.9.22-2) unstable; urgency=low

  [ Sandro Tosi ]
  * debian/control
    - switch Vcs-Browser field to viewsvn
    - bump python-pydoctor to requre >= 0.2-4.1, this version is needed to build
      kiwi with Python 2.6 as default; thanks to Jakub Wilk for the report;
      Closes: #571492
    - replace b-d-i on python-all-dev with python-all, since building arch:all
    - added misc:Depends to binary package Depends
  * debian/python-kiwi.doc-base.api
    - set section to Programming/Python
  * debian/compat
    - set compat version to 5
  * debian/preinst
    - 'set -e' explicitly
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 May 2010 13:53:04 +0100

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
kiwi (1.9.22-1) unstable; urgency=low

  * New upstream release
  * debian/patches/03_fix_gazpacholoader.diff: removed patch
    applied upstream.
  * debian/control:
    - removed unneeded -1 from some build-depency versions
    - removed build-dependency on xbase-clients

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  04 Nov 2008 21:28:02 +0000

Available diffs

Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
kiwi (1.9.21-1) unstable; urgency=low

  [ Sandro Tosi ]
  * debian/control
    - uniforming Vcs-Browser field

  [ Goedson Teixeira Paixao ]
  * New upstream release
  * debian/control: depend on python-pkg-resources instead of
    python-setuptools (Closes: #468717).

 -- Nicolas Valc?rcel (nxvl) <email address hidden>   Fri,  30 May 2008 08:33:48 +0100

Available diffs

Superseded in intrepid-release on 2008-05-30
Obsolete in hardy-release on 2015-04-24
kiwi (1.9.19-2ubuntu1) hardy; urgency=low

  * Resynchronized with Debian, remaining Ubuntu changes:
    - debian/control: Package: python-kiwi Replaces: kiwi.
    - Modify Maintainer value to match Debian-Maintainer-Field Spec

Superseded in hardy-release on 2007-12-11
Obsolete in gutsy-release on 2011-09-16
kiwi (1.9.16-0ubuntu1) gutsy; urgency=low

  * New upstream release:
    - Polish translation (Jarek Zgoda)
    - ObjectList updates
    - Support for currency marker in KiwiLabel (#3389, Ronaldo Maia)
    - Improvements to glade-3 plugin (Ali, #3461)
    - ObjectList::row-expanded signal (Ali, #3460)
    - Kiwi completion fixes/workaround (Ali, #2901)
    - Tasklet updates (Gustavo)
    - ValueUnset and KiwiEntry  (Ali, #3408)
    - Gaxml support in loader
    - Gazpacho support for ObjectList (Ali, #3389)
    - Rml translation support
    - SQLObject full text index support

 -- Aron Sisak <email address hidden>   Thu, 19 Jul 2007 20:32:02 +0200
Superseded in gutsy-release on 2007-07-20
kiwi (1.9.15-1ubuntu1) gutsy; urgency=low

  * Resynchronized with Debian, remaining Ubuntu changes:
    - debian/control: Package: python-kiwi Replaces: kiwi.
    - Modify Maintainer value to match Debian-Maintainer-Field Spec

Superseded in gutsy-release on 2007-06-28
kiwi (1.9.15-0ubuntu1) gutsy; urgency=low

  * New upstream release.
  * debian/control:
    - Drop from Build-Depends: python-epydoc, python-twisted-core,
      xvfb, xbase-clients, xfonts-base
  * debian/compat: Change to 5.
  * debian/patches:
    - 01_avoid_building_howto.diff: Updated.
    - 02_avoid_version_checking.diff: Updated.
    - 03_epyrun_use_local_modules.diff: Dropped.
    - 04_avoid_building_helper_module.diff: Updated.
  * debian/rules:
    - Don't remove the API documention until we have pydoctor to recreate it.

 -- Michael Bienia <email address hidden>   Sat, 26 May 2007 21:36:44 +0200
Superseded in gutsy-release on 2007-05-26
kiwi (1.9.13-4ubuntu1) gutsy; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/control:
      + Replaces: kiwi (needs to be kept till the next Ubuntu LTS release)
  * debian/control:
    - Move python-support from B-D-I to B-D and depend on >= 0.6.4
    - Change python-all-dev to python-all
    - Change Maintainer/XSBC-Original-Maintainer field.
    - Remove X[SB]-Python-Version and move it to debian/pyversions as
      suggested by the warning

Superseded in gutsy-release on 2007-05-24
Obsolete in feisty-release on 2009-08-20
kiwi (1.9.13-0ubuntu1) feisty; urgency=low

  * New upstream release:
    - Workaround GtkEntry bug when resizing the size of its GtkWindows.
    - Include _kiwi.c in tarball, fixes build.
    - Use pkg-config to find pygtk version.
  * debian/control:
    - added pkg-config to Build-Depends.
  * debian/patches/02_avoid_version_checking.diff:
    - updated.

 -- Daniel Holbach <email address hidden>   Tue,  6 Feb 2007 09:42:28 +0100
Superseded in feisty-release on 2007-02-06
kiwi (1.9.12-0ubuntu1) feisty; urgency=low

  * New upstream release.
  * debian/patches/03_epyrun_use_local_modules.patch:
    - updated.
  * debian/control:
    - moved python-support from Build-Depends to Build-Depends-Indep.

 -- Daniel Holbach <email address hidden>   Tue, 30 Jan 2007 09:52:28 +0100
Superseded in feisty-release on 2007-01-30
kiwi (1.9.9-2ubuntu1) feisty; urgency=low

  * debian/control:
    - Replaces: kiwi.

Superseded in feisty-release on 2006-12-20
Obsolete in edgy-release on 2008-06-19
kiwi (1.9.9-1ubuntu1) edgy; urgency=low

  * Sync with Debian
  * debian/control:
    - Replaces kiwi

 -- Sebastien Bacher <email address hidden>   Sun, 27 Aug 2006 18:33:24 +0200
Superseded in edgy-release on 2006-09-01
kiwi (1.9.9-0ubuntu1) edgy; urgency=low

  * New upstream release:
    - KiwiEntry improvements
    - Win32 installation fixes for Gazpacho & Kiwi
    - DateEntry fixes
    - DateEntry win32 support
    - Logging improvements
    - Datatypes refactoring and improved Gazpacho integration
    - Add UI tests
    - Lots of Bugfixes

 -- Daniel Holbach <email address hidden>   Fri, 25 Aug 2006 09:37:40 +0200
Superseded in edgy-release on 2006-08-25
kiwi (1.9.8-5ubuntu1) edgy; urgency=low

  * debian/control:
    + Add Replaces on kiwi (Ubuntu: #55778)

 -- Sebastian Dröge <email address hidden>   Wed,  9 Aug 2006 15:14:16 +0200
Superseded in edgy-release on 2006-08-09
kiwi (1.9.8-5) unstable; urgency=low

  * debian/01_python2.3_install.diff:
  - removed; no longer needed
  * debian/control, debian/rules, debian/pyversions, debian/pycompat:
  - use python-support 0.3 and newer cdbs, that builds using the
    minor version required by the package; also make the build system
    more robust (Closes: #375270)

Superseded in edgy-release on 2006-08-08
Obsolete in dapper-release on 2011-09-06
kiwi (1.9.8-0ubuntu1) dapper; urgency=low

  * New upstream release.
  * debian/kiwi.install:
    - updated.

 -- Daniel Holbach <email address hidden>   Tue, 25 Apr 2006 22:16:02 +0200
Superseded in dapper-release on 2006-05-03
Superseded in dapper-release on 2006-02-03
kiwi (1.9.3-0ubuntu1) dapper; urgency=low


  * New upstream release:
    - UI Test framework
    - Add a hyperlink widget (Ali Afshar)
    - Add a selectable box
    - Currency datatype
    - Simple dialogs
    - Logging helpers
    - Validation improvements
    - Documentation improvemnets

 -- Daniel Holbach <email address hidden>  Thu, 15 Dec 2005 23:06:04 +0100
119 of 19 results